Need help with JVC DLA X70 - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 9 Old 07-02-2012, 04:39 PM - Thread Starter
Newbie
 
felepe's Avatar
 
Join Date: Nov 2007
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hello everyone, I just received my JVC dla-x70 back from JVC, When the lens cover opens there is a piece of rubber that surrounds the lense , I never noticed it before, I phoned JVC and they told me to remove it, I tried to pull it off without success, anybody else have this problem, Its a long weekend in canada any my dealer is closed till wednesday, thanks:)
felepe is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 07-02-2012, 05:30 PM
AVS Special Member
 
ultra 150 pilot's Avatar
 
Join Date: Jan 2002
Location: Western mass
Posts: 1,072
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 17
Try taking a high quality photo if you can and post it
ultra 150 pilot is offline  
post #3 of 9 Old 07-02-2012, 06:13 PM - Thread Starter
Newbie
 
felepe's Avatar
 
Join Date: Nov 2007
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
450
felepe is offline  
post #4 of 9 Old 07-02-2012, 06:14 PM - Thread Starter
Newbie
 
felepe's Avatar
 
Join Date: Nov 2007
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
450
felepe is offline  
post #5 of 9 Old 07-02-2012, 06:15 PM - Thread Starter
Newbie
 
felepe's Avatar
 
Join Date: Nov 2007
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I hope these pics help, thanks
felepe is offline  
post #6 of 9 Old 07-03-2012, 02:06 AM
AVS Special Member
 
Manni01's Avatar
 
Join Date: Sep 2008
Posts: 2,228
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 54 Post(s)
Liked: 102
It looks like the piece of rubber that fills the gap around the lens when you lens shift it. Don't remove it! It's normal. Just move your lens using lens shift on the remote, and you'll see why it's there.

As long as it's not in the way of the usable part of the lens (i.e. obscures part of the projected 1080p picture) it's not a problem.
Manni01 is online now  
post #7 of 9 Old 07-03-2012, 09:05 AM
AVS Special Member
 
ultra 150 pilot's Avatar
 
Join Date: Jan 2002
Location: Western mass
Posts: 1,072
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 17
I would wait and talk to your dealer, if you rip that out and you shouldn't have then you will have to send it to jvc for repair.

I would document who at jvc said to remove it
ultra 150 pilot is offline  
post #8 of 9 Old 07-03-2012, 09:28 AM - Thread Starter
Newbie
 
felepe's Avatar
 
Join Date: Nov 2007
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Thanks everyone, I just found out that its part of the seal to keep light from escaping out of the projector, they told me to take a pencil and with the eraser end to gently push back along the edges until it disappears, I can' t believe that customer service told me to rip it out in the first place. thanks for your help guys.smile.gif
felepe is offline  
post #9 of 9 Old 07-03-2012, 06:11 PM
AVS Special Member
 
ultra 150 pilot's Avatar
 
Join Date: Jan 2002
Location: Western mass
Posts: 1,072
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 17
Glad too hear it, enjoy my friend
ultra 150 pilot is offline  
Reply Digital Hi-End Projectors - $3,000+ USD MSRP

Tags
Jvc Dla X70 Projector

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off