Mohu Leaf - Amplified or Not - AVS Forum
Forum Jump: 
 
Thread Tools
Old 07-20-2014, 08:15 AM - Thread Starter
Member
 
Join Date: Jun 2014
Posts: 82
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 44 Post(s)
Liked: 9
Mohu Leaf - Amplified or Not

So I have a mohu leaf 50, which is the amplified version. When I have the amplifier plugged in, I get 100% signal strength. After doing some searching online, I've read that using an amplifier can result in an overdriven signal and actually hurt PQ if it's not needed, so I unplugged the amplifier to see what the signal strength is unamplified. Right now, I'm getting 60-75% depending on channel. So, what do people think - use the amplifier or not?
Duke02 is offline  
Sponsored Links
Advertisement
 
Old 07-20-2014, 11:36 AM
AVS Special Member
 
ProjectSHO89's Avatar
 
Join Date: Feb 2009
Posts: 2,711
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 77 Post(s)
Liked: 73
If you unplug the power to the amplifier without physically removing the amp from the circuit, you will only get the strongest signals.

Use whatever configuration works best.
ProjectSHO89 is offline  
Old 07-22-2014, 03:59 PM
Advanced Member
 
bac522's Avatar
 
Join Date: Jan 2003
Posts: 906
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 49 Post(s)
Liked: 53
Quote:
Originally Posted by Duke02 View Post
I've read that using an amplifier can result in an overdriven signal and actually hurt PQ if it's not needed, so I unplugged the amplifier to see what the signal strength is unamplified.
You would notice PQ being affected if the tuner was being over-driven similar to a signal not being strong enough. My guess is you're probably seeing no difference between the PQ at 100% and at 60-75%...where you'll have the problem is losing channels that were weak before and now no longer work. If you want to channels too, then turn the Amp back on.
bac522 is offline  
 
Thread Tools


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off