TV outputs sound via optical only during sound test - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
Thread Tools
post #1 of 4 Unread Today, 02:37 PM - Thread Starter
Newbie
 
Join Date: Mar 2017
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 0
TV outputs sound via optical only during sound test

I just got a new integrated amp and when I connect the optical out from my Samsung PN58C550G1FXZA to the amp I don't get any sound. When I connect a CD player to the amp optical in using the same cables I get sound, so I know the cable is good (have tried 2 diff. cables). Here's the kicker, when I do a self-diagnosis on the sound (via menu settings) it plays sound out of the speakers! That makes no sense.

I have it set to TV speakers because no sound comes out using external speakers. I initiated a chat with Samsung support and they said I needed a technician. But I get sound during self-diagnosis sound test. Any ideas on what could be wrong. Has anyone seen something similar on other TVs? Everything was working with my old amp. Same cables, same TV, etc. All I did was switch out the amp. But the optical in on the amp is working.

Thanks in advance.

Ken
treebeard1 is online now  
Sponsored Links
Advertisement
 
post #2 of 4 Unread Today, 05:07 PM
Member
 
Channel99's Avatar
 
Join Date: Feb 2012
Posts: 195
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 55 Post(s)
Liked: 19
Quote:
Originally Posted by treebeard1 View Post
I just got a new integrated amp and when I connect the optical out from my Samsung PN58C550G1FXZA to the amp I don't get any sound. When I connect a CD player to the amp optical in using the same cables I get sound, so I know the cable is good (have tried 2 diff. cables). Here's the kicker, when I do a self-diagnosis on the sound (via menu settings) it plays sound out of the speakers! That makes no sense.

I have it set to TV speakers because no sound comes out using external speakers. I initiated a chat with Samsung support and they said I needed a technician. But I get sound during self-diagnosis sound test. Any ideas on what could be wrong. Has anyone seen something similar on other TVs? Everything was working with my old amp. Same cables, same TV, etc. All I did was switch out the amp. But the optical in on the amp is working.

Thanks in advance.

Ken
There should be a setup menu selection for SPDIF output - try changing the setting. My Samsung feeds only a soundbar and is set to Dolby. However if I change to PCM, it will, not unexpectedly, give only very weak audio. If that is not the issue, you may want to post under the Display Devices section in LCD Flat Panel Displays.
Channel99 is online now  
post #3 of 4 Unread Today, 05:10 PM
AVS Forum Addicted Member
 
Otto Pylot's Avatar
 
Join Date: May 2004
Location: San Jose, CA
Posts: 10,867
Mentioned: 3 Post(s)
Tagged: 1 Thread(s)
Quoted: 1402 Post(s)
Liked: 878
If you are going to use optical out from your tv to the receiver you need to disable the tv speakers and make sure you select the correct input on the receiver or have it setup correctly. I use the receiver as the hub of our HTS so all of the devices are connected directly to the receiver with a single HDMI cable for video connecting the receiver to the tv and an optical cable from the tv to the receiver for OTA television audio. The TV audio setting is disabled.
Otto Pylot is online now  
 
post #4 of 4 Unread Today, 05:31 PM - Thread Starter
Newbie
 
Join Date: Mar 2017
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 0
Channel99,
My only option is PCM. Dolby is greyed out. I have a 2-channel amp.

Otto Pylot,
It's connected correctly. I only have one optical input on my integrated amp so it's kinda hard to mess it up . It was working before with my old DAC, just not when I plugged in the integrated. But like I said, other devices, like CD, can play through the optical, just not the TV. This is the same setup I had before using TV speakeers and it worked. If I switch to external speakers there is no sound. Same with my old setup.
treebeard1 is online now  
Sponsored Links
Advertisement
 
Reply HDTV Technical

Tags
audio prob , samsung 58 inch plasma hdtv pn58c550
Gear in this thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off