JVC RS20 and complete theater system - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 3 Old 03-11-2013, 10:31 AM - Thread Starter
Senior Member
 
Frosteh's Avatar
 
Join Date: Jun 2011
Posts: 304
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 16
I've got a very high end theater setup that I'm sad to sell, but other things in life are beckoning! I'd like to get $9000 for it (a very reasonable offer, in my opinion) but I'll entertain fair offers below that. I'm also open to part them out, but the individual parts cost more than the whole.

Here's the setup:

Video:
JVC RS20 projector (30 hours on bulb)
Panamorph UH480 anamorphic lens

Amplification:
Denon 3311CI AVR
Behringer EP2500 amplifier (for the subwoofer)

Speakers:
3x 4Pi speakers for LCR using fully upgraded drivers (B&C DE250 and JBL 2226H) and upgraded crossover inductors (see www.pispeakers.com for info or search the forums about these)
4x JBL 8340 cinema series speakers for the side and rear surrounds (the original MDF ones, not the plastic ones that are currently being made)
1x Custom subwoofer using JBL 2242H 18" driver (subwoofer box identical to the JBL 4645C cinema subwoofer, except that I've used a different port to tune it to 22Hz instead of 25Hz as it comes out of the factory)

Some minor issues:
The projector has a thin blue band that runs vertically on the rightmost side of the picture. It is out of the picture for Blu Rays (I think XBMC clips it just slightly) but is visible during other content. It goes away after about 15-20 mins of use after the projector warms up. You can use the mask feature on the projector, which works well too.
The Panamorph lens has a chip in the glass in the upper left corner. However, the chip is completely out of the image at all throw ranges for this projector so it makes zero difference. The lens still works flawlessly.
Overall, the theater has seen a bit of use, so there are some scratches and nicks here and there, but nothing that affects the performance and, frankly, isn't noticeable unless you're really looking for them. I just wanted to be open.

Shoot me a PM if you'd like a demo or to see pictures of the system. I'm located in Bellingham, WA, but I'd be open to drive to meet you somewhere as far south as Seattle or the Eastside (Bellevue, Kirkland, Redmond).

Frosteh is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 03-11-2013, 03:39 PM
AVS Special Member
 
barhoram's Avatar
 
Join Date: Jan 2002
Posts: 2,409
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 37 Post(s)
Liked: 14
How old is the projector, and is it still under warranty?

I don't really like talking about my flair

My Home Theater Project:
barhoram is online now  
post #3 of 3 Old 03-11-2013, 03:51 PM - Thread Starter
Senior Member
 
Frosteh's Avatar
 
Join Date: Jun 2011
Posts: 304
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 16
Hi there,

Projector is not under warranty. This one was shipped to the original buyer in January of 2009 (I have the original receipt) so it is about 4 years old. I don't believe there are any JVC RS10/20/HD350/750's with warranty left since they stopped making these in 2009 and they only had a 3 year warranty.

Despite the age, however, this unit works perfectly minus the blue band on the right side which I mentioned.

Frosteh is offline  
Reply Front Projector

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off