Problem HTPC - ATI blacks/brightness varies constantly with MPEG2 and EVR/VMR9 - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 11 Old 09-02-2008, 10:29 AM - Thread Starter
Newbie
 
Budje's Avatar
 
Join Date: Jan 2008
Location: Netherlands
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Relevant Specs:
Gigabyte 780G motherboard, onboard ATI 3200
CPU AMD X2 3800EE SFF
Panasonic 42PZ85 plasma, connected via HDMI (All picture improvement' settings off)
FloppyDTV DVB-C digital tv card
and the usual stuff.

Software used,
- Vista Media Center. All known updates
- Haali splitter,
- AC3 filter
- CoreAVC Professional
For testing I use also
- Media Player Classic,
- Cyberlink PowerDVD 7.3 Ultra,
- DVBviewer
- Ffdshow

ATI driver Catalyst 8.8 (tried other drivers but all gave the same results)

I have one major very irritating problem (okay my wife DOES NOT see itbut I do).
Normally I prefer to use Vista Media Center for all viewing purposes, so DVD (MPEG-2), DVB-C (MPEG-2) and MKV (H.264/X.264).
I have a mostly washed out picture, with all contents I normally watch, MPEG2 and MKV's. It is not always just washed out, but it's varies constantly depending on the light in that scene. With very bright scenes, the minor blacks are black as they are opposed to be. But when the scnes are getting darker, the blacks are turning into darkgrey. It looks like a dynamic' brightness or something. This is very annoying to watch. It is especially noticed on the black bar's of a widescreen movie, you can just watch the movie and constant changing the blackiness of the black bars!

I read hours and hours but found nothing exactly similar to my findings, but I learned a lot about VMR9, YV12, RGB32, 0-255/16-236 levels and so on. I do think though it's all connected
So I tried several things:

First little success:
When I installed CoreAVC and made this the preferred HD decoder, the problem went away for MKV files. Hurray! But of course it changed nothing for MPEG-2.
So now I was sure the ATI card was cabable to send a perfectly acceptable signal to my TV and the problem would probably not go away by fiddling with drivers.

Now the suspect was the MPEG-2 decoder. So I tried a lot of decoders (Vista's own decoder, PowerDVD decoder, ATI's decoder and some more).
The problem stayed exactly the same. So the MPEG-2 decoders could not do much about it (till then)

Next suspect, the output renderer. Vista Media Center always uses the own EVR/VMR9 renderer. You cannot change it, sadly. But I could try more software from which I could change the renderer as MPC and DVBViewer.
When I started a DVD in MPC, the problem was the same. However, when I changed the outputrenderer to Overlay, the problem went away.
When I was seeing a MPEG-2 stream from my DVB-C decoder in DVBviewer, the problem was the same. However, when I changed the outputrenderer to 'DirectX Video Renderer' the problem went away.
AHA, so far, by changing the VMR9/EVR renderer to the Overlay renderer the problem does not exists.

But that's no solution because I want to use Media Center. Even Media Portal uses VMR9 so that was no second choice either.

Then I read something about the FFDSHOW settings you can change, as LEVELS. So I installed FFDSHOW, only the MPEG-2 decoder, and changed the LEVELS-tab for the inputlevel 16-236. Also ticked the Use full range. Then I changed the Mediacenter decoder so it used the FFDSHOW decoder in stead of the own MPEG-2 deocder, and the problem went awayhurray. But euhhhno, that's a not-so-nice decoder, aliasing is bad, noise is bad, and deinterlacing is bad. And Mediacenter thinks I am not using my pc and gets me the screensaver after x minutes. So FFDSHOW would need a lot of additional tweaking.

What is happening here? Is my conclusion correct, the mapping between the MPEG2 decoder and the VMR9 renderer is not functioning properly??? CoreAVC is capable to change something at inputlevels (is set to Automatic), and FFDSHOW is capable to change something at inputlevels.

Are there people who have similar findings? When I read similar topics I got a feeling you have all problems with constant washed out pictures (not variying). When I had that, I could at least lower the brightness on my plasma, but I cannot use such a trick. Because that would only shift my problem (the blacks in bright scenes would be blacker then needed)
I also tried the UseBT601CSC=1 register setting, but this changed nothing.

Or am I missing something here completely?
Budje is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 09-03-2008, 06:12 AM
Senior Member
 
el Filou's Avatar
 
Join Date: Aug 2008
Location: Belgium
Posts: 221
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
With the HD 4xxx series of cards ATI introduced "Dynamic Contrast" (another useless feature on which their engineers wasted their time instead of fixing the list of 12-months old bugs... ), maybe it's also enabled in the HD 3200?

Check in CCC if you have a Dynamic Contrast option in Avivo settings.
el Filou is offline  
post #3 of 11 Old 09-04-2008, 06:08 AM - Thread Starter
Newbie
 
Budje's Avatar
 
Join Date: Jan 2008
Location: Netherlands
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Yep I know that setting. But it is indeed only for the new 4850 en 4870 cards. I saw the setting in the register, but it has the value =0, what is what I would expect.
Budje is offline  
post #4 of 11 Old 09-04-2008, 01:26 PM - Thread Starter
Newbie
 
Budje's Avatar
 
Join Date: Jan 2008
Location: Netherlands
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Solved. Via DXVAchecker I could change the UseBT601CSC setting to 1. This time it succeeded.
Budje is offline  
post #5 of 11 Old 01-23-2009, 03:13 AM
Newbie
 
Alex_Smithson's Avatar
 
Join Date: Jan 2009
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hi guys,

I seem to have a very similar problem to the one described by Budje, i.e. I have constantly varying brightness of the accelerated HD-video (H.264/AVC, MPEG2 etc.). This is encountered on BD-discs using both PowerDVD8 and Arcsoft Total MediaTheatre when using the "hardware acceleration" settings. No such problem is encountered when it is switched off, but obviously it's not an option for such a processor-heavy media.

My setup is:
Intel Core2Duo 2.2 GHz
WinXP SP2
ATI Radeon HD 4650
Catalyst 8.9 (I've tried to switch to 8.12 but it only
screws up the aspect ratio for a secondary display,
while the brightness variations persist).

I've tried the solution that worked for Budje, i.e. changing UseBT601CSC setting to 1 with DXVAChecker, but unfortunately the problem stays.

Anyone has a solution to this?
Alex_Smithson is offline  
post #6 of 11 Old 01-23-2009, 07:14 AM
Member
 
deltronik's Avatar
 
Join Date: Aug 2008
Posts: 22
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I found that this issue was caused by a setting on my lcd for me.
I have a panasonic, can't remember the setting right now... something vr
turned that off and the constantly varying brightness went away.
deltronik is offline  
post #7 of 11 Old 01-23-2009, 07:18 AM
Member
 
tester3001's Avatar
 
Join Date: Jul 2007
Posts: 19
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I have the same problem with my 4350. Makes me want to switch back to nvidia.
tester3001 is offline  
post #8 of 11 Old 01-23-2009, 07:36 AM
Newbie
 
Alex_Smithson's Avatar
 
Join Date: Jan 2009
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Setting on the LCD itself? For me it doesn't seem to be a monitor problem, since I also have absolutely the same problem when I make my secondary display (Panasonic plasma) primary in order to play BD's ona big screen (since we are obviously not allowed to have a dual-display playback). No matter which display is active, plasma or LCD, the brightness constantly varies all the same.

I used to have a Radeon HD2600XT and didn't have this problem (but no HD-sound either). Now that I've switched to the 4650 for the HDMI-7.1 sound, I have great sound but crappier video. I wonder if anyone knows what the exact problem is (ATI drivers, something in the system or some other settings) and the way around it.
Alex_Smithson is offline  
post #9 of 11 Old 01-23-2009, 11:56 AM
Member
 
kosta20071's Avatar
 
Join Date: Jan 2009
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
have the same problem...
i've got 4850HD and pioneer pdp-428XD which is connected via dvi/hdmi cable.
I use vista 64bit and 8/12 driver.
On scenes where almost all the screen is dark the blacks look brighter on bright scenes the blacks look perfect :'\\
plsss help!
kosta20071 is offline  
post #10 of 11 Old 01-24-2009, 11:32 AM
Newbie
 
Alex_Smithson's Avatar
 
Join Date: Jan 2009
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
OK, solved this one for myself. From a lot of experimenting it has become obvious that the brightness changes were not just specific to a hardware acceleration (tried MPC with Cyberlink H.264/AVC decoder - no such problem), but appeared exclusively when the AVIVO was used, which both PowerDVD and Arcsoft TMT do. Finally I've found a setting in the CCC: Avivo Video-All Settings-Enable Dynamic Contrast, and turned the bloody thing OFF! But it took a really long time to find it, since it is not available in the ATI Tray Tools, only in the CCC itself, and it's hidden at the very bottom line of the Advanced Options.

I don't know what they were thinking at the ATI turning this on by default - the feature really works horribly, it completely screws up the video (stuff like white-on-black movie end credits looks something like white-on-medium gray). And the most irritating thing is it is only supposed to be implemented in the 4800 series!

Anyway, I'm happy with my HD4650 now, good picture and really superb sound via HDMI. Hope this helps some other poor soul like me who did not expect this half-ass feature to be active.
Alex_Smithson is offline  
post #11 of 11 Old 01-03-2013, 11:10 PM
AVS Special Member
 
b_scott's Avatar
 
Join Date: Jan 2008
Location: Chicago
Posts: 6,662
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 14
for the black bars:
Quote:
If you are using an AMD (ATI) graphics card and getting a black border or zoomed out effect when connected to your monitor using HDMI, you need to adjust the overscan setting in catalyst control panel. Further more you need to do this for every different refresh rate and resolution to fix the problem in 3d modeslike running games fullscreen.
Open Catalyst, drop down graphics and select ‘Desktop & Displays’. Then right click on the small screen at the bottom and click configure. Enable GPU scaling, then click on the ‘Scaling Options’ tab and set underscan to 0%. Click apply. Don’t close the window.
Now right click on the windows desktop. Select screen resolution and advanced settings. Select monitor and change the refresh rate to all the different rates. For each one, apply, then go back into catalyst and set the underscan setting to 0% again. Repeat for all desired combinations of resolution and refresh rate.
Now the borders should have gone.

this fixes it.
b_scott is offline  
Reply Home Theater Computers

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off