ATI Radeon 3870 - Horizontal scan lines during video playback - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 20 Old 09-10-2008, 07:53 PM - Thread Starter
Member
 
bnieman's Avatar
 
Join Date: May 2006
Posts: 191
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Video content, including all video played through Windows Media Player and YouTube via Internet Explorer or FireFox, yield horizontal scan lines during playback. The lines appear for a fraction of a second during fast panning, action, or abrupt scene changes. The problem is extremely noticeable when trying to watch a movie and is very distracting. When viewing a video in a window, the scan lines are contained in the video frame and do not affect the rest of the screen. I have tried many different screens including multiple monitors via DVI and a HDTV home theater projector via HDMI.



I cannot take a screen shot of the problem, the screen shot displays perfectly. Instead I took the above photo with my digital camera, notice the line in the top half of the picture. Can this be fixed or is it a problem with my video card?

I have gone through all the settings in Catalyst Control Center including pulldown detection and anti-aliasing with no success. The problem has been prevalent since the purchase of the card and has continued through multiple driver updates (currently I am running Catalyst version 8.8).

The problem seems to be worst in Flash videos, MKV, and Xvid files. I have tried (2) different codec packs with the same result with both.


Here is some relevant information:

OS: Windows Vista Ultimate x64
Video Card: MSI Radeon HD 3870 512MB PCI-e
Driver Version: Catalyst 8.8
Memory: 4GB
Processor: Intel Core 2 Quad Core q9300 @ 2.5ghz
Video Players Used: Windows Media Player 11, Media Player Classic, Flash Plugin for Internet Explorer 7, Firefox 2, and Firefox 3
bnieman is offline  
Sponsored Links
Advertisement
 
post #2 of 20 Old 09-10-2008, 08:07 PM
Senior Member
 
sneakerx's Avatar
 
Join Date: Aug 2007
Posts: 326
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
I've noticed that when Aero is turned on I no longer have screen tearing, which is what you are experiencing.
sneakerx is offline  
post #3 of 20 Old 09-10-2008, 08:47 PM - Thread Starter
Member
 
bnieman's Avatar
 
Join Date: May 2006
Posts: 191
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by sneakerx View Post

I've noticed that when Aero is turned on I no longer have screen tearing, which is what you are experiencing.

Sneakerx,
Your suggestion definitely helped but it still isn't flawless. I still get the "screen tearing" just not as often or as bad.

The reason I was not using Aero is when using Aero every so often my screen goes blank for a second and comes back and says "atikmdag stopped responding then recovered". It started happening every few days or so and then recently it started happening a few times a day so I just went to the Vista Basic theme.

Thanks for your suggestion, it definitely makes the video more watchable. Do you think the problem would be non-existent in Windows XP?

Cheers,
Bryan
bnieman is offline  
post #4 of 20 Old 09-11-2008, 04:13 AM
Advanced Member
 
terryj47's Avatar
 
Join Date: Oct 2007
Location: Arleta, CA
Posts: 625
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by bnieman View Post

Sneakerx,
Your suggestion definitely helped but it still isn't flawless. I still get the "screen tearing" just not as often or as bad.

The reason I was not using Aero is when using Aero every so often my screen goes blank for a second and comes back and says "atikmdag stopped responding then recovered". It started happening every few days or so and then recently it started happening a few times a day so I just went to the Vista Basic theme.

Thanks for your suggestion, it definitely makes the video more watchable. Do you think the problem would be non-existent in Windows XP?

Cheers,
Bryan

I get this sometimes while watching a video online while browsing. IE lauches media player. If I download it and watch it it's fine. My HDTV stuff-- live or recorded using Media CENTER is fine although I had to give up on the HD 3870 card due to video stutter. Read my thread by searching for "more media center stuttering". Good luck.
terryj47 is offline  
post #5 of 20 Old 09-11-2008, 04:46 AM
Senior Member
 
sneakerx's Avatar
 
Join Date: Aug 2007
Posts: 326
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Make sure your computer's refresh rate matches whatever your display is capable of(e.g. 60Hz, 59.94Hz, etc). You might want to try Media Player Classic Homecinema as well, and use EVR custom as the renderer. If that doesn't get rid of it then there's also an option in there to turn on vsync, though he calls it something else, to match the video playback to the displays refresh rate eliminating tearing completely. I've posted the following about ATIKMDAG before from the Hellgate: London forums, but haven't had the problem since using Catalyst 8.5 and 8.6, so I don't know if it really works:

-----


http://forums.anandtech.com/messagev...readid=2060689

Basic instructions:

1. From the search box in the start menu run "msconfig.exe"
2. Switch to the boot tab, and open advanced options.
3. At the top of the new box that opens, tick both the "Number of processors" and "Maximum memory" options and set them to the correct values for your system. NOTE THAT MULTIPLE CORES DO NOT MEAN MULTIPLE PROCESSORS!!
4. Also tick the option for "Detect HAL"
5. Click OK to close advanced options. Back on the boot tab tick "Make all boot settings permanent", click apply and confirm your choice. Finally click OK to close msconfig.exe.
6. Restart your system.

After these changes I immediately found my system both more responsive and more stable. I usually was seeing the ATIKMDAG error within minutes of loading the system, but now have not seen the error in 10+ hours puttering around windows. The crashes in HG:L have also not reappeared after 4+ hours in game (Usually I could only play for 30-45 minutes before crashing or freezing).
sneakerx is offline  
post #6 of 20 Old 09-11-2008, 07:56 AM - Thread Starter
Member
 
bnieman's Avatar
 
Join Date: May 2006
Posts: 191
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by terryj47 View Post

I get this sometimes while watching a video online while browsing. IE lauches media player. If I download it and watch it it's fine. My HDTV stuff-- live or recorded using Media CENTER is fine although I had to give up on the HD 3870 card due to video stutter. Read my thread by searching for "more media center stuttering". Good luck.

Terry,
I perused your 4 page thread on video stuttering, I am sorry you had to go through that! I hate problems like which is what my problem seems to be turning into I am glad you were able to get your system running smoothly though.

I get the tearing on web videos and downloaded material, although turning Aero on seemed to alleviate most if not all tearing on web content. Now I am just dealing with tearing on downloaded content (although not as severe as the screen shot I posted as that was what the web video was doing).

I will post any updates here.

bryan
bnieman is offline  
post #7 of 20 Old 09-11-2008, 08:11 AM
Senior Member
 
magnusr's Avatar
 
Join Date: Apr 2007
Posts: 429
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 16 Post(s)
Liked: 10
I have this if both monitors is enabled and playing video. If I make my 42" the main screen and disable the second screen in control center wizard, problem goes away. This is on 4850.

AMP: Hegel H100, DAC: Arcam rDAC, Speakers: Tannoy Revolution Signature DC6T, TV: LG Oled 55EC930V (US: 5EC9300), HTPC: ATI 280x, Windows 8.1 with blu-ray
magnusr is offline  
post #8 of 20 Old 09-11-2008, 08:19 AM - Thread Starter
Member
 
bnieman's Avatar
 
Join Date: May 2006
Posts: 191
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by magnusr View Post

I have this if both monitors is enabled and playing video. If I make my 42" the main screen and disable the second screen in control center wizard, problem goes away. This is on 4850.

Magnusr,

Thank you for your input. I have tried to disable the second screen and it had no affect on the problem.

Bryan
bnieman is offline  
post #9 of 20 Old 09-11-2008, 08:30 AM - Thread Starter
Member
 
bnieman's Avatar
 
Join Date: May 2006
Posts: 191
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by sneakerx View Post

Make sure your computer's refresh rate matches whatever your display is capable of(e.g. 60Hz, 59.94Hz, etc). You might want to try Media Player Classic Homecinema as well, and use EVR custom as the renderer. If that doesn't get rid of it then there's also an option in there to turn on vsync, though he calls it something else, to match the video playback to the displays refresh rate eliminating tearing completely. I've posted the following about ATIKMDAG before from the Hellgate: London forums, but haven't had the problem since using Catalyst 8.5 and 8.6, so I don't know if it really works:

-----


http://forums.anandtech.com/messagev...readid=2060689

Basic instructions:

1. From the search box in the start menu run "msconfig.exe"
2. Switch to the boot tab, and open advanced options.
3. At the top of the new box that opens, tick both the "Number of processors" and "Maximum memory" options and set them to the correct values for your system. NOTE THAT MULTIPLE CORES DO NOT MEAN MULTIPLE PROCESSORS!!
4. Also tick the option for "Detect HAL"
5. Click OK to close advanced options. Back on the boot tab tick "Make all boot settings permanent", click apply and confirm your choice. Finally click OK to close msconfig.exe.
6. Restart your system.

After these changes I immediately found my system both more responsive and more stable. I usually was seeing the ATIKMDAG error within minutes of loading the system, but now have not seen the error in 10+ hours puttering around windows. The crashes in HG:L have also not reappeared after 4+ hours in game (Usually I could only play for 30-45 minutes before crashing or freezing).

Sneakerx,
I have matched the computer's refresh rate with rates capable by the monitors.

I tried your suggestion of using Media Player Classic Home Cinema and the problem still persists. I tried using EVR as the renderer and enabling the screen tearing option. I tried both x86 (32bit) and x64 (64bit) version of the application and tearing was the same on both, but the video quality was DRASTICALLY worse on the x64 version. It made the video look highly compressed and blotchy.

If the atikmdag error comes upa again I will try your solution, but for now I am going to concentrate on the tearing.

Thanks for your ideas! Very good input. I will keep working on it and report back.

Bryan
bnieman is offline  
post #10 of 20 Old 09-15-2008, 05:14 PM - Thread Starter
Member
 
bnieman's Avatar
 
Join Date: May 2006
Posts: 191
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by sneakerx View Post

Make sure your computer's refresh rate matches whatever your display is capable of(e.g. 60Hz, 59.94Hz, etc). You might want to try Media Player Classic Homecinema as well, and use EVR custom as the renderer. If that doesn't get rid of it then there's also an option in there to turn on vsync, though he calls it something else, to match the video playback to the displays refresh rate eliminating tearing completely. I've posted the following about ATIKMDAG before from the Hellgate: London forums, but haven't had the problem since using Catalyst 8.5 and 8.6, so I don't know if it really works:

-----


http://forums.anandtech.com/messagev...readid=2060689

Basic instructions:

1. From the search box in the start menu run "msconfig.exe"
2. Switch to the boot tab, and open advanced options.
3. At the top of the new box that opens, tick both the "Number of processors" and "Maximum memory" options and set them to the correct values for your system. NOTE THAT MULTIPLE CORES DO NOT MEAN MULTIPLE PROCESSORS!!
4. Also tick the option for "Detect HAL"
5. Click OK to close advanced options. Back on the boot tab tick "Make all boot settings permanent", click apply and confirm your choice. Finally click OK to close msconfig.exe.
6. Restart your system.

After these changes I immediately found my system both more responsive and more stable. I usually was seeing the ATIKMDAG error within minutes of loading the system, but now have not seen the error in 10+ hours puttering around windows. The crashes in HG:L have also not reappeared after 4+ hours in game (Usually I could only play for 30-45 minutes before crashing or freezing).

I tried following the above steps to resolve the ATIKMDAG error but it did not help. Today the error came up about 6 times in a row followed by a blue screen of death. I am thinking about reinstalling Vista and forgoing the Catalyst Control Center. Does anyone know if I can still set the output to my projector to 24hz without CCC? What other functionality do I lose?

I think enabling Aero fixed the screen tearing issue but intermittent times during playback of AVI and MKV files there is still a line of pixels that do not match up with the rest of the image. The location of this line varies... it is not very noticeable and if I wasn't the perfectionist I am I probably wouldn't notice it. I want to run some more tests with different source material, I will report back in case anyone is watching this thread.
bnieman is offline  
post #11 of 20 Old 10-24-2008, 01:20 PM
Newbie
 
infoman9's Avatar
 
Join Date: Oct 2008
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
This has got to be a problem with ATI Catalyst. All worked great until I used it to change an option and all of a sudden one night I noticed my screen saver had the exact same symtom as the pic below.

Also games and vids won't display without it. I've tried every conceivable combination of resolutions and scan rates but nothing works to get rid of it.

Going to try completely removing Catalyst and will post back if I'm successful.

Otherwise MAinGear is sending me a new card to try out.
infoman9 is offline  
post #12 of 20 Old 10-24-2008, 03:02 PM
Newbie
 
infoman9's Avatar
 
Join Date: Oct 2008
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Removed all drivers and ati catalyst software. no luck.

Still have what looks like pic at top of thread. Worse with higher gpu load.

I'm not a happy camper.
infoman9 is offline  
post #13 of 20 Old 10-24-2008, 07:03 PM
AVS Special Member
 
nintari's Avatar
 
Join Date: May 2002
Posts: 1,593
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 13
in your 3D options go to all settings and set v-sync to always on, then try things out
nintari is offline  
post #14 of 20 Old 10-24-2008, 08:45 PM
Newbie
 
infoman9's Avatar
 
Join Date: Oct 2008
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Ok, I have eliminated the tearing. What I did: (I hope I can get this straight)

Uninstalled all ATI.
Uninstalled video card entries from device mgr without restarting
manually updated ati card drivers from cd instead of running ati installer
installed ati ccc
rebooted

seems to have fixed my problems

Note: With wait for vertical refresh (vsync) on I was still having the problem before I performed above procedure. Now there is minimal tearing and only with gpu intensive stuff. With vsync checked there is no evidence of tearing whatsoever. Looks Great!

If anyone else can't get this to work I'll backtrack and try it again to make sure I got my steps right.

This is obviously a driver/ati control center problem. Oh, I'm using the beta download of catalyst 8.6, not the regular one.
infoman9 is offline  
post #15 of 20 Old 10-27-2008, 01:03 PM
Newbie
 
infoman9's Avatar
 
Join Date: Oct 2008
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Wow, I hate to think I went through all that for nothing but that may be the case.

After updating to all latest versions and getting the problem back I realized that Wait for Vertical Refresh setting was somehow reverting to "off unless app specifies". Why would this change?

After setting it back to "on unless app specifies" my tearing prob goes away. If a game or app chooses to not wait for vertical refresh does the option revert to the default setting in CCC?

?????
infoman9 is offline  
post #16 of 20 Old 11-10-2008, 09:31 AM
Member
 
toolio's Avatar
 
Join Date: Apr 2005
Posts: 21
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I have experienced the tearing problem on a number of different ATI cards, all on different computers, all connected with different TVs and using various versions of Catalyst.

In all cases, it exists only when the card is running a monitor and TV simultaneously. If I configure a profile for TV only, it seems to go away.

I am getting the same thing again with a 4670 i just installed a week or so ago.
toolio is offline  
post #17 of 20 Old 03-22-2011, 01:27 PM
Member
 
sannitig's Avatar
 
Join Date: Jan 2011
Posts: 67
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Did you end up fixing this? My ATI HD 4250 is doign the same thing with the horizontal lines.

I managed to enable Aero and the image does not have the lines anymore. The panning is still a little choppy though.

I may just install an nVidia card and use that instead of the intergrated one.

Let me know if you solved this completely.

I knowit's an old thread but there is not much info in this issue on the web from what I could see.
sannitig is offline  
post #18 of 20 Old 03-22-2011, 03:30 PM - Thread Starter
Member
 
bnieman's Avatar
 
Join Date: May 2006
Posts: 191
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I never did fix it completely. I built a new system a while ago. Good luck!
bnieman is offline  
post #19 of 20 Old 12-13-2011, 01:02 PM
Newbie
 
Andrew.Hall's Avatar
 
Join Date: Dec 2011
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Want to know what is hilarious?

I just bought a new top-of-the-line Sapphire Radeon 9850, and this scanline / vsync-is-out-of-sync problem is STILL present.

But I have fixed 50% of the problem or so, at least, by one simple option switch:

This better make everyone laugh.

I turned off "Smooth Video Playback" in the Catalyst Center.

It apparently seems to be something designed to improve vsync that does it TERRIBLY badly. I turned it off and the scanline problem only appeared on the fastest motion cuts of video, instead of on most moving cuts; which is good, because otherwise I would have taken the card back!

In general the speed of this card is insanely good; but the polish (vsync/software) is not. Still, hard to complain too much when this makes the vsync problem MUCH less noticeable and I can run full 1080p video at 60Hz and no frameskip!
Andrew.Hall is offline  
post #20 of 20 Old 12-13-2011, 01:29 PM
Newbie
 
Andrew.Hall's Avatar
 
Join Date: Dec 2011
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
By the way, as far as YouTube goes - something very odd here - I turned on triple buffering on OpenGL and seemed to INSTANTLY notice a difference. If YouTube or other video applications are using any kind of approach reliant on 3D technologies, that could actually make a difference.

Now even in a video with fast cuts, there are only a few noticeable scanlines.

It's not perfect, but wow, it's a lot better, and this 9850 zips through 1080p at 60 frames per second with no problems other than that. It's really quite nice on the whole.

Seems like a problem inherent to Radeons; I might write a letter to AMD about it.

Hope this helps anyone who bought a new card and came across this problem, even on this old thread!
Andrew.Hall is offline  
Reply Home Theater Computers

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off