EDID Override Thread - Page 19 - AVS Forum
Forum Jump: 
 2Likes
Reply
 
Thread Tools
post #541 of 3199 Old 01-06-2010, 09:46 PM
AVS Special Member
 
vladd's Avatar
 
Join Date: Jun 2006
Location: Louisville, KY
Posts: 5,469
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 36
@ewilts: When you are reading the saving the MonInfo report, are you selecting the entries that say "[Real-time 0x...]? If you are selecting the enties that say "[Registry*]", it will only give the main block and not the extension block.
vladd is offline  
Sponsored Links
Advertisement
 
post #542 of 3199 Old 01-09-2010, 09:08 AM
Newbie
 
Domingo_X's Avatar
 
Join Date: Dec 2009
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I'm in need of a little help. I've got a Samsung HL-T6176S TV (DLP) and it's hooked up to a Sony STR-DN1000.
I've tried using Tulli's fix (both the Denon and Onylo) in order to get bistreaming to work, however it only allows my TV to display 1080i.
Normally I'd get their values from moninfo and create my own EDID file, but I'm running an ATI 5x card and I guess the moninfo information using those cards isn't correct.
Anyone have any suggestions? I've tried mixing different values posted in this thread, but either I don't get bistreaming or they bungle my display.
Anyone have any values for my hardware or some way to get moninfo information from a 5x card?
Any help would be appreciated.
Domingo_X is offline  
post #543 of 3199 Old 01-09-2010, 09:16 AM
AVS Club Gold
 
Tulli's Avatar
 
Join Date: Nov 2001
Posts: 5,200
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 37 Post(s)
Liked: 84
Quote:
Originally Posted by Domingo_X View Post

I'm in need of a little help. I've got a Samsung HL-T6176S TV (DLP) and it's hooked up to a Sony STR-DN1000.
I've tried using Tulli's fix (both the Denon and Onylo) in order to get bistreaming to work, however it only allows my TV to display 1080i.
Normally I'd get their values from moninfo and create my own EDID file, but I'm running an ATI 5x card and I guess the moninfo information using those cards isn't correct.
Anyone have any suggestions? I've tried mixing different values posted in this thread, but either I don't get bistreaming or they bungle my display.
Anyone have any values for my hardware or some way to get moninfo information from a 5x card?
Any help would be appreciated.

The modded drivers on the PDVD9 thread have video tiimings from my Samsung LCD TV that don't work for your DLP TV, so it seems.

Just post the full 256-bytes EDID of your AVR (with the DLP TV HDMI-connected to it of course) to take a look at it. I'll post a modded driver to see if it solves your video issues.

EDID Overrides (capture, install/uninstall, troubleshooting)
Tulli is offline  
post #544 of 3199 Old 01-09-2010, 10:12 AM
Newbie
 
Domingo_X's Avatar
 
Join Date: Dec 2009
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Here's what Moninfo pulls for me as an INF. If another format works better, definitely let me know
Here's the receiver:

; INF file generated by Monitor Asset Manager, 1/9/2010
; Copyright (c) EnTech Taiwan, 1995-2009.
; Internet: http://www.entechtaiwan.com

[Version]
Signature="$WINDOWS NT$"
Class=Monitor
ClassGUID={4d36e96e-e325-11ce-bfc1-08002be10318}
Provider=%MFG%
DriverVer=1/9/2010, 1.0.0.0
;CatalogFile=YourSignedCatalogFile.cat

[DestinationDirs]
DefaultDestDir=23

[SourceDisksNames]
1=%DISC%

[SourceDisksFiles]
;YourColorProfileFile.icm

[Manufacturer]
%VENDOR%=EDID_OVERRIDE,NTx86,NTamd64

[EDID_OVERRIDE.NTx86]
%PRODUCTID%=OVERRIDDEN-EDID.Install, MONITOR\\SNY9301

[EDID_OVERRIDE.NTamd64]
%PRODUCTID%=OVERRIDDEN-EDID.Install.NTamd64, MONITOR\\SNY9301

[OVERRIDDEN-EDID.Install.NTx86]
DelReg=DEL_CURRENT_REG
AddReg=OVERRIDDEN-EDID.AddReg, MODE1, DPMS
CopyFiles=OVERRIDDEN-EDID.CopyFiles

[OVERRIDDEN-EDID.Install.NTamd64]
DelReg=DEL_CURRENT_REG
AddReg=OVERRIDDEN-EDID.AddReg, MODE1, DPMS
CopyFiles=OVERRIDDEN-EDID.CopyFiles

[OVERRIDDEN-EDID.Install.NTx86.HW]
AddReg=OVERRIDDEN-EDID_AddReg

[OVERRIDDEN-EDID.Install.NTamd64.HW]
AddReg=OVERRIDDEN-EDID_AddReg

[OVERRIDDEN-EDID_AddReg]
;Base EDID
HKR,EDID_OVERRIDE,"0",0x01,0x00,0xFF,0xFF,0xFF,0xFF,0xFF,0xFF,0x00,0x4D,0xD9,0x01 ,0x93,0x01,0x01,0x01,0x01,0x0A,0x13,0x01,0x03,0x80,0x10,0x09 ,0x78,0x0A,0xCF,0x9B,0xA3,0x57,0x4C,0x9E,0x26,0x0F,0x4A,0x4C ,0x20,0x00,0x00,0x01,0x01,0x01,0x01,0x01,0x01,0x01,0x01,0x01 ,0x01,0x01,0x01,0x01,0x01,0x01,0x01,0x02,0x3A,0x80,0x18,0x71 ,0x38,0x2D,0x40,0x58,0x2C,0x45,0x00,0xA0,0x5A,0x00,0x00,0x00 ,0x1E,0x01,0x1D,0x80,0x18,0x71,0x1C,0x16,0x20,0x58,0x2C,0x25 ,0x00,0xA0,0x5A,0x00,0x00,0x00,0x9E,0x00,0x00,0x00,0xFC,0x00 ,0x53,0x4F,0x4E,0x59,0x20,0x41,0x56,0x41,0x4D,0x50,0x0A,0x20 ,0x20,0x00,0x00,0x00,0xFD,0x00,0x3B,0x3D,0x1E,0x44,0x0F,0x00 ,0x0A,0x20,0x20,0x20,0x20,0x20,0x20,0x01,0x69

[DEL_CURRENT_REG]
HKR,MODES
HKR,EDID_OVERRIDE
HKR,,MaxResolution
HKR,,DPMS
HKR,,ICMProfile

[DPMS]
HKR,,DPMS,,0

[MODE1]
HKR,,MaxResolution,,"1920,1080"

[OVERRIDDEN-EDID.AddReg]
HKR,"MODES\\1920,1080",Mode1,,"30.0-68.0,59.0-61.0,+,+"

[OVERRIDDEN-EDID.CopyFiles]
;YourColorProfileFile.icm

[Strings]
MFG="EnTech Taiwan"
DISC="Monitor EDID Override Installation Disk"
PRODUCTID="SONY AVAMP (EDID Override)"
VENDOR="Sony"

Here's the TV listing I got when going right into the TV:

; INF file generated by Monitor Asset Manager, 1/9/2010
; Copyright (c) EnTech Taiwan, 1995-2009.
; Internet: http://www.entechtaiwan.com

[Version]
Signature="$WINDOWS NT$"
Class=Monitor
ClassGUID={4d36e96e-e325-11ce-bfc1-08002be10318}
Provider=%MFG%
DriverVer=1/9/2010, 1.0.0.0
;CatalogFile=YourSignedCatalogFile.cat

[DestinationDirs]
DefaultDestDir=23

[SourceDisksNames]
1=%DISC%

[SourceDisksFiles]
;YourColorProfileFile.icm

[Manufacturer]
%VENDOR%=EDID_OVERRIDE,NTx86,NTamd64

[EDID_OVERRIDE.NTx86]
%PRODUCTID%=OVERRIDDEN-EDID.Install, MONITOR\\SAM029C

[EDID_OVERRIDE.NTamd64]
%PRODUCTID%=OVERRIDDEN-EDID.Install.NTamd64, MONITOR\\SAM029C

[OVERRIDDEN-EDID.Install.NTx86]
DelReg=DEL_CURRENT_REG
AddReg=OVERRIDDEN-EDID.AddReg, MODE1, DPMS
CopyFiles=OVERRIDDEN-EDID.CopyFiles

[OVERRIDDEN-EDID.Install.NTamd64]
DelReg=DEL_CURRENT_REG
AddReg=OVERRIDDEN-EDID.AddReg, MODE1, DPMS
CopyFiles=OVERRIDDEN-EDID.CopyFiles

[OVERRIDDEN-EDID.Install.NTx86.HW]
AddReg=OVERRIDDEN-EDID_AddReg

[OVERRIDDEN-EDID.Install.NTamd64.HW]
AddReg=OVERRIDDEN-EDID_AddReg

[OVERRIDDEN-EDID_AddReg]
;Base EDID
HKR,EDID_OVERRIDE,"0",0x01,0x00,0xFF,0xFF,0xFF,0xFF,0xFF,0xFF,0x00,0x4C,0x2D,0x9C ,0x02,0x00,0x00,0x00,0x00,0x2D,0x10,0x01,0x03,0x80,0x10,0x09 ,0x78,0x0A,0xCF,0x9B,0xA3,0x57,0x4C,0x9E,0x26,0x0F,0x4A,0x4C ,0x20,0x00,0x00,0x01,0x01,0x01,0x01,0x01,0x01,0x01,0x01,0x01 ,0x01,0x01,0x01,0x01,0x01,0x01,0x01,0x02,0x3A,0x80,0x18,0x71 ,0x38,0x2D,0x40,0x58,0x2C,0x45,0x00,0xA0,0x5A,0x00,0x00,0x00 ,0x1E,0x01,0x1D,0x80,0x18,0x71,0x1C,0x16,0x20,0x58,0x2C,0x25 ,0x00,0xA0,0x5A,0x00,0x00,0x00,0x9E,0x00,0x00,0x00,0xFC,0x00 ,0x53,0x41,0x4D,0x53,0x55,0x4E,0x47,0x0A,0x20,0x20,0x20,0x20 ,0x20,0x00,0x00,0x00,0xFD,0x00,0x3B,0x3D,0x1E,0x44,0x0F,0x00 ,0x0A,0x20,0x20,0x20,0x20,0x20,0x20,0x01,0x50

[DEL_CURRENT_REG]
HKR,MODES
HKR,EDID_OVERRIDE
HKR,,MaxResolution
HKR,,DPMS
HKR,,ICMProfile

[DPMS]
HKR,,DPMS,,0

[MODE1]
HKR,,MaxResolution,,"1920,1080"

[OVERRIDDEN-EDID.AddReg]
HKR,"MODES\\1920,1080",Mode1,,"30.0-68.0,59.0-61.0,+,+"

[OVERRIDDEN-EDID.CopyFiles]
;YourColorProfileFile.icm

[Strings]
MFG="EnTech Taiwan"
DISC="Monitor EDID Override Installation Disk"
PRODUCTID="SAMSUNG (EDID Override)"
VENDOR="Samsung"


Thanks for taking the time to help me out - it's much appreciated!
Domingo_X is offline  
post #545 of 3199 Old 01-09-2010, 10:33 AM
AVS Club Gold
 
Tulli's Avatar
 
Join Date: Nov 2001
Posts: 5,200
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 37 Post(s)
Liked: 84
There's no extension block there. You should see something like this:

Code:
;Base EDID
HKR,EDID_OVERRIDE,"0",0x01,0x00,0xFF,0xFF,0xFF,0xFF,0xFF,0xFF,0x00,0x4C,0x2D,0x3E,0x02,0x00,0x00,0x00,0x00,0x0A,0x10,0x01,0x03,0x80,0x10,0x09,0x78,0x0A,0xEE,0x91,0xA3,0x54,0x4C,0x99,0x26,0x0F,0x50,0x54,0x20,0x00,0x00,0x01,0x01,0x01,0x01,0x01,0x01,0x01,0x01,0x01,0x01,0x01,0x01,0x01,0x01,0x01,0x01,0x01,0x1D,0x80,0x18,0x71,0x1C,0x16,0x20,0x58,0x2C,0x25,0x00,0xA0,0x5A,0x00,0x00,0x00,0x9E,0x01,0x1D,0x00,0x72,0x51,0xD0,0x1E,0x20,0x6E,0x28,0x55,0x00,0xA0,0x5A,0x00,0x00,0x00,0x1E,0x00,0x00,0x00,0xFD,0x00,0x17,0x3D,0x19,0x44,0x10,0x00,0x0A,0x20,0x20,0x20,0x20,0x20,0x20,0x00,0x00,0x00,0xFC,0x00,0x53,0x41,0x4D,0x53,0x55,0x4E,0x47,0x0A,0x20,0x20,0x20,0x20,0x20,0x01,0xB7

;Extension bloc #1, e.g., CEA-EXT, DID-EXT, etc.
HKR,EDID_OVERRIDE,"1",0x01,0x02,0x03,0x30,0x71,0x47,0x85,0x04,0x03,0x10,0x20,0x0F,0x24,0x38,0x0F,0x7F,0x07,0x3D,0x1E,0xC0,0x15,0x07,0x50,0x5F,0x7E,0x01,0x57,0x06,0x00,0x65,0x7E,0x00,0x67,0x1E,0x00,0x4D,0x02,0x00,0x83,0x5F,0x00,0x00,0x66,0x03,0x0C,0x00,0x21,0x00,0x80,0x8C,0x0A,0xD0,0x8A,0x20,0xE0,0x2D,0x10,0x10,0x3E,0x96,0x00,0xA0,0x5A,0x00,0x00,0x00,0x18,0x02,0x3A,0x80,0x18,0x71,0x38,0x2D,0x40,0x58,0x2C,0x45,0x00,0xA0,0x5A,0x00,0x00,0x00,0x1E,0x01,0x1D,0x80,0x3E,0x73,0x38,0x2D,0x40,0x7E,0x2C,0x45,0x80,0xA0,0x5A,0x00,0x00,0x00,0x1E,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x7D
Again, the extension block is required to deal with EDID issues. Plug another non-5xxx graphic card, a laptop, etc. and grab the [real-time] EDID of your AVR connected to the DLP TV.

EDID Overrides (capture, install/uninstall, troubleshooting)
Tulli is offline  
post #546 of 3199 Old 01-09-2010, 11:34 AM
Member
 
AntonyDu92's Avatar
 
Join Date: Jan 2010
Posts: 37
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hello,
I have ATI 5750 card on windows 7, connected in hdmi to a yamaha rx-v465.
The DVD multicanal sounds blinks. After reading a bit avsforum i think it could be an EDID issue.
But using "moninfo" (same with phoenix) does not find my yamaha connected (there is no [Real-time..] info for it). There is only a [Registry*] info for it. I don't think it would usefull to take this one to create an inf file : it surely already is what the "Generic PnP monitor" has when my yamaha is connected..
so is there anyone to give me the EDID info for a yamaha rx-v465 ? I already have the rx-v663 info in this forum but a x65 would be better.
AntonyDu92 is offline  
post #547 of 3199 Old 01-09-2010, 11:39 AM
Senior Member
 
ewilts's Avatar
 
Join Date: Sep 2000
Location: Mounds View, MN, USA
Posts: 228
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by vladd View Post

@ewilts: When you are reading the saving the MonInfo report, are you selecting the entries that say "[Real-time 0x...]? If you are selecting the enties that say "[Registry*]", it will only give the main block and not the extension block.

I finally found out what I was doing wrong - by default, moninfo does not run as administrator. You have to specifically select "Run As Administrator" to see the real-time settings. This is true even if the user is in a member of the Administrator's group.

I'll be re-collecting the data later today (I finally just figured out how to get back to a factory default build on my Zino).

Happy owner of an HP PL-4260N that I won from HP in an online sweepstakes!
ewilts is offline  
post #548 of 3199 Old 01-09-2010, 11:41 AM
Senior Member
 
ewilts's Avatar
 
Join Date: Sep 2000
Location: Mounds View, MN, USA
Posts: 228
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by AntonyDu92 View Post

I have ATI 5750 card on windows 7, connected in hdmi to a yamaha rx-v465.
The DVD multicanal sounds blinks. After reading a bit avsforum i think it could be an EDID issue.
But using "moninfo" (same with phoenix) does not find my yamaha connected (there is no [Real-time..] info for it). There is only a [Registry*] info for it.

Right-click on the icon for moninfo and select "Run As Administrator". That will allow it to collect the realtime info.

Happy owner of an HP PL-4260N that I won from HP in an online sweepstakes!
ewilts is offline  
post #549 of 3199 Old 01-09-2010, 12:06 PM
Member
 
AntonyDu92's Avatar
 
Join Date: Jan 2010
Posts: 37
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
@ewilts: that was already done..
There is no administrator access problem: for example i have the [Real time ..] info off my monitor (Acer P243W) which is connected via the DVI port. But nothing "[Real time ..]" for my Yamaha rx-v465 connected via HDMI. it is an issue already described by tulli for ATI 5xxx owners. tulli proposed for them to use phoenix instead but it is the same result.
So again : is there anyone to give me the EDID info for a yamaha rx-v465 ? I already have the rx-v663 info in this forum but a x65 would be better.
AntonyDu92 is offline  
post #550 of 3199 Old 01-09-2010, 08:17 PM
Member
 
mudkip's Avatar
 
Join Date: Sep 2009
Posts: 118
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
**Paying 10$ via paypal To the first person that makes me a working EDID fix.** ---"Tulli" is working on it no one else try



Been trying and reading for 4 weeks i can't understand how put together the hex's and what not, the way you guys are describing it makes no sense. And I've already narrowed it down to an EDID problem. I know you guys can make this in a flash...why not make 10$ in the process!


Specs:
Video Card: HIS HD4850 [DVI]
Receiver: Pioneer VSX-519V-K [HDMI-Repeater]
Monitor: NEC MultiSync 23" LCD EA231WMi [DVI]

I'm only getting 2 channel audio...........with my nec screen but when i try my HP 2709m screen i get full 5.1 no problem.

 

NEC Monitor EDID and Raw Data.zip 1.6025390625k . file

 

Pioneer EDID and Raw Data.zip 1.6416015625k . file
Attached Files
File Type: zip Pioneer EDID and Raw Data.zip (1.6 KB, 22 views)
File Type: zip NEC Monitor EDID and Raw Data.zip (1.6 KB, 15 views)
mudkip is offline  
post #551 of 3199 Old 01-09-2010, 09:06 PM
Senior Member
 
ewilts's Avatar
 
Join Date: Sep 2000
Location: Mounds View, MN, USA
Posts: 228
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Tulli View Post
hmmm, again, those 3 captured files only have the base extension block. There are only 128 bytes (32 per line, 4 lines) in those captures.

But anyway, as your problem is audio, if you could just properly capture the 605 EDID, you could use it right away to override the default Windows detected EDID. This would be enough, so no need to merge the TV EDID as you have no video issues.

But no way with 128 bytes EDIDs. Have no clue as to why you're only getting half the EDID in each case. Maybe use another PC, a laptop? Uograde to latest version of Moninfo?
By running the app as an administrator, I've captured the files. I've got both the INF and text files. One connected just to the TV and one connected to the receiver without the cable going to the TV.

I understood you to say that I could just use the AVR inf file to update the monitor driver so I tried that. Now I get an "unknown signal" on my TV. If I connect the HDMI cable directly to the TV, I'm fine but I can't get a signal when it's connected to the AVR. How do I revert that driver? I don't see a revert option for the monitor when I connect it to the TV.

Thanks again for all the help!

 

txsr605-pl4260n.zip 5.94140625k . file
Attached Files
File Type: zip txsr605-pl4260n.zip (5.9 KB, 7 views)

Happy owner of an HP PL-4260N that I won from HP in an online sweepstakes!
ewilts is offline  
post #552 of 3199 Old 01-09-2010, 09:21 PM
AVS Club Gold
 
Tulli's Avatar
 
Join Date: Nov 2001
Posts: 5,200
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 37 Post(s)
Liked: 84
Quote:
Originally Posted by ewilts View Post

By running the app as an administrator, I've captured the files. I've got both the INF and text files. One connected just to the TV and one connected to the receiver without the cable going to the TV.

I understood you to say that I could just use the AVR inf file to update the monitor driver so I tried that. Now I get an "unknown signal" on my TV. If I connect the HDMI cable directly to the TV, I'm fine but I can't get a signal when it's connected to the AVR. How do I revert that driver? I don't see a revert option for the monitor when I connect it to the TV.

Thanks again for all the help!

Ok, now captures are fine. Will post your driver tomorrow.

To revert your current EDID override right click on Properties on My Computer and select Device Manager. Expand on Monitors Tab. Right click on overriden monitor and select Uninstall and check the "Delete the driver software for this device" and click on OK. Reboot.

EDID Overrides (capture, install/uninstall, troubleshooting)
Tulli is offline  
post #553 of 3199 Old 01-09-2010, 09:24 PM
Senior Member
 
ewilts's Avatar
 
Join Date: Sep 2000
Location: Mounds View, MN, USA
Posts: 228
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Tulli View Post

Ok, now captures are fine. Will post your driver tomorrow.

Thanks!

Quote:


To revert your current EDID override right click on Properties on My Computer and select Device Manager. Expand on Monitors Tab. Right click on overriden monitor and select Uninstall and check the "Delete the driver software for this device" and click on OK. Reboot.

It's not so simple - if I connect the computer to the AVR, I have no video so I can't see what I'm doing to uninstall the driver. If I connect the computer directly to the TV, it works fine. The device for the connection to the AVR seems to be different than the device for the TV. Or am I missing something obvious here?

Thanks again!

Happy owner of an HP PL-4260N that I won from HP in an online sweepstakes!
ewilts is offline  
post #554 of 3199 Old 01-09-2010, 09:25 PM
AVS Club Gold
 
Tulli's Avatar
 
Join Date: Nov 2001
Posts: 5,200
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 37 Post(s)
Liked: 84
Quote:
Originally Posted by mudkip View Post

**Paying 10$ via paypal To the first person that makes me a working EDID fix.**



Been trying and reading for 4 weeks i can't understand how put together the hex's and what not, the way you guys are describing it makes no sense. And I've already narrowed it down to an EDID problem. I know you guys can make this in a flash...why not make 10$ in the process!


Specs:
Video Card: HIS HD4850 [DVI]
Receiver: Pioneer VSX-519V-K [HDMI-Repeater]
Monitor: NEC MultiSync 23" LCD EA231WMi [DVI]

I'm only getting 2 channel audio...........with my nec screen but when i try my HP 2709m screen i get full 5.1 no problem.

10$? I'll bite! Will post driver tomorrow ...

EDID Overrides (capture, install/uninstall, troubleshooting)
Tulli is offline  
post #555 of 3199 Old 01-09-2010, 09:31 PM
AVS Club Gold
 
Tulli's Avatar
 
Join Date: Nov 2001
Posts: 5,200
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 37 Post(s)
Liked: 84
Quote:
Originally Posted by ewilts View Post

Thanks!


It's not so simple - if I connect the computer to the AVR, I have no video so I can't see what I'm doing to uninstall the driver. If I connect the computer directly to the TV, it works fine. The device for the connection to the AVR seems to be different than the device for the TV. Or am I missing something obvious here?

Thanks again!

Connect the TV and do a system restore, maybe?

EDID Overrides (capture, install/uninstall, troubleshooting)
Tulli is offline  
post #556 of 3199 Old 01-09-2010, 10:00 PM
Member
 
mudkip's Avatar
 
Join Date: Sep 2009
Posts: 118
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Tulli View Post

10$? I'll bite! Will post driver tomorrow ...

Ok you have it first no one else try
mudkip is offline  
post #557 of 3199 Old 01-10-2010, 07:01 AM
AVS Club Gold
 
Tulli's Avatar
 
Join Date: Nov 2001
Posts: 5,200
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 37 Post(s)
Liked: 84
@ewilts

I attach your driver. Here's what I did:

1. As your main problem is audio detection I replaced the 605 audio descriptors with the onkyo 906's, which are known to work fine with latest ATI drivers.

2. I replaced the 605 video timings with your pl4260n TV's.

In case you need to revert follow this procedure:

1. Plug in the TV.

2. Go to Computer->Device Manager->(Expand on) Monitors.

3. Install the EDID override for the TV.

4. Now uninstall it and select "Delete the driver software for this device", and click on OK.

5. Reboot.

Cheers.

 

pl4260n-tx-sr605_MOD.zip 1.1572265625k . file
Attached Files
File Type: zip pl4260n-tx-sr605_MOD.zip (1.2 KB, 13 views)

EDID Overrides (capture, install/uninstall, troubleshooting)
Tulli is offline  
post #558 of 3199 Old 01-10-2010, 07:57 AM
AVS Club Gold
 
Tulli's Avatar
 
Join Date: Nov 2001
Posts: 5,200
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 37 Post(s)
Liked: 84
@mudkip

Hi. First of all I was just kidding about taking the $10. I am of the opinion of freely exchanging info & help, in the best spirit of this forum. As a matter of fact I owe to many others, even on this thread, that I learned to solve my EDID issues. So I'd have to share those $10 with many, which is ludicrous, isn't it? I should even share at least 50% of that with AVS forum collaborator vladd, whose free-to-all EDID Editor tool I heavily use for these mods ... (so no, vladd, you won't get those 5 bucks as well! ).

Now, to your problem. That NEC EDID is the most non-standard that I've seen so far. It lacks video and audio descriptors, as well as vendor's ID and speaker allocation block. The whole extension block is filled wih 6 video timings descriptors.

What I did is to try to make it the most similar to what I've seen as a "standard/expected ATI AVR EDID". So here's what I did to make this "Frankenstein EDID", which I hope will work for you:

1. I could not fit a standard video block + Pioneer audio descriptors + Speaker Allocation + NEC Timings in the 128-bytes available on the extension block, so I did NOT include the timings for 1920x540.

2. I added the shortest Video block that I know (my Denon's 988).

3. I merged your Pio AVR info with the 5 remaining timings of the NEC.

After doing this there was only 1 byte left on the extension block, but the resulting EDID is as standard as I know that an ATI driver can parse.

Let me know how it goes ...

 

NEC_DD-Pioneer_AVR_MOD.zip 1.2138671875k . file
Attached Files
File Type: zip NEC_DD-Pioneer_AVR_MOD.zip (1.2 KB, 16 views)

EDID Overrides (capture, install/uninstall, troubleshooting)
Tulli is offline  
post #559 of 3199 Old 01-10-2010, 08:41 AM
Newbie
 
Domingo_X's Avatar
 
Join Date: Dec 2009
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hopefully these will work. I got these two files (the Sony one is w/ the AVAMP, the Samsung is straight into the TV) by hooking up my wife's PC using a DVI to HDMI hook-up into my set-up.

As always - thanks for helping us neophytes with things like this

 

Sony+Samsung.zip 2.2685546875k . file
Attached Files
File Type: zip Sony+Samsung.zip (2.3 KB, 13 views)
Domingo_X is offline  
post #560 of 3199 Old 01-10-2010, 09:12 AM
AVS Club Gold
 
Tulli's Avatar
 
Join Date: Nov 2001
Posts: 5,200
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 37 Post(s)
Liked: 84
Quote:
Originally Posted by Domingo_X View Post
Hopefully these will work. I got these two files (the Sony one is w/ the AVAMP, the Samsung is straight into the TV) by hooking up my wife's PC using a DVI to HDMI hook-up into my set-up.

As always - thanks for helping us neophytes with things like this
Yup, those captures are fine.

The Sony EDID shows the same video data as the DLP TV, so nothing to do there. But there were 2 audio blocks! I replaced them with the Onkyo 906's single audio block that works fine with ATI drivers/5xxx.

 

Sony STR-DN1000_MOD.zip 1.166015625k . file
Attached Files
File Type: zip Sony STR-DN1000_MOD.zip (1.2 KB, 19 views)

EDID Overrides (capture, install/uninstall, troubleshooting)
Tulli is offline  
post #561 of 3199 Old 01-10-2010, 09:28 AM
Newbie
 
Domingo_X's Avatar
 
Join Date: Dec 2009
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Tulli - you sir are the man I installed that driver and everything works great. I'm at 1920x1080 (60hz) and am able to bitstream TrueHD and DTS-HD just fine. Thanks for all of your help!
Domingo_X is offline  
post #562 of 3199 Old 01-10-2010, 01:04 PM
Senior Member
 
ewilts's Avatar
 
Join Date: Sep 2000
Location: Mounds View, MN, USA
Posts: 228
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Tulli View Post

@ewilts

I attach your driver. Here's what I did:

1. As your main problem is audio detection I replaced the 605 audio descriptors with the onkyo 906's, which are known to work fine with latest ATI drivers.

2. I replaced the 605 video timings with your pl4260n TV's.

In case you need to revert follow this procedure:

1. Plug in the TV.

2. Go to Computer->Device Manager->(Expand on) Monitors.

3. Install the EDID override for the TV.

4. Now uninstall it and select "Delete the driver software for this device", and click on OK.

5. Reboot.

Cheers.

I'm cheering! I have sound!!!

In order to to do the uninstall, I had to boot to a safe mode command line and manually delete the directory for the bad driver. As soon as I rebooted, I had sound (but a narrow display). I applied your driver and the sound is working.

In the sound control panel, however, I still see only stereo selected - no 5.1, 7.1, etc. Is this still a limitation of the driver or is there something else at play here?

Thanks again!!!

Happy owner of an HP PL-4260N that I won from HP in an online sweepstakes!
ewilts is offline  
post #563 of 3199 Old 01-10-2010, 02:01 PM
AVS Club Gold
 
Tulli's Avatar
 
Join Date: Nov 2001
Posts: 5,200
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 37 Post(s)
Liked: 84
Must be an ATI driver problem now. You have no option to manually select 5.1 or 7.1 for the HDMI audio device? Do you have the latest Catalyst version installed? You could even try the Realtek 2.39 ATI HDMI audio driver.

But anyway, the EDID override has proven to work very well for 4xxx & 5xxx graphic adapters. FWIW I had mixed results on my 3850. So it's a matter of finding a working driver for your HD3200. As far as the EDID is concerned all I know is that current ATI drivers work fine with the audio block of the modded monitor driver that you have just installed.

EDID Overrides (capture, install/uninstall, troubleshooting)
Tulli is offline  
post #564 of 3199 Old 01-10-2010, 08:26 PM
Member
 
mudkip's Avatar
 
Join Date: Sep 2009
Posts: 118
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Tulli View Post
@mudkip

Hi. First of all I was just kidding about taking the $10. I am of the opinion of freely exchanging info & help, in the best spirit of this forum. As a matter of fact I owe to many others, even on this thread, that I learned to solve my EDID issues. So I'd have to share those $10 with many, which is ludicrous, isn't it? I should even share at least 50% of that with AVS forum collaborator vladd, whose free-to-all EDID Editor tool I heavily use for these mods ... (so no, vladd, you won't get those 5 bucks as well! ).

Now, to your problem. That NEC EDID is the most non-standard that I've seen so far. It lacks video and audio descriptors, as well as vendor's ID and speaker allocation block. The whole extension block is filled wih 6 video timings descriptors.

What I did is to try to make it the most similar to what I've seen as a "standard/expected ATI AVR EDID". So here's what I did to make this "Frankenstein EDID", which I hope will work for you:

1. I could not fit a standard video block + Pioneer audio descriptors + Speaker Allocation + NEC Timings in the 128-bytes available on the extension block, so I did NOT include the timings for 1920x540.

2. I added the shortest Video block that I know (my Denon's 988).

3. I merged your Pio AVR info with the 5 remaining timings of the NEC.

After doing this there was only 1 byte left on the extension block, but the resulting EDID is as standard as I know that an ATI driver can parse.

Let me know how it goes ...
omfg thanks a lot for the help man i appreciate it !!! but this one didn't work its my fault.....I had the ATI DVI-HDMI Adapter on my NEC screen so it has wrong readings for my NEC screen. Now i took the reading again with direct DVI-DVI connection and its different. Can you make another one if you have the time? didn't think the adapter would of made a difference. sorry man


New one Uploaded below

 

Nec Monitor EDID and Raw Data.zip 2.8505859375k . file

 

Pioneer Receiver EDID and Raw Data.zip 2.84375k . file
Attached Files
File Type: zip Pioneer Receiver EDID and Raw Data.zip (2.8 KB, 15 views)
File Type: zip Nec Monitor EDID and Raw Data.zip (2.9 KB, 11 views)
mudkip is offline  
post #565 of 3199 Old 01-10-2010, 09:32 PM
AVS Special Member
 
vladd's Avatar
 
Join Date: Jun 2006
Location: Louisville, KY
Posts: 5,469
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 36
Quote:
Originally Posted by Tulli View Post

I should even share at least 50% of that with AVS forum collaborator vladd, whose free-to-all EDID Editor tool I heavily use for these mods ... (so no, vladd, you won't get those 5 bucks as well! ).

I was going to let you have the first $10 but we would have to talk if you were getting 5-10 jobs a week.
vladd is offline  
post #566 of 3199 Old 01-11-2010, 06:14 AM
AVS Club Gold
 
Tulli's Avatar
 
Join Date: Nov 2001
Posts: 5,200
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 37 Post(s)
Liked: 84
Quote:
Originally Posted by mudkip View Post

omfg thanks a lot for the help man i appreciate it !!! but this one didn't work its my fault.....I had the ATI DVI-HDMI Adapter on my NEC screen so it has wrong readings for my NEC screen. Now i took the reading again with direct DVI-DVI connection and its different. Can you make another one if you have the time? didn't think the adapter would of made a difference. sorry man


New one Uploaded below

No difference, that NEC EDID is the same as the one before.

Anyway, according to the monitor driver this is your display device, right? That's a PC monitor, i.e, a non-standard HDTV device.

So set the Pioneer HDMI mode to a non-passthrough TV mode (on my Denon is named "AMP"), so that the HTPC (the ATI driver) will get your Pioneer EDID, with which it should have no issues.

A similar issue has just been discussed on the ATI 5xxx thread.

EDID Overrides (capture, install/uninstall, troubleshooting)
Tulli is offline  
post #567 of 3199 Old 01-12-2010, 12:22 AM
Member
 
colinfindlay's Avatar
 
Join Date: Oct 2006
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I've got weird issues in Windows 7 that I think modifying the EDID will fix, but I can't seem to find a link to Vladds EDID editor, can someone help?
I'll also explain my problem - just in case the EDID hack doesn't work, or someone else has a better solution:

Currently during HDMI signal negotiation the TV/Reciever flicks to 720p then up to 1080p - unfortunately it seems that Windows 7 doesn't always send these resolution changes to all fullscreen apps currently running - resulting in applications that are fullscreen - but only across half the screen. I've seen reports of this in SageTV, MediaPortal & even Windows 7 MC. (Both ATI & NVidia I think - but I'd need to hunt down the bug reports)
Someone suggested modifying the EDID to drop all resolutions except 1080p - so I thought I'd give that a crack.
colinfindlay is offline  
post #568 of 3199 Old 01-12-2010, 01:40 AM
AVS Special Member
 
vladd's Avatar
 
Join Date: Jun 2006
Location: Louisville, KY
Posts: 5,469
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 36
Quote:
Originally Posted by colinfindlay View Post

I've got weird issues in Windows 7 that I think modifying the EDID will fix, but I can't seem to find a link to Vladds EDID editor, can someone help?

I never posted it publicly, sorry (I just never got around to it). See next post for it and some basic instructions. It's just an editor and checksum calculator. It's meant to be used with MonInfo and Extron's EDID Manager (great for checking the EDID data), neither of which will actually let you edit the EDID.


Quote:
Originally Posted by colinfindlay View Post

I'll also explain my problem - just in case the EDID hack doesn't work, or someone else has a better solution:

Currently during HDMI signal negotiation the TV/Reciever flicks to 720p then up to 1080p - unfortunately it seems that Windows 7 doesn't always send these resolution changes to all fullscreen apps currently running - resulting in applications that are fullscreen - but only across half the screen. I've seen reports of this in SageTV, MediaPortal & even Windows 7 MC. (Both ATI & NVidia I think - but I'd need to hunt down the bug reports)
Someone suggested modifying the EDID to drop all resolutions except 1080p - so I thought I'd give that a crack.

Yup, EDID override should fix that. I had the same issue.
vladd is offline  
post #569 of 3199 Old 01-12-2010, 01:43 AM
AVS Special Member
 
vladd's Avatar
 
Join Date: Jun 2006
Location: Louisville, KY
Posts: 5,469
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 36
http://www.oshinetworks.com/EDID_Editor.zip

First, some things it won't do:
  • Parse and validate the EDID data.
  • Import partial EDID data. You will need to import either a complete block (base or extended) or a complete EDID (base + extended).

Now what it will do:
  • Import EDID text data from clipboard.
  • Import EDID data from a binary file like those produced by the Extron EDID Manager.
  • Validate and repair the checksum of each EDID block.
  • Allow you to manually edit the EDID data.
  • Display the EDID blocks in the form of override strings.
  • Copy the override strings to the clipboard.
  • Export the EDID data to a binary file that can be read by the Extron EDID Manager.

To use:

If you want to import from the clipboard, copy the EDID string from a MonInfo report, a .reg file or an EDID override inf then simply click the "Paste from clipboard" button. If the data is a single EDID block, you will get a popup asking if it is the Base block. If you click "No", the data will be imported to the Extended block instead.

If you want to import a .bin file from the Extron EDID Manager, just click "Load Binary File" and select the .bin file. You can save the edited file by clicking "Save Binary File".

To edit the data, click the block you want to edit and type in the new value (00 - FF). The last two values in each grid are not used but the 10x13 grid made it easy for me with calculations.

If the checksum is invalid on a particular block, a button will be enabled to fix it. If the button for a particular block is disabled, the checksum is valid.

The text box will display the override inf entries and it is updated in realtime when you exit the cell you are editing. You can select all or some of the text and right click to copy it to the clipboard. Clicking the "Copy override to clipboard" will copy the entire contents of the text box.

When you are done editing, export the binary file and check it with the Extron EDID Manager. If everything looks OK, you can copy the override strings to create your INF.

The following formats can be imported from the clipboard:

Registry entry (only the value and data line, not the key)
Code:
"EDID"=hex:00,ff,ff,ff,ff,ff,ff,00,5a,63,22,38,01,01,01,01,1a,13,01,03,80,34,\\
  1d,78,2e,ee,d5,a5,55,48,9b,26,12,50,54,bf,ef,80,d1,c0,b3,00,a9,40,95,00,90,\\
  40,81,80,81,40,71,4f,01,1d,80,18,71,1c,16,20,58,2c,25,00,08,22,21,00,00,9e,\\
  00,00,00,ff,00,52,34,46,30,39,32,36,30,31,35,36,36,0a,00,00,00,fd,00,32,4b,\\
  0f,52,12,00,0a,20,20,20,20,20,20,00,00,00,fc,00,56,58,32,34,33,33,77,6d,0a,\\
  20,20,20,20,01,36
INF entry (not the section header). You can import a single block or both blocks.
Code:
;Base EDID
HKR,EDID_OVERRIDE,"0",0x01,0x00,0xFF,0xFF,0xFF,0xFF,0xFF,0xFF,0x00,0x11,0xEE,0x0D,0x00,0x01,0x01,0x01,0x01,0x00,0x11,0x01,0x03,0x80,0x10,0x09,0x78,0x0A,0xEE,0x91,0xA3,0x54,0x4C,0x99,0x26,0x0F,0x50,0x54,0x20,0x00,0x00,0x01,0x01,0x01,0x01,0x01,0x01,0x01,0x01,0x01,0x01,0x01,0x01,0x01,0x01,0x01,0x01,0x01,0x1D,0x80,0x18,0x71,0x1C,0x16,0x20,0x58,0x2C,0x25,0x00,0xA0,0x5A,0x00,0x00,0x00,0x9E,0x01,0x1D,0x00,0x72,0x51,0xD0,0x1E,0x20,0x6E,0x28,0x55,0x00,0xA0,0x5A,0x00,0x00,0x00,0x1E,0x00,0x00,0x00,0xFD,0x00,0x17,0x3D,0x19,0x44,0x10,0x00,0x0A,0x20,0x20,0x20,0x20,0x20,0x20,0x00,0x00,0x00,0xFC,0x00,0x44,0x45,0x4E,0x4F,0x4E,0x2D,0x41,0x56,0x41,0x4D,0x50,0x0A,0x20,0x01,0xF1

;Extension bloc #1, e.g., CEA-EXT, DID-EXT, etc.
HKR,EDID_OVERRIDE,"1",0x01,0x02,0x03,0x30,0x71,0x47,0x85,0x04,0x03,0x10,0x20,0x0F,0x24,0x38,0x0F,0x7F,0x07,0x3D,0x1E,0xC0,0x15,0x07,0x50,0x5F,0x7E,0x01,0x57,0x06,0x00,0x65,0x7E,0x00,0x67,0x1E,0x00,0x4D,0x02,0x00,0x83,0x5F,0x00,0x00,0x66,0x03,0x0C,0x00,0x22,0x00,0x80,0x8C,0x0A,0xD0,0x8A,0x20,0xE0,0x2D,0x10,0x10,0x3E,0x96,0x00,0xA0,0x5A,0x00,0x00,0x00,0x18,0x02,0x3A,0x80,0x18,0x71,0x38,0x2D,0x40,0x58,0x2C,0x45,0x00,0xA0,0x5A,0x00,0x00,0x00,0x1E,0x01,0x1D,0x80,0x3E,0x73,0x38,0x2D,0x40,0x7E,0x2C,0x45,0x80,0xA0,0x5A,0x00,0x00,0x00,0x1E,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x7C
Moninfo style raw data
Code:
00,FF,FF,FF,FF,FF,FF,00,5A,63,22,38,01,01,01,01,1A,13,01,03,80,34,1D,78,2E,EE,D5,A5,55,48,9B,26,
  12,50,54,BF,EF,80,D1,C0,B3,00,A9,40,95,00,90,40,81,80,81,40,71,4F,01,1D,80,18,71,1C,16,20,58,2C,
  25,00,08,22,21,00,00,9E,00,00,00,FF,00,52,34,46,30,39,32,36,30,31,35,36,36,0A,00,00,00,FD,00,32,
  4B,0F,52,12,00,0A,20,20,20,20,20,20,00,00,00,FC,00,56,58,32,34,33,33,77,6D,0A,20,20,20,20,01,36
or
Code:
00  FF  FF  FF  FF  FF  FF  00  5A  63  22  38  01  01  01  01  1A  13  01  03  80  34  1D  78  2E  EE  D5  A5  55  48  9B  26  
  12  50  54  BF  EF  80  D1  C0  B3  00  A9  40  95  00  90  40  81  80  81  40  71  4F  01  1D  80  18  71  1C  16  20  58  2C  
  25  00  08  22  21  00  00  9E  00  00  00  FF  00  52  34  46  30  39  32  36  30  31  35  36  36  0A  00  00  00  FD  00  32  
  4B  0F  52  12  00  0A  20  20  20  20  20  20  00  00  00  FC  00  56  58  32  34  33  33  77  6D  0A  20  20  20  20  01  36
I suck at instructions but hopefully that's enough to get you going. Honestly, if these basic instructions aren't enough to get started), it's probably best if you ask someone else (like Tulli) to do it for you. I do expect some questions of course, so feel free to ask. But, I am in no way responsible if you mess up your system by creating a bad EDID. (It really wouldn't be hard to undo anyway but I have to put that disclaimer).
coldblackice and lsaranto like this.
vladd is offline  
post #570 of 3199 Old 01-12-2010, 07:56 AM
AVS Special Member
 
archibael's Avatar
 
Join Date: Jul 2002
Location: Phoenix, AZ
Posts: 4,098
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Genius! Thanks, vladd! Checksum was always a pain in the ass for me.

I do not speak officially in any sense for
Intel Corp., Technology Manufacturing Group
but I do work there.
archibael is offline  
Reply Home Theater Computers

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off