EDID Override Thread - Page 34 - AVS Forum
Forum Jump: 
 2Likes
Reply
 
Thread Tools
post #991 of 3183 Old 11-22-2010, 06:32 PM
Senior Member
 
bob2300NX's Avatar
 
Join Date: Jun 2005
Posts: 334
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 12
Tulli, right now I have a problem with handshake. I dont use the audio from the HDMI just having problems with the video.

Everything works perfectly, but if my computer is out of sleep and recording and I turn the tv on I get no picture. It seems the TV needs to be on before the computer. This is a problem if my computer is ever recording since I cant turn it off.

Would one of your EDID override files work in this scenario? If so ill get you all the model numbers and any other info that you need.

Thanks alot!
bob2300NX is offline  
Sponsored Links
Advertisement
 
post #992 of 3183 Old 11-22-2010, 07:07 PM
AVS Club Gold
 
Tulli's Avatar
 
Join Date: Nov 2001
Posts: 5,175
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 21 Post(s)
Liked: 81
Quote:
Originally Posted by bob2300NX View Post

Tulli, right now I have a problem with handshake. I dont use the audio from the HDMI just having problems with the video.

Everything works perfectly, but if my computer is out of sleep and recording and I turn the tv on I get no picture. It seems the TV needs to be on before the computer. This is a problem if my computer is ever recording since I cant turn it off.

Would one of your EDID override files work in this scenario? If so ill get you all the model numbers and any other info that you need.

Thanks alot!

Could work so it's worth trying. OTH have you already tried HdmiYO?

If one of the listed overrides works and you still need a custom EDID override just post your TV and AVR EDIDs and I'll do the mod.

EDID Overrides (capture, install/uninstall, troubleshooting)
Tulli is offline  
post #993 of 3183 Old 11-22-2010, 07:49 PM
Senior Member
 
bob2300NX's Avatar
 
Join Date: Jun 2005
Posts: 334
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 12
Quote:
Originally Posted by Tulli View Post

Could work so it's worth trying. OTH have you already tried HdmiYO?

If one of the listed overrides works and you still need a custom EDID override just post your TV and AVR EDIDs and I'll do the mod.

HDMIYo sends the extra command when the computer comes out of sleep. This doesnt work in my situation (I only have problems when the computer is on before the tv ie when it is recording). I instead have a manual hotkey in HDMIYo which definitely works. I was asking you since wouldnt your modified EDID make it so I dont have to do the hotkey? Im just trying to get my HTPC as automated as possible and this is really the only thing holding me back. Plus my mom likes it simples and will harass me lol.
bob2300NX is offline  
post #994 of 3183 Old 11-22-2010, 11:26 PM
Member
 
bgnt44's Avatar
 
Join Date: Nov 2010
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Tulli View Post

AFAIK Moninfo still doesn't work on Nvidia 4xx cards. Most probably your EDID override is only 128 bytes (i.e. no extension block), so it's not including an audio descriptor.

Anyway, you can confirm this by checking the .inf file generated by moninfo and see that it has an extension block line this:

;Extension bloc #1, e.g., CEA-EXT, DID-EXT, etc.
HKR,EDID_OVERRIDE,"1",0x01, ...

Each of my inf file has a extension bloc 0 line ...

I ve put the two in my final inf remplacing "0" By "1"1 for one line
bgnt44 is offline  
post #995 of 3183 Old 11-23-2010, 02:01 AM
AVS Club Gold
 
Tulli's Avatar
 
Join Date: Nov 2001
Posts: 5,175
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 21 Post(s)
Liked: 81
Quote:
Originally Posted by bob2300NX View Post

HDMIYo sends the extra command when the computer comes out of sleep. This doesnt work in my situation (I only have problems when the computer is on before the tv ie when it is recording). I instead have a manual hotkey in HDMIYo which definitely works. I was asking you since wouldnt your modified EDID make it so I dont have to do the hotkey? Im just trying to get my HTPC as automated as possible and this is really the only thing holding me back. Plus my mom likes it simples and will harass me lol.

Yes, an EDID override won't require a hotkey.

EDID Overrides (capture, install/uninstall, troubleshooting)
Tulli is offline  
post #996 of 3183 Old 11-23-2010, 02:26 AM
AVS Club Gold
 
Tulli's Avatar
 
Join Date: Nov 2001
Posts: 5,175
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 21 Post(s)
Liked: 81
Quote:
Originally Posted by bgnt44 View Post
Each of my inf file has a extension bloc 0 line ...

I ve put the two in my final inf remplacing "0" By "1"1 for one line
Get the 'HKR,EDID_OVERRIDE,"1" ...' line from the attached Onkyo 507 .inf file.

 

onkyo 507.zip 1.1953125k . file
Attached Files
File Type: zip onkyo 507.zip (1.2 KB, 2 views)

EDID Overrides (capture, install/uninstall, troubleshooting)
Tulli is offline  
post #997 of 3183 Old 11-23-2010, 09:55 AM
Member
 
bgnt44's Avatar
 
Join Date: Nov 2010
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Tulli View Post

Get the 'HKR,EDID_OVERRIDE,"1" ...' line from the attached Onkyo 507 .inf file.

you're a boss !! really !

it work with your advice !

i don't try Hd Audio yet but i'll do it soon !
bgnt44 is offline  
post #998 of 3183 Old 11-24-2010, 02:55 PM
Newbie
 
deano_t's Avatar
 
Join Date: Nov 2010
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Dear Master Tulli,
Firstly, I must commend you for your tireless dedication to helping us AV newbies. I too have been pulling out my hair and raising fists to the heavens in frustration.
My story is very similar to most - I cannot get 5.1 or higher through my Yamaha RX-V467, no video issues I can report. Although I must say when I first plugged in everything 5.1 worked but then I upgraded the codecs and drivers which from then on it all went wrong.
My set-up comprises of
HTPC (Win7 Pro + ATI 3450 HD) ->> HDMI ->> Yamaha RX-V467->> HDMI ->> Samsung LE37C650
I feel I have followed every AVS EDID thread written by man and tried every permutated configuration.
Basically, I have tried all ATI drivers from version 9 with RealTek R249 HD.
I have also followed the MonInfo guide and think I have captured, what I imagine, a good SAMSUNG real-time that I have converted into usable EDID OVERRIDE, see attached(change extension from zip to rar). However, no matter what I do everytime I reboot and review my audio devices, I get nothing but 2 channels.
Now for the dumb questions
Bitstreaming is available with later cards and nothing to do with I am trying to achieve, correct?
Do I need something like TMT3, which I have, to drive / activate 5.1 through my card ?
What am I doing wrong?
Should I just upgrade my ATI card to 5XXX and get all the audio goodies that come with it, but I am not sure what I am missing?

 

edid.zip 1.78125k . file
Attached Files
File Type: zip edid.zip (1.8 KB, 1 views)
deano_t is offline  
post #999 of 3183 Old 11-24-2010, 03:40 PM
AVS Club Gold
 
Tulli's Avatar
 
Join Date: Nov 2001
Posts: 5,175
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 21 Post(s)
Liked: 81
Quote:
Originally Posted by deano_t View Post

Dear Master Tulli,
Firstly, I must commend you for your tireless dedication to helping us AV newbies. I too have been pulling out my hair and raising fists to the heavens in frustration.
My story is very similar to most - I cannot get 5.1 or higher through my Yamaha RX-V467, no video issues I can report. Although I must say when I first plugged in everything 5.1 worked but then I upgraded the codecs and drivers which from then on it all went wrong.
My set-up comprises of
HTPC (Win7 Pro + ATI 3450 HD) ->> HDMI ->> Yamaha RX-V467->> HDMI ->> Samsung LE37C650
I feel I have followed every AVS EDID thread written by man and tried every permutated configuration.
Basically, I have tried all ATI drivers from version 9 with RealTek R249 HD.
I have also followed the MonInfo guide and think I have captured, what I imagine, a good SAMSUNG real-time that I have converted into usable EDID OVERRIDE, see attached(change extension from zip to rar). However, no matter what I do everytime I reboot and review my audio devices, I get nothing but 2 channels.
Now for the dumb questions -
Bitstreaming is available with later cards and nothing to do with I am trying to achieve, correct?
Do I need something like TMT3, which I have, to drive / activate 5.1 through my card ?
What am I doing wrong?
Should I just upgrade my ATI card to 5XXX and get all the audio goodies that come with it, but I am not sure what I am missing?

That EDID is fine so your problem is elsewhere. Have you already checked the Yamaha RX-V467 HDMI setup so that it does NOT repeat the TV audio specs? (on my Denon I must set it to "AMP").

What's the max number of channels that you get on the "Supported Formats" ATI HDMI driver windows?

EDID Overrides (capture, install/uninstall, troubleshooting)
Tulli is offline  
post #1000 of 3183 Old 11-24-2010, 03:50 PM
Member
 
bgnt44's Avatar
 
Join Date: Nov 2010
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hey !!

I came back because i've seen a problem now with my edid override !

In fact it seem that the ;Extension bloc #1, e.g., CEA-EXT, DID-EXT, etc.

for my onkyo has changed resolution and timing settings ...

3d vision doesn't work anymore... (probably refresh rate problem or confusion between both EDID lines)

is it possible to remove all display data of my the onkyo 507 edid to keep only sound informations ?

how can i do that ...

other things that i've notice is that extron edid manager doesn't give the same informations that Moninfo ...

and one more info ...

the inf EDID :
HKR,EDID_OVERRIDE,"0",0x01,0x00,0xFF,0xFF,0xFF,0xFF,0xFF,0xFF,0x00,0x3E,0x8D,0x34 ,0x30,0xFD,0x00,0x00,0x00,0x10,0x14,0x01,0x03,0x80,0x00,0x00 ,0x00,0x2F,0x00,0x00,0xA4,0x50,0x4F,0x8C,0x23,0x12,0x48,0x4F ,0xAF,0xEF,0x80,0x61,0x7C,0x81,0x00,0x81,0x80,0xA9,0x40,0x81 ,0xFC,0x81,0xC0,0x45,0x7C,0xB3,0x00,0x1A,0x1D,0x00,0x80,0x51 ,0xD0,0x1C,0x20,0x40,0x80,0x35,0x00,0x00,0x00,0x00,0x00,0x00 ,0x1C,0x01,0x1D,0x00,0xBC,0x52,0xD0,0x1E,0x20,0xB8,0x28,0x55 ,0x00,0x00,0x00,0x00,0x00,0x00,0x1E,0x00,0x00,0x00,0xFD,0x00 ,0x38,0x78,0x1E,0x78,0x11,0x00,0x0A,0x20,0x20,0x20,0x20,0x20 ,0x20,0x00,0x00,0x00,0xFC,0x00,0x4F,0x70,0x74,0x6F,0x6D,0x61 ,0x20,0x33,0x44,0x30,0x34,0x0A,0x20,0x01,0x6E
;Extension bloc #1, e.g., CEA-EXT, DID-EXT, etc.
HKR,EDID_OVERRIDE,"1",0x01,0x02,0x03,0x32,0x71,0x49,0x05,0x04,0x02,0x03,0x90,0x0E ,0x0F,0x23,0x24,0x38,0x09,0x7F,0x07,0x0F,0x7F,0x07,0x17,0x07 ,0x50,0x3F,0x06,0xC0,0x4D,0x02,0x00,0x57,0x06,0x00,0x5F,0x7E ,0x01,0x67,0x54,0x00,0x83,0x4F,0x00,0x00,0x66,0x03,0x0C,0x00 ,0x12,0x00,0x80,0x8C,0x0A,0xD0,0x8A,0x20,0xE0,0x2D,0x10,0x10 ,0x3E,0x96,0x00,0x10,0x09,0x00,0x00,0x00,0x18,0x8C,0x0A,0xD0 ,0x8A,0x20,0xE0,0x2D,0x10,0x10,0x3E,0x96,0x00,0x04,0x03,0x00 ,0x00,0x00,0x18,0x01,0x1D,0x80,0x18,0x71,0x1C,0x16,0x20,0x58 ,0x2C,0x25,0x00,0xC4,0x8E,0x21,0x00,0x00,0x9E,0x00,0x00,0x00 ,0x10,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00 ,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x6B

the both device are ONKYO 507 and OPTOMA HD67
bgnt44 is offline  
post #1001 of 3183 Old 11-24-2010, 04:00 PM
AVS Club Gold
 
Tulli's Avatar
 
Join Date: Nov 2001
Posts: 5,175
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 21 Post(s)
Liked: 81
Quote:
Originally Posted by bgnt44 View Post

Hey !!

I came back because i've seen a problem now with my edid override !

In fact it seem that the ;Extension bloc #1, e.g., CEA-EXT, DID-EXT, etc.

for my onkyo has changed resolution and timing settings ...

3d vision doesn't work anymore... (probably refresh rate problem or confusion between both EDID lines)

is it possible to remove all display data of my the onkyo 507 edid to keep only sound informations ?

how can i do that ...

other things that i've notice is that extron edid manager doesn't give the same informations that Moninfo ...

and one more info ...

the inf EDID :
HKR,EDID_OVERRIDE,"0",0x01,0x00,0xFF,0xFF,0xFF,0xFF,0xFF,0xFF,0x00,0x3E,0x8D,0x34 ,0x30,0xFD,0x00,0x00,0x00,0x10,0x14,0x01,0x03,0x80,0x00,0x00 ,0x00,0x2F,0x00,0x00,0xA4,0x50,0x4F,0x8C,0x23,0x12,0x48,0x4F ,0xAF,0xEF,0x80,0x61,0x7C,0x81,0x00,0x81,0x80,0xA9,0x40,0x81 ,0xFC,0x81,0xC0,0x45,0x7C,0xB3,0x00,0x1A,0x1D,0x00,0x80,0x51 ,0xD0,0x1C,0x20,0x40,0x80,0x35,0x00,0x00,0x00,0x00,0x00,0x00 ,0x1C,0x01,0x1D,0x00,0xBC,0x52,0xD0,0x1E,0x20,0xB8,0x28,0x55 ,0x00,0x00,0x00,0x00,0x00,0x00,0x1E,0x00,0x00,0x00,0xFD,0x00 ,0x38,0x78,0x1E,0x78,0x11,0x00,0x0A,0x20,0x20,0x20,0x20,0x20 ,0x20,0x00,0x00,0x00,0xFC,0x00,0x4F,0x70,0x74,0x6F,0x6D,0x61 ,0x20,0x33,0x44,0x30,0x34,0x0A,0x20,0x01,0x6E
;Extension bloc #1, e.g., CEA-EXT, DID-EXT, etc.
HKR,EDID_OVERRIDE,"1",0x01,0x02,0x03,0x32,0x71,0x49,0x05,0x04,0x02,0x03,0x90,0x0E ,0x0F,0x23,0x24,0x38,0x09,0x7F,0x07,0x0F,0x7F,0x07,0x17,0x07 ,0x50,0x3F,0x06,0xC0,0x4D,0x02,0x00,0x57,0x06,0x00,0x5F,0x7E ,0x01,0x67,0x54,0x00,0x83,0x4F,0x00,0x00,0x66,0x03,0x0C,0x00 ,0x12,0x00,0x80,0x8C,0x0A,0xD0,0x8A,0x20,0xE0,0x2D,0x10,0x10 ,0x3E,0x96,0x00,0x10,0x09,0x00,0x00,0x00,0x18,0x8C,0x0A,0xD0 ,0x8A,0x20,0xE0,0x2D,0x10,0x10,0x3E,0x96,0x00,0x04,0x03,0x00 ,0x00,0x00,0x18,0x01,0x1D,0x80,0x18,0x71,0x1C,0x16,0x20,0x58 ,0x2C,0x25,0x00,0xC4,0x8E,0x21,0x00,0x00,0x9E,0x00,0x00,0x00 ,0x10,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00 ,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x6B

the both device are ONKYO 507 and OPTOMA HD67

Well, what is really needed is the Vendor Specific Data block and other data blocks that are present on your Optoma HD67 EDID extension block, for a complete merge of the Optoma EDID + ONKYO audio block. But that means of course capturing the full 256-EDID of the Optoma with Moninfo, which cannot be done now on Nvidia 4xx.

So, do you have an older card, another PC (a laptop with an HDMI port?) to capture the Optoma full EDID? Post it and I'll do the merge if necessary.

EDID Overrides (capture, install/uninstall, troubleshooting)
Tulli is offline  
post #1002 of 3183 Old 11-24-2010, 04:47 PM
Member
 
bgnt44's Avatar
 
Join Date: Nov 2010
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Tulli View Post

Well, what is really needed is the Vendor Specific Data block and other data blocks that are present on your Optoma HD67 EDID extension block, for a complete merge of the Optoma EDID + ONKYO audio block. But that means of course capturing the full 256-EDID of the Optoma with Moninfo, which cannot be done now on Nvidia 4xx.

So, do you have an older card, another PC (a laptop with an HDMI port?) to capture the Optoma full EDID? Post it and I'll do the merge if necessary.

ok i'll do that as soon as possible ...

I would like some advice to clean registry too ...

I've notice in ENUM : default monitor : 2 subdirectory
ONK0861 .. with edid and edid_override
OTM3034 with only optoma edid

and something change if i restart my receiver after windows loading ...
for example in "supported audio format", i only got DTS and DD when i start the computer and if i restart the onkyo i got HD format too ( dts master and true hd ) ... make me think that something wrong somewhere
bgnt44 is offline  
post #1003 of 3183 Old 11-24-2010, 05:50 PM
Newbie
 
deeshell's Avatar
 
Join Date: Nov 2010
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
hi does anyone have an inf or edid dump for an rx-v3900 yamaha reciever?
Thanks.
deeshell is offline  
post #1004 of 3183 Old 11-24-2010, 06:08 PM
AVS Club Gold
 
Tulli's Avatar
 
Join Date: Nov 2001
Posts: 5,175
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 21 Post(s)
Liked: 81
Quote:
Originally Posted by bgnt44 View Post

ok i'll do that as soon as possible ...

I would like some advice to clean registry too ...

I've notice in ENUM : default monitor : 2 subdirectory
ONK0861 .. with edid and edid_override
OTM3034 with only optoma edid

and something change if i restart my receiver after windows loading ...
for example in "supported audio format", i only got DTS and DD when i start the computer and if i restart the onkyo i got HD format too ( dts master and true hd ) ... make me think that something wrong somewhere

Follow the uninstalling of leftovers procedure from link in my signature.

EDID Overrides (capture, install/uninstall, troubleshooting)
Tulli is offline  
post #1005 of 3183 Old 11-24-2010, 06:20 PM
AVS Club Gold
 
Tulli's Avatar
 
Join Date: Nov 2001
Posts: 5,175
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 21 Post(s)
Liked: 81
Quote:
Originally Posted by deeshell View Post
hi does anyone have an inf or edid dump for an rx-v3900 yamaha reciever?
Thanks.
I attach the v1900 .inf which should be fine.

 

Yamaha RX-V1900.zip 1.1875k . file
Attached Files
File Type: zip Yamaha RX-V1900.zip (1.2 KB, 11 views)

EDID Overrides (capture, install/uninstall, troubleshooting)
Tulli is offline  
post #1006 of 3183 Old 11-24-2010, 08:59 PM
Newbie
 
deeshell's Avatar
 
Join Date: Nov 2010
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Thanks Tulli,
Yeah your rx-v1900.inf it was different to the rx-v3900.inf I was able to generate using a gtx460 graphics card and the latest version of Moninfo. Moninfo might not fully support the gtx460 yet hence the difference......will try out the rx-v1900.inf how it goes.....my hdmi is currently thinking it is a spdif in powerdvd and windvd.
deeshell is offline  
post #1007 of 3183 Old 11-24-2010, 09:43 PM
Newbie
 
Matthi4s's Avatar
 
Join Date: Nov 2010
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I've had an HTPC hooked up to my TV working fine for a while now in this configuration
HD 4350 DVI to HDMI adapter -> TV

I just purchased a Pioneer VSX-520-K so I could eventually stream TrueHD and DTS-HD. When I switch to the HTPC output on the receiver the screen is blank for a few seconds then nothing but wallpaper shows up and the sides are cropped in a few inches. Switching the outputs fixes this (i.e switch to DVD then back to BD) but Media portal is now displayed in a very small box in the upper corner of the screen.

I have tried the EDID overide using Moninfo to get the EDID of the receiver but this has not fixed the issue.

I was wondering if purchasing an HD 5xxxx series would fix this as it would be direct hdmi to the receiver?

This is all very disappointing as I was really excited to get this hooked up and working tonight and at least have 8 channel LPCM capabilities until I get an 5xxx series card. I really don't want to return the receiver.

Any other suggestions?

Edit: Media Portal seems to be correcting itself, I'm not sure if it's doing it all the time or just some times. This still leaves the issue of switching to BD and having nothing but wallpaper and cropped sides (what is it even doing?) and having to switch to a different output and back again to fix it...
Matthi4s is offline  
post #1008 of 3183 Old 11-25-2010, 02:20 AM
AVS Club Gold
 
Tulli's Avatar
 
Join Date: Nov 2001
Posts: 5,175
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 21 Post(s)
Liked: 81
Quote:
Originally Posted by deeshell View Post

Thanks Tulli,
Yeah your rx-v1900.inf it was different to the rx-v3900.inf I was able to generate using a gtx460 graphics card and the latest version of Moninfo. Moninfo might not fully support the gtx460 yet hence the difference......will try out the rx-v1900.inf how it goes.....my hdmi is currently thinking it is a spdif in powerdvd and windvd.

That rx-v1900 EDID has the base block of a JVC DLA-RS10U projector, so you might run into video issues. If so combine the base block of your display device EDID with the extension block of the rx-v1900. Ideally you would only need to replace the audio and speakers block of your display device EDID, but that would require capturing it with a different graphic card.

EDID Overrides (capture, install/uninstall, troubleshooting)
Tulli is offline  
post #1009 of 3183 Old 11-25-2010, 02:32 AM
AVS Club Gold
 
Tulli's Avatar
 
Join Date: Nov 2001
Posts: 5,175
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 21 Post(s)
Liked: 81
Quote:
Originally Posted by Matthi4s View Post

I've had an HTPC hooked up to my TV working fine for a while now in this configuration
HD 4350 DVI to HDMI adapter -> TV

I just purchased a Pioneer VSX-520-K so I could eventually stream TrueHD and DTS-HD. When I switch to the HTPC output on the receiver the screen is blank for a few seconds then nothing but wallpaper shows up and the sides are cropped in a few inches. Switching the outputs fixes this (i.e switch to DVD then back to BD) but Media portal is now displayed in a very small box in the upper corner of the screen.

I have tried the EDID overide using Moninfo to get the EDID of the receiver but this has not fixed the issue.

I was wondering if purchasing an HD 5xxxx series would fix this as it would be direct hdmi to the receiver?

This is all very disappointing as I was really excited to get this hooked up and working tonight and at least have 8 channel LPCM capabilities until I get an 5xxx series card. I really don't want to return the receiver.

Any other suggestions?

Edit: Media Portal seems to be correcting itself, I'm not sure if it's doing it all the time or just some times. This still leaves the issue of switching to BD and having nothing but wallpaper and cropped sides (what is it even doing?) and having to switch to a different output and back again to fix it...

That's not an EDID issue. It looks like tha ATI driver is switching to extended mode when detecting the AVR, so maybe your primary and secondary displays need to be re-hooked/re-detected/setup in proper order. Try cleaning up of all registry leftovers by following procedure inlcuded on 1st post of link in my sig. Then see that the ATI driver correctly detects primary and secondary monitors. The primary monitor should always show the desktop of course. If OTH you're using clone mode make sure that display resolutions match.

EDID Overrides (capture, install/uninstall, troubleshooting)
Tulli is offline  
post #1010 of 3183 Old 11-25-2010, 09:50 AM
Newbie
 
Matthi4s's Avatar
 
Join Date: Nov 2010
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Thanks for the reply,

I do not have any other display attached, only the AVR. I followed the procedure for uninstalling the EDID and removing any greyed out devices. I went into CCC and clicked detect monitor and the 1 showed up on my TV. Then I went into the screen resolution settings from the desktop and clicked two other displays that were showing up and removed them. I restarted the computer and tried switching to the output i use for cable tv then switched back and this time nothing showed up. The HDMI light on the AVR was blinking indicating that there was no signal. Again I had to switch to another output and back to get picture. The desktop was in the correct resolution but Media Portal was shrunk into a corner. I checked in the resolution settings from the desktop again and it's showing a secondary display as S-Video. The settings for the primary display show as VSX-520 a it's set to show desktop only on 1.
Matthi4s is offline  
post #1011 of 3183 Old 11-25-2010, 10:51 AM
AVS Club Gold
 
Tulli's Avatar
 
Join Date: Nov 2001
Posts: 5,175
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 21 Post(s)
Liked: 81
Quote:
Originally Posted by Matthi4s View Post

Thanks for the reply,

I do not have any other display attached, only the AVR. I followed the procedure for uninstalling the EDID and removing any greyed out devices. I went into CCC and clicked detect monitor and the 1 showed up on my TV. Then I went into the screen resolution settings from the desktop and clicked two other displays that were showing up and removed them. I restarted the computer and tried switching to the output i use for cable tv then switched back and this time nothing showed up. The HDMI light on the AVR was blinking indicating that there was no signal. Again I had to switch to another output and back to get picture. The desktop was in the correct resolution but Media Portal was shrunk into a corner. I checked in the resolution settings from the desktop again and it's showing a secondary display as S-Video. The settings for the primary display show as VSX-520 a it's set to show desktop only on 1.

I can't explain how you get more than one display detected while having only one connection to the AVR. Try a driver re-install with cleanup, and if that doesn't even work a fresh system install might be required.

EDID Overrides (capture, install/uninstall, troubleshooting)
Tulli is offline  
post #1012 of 3183 Old 11-25-2010, 11:38 AM
Newbie
 
Matthi4s's Avatar
 
Join Date: Nov 2010
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I reinstalled the the ATI drivers to no avail. Unfortunately I think a fresh install maybe in order. I wanted to wait until SSD prices came down before I did a new install so I guess I'll have to deal with this for now.
Matthi4s is offline  
post #1013 of 3183 Old 11-26-2010, 03:59 AM
Member
 
bgnt44's Avatar
 
Join Date: Nov 2010
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Tulli View Post

Well, what is really needed is the Vendor Specific Data block and other data blocks that are present on your Optoma HD67 EDID extension block, for a complete merge of the Optoma EDID + ONKYO audio block. But that means of course capturing the full 256-EDID of the Optoma with Moninfo, which cannot be done now on Nvidia 4xx.

So, do you have an older card, another PC (a laptop with an HDMI port?) to capture the Optoma full EDID? Post it and I'll do the merge if necessary.

Hey,

i got the complete Optoma HD67 EDID informations :

so if you can merge it with ONKYO 507 it would be great !!

Raw data
00,FF,FF,FF,FF,FF,FF,00,3E,8D,34,30,FD,00,00,00,10,14,01,03, 80,00,00,00,2F,00,00,A4,50,4F,8C,23,12,48,4F,AF,EF,80,61,7C, 81,00,81,80,A9,40,81,FC,81,C0,45,7C,B3,00,1A,1D,00,80,51,D0, 1C,20,40,80,35,00,00,00,00,00,00,1C,01,1D,00,BC,52,D0,1E,20, B8,28,55,00,00,00,00,00,00,1E,00,00,00,FD,00,38,78,1E,78,11, 00,0A,20,20,20,20,20,20,00,00,00,FC,00,4F,70,74,6F,6D,61,20, 33,44,30,34,0A,20,01,6E,02,03,20,76,4B,10,1F,05,14,04,22,13, 03,12,20,21,23,09,1F,07,83,2F,00,00,67,03,0C,00,10,00,28,2D, 01,1D,80,18,71,1C,16,20,58,2C,25,00,00,00,00,00,00,9E,01,1D, 80,D0,72,1C,16,20,10,2C,25,00,00,00,00,00,00,9E,01,1D,00,72, 51,D0,1E,20,6E,28,55,00,00,00,00,00,00,1E,8C,0A,D0,90,20,40, 31,20,0C,40,55,00,00,00,00,00,00,18,8C,0A,D0,8A,20,E0,2D,10, 10,3E,96,00,00,00,00,00,00,18,00,00,00,00,00,F2


AND

[OVERRIDDEN-EDID_AddReg]
;Base EDID
HKR,EDID_OVERRIDE,"0",0x01,0x00,0xFF,0xFF,0xFF,0xFF,0xFF,0xFF,0x00,0x3E,0x8D,0x34 ,0x30,0xFD,0x00,0x00,0x00,0x10,0x14,0x01,0x03,0x80,0x00,0x00 ,0x00,0x2F,0x00,0x00,0xA4,0x50,0x4F,0x8C,0x23,0x12,0x48,0x4F ,0xAF,0xEF,0x80,0x61,0x7C,0x81,0x00,0x81,0x80,0xA9,0x40,0x81 ,0xFC,0x81,0xC0,0x45,0x7C,0xB3,0x00,0x1A,0x1D,0x00,0x80,0x51 ,0xD0,0x1C,0x20,0x40,0x80,0x35,0x00,0x00,0x00,0x00,0x00,0x00 ,0x1C,0x01,0x1D,0x00,0xBC,0x52,0xD0,0x1E,0x20,0xB8,0x28,0x55 ,0x00,0x00,0x00,0x00,0x00,0x00,0x1E,0x00,0x00,0x00,0xFD,0x00 ,0x38,0x78,0x1E,0x78,0x11,0x00,0x0A,0x20,0x20,0x20,0x20,0x20 ,0x20,0x00,0x00,0x00,0xFC,0x00,0x4F,0x70,0x74,0x6F,0x6D,0x61 ,0x20,0x33,0x44,0x30,0x34,0x0A,0x20,0x01,0x6E

;Extension bloc #1, e.g., CEA-EXT, DID-EXT, etc.
HKR,EDID_OVERRIDE,"1",0x01,0x02,0x03,0x20,0x76,0x4B,0x10,0x1F,0x05,0x14,0x04,0x22 ,0x13,0x03,0x12,0x20,0x21,0x23,0x09,0x1F,0x07,0x83,0x2F,0x00 ,0x00,0x67,0x03,0x0C,0x00,0x10,0x00,0x28,0x2D,0x01,0x1D,0x80 ,0x18,0x71,0x1C,0x16,0x20,0x58,0x2C,0x25,0x00,0x00,0x00,0x00 ,0x00,0x00,0x9E,0x01,0x1D,0x80,0xD0,0x72,0x1C,0x16,0x20,0x10 ,0x2C,0x25,0x00,0x00,0x00,0x00,0x00,0x00,0x9E,0x01,0x1D,0x00 ,0x72,0x51,0xD0,0x1E,0x20,0x6E,0x28,0x55,0x00,0x00,0x00,0x00 ,0x00,0x00,0x1E,0x8C,0x0A,0xD0,0x90,0x20,0x40,0x31,0x20,0x0C ,0x40,0x55,0x00,0x00,0x00,0x00,0x00,0x00,0x18,0x8C,0x0A,0xD0 ,0x8A,0x20,0xE0,0x2D,0x10,0x10,0x3E,0x96,0x00,0x00,0x00,0x00 ,0x00,0x00,0x18,0x00,0x00,0x00,0x00,0x00,0xF2
bgnt44 is offline  
post #1014 of 3183 Old 11-26-2010, 06:57 AM
AVS Club Gold
 
Tulli's Avatar
 
Join Date: Nov 2001
Posts: 5,175
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 21 Post(s)
Liked: 81
Quote:
Originally Posted by bgnt44 View Post
Hey,

i got the complete Optoma HD67 EDID informations :

so if you can merge it with ONKYO 507 it would be great !!

Raw data
00,FF,FF,FF,FF,FF,FF,00,3E,8D,34,30,FD,00,00,00,10,14,01,03, 80,00,00,00,2F,00,00,A4,50,4F,8C,23,12,48,4F,AF,EF,80,61,7C, 81,00,81,80,A9,40,81,FC,81,C0,45,7C,B3,00,1A,1D,00,80,51,D0, 1C,20,40,80,35,00,00,00,00,00,00,1C,01,1D,00,BC,52,D0,1E,20, B8,28,55,00,00,00,00,00,00,1E,00,00,00,FD,00,38,78,1E,78,11, 00,0A,20,20,20,20,20,20,00,00,00,FC,00,4F,70,74,6F,6D,61,20, 33,44,30,34,0A,20,01,6E,02,03,20,76,4B,10,1F,05,14,04,22,13, 03,12,20,21,23,09,1F,07,83,2F,00,00,67,03,0C,00,10,00,28,2D, 01,1D,80,18,71,1C,16,20,58,2C,25,00,00,00,00,00,00,9E,01,1D, 80,D0,72,1C,16,20,10,2C,25,00,00,00,00,00,00,9E,01,1D,00,72, 51,D0,1E,20,6E,28,55,00,00,00,00,00,00,1E,8C,0A,D0,90,20,40, 31,20,0C,40,55,00,00,00,00,00,00,18,8C,0A,D0,8A,20,E0,2D,10, 10,3E,96,00,00,00,00,00,00,18,00,00,00,00,00,F2


AND

[OVERRIDDEN-EDID_AddReg]
;Base EDID
HKR,EDID_OVERRIDE,"0",0x01,0x00,0xFF,0xFF,0xFF,0xFF,0xFF,0xFF,0x00,0x3E,0x8D,0x34 ,0x30,0xFD,0x00,0x00,0x00,0x10,0x14,0x01,0x03,0x80,0x00,0x00 ,0x00,0x2F,0x00,0x00,0xA4,0x50,0x4F,0x8C,0x23,0x12,0x48,0x4F ,0xAF,0xEF,0x80,0x61,0x7C,0x81,0x00,0x81,0x80,0xA9,0x40,0x81 ,0xFC,0x81,0xC0,0x45,0x7C,0xB3,0x00,0x1A,0x1D,0x00,0x80,0x51 ,0xD0,0x1C,0x20,0x40,0x80,0x35,0x00,0x00,0x00,0x00,0x00,0x00 ,0x1C,0x01,0x1D,0x00,0xBC,0x52,0xD0,0x1E,0x20,0xB8,0x28,0x55 ,0x00,0x00,0x00,0x00,0x00,0x00,0x1E,0x00,0x00,0x00,0xFD,0x00 ,0x38,0x78,0x1E,0x78,0x11,0x00,0x0A,0x20,0x20,0x20,0x20,0x20 ,0x20,0x00,0x00,0x00,0xFC,0x00,0x4F,0x70,0x74,0x6F,0x6D,0x61 ,0x20,0x33,0x44,0x30,0x34,0x0A,0x20,0x01,0x6E

;Extension bloc #1, e.g., CEA-EXT, DID-EXT, etc.
HKR,EDID_OVERRIDE,"1",0x01,0x02,0x03,0x20,0x76,0x4B,0x10,0x1F,0x05,0x14,0x04,0x22 ,0x13,0x03,0x12,0x20,0x21,0x23,0x09,0x1F,0x07,0x83,0x2F,0x00 ,0x00,0x67,0x03,0x0C,0x00,0x10,0x00,0x28,0x2D,0x01,0x1D,0x80 ,0x18,0x71,0x1C,0x16,0x20,0x58,0x2C,0x25,0x00,0x00,0x00,0x00 ,0x00,0x00,0x9E,0x01,0x1D,0x80,0xD0,0x72,0x1C,0x16,0x20,0x10 ,0x2C,0x25,0x00,0x00,0x00,0x00,0x00,0x00,0x9E,0x01,0x1D,0x00 ,0x72,0x51,0xD0,0x1E,0x20,0x6E,0x28,0x55,0x00,0x00,0x00,0x00 ,0x00,0x00,0x1E,0x8C,0x0A,0xD0,0x90,0x20,0x40,0x31,0x20,0x0C ,0x40,0x55,0x00,0x00,0x00,0x00,0x00,0x00,0x18,0x8C,0x0A,0xD0 ,0x8A,0x20,0xE0,0x2D,0x10,0x10,0x3E,0x96,0x00,0x00,0x00,0x00 ,0x00,0x00,0x18,0x00,0x00,0x00,0x00,0x00,0xF2
Optoma HD67 + (Onkyo 507 Audio & Speakers descriptors) .inf attached ... (Ids on base block set to Onkyo's, as it should be).

 

Optoma HD67 - ONKYO TX-SR507.zip 1.2275390625k . file
Attached Files
File Type: zip Optoma HD67 - ONKYO TX-SR507.zip (1.2 KB, 5 views)

EDID Overrides (capture, install/uninstall, troubleshooting)
Tulli is offline  
post #1015 of 3183 Old 11-26-2010, 09:13 AM
Member
 
bgnt44's Avatar
 
Join Date: Nov 2010
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Tulli View Post

Optoma HD67 + (Onkyo 507 Audio & Speakers descriptors) .inf attached ... (Ids on base block set to Onkyo's, as it should be).

thanks... i'll test that as soon as possible but i'm afraid that using onkyo as base may be make 3d vision unavailable ... (because nvidia drivers detect which one is connected )

is there any way to make NV drivers think that the connected device is Optoma ?
bgnt44 is offline  
post #1016 of 3183 Old 11-26-2010, 12:16 PM
AVS Club Gold
 
Tulli's Avatar
 
Join Date: Nov 2001
Posts: 5,175
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 21 Post(s)
Liked: 81
Quote:
Originally Posted by bgnt44 View Post

thanks... i'll test that as soon as possible but i'm afraid that using onkyo as base may be make 3d vision unavailable ... (because nvidia drivers detect which one is connected )

is there any way to make NV drivers think that the connected device is Optoma ?

No, it's only the Ids, i.e. except for the 2 ID descriptors the base block is the exact replica of the Optoma EDID. This is equivalent to "repeating" the Optoma base block through the Onkyo, so it shouldn't affect the video detection at all.

However if you do prefer/need to have the EDID override with the Optoma ID just replace the 'HKR,EDID_OVERRIDE,"0"...' line of the EDID override with the Optoma original .inf file that you captured.

EDID Overrides (capture, install/uninstall, troubleshooting)
Tulli is offline  
post #1017 of 3183 Old 11-27-2010, 04:02 AM
Member
 
bgnt44's Avatar
 
Join Date: Nov 2010
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Tulli View Post
No, it's only the Ids, i.e. except for the 2 ID descriptors the base block is the exact replica of the Optoma EDID. This is equivalent to "repeating" the Optoma base block through the Onkyo, so it shouldn't affect the video detection at all.

However if you do prefer/need to have the EDID override with the Optoma ID just replace the 'HKR,EDID_OVERRIDE,"0"...' line of the EDID override with the Optoma original .inf file that you captured.
I've just test it ... and like i was thinking 3d vision doen't work, so it has to be considered as an optoma device to work ... but by the way, i've no Hd sound in windows sound manager ... or i've got to restart the onkyo, no very usefull...

is there any way to use the Optoma inf and had HD sound capability to it (just hiding the onkyo), i think that the hard part is that the onkyo should be reconize as an optoma each time ... i'm really lost in that, which part of onkyo keep and which part to make optoma !

I'm thinking of testing your second solution (use optoma inf except for EDID "1" line : keep onkyo) i've try it and it doesn't work good ... resolution issues ... is it possible to mix the edid "1" line to keep only the audio part of onkyo and let other data refering the optoma ?

soon i'll try another solution : use the inf data of the optoma and keep your EDID line ... maybe 3d vision only use the manufacturer data (brand and name) to enable 3d vision... i know that these data are in edid too, but i'm not sure windows use these !
bgnt44 is offline  
post #1018 of 3183 Old 11-27-2010, 04:35 AM
Member
 
bgnt44's Avatar
 
Join Date: Nov 2010
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by bgnt44 View Post
I've just test it ... and like i was thinking 3d vision doen't work, so it has to be considered as an optoma device to work ... but by the way, i've no Hd sound in windows sound manager ... or i've got to restart the onkyo, no very usefull...

is there any way to use the Optoma inf and had HD sound capability to it (just hiding the onkyo), i think that the hard part is that the onkyo should be reconize as an optoma each time ... i'm really lost in that, which part of onkyo keep and which part to make optoma !

I'm thinking of testing your second solution (use optoma inf except for EDID "1" line : keep onkyo) i've try it and it doesn't work good ... resolution issues ... is it possible to mix the edid "1" line to keep only the audio part of onkyo and let other data refering the optoma ?

soon i'll try another solution : use the inf data of the optoma and keep your EDID line ... maybe 3d vision only use the manufacturer data (brand and name) to enable 3d vision... i know that these data are in edid too, but i'm not sure windows use these !
Ok i've no good result, hd sound still unavailable and if i stop and stard the optoma in windows i lost 3d vision ...

should i use edid blocker (if that exist ?)
bgnt44 is offline  
post #1019 of 3183 Old 11-27-2010, 05:25 AM
AVS Club Gold
 
Tulli's Avatar
 
Join Date: Nov 2001
Posts: 5,175
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 21 Post(s)
Liked: 81
Like I said, try replacing the 'HKR,EDID_OVERRIDE,"0"...' (base block) of the EDID override with the one from the Optoma.

Anyway, you should definitely get HD audio at least. Did you reboot after install?

EDIT:

Ok, I attach the override with original base block from the Optoma. Do a full cleanup of all registry leftovers again, install and reboot.

 

Optoma HD67 - ONKYO TX-SR507.zip 1.2275390625k . file

EDID Overrides (capture, install/uninstall, troubleshooting)
Tulli is offline  
post #1020 of 3183 Old 11-27-2010, 06:29 AM
Member
 
bgnt44's Avatar
 
Join Date: Nov 2010
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Tulli View Post
Like I said, try replacing the 'HKR,EDID_OVERRIDE,"0"...' (base block) of the EDID override with the one from the Optoma.

Anyway, you should definitely get HD audio at least. Did you reboot after install?

EDIT:

Ok, I attach the override with original base block from the Optoma. Do a full cleanup of all registry leftovers again, install and reboot.
ok that work but windows don't detect True HD and DTS master capability... and if i reboot the optoma i've got to restart computer to get 3d vision working again (not a big problem by the way)

In 3d vision drivers, there 's an inf file which contains that :

HKLM,"System\\CurrentControlSet\\Services\\NvStUSB\\Parameters\\OT M_3034","9D1C0000C00320032103A000510320007C025802590224005C020400",1,0xb7,0x86,0x01,0x00,0xab,0xe5,0x00,0x00,0x36,0x87,0x00,0x 00,0x92,0x0d,0x00,0x00,0x01,0x04,0x03,0x02
HKLM,"System\\CurrentControlSet\\Services\\NvStUSB\\Parameters\\OT M_3034","1E2D0000A00400040104A000310420002D03000301032D0004030400",1,0xaa,0x86,0x01,0x00,0xb0,0xe5,0x00,0x00,0x3c,0x87,0x00,0x 00,0x92,0x0d,0x00,0x00,0x01,0x04,0x03,0x02
HKLM,"System\\CurrentControlSet\\Services\\NvStUSB\\Parameters\\OT M_3034","1C3F0000D00600050105D001610588000403D002D1023400D2020300",1,0xa3,0x86,0x01,0x00,0xab,0xe5,0x00,0x00,0x39,0x87,0x00,0x 00,0x98,0x0d,0x00,0x00,0x01,0x04,0x03,0x02


maybe modding with onkyo data may be enable 3d vision for onkyo ( and let me use Generic p&p monitor)

comparing to other device i think that data "9D1C0000C00320032103A000510320007C025802590224005C020400" are for 3d stereo mode (same for multiple projector)
but binary data may be used for edid detection ... what do you think of that ??
bgnt44 is offline  
Reply Home Theater Computers

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off