Why do my MKVs with FLAC have low volume? - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 21 Old 11-12-2009, 07:12 PM - Thread Starter
Member
 
Gabuk's Avatar
 
Join Date: Mar 2002
Posts: 64
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I have some questions about multichannel FLAC files in an MKV and why everything is at a low volume. Here's my setup as well as how I create the MKV files.

Zotac mATX 9300 with and E7400 (no additional video card or sound card)
Windows 7 Ultimate (fully patched) utilizing Shark's 007 32 and 64 bit codec packs. I run Media Browser as my frontend and playback via W7. Hardware assist works on all supported formats and SD is handled by the MS decoder. All current Nvidia HDMI drivers and setup as 5.1.

HDMI out of Zotac to Pioneer SC-05. Everything sounds great but the volume level is so low. I have to maximize the Windows volume and crank up the SC-05's volume to match what I would normally get out of a DVD/BD that plays out of my OPPO BDP-83.

Using Shark's menu selection, I go to the AC-3 filter plugin and switch PCM to read as 32 bit. I don't adjust any of the levels. The Pioneer reads all audio streams as PCM and plays them back in 5.1 with no issues but the sound is so low. I am stumped?!?

Here's my process of making BD/HD-DVD MKVs (SD is handled via MakeMKV).

AnyDVD for decryption.

HDBR Stream to demux the chapters to text, video to MKV, and DTS/AC3 to FLAC. Once finished, everything is remuxed with MKV Merge. Playback has been great and sound via headphones (stereo) is awesome. But once I connect to my 5.1 setup, the volume is always low.

I used ClownBD to test out a TS file with the Dolby Digital Streams set to downconvert to 640k. Once ClownBD finishes the TS file, playback of this file is much louder than the FLAC version. I tested this with The Italian Job and 300 BD versions. The SC-05 reports the Dolby Digital stream and the volume level seems to match the BD version. However, with the TS files I lose chapter support if I playback files via MPC.

I also decided to try a test with South Park season 12 on Blu-Ray. I used HDBR to demux like normal but instead of FLAC for audio, I chose AC3. After remuxing the files, and having Mediainfo report that the audio was 640k AC3, the SC-05 still states it was PCM and the volume was still low.

I am at a loss of what to do. I have too much pre-existing media to re-mux but moving forward, I want to get things right.

Should I use the SPDIF output for audio instead of the HDMI chain? Should I always select no conversion for audio in Clown BD instead of 640k AC3?

Thanks for all the help.
Gabuk
Gabuk is offline  
Sponsored Links
Advertisement
 
post #2 of 21 Old 11-12-2009, 10:04 PM
AVS Club Gold
 
renethx's Avatar
 
Join Date: Jan 2006
Posts: 16,243
Mentioned: 13 Post(s)
Tagged: 0 Thread(s)
Quoted: 241 Post(s)
Liked: 389
As for playback, madFlac Decoder + ReClock WASAPI exclusive is the solution. If you still have low volume, then it is the FLAC track itself (i.e. how you created it from the original audio track) that is the problem. TrueHD: use eac3to; DTS-HD MA: eac3to with TMT2; DD/DTS: don't convert to FLAC.
renethx is offline  
post #3 of 21 Old 11-17-2009, 01:52 PM
Senior Member
 
tlmaclennan's Avatar
 
Join Date: Apr 2009
Location: Garden Grove, CA
Posts: 423
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I use ffdshow to decode my FLAC tracks. I've noticed it's low as well, especially compared to the original audio track on the disc. I found that if I bump up the volume in ffdshow to 200% it is at a much better level.
tlmaclennan is offline  
post #4 of 21 Old 11-17-2009, 01:56 PM
Advanced Member
 
tman247's Avatar
 
Join Date: Sep 2007
Location: UK
Posts: 891
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 14 Post(s)
Liked: 32
I agree too. My converted FLAC audio is always quieter than the original source. I really have to bump up the volume to get sound levels the same.
tman247 is online now  
post #5 of 21 Old 11-17-2009, 02:22 PM
AVS Club Gold
 
renethx's Avatar
 
Join Date: Jan 2006
Posts: 16,243
Mentioned: 13 Post(s)
Tagged: 0 Thread(s)
Quoted: 241 Post(s)
Liked: 389
Hmm, have you ever tried madFlac Decoder + ReClock WASAPI exclusive mode instead of ffdshow (or any other FLAC decoder) + Windows Audio Engine? FLAC is lossless, encoded faithfully to the original audio track; leaving it to Windows Audio Engine does not look a nice idea. Go with "bit-perfect".
renethx is offline  
post #6 of 21 Old 11-17-2009, 04:49 PM - Thread Starter
Member
 
Gabuk's Avatar
 
Join Date: Mar 2002
Posts: 64
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hey Renethx,

I have MadFlac installed via Shark's 007 codec and downloaded Reclock. I followed your instructions per another thread as a guide. I setup Reclock to WASAPI exclusive and have it take over "one time" for W7MC, WMP12, and MPC-HC.

BAM! MKVs with AC3 or DTS converted to FLAC now report "DD Digital" instead of PCM on the SC-05 when I playback via any media player. The volume levels are no longer low and match a real BD/DVD.

That setup works great now. I can continue to create MKVs as FLAC and not have low-volume issues.

One other setup question...if I want to Bitstream DD True HD or DTS HD MA, that requires a 5800 series ATI card or the new I5/I3 chip, and using PDVD or TMT for playback, right? Is there a way to bitstream via W7 MC without any of those programs or HW?
Gabuk is offline  
post #7 of 21 Old 11-17-2009, 05:24 PM
AVS Club Gold
 
renethx's Avatar
 
Join Date: Jan 2006
Posts: 16,243
Mentioned: 13 Post(s)
Tagged: 0 Thread(s)
Quoted: 241 Post(s)
Liked: 389
ffdshow tryouts may support HD audio bitstreaming, hopefully soon (read the "ffdshow tryouts project: Dicussion & Development" thread starting at this post). Hardware is supposed to be any HDMI audio device supporting multichannel LPCM (i.e. having enough bandwidth), but currently tested only with HD 5xxx.
renethx is offline  
post #8 of 21 Old 11-18-2009, 04:21 AM
AVS Addicted Member
 
dbone1026's Avatar
 
Join Date: Aug 2008
Location: Long Island, New York
Posts: 11,335
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 30 Post(s)
Liked: 71
Quote:
Originally Posted by Gabuk View Post

Hey Renethx,

I have MadFlac installed via Shark's 007 codec and downloaded Reclock. I followed your instructions per another thread as a guide. I setup Reclock to WASAPI exclusive and have it take over "one time" for W7MC, WMP12, and MPC-HC.

BAM! MKVs with AC3 or DTS converted to FLAC now report "DD Digital" instead of PCM on the SC-05 when I playback via any media player. The volume levels are no longer low and match a real BD/DVD.

That setup works great now. I can continue to create MKVs as FLAC and not have low-volume issues.

One other setup question...if I want to Bitstream DD True HD or DTS HD MA, that requires a 5800 series ATI card or the new I5/I3 chip, and using PDVD or TMT for playback, right? Is there a way to bitstream via W7 MC without any of those programs or HW?

Do you have a link to Renethx's thread you followed to setup Reclock? I have had the same issue with low volume on FLACs using FFDShow.

I am starting to tinker around with FLAC (using Curt Palmes tool), but havent decided if I should go full force with since it seems like we are getting very close to having bitstream of DTS-MA/TrueHD more universally supported (I currently use Clown_BD and keep the original HD track)

Cheers,
Damian

MSS.net blog (contributing editor) - http://www.mediasmartserver.net

Windows Entertainment and Connected Home MVP 2010-2012

dbone1026 is offline  
post #9 of 21 Old 11-18-2009, 06:06 AM
<><
Advanced Member
 
<><'s Avatar
 
Join Date: Dec 2005
Location: Atlanta, Ga
Posts: 844
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 11
Hum, i expereince the same thing (comparing HD audio converted to flac vs the same movie with DD/DTS) but thoguht it was just how Flac/LPCM was...wasn't that big of an issue since i just had to turn up the volume...

Currently i'm just using the MadFlac decoder, but will give ReClock WASAPI a try along with it

dbone: http://www.avsforum.com/avs-vb/showt...2#post16594992
<>< is offline  
post #10 of 21 Old 11-18-2009, 06:15 AM
Advanced Member
 
tman247's Avatar
 
Join Date: Sep 2007
Location: UK
Posts: 891
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 14 Post(s)
Liked: 32
I try to stay clear of codec packs, and just use Haali/MadFLAC for all splitting/decoding. As MadFLAC is a standard DirectShow filter, it must be something in the codec pack that is converting FLAC to DD on the fly, which is why your decoder is detecting DD (i.e. bitstreaming). This could also mean it's throwing away some of the lossless audio in the FLAC file, and downsampling the audio to DD.

Reclock will sync video/audio, but not convert it, and with the current option in ATI CAT's to smooth playback of video, I no longer find I need ReClock. I also believe WASAPI exclusive will only work correctly using the Realtek ATI HDMI audio drivers, and not the ones shipped in the standard CAT package (correct me if I'm wrong).

All in all, it's a long winded solution to the low volume problem.
tman247 is online now  
post #11 of 21 Old 11-18-2009, 06:26 AM
AVS Special Member
 
oliverjg's Avatar
 
Join Date: Sep 2006
Posts: 1,760
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by dbone1026 View Post

Do you have a link to Renethx's thread you followed to setup Reclock? I have had the same issue with low volume on FLACs using FFDShow.

I am starting to tinker around with FLAC (using Curt Palmes tool), but havent decided if I should go full force with since it seems like we are getting very close to having bitstream of DTS-MA/TrueHD more universally supported (I currently use Clown_BD and keep the original HD track)

i am just waiting for the open source community to have a dts ma decoder. don't really see the point in replacing all the hardware in the world just because some corporations want to sell new avr's. nice for them but where is the overall benefit? just filling up landfills for no reason imo.

i don't have a problem with using flac for now. later on when their is a decoder i can switch to m2ts or stick with mkv/flac. having the flac around won't hurt anything. the files will still be smaller than the ones with dts hd ma.

once an open source dts ma decoder exists, you can basically build your own preamp and bitstreaming isn't needed.
oliverjg is offline  
post #12 of 21 Old 11-18-2009, 07:10 AM
<><
Advanced Member
 
<><'s Avatar
 
Join Date: Dec 2005
Location: Atlanta, Ga
Posts: 844
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 11
Just another question also, when would one benefit using WASAPI exclusive?

For example, if using headphones or HDMI out connected to a 2.0 display but playing a 5.1 or 7.1 source, i'm guessing that's not when you would want to use WASAPI exclusive since it bypasses all settings of the player as well as any windows settings?

If someone can shed some light exactly why and when one needs to use WASAPI exclusive....

Thanks
<>< is offline  
post #13 of 21 Old 11-18-2009, 08:48 AM
AVS Special Member
 
Jeff Flowerday's Avatar
 
Join Date: Jan 2007
Location: Calgary, AB Canada
Posts: 1,212
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by <><</strong> View Post

Just another question also, when would one benefit using WASAPI exclusive?

For example, if using headphones or HDMI out connected to a 2.0 display but playing a 5.1 or 7.1 source, i'm guessing that's not when you would want to use WASAPI exclusive since it bypasses all settings of the player as well as any windows settings?

If someone can shed some light exactly why and when one needs to use WASAPI exclusive....

Thanks

If you don't use WASAPI, windows mixer messes with the audio before sending it out the HDMI port. Not sure the exact specifics, but it supposedly down converts it to 16/48 first and converts it back to what ever format (ie) 24/96) that you have specified as the standard output.

My Band: Scotch on Sunday
Jeff Flowerday is offline  
post #14 of 21 Old 11-18-2009, 06:24 PM
<><
Advanced Member
 
<><'s Avatar
 
Join Date: Dec 2005
Location: Atlanta, Ga
Posts: 844
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 11
Quote:
Originally Posted by Jeff Flowerday View Post

If you don't use WASAPI, windows mixer messes with the audio before sending it out the HDMI port. Not sure the exact specifics, but it supposedly down converts it to 16/48 first and converts it back to what ever format (ie) 24/96) that you have specified as the standard output.

Thanks, but what I was trying to find out is what if your display/output is 2.0 (headphones or HDMI connected to LCD) and you play a media that is 5.1 or 7.1..
Just tried that and it doesn't work, the sound is from the RF or RL or the BL or BR in the headphones...

So i'm guessing exclusive mode is only useful if using w/ a 7.1 setup or if only playing music/2.0 media?
<>< is offline  
post #15 of 21 Old 11-18-2009, 06:40 PM
Advanced Member
 
andrewfee's Avatar
 
Join Date: Mar 2004
Posts: 785
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Quote:
Originally Posted by <><</strong> View Post

Thanks, but what I was trying to find out is what if your source is 2.0 and you play a media that is 5.1 or 7.1..
Just tried that and it doesn't work, the sound is from the RF or RL or the BL or BR in the headphones...

So i'm guessing exclusive mode is only useful if using w/ a 7.1 setup or if only playing music/2.0 media?

If you use ffdshow, enable uncompressed in the audio codecs section and you can then use the mixer to downmix to 2.0 first which still lets you use WASAPI.

If you use the normalize matrix option in the mixer, volume will be lowered significantly to ensure that there is no clipping. Disabling this will make it play back at the original volume, but I have noticed clipping before when it's like this.
andrewfee is offline  
post #16 of 21 Old 11-18-2009, 07:10 PM
<><
Advanced Member
 
<><'s Avatar
 
Join Date: Dec 2005
Location: Atlanta, Ga
Posts: 844
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 11
Quote:
Originally Posted by andrewfee View Post

If you use ffdshow, enable uncompressed in the audio codecs section and you can then use the mixer to downmix to 2.0 first which still lets you use WASAPI.

If you use the normalize matrix option in the mixer, volume will be lowered significantly to ensure that there is no clipping. Disabling this will make it play back at the original volume, but I have noticed clipping before when it's like this.


No, not using ffdshow, only thing i have installed is madflac and haali (and now reclock)...but thanks for the tip

Another thing with DVDs is that it also doesn't pass DD to the receiver, the receiver sees it as PCM i guess, so it doesn't apply the DDPLIIx I have setup for DD
<>< is offline  
post #17 of 21 Old 11-18-2009, 07:44 PM
AVS Club Gold
 
renethx's Avatar
 
Join Date: Jan 2006
Posts: 16,243
Mentioned: 13 Post(s)
Tagged: 0 Thread(s)
Quoted: 241 Post(s)
Liked: 389
madFlac + WASAPI exclusive means "bit-perfect" sounds; there is no way to downmix to stereo. You should use ffdshow instead of madFlac for this purpose.

If you use Realtek ATI HDMI Device driver, then you need to check the box next to "Set matching speaker configuration for PCM sound" to get the correct channel count in AVR so that DD PLIIx is applied. ATI driver does not suffer from this issue (but there is another serious issue that ReClock can output only 16 bit to the driver).
renethx is offline  
post #18 of 21 Old 11-19-2009, 05:54 AM
<><
Advanced Member
 
<><'s Avatar
 
Join Date: Dec 2005
Location: Atlanta, Ga
Posts: 844
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 11
Quote:
Originally Posted by renethx View Post

madFlac + WASAPI exclusive means "bit-perfect" sounds; there is no way to downmix to stereo. You should use ffdshow instead of madFlac for this purpose.

If you use Realtek ATI HDMI Device driver, then you need to check the box next to "Set matching speaker configuration for PCM sound" to get the correct channel count in AVR so that DD PLIIx is applied. ATI driver does not suffer from this issue (but there is another serious issue that ReClock can output only 16 bit to the driver).

Testing this on my 7.1 setup, I had a check next to "Set matching speaker configuartion for PCM sound", but when playing a DD movie, the receiver still showed Multi Channel Auido HDMI...disabling Reclock and playing the same movie the Reciever now shows DD with DD PLIIx applied.

Using Realtek ATI HDMI Sound drivers R2.35 with an ATI 4670.
<>< is offline  
post #19 of 21 Old 11-19-2009, 07:07 AM
AVS Club Gold
 
renethx's Avatar
 
Join Date: Jan 2006
Posts: 16,243
Mentioned: 13 Post(s)
Tagged: 0 Thread(s)
Quoted: 241 Post(s)
Liked: 389
Dolby PLIIx can be applied to not only DD but also stereo/5.1 PCM too. When you use ReClock, sending 5.1 PCM to AVR is recommended instead of DD bitstreams.
renethx is offline  
post #20 of 21 Old 11-19-2009, 06:28 PM
<><
Advanced Member
 
<><'s Avatar
 
Join Date: Dec 2005
Location: Atlanta, Ga
Posts: 844
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 11
Quote:
Originally Posted by renethx View Post

Dolby PLIIx can be applied to not only DD but also stereo/5.1 PCM too. When you use ReClock, sending 5.1 PCM to AVR is recommended instead of DD bitstreams.

Not on my receiver (Integra 5.8), the only listening modes i can select while in MultiChannel HDMI on the reciever is Multi-Ch and Direct, cannot select any other modes like I can when I have DD being passed.

I guess it's an older receiver (2007 model) but i think the HDMI Multi-Ch LPCM is being treated similar to the analog multi-channel, w/ no control from the receiver...
<>< is offline  
post #21 of 21 Old 02-18-2010, 07:06 PM
Senior Member
 
S2G-Unit's Avatar
 
Join Date: Apr 2005
Location: Montreal, Canada
Posts: 220
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by <><</strong> View Post

Not on my receiver (Integra 5.8), the only listening modes i can select while in MultiChannel HDMI on the reciever is Multi-Ch and Direct, cannot select any other modes like I can when I have DD being passed.

I guess it's an older receiver (2007 model) but i think the HDMI Multi-Ch LPCM is being treated similar to the analog multi-channel, w/ no control from the receiver...

Same with me. So that means we cant use PLIIx on movies. Although, my receiver shows the output being 7 channels.

What is the disadvantage?
S2G-Unit is offline  
Reply Home Theater Computers



Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off