Problems playing blu-ray combo discs - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 9 Old 02-02-2010, 11:37 AM - Thread Starter
Member
 
littleman00's Avatar
 
Join Date: Nov 2006
Posts: 31
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I recently bought an LG Blu-ray drive for my old HTPC, and so far everything works great. Except for District 9.

I understand it's a combo disc that features the God of War III game demo. I'm wondering if it's interfering with playback. Basically, I pop the disc into my drive, and it tells me that there's an unsupported disc in there.

I'm running:

Windows XP
AMD X2 4200+
2GB RAM
LG Super-multi Blu-ray drive
ATI Radeon HD 4670 1GB
PowerDVD 9 Ultra
littleman00 is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 02-02-2010, 11:49 AM
AVS Special Member
 
sitlet's Avatar
 
Join Date: Jun 2007
Posts: 1,591
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 19
have you updated the drive's firmware?

do a search on here or even google for this. i know i have read a few other threads with people having issues with this disc.
sitlet is offline  
post #3 of 9 Old 02-02-2010, 11:53 AM
AVS Special Member
 
jrwalte's Avatar
 
Join Date: Jun 2007
Posts: 2,537
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
I was able to get it working. I forget if I had AnyDVD running or not. Do you have AnyDVD? If so, try closing out of it.

Also, try opening up PowerDVD9 software first and then insert the disc.
jrwalte is offline  
post #4 of 9 Old 02-03-2010, 12:59 AM - Thread Starter
Member
 
littleman00's Avatar
 
Join Date: Nov 2006
Posts: 31
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I just updated the drive's firmware (ver.1 to ver.2) with a patch directly from LG's website.

No go.

I'm still getting the same error message (unsupported disc in drive). Any other thoughts? I appreciate the help!
littleman00 is offline  
post #5 of 9 Old 02-03-2010, 04:52 AM
tsb
AVS Special Member
 
tsb's Avatar
 
Join Date: May 2005
Posts: 4,917
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by littleman00 View Post

I just updated the drive's firmware (ver.1 to ver.2) with a patch directly from LG's website.

No go.

I'm still getting the same error message (unsupported disc in drive). Any other thoughts? I appreciate the help!

did you try anydvd hd?
tsb is offline  
post #6 of 9 Old 02-04-2010, 04:53 PM - Thread Starter
Member
 
littleman00's Avatar
 
Join Date: Nov 2006
Posts: 31
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by tsb View Post

did you try anydvd hd?

Yes, I've tried using AnyDVD HD and still the same. It tells me there's an unsupported disc format in the drive. I thought it was maybe just a bad disc I had, but I popped it in someone's standalone blu-ray player and it plays fine.
littleman00 is offline  
post #7 of 9 Old 02-04-2010, 05:07 PM
AVS Special Member
 
jrwalte's Avatar
 
Join Date: Jun 2007
Posts: 2,537
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Did you load PowerDVD9 first before inserting the disc? Some discs have a copy protection to try and prevent a PC from reading the disc. Having the BD software open can help get past this. Doesn't always work, though. Usually the latest version of AnyDVD resolves it.
jrwalte is offline  
post #8 of 9 Old 02-04-2010, 07:49 PM - Thread Starter
Member
 
littleman00's Avatar
 
Join Date: Nov 2006
Posts: 31
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by jrwalte View Post

Did you load PowerDVD9 first before inserting the disc? Some discs have a copy protection to try and prevent a PC from reading the disc. Having the BD software open can help get past this. Doesn't always work, though. Usually the latest version of AnyDVD resolves it.

Yes, I've tried playing the disc by opening PowerDVD first, then inserting the disc. No change. I'm also running the latest version of AnyDVD HD, however it's a trial version I downloaded from their website. Also, I don't know if it's a copy-protection issue, or if it's an issue with the PS3 game files being on the disc.

And I'm curious, what make/model blu-ray drive are you using?
littleman00 is offline  
post #9 of 9 Old 02-05-2010, 06:33 AM
AVS Special Member
 
jrwalte's Avatar
 
Join Date: Jun 2007
Posts: 2,537
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
I use the LG GGC-H20L
jrwalte is offline  
Reply Home Theater Computers

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off