Netflix Streaming on Windows7 : Any Fix for Tearing? - AVS Forum
Forum Jump: 
Reply
 
Thread Tools
post #1 of 34 Old 03-21-2010, 01:01 PM - Thread Starter
Advanced Member
 
Marc_G's Avatar
 
Join Date: Dec 2005
Location: Indianapolis Metro Area
Posts: 939
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 17 Post(s)
Liked: 34
Hi folks,

Is there any fix for us Windows users streaming Netflix content, who get the awful vertical tearing problems? It makes any movie with notable motion scenes almost unwatchable. I've heard many theories about the causes but no solutions yet.

I'm on W7 HP x32 and get the tearing either through WMC via the NF App or from IE / Firefox going to the Netflix site. I have a 1080i plasma and have tried sending it either 1080i resolution or the panel's native 1366x768. Same deal either way. I believe I've tried Aero on and off (I've got it off at the moment I think).

Would greatly appreciate any suggestions for fixing this. What I see during motion scenes is a flickery artifact where at some point the top of the video and at some point lower are displaying different video frames. Happens on all content streamed through netflix without exception, constantly whenever there is motion on screen.

Help!

Marc

Sometimes, I see dead pixels...
Marc_G is offline  
Sponsored Links
Advertisement
 
post #2 of 34 Old 03-21-2010, 01:22 PM
AVS Special Member
 
ilovejedd's Avatar
 
Join Date: Aug 2006
Posts: 3,725
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 38 Post(s)
Liked: 59
Hmm, what computer specs?
ilovejedd is offline  
post #3 of 34 Old 03-21-2010, 01:25 PM
AVS Special Member
 
kapone's Avatar
 
Join Date: Jan 2003
Posts: 4,437
Mentioned: 8 Post(s)
Tagged: 0 Thread(s)
Quoted: 89 Post(s)
Liked: 128
A possible solution for nVidia cards (apparently) that has been posted elsewhere.

Quote:


OK, I believe I have a solution for Netflix users and Nvdia cards and this has appeared to completely solved the problem. I don't know if this works on Macs, but this worked for me running Windows XP and having a Nvidia 7900 GT card. Anyway, first of all, so we're all on the same page, download the latest drivers from nvidia. They release new ones every other month or so, so don't think you have the newest version. This may not be necessary, but do it anyway so you can properly follow along.
http://www.nvidia.com/Download/index.aspx?lang=en-us
Secondly, open the Nvidia control panel. Right click on the green nivida symbol that should be in your icon tray next to the system time in lower right hand corner of the monitor, and open the "Nvidia Control Panel". Expand "Display" if it isn't already expanded in the left bar and choose "Adjust desktop size and position". Under section 2. that says "When a resolution lower than my display's native resolution..." mine was originally set on "Use my display's built in scaling". Personally, I changed that to, "Use NVIDIA scaling with fixed aspect ratio" and my tearing problems were completely solved. Use the other Nvidia scaling option if you dont like the result.

This actually leads me to believe that the problem is not necessarily with Nvidia and Silverlight, but perhaps with Silverlight and my monitor. In any event it works perfectly and I'm happy now.

kapone is offline  
post #4 of 34 Old 03-21-2010, 01:26 PM
Member
 
ivanhoek's Avatar
 
Join Date: Jan 2008
Location: San Antonio
Posts: 182
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 24
Quote:
Originally Posted by Marc_G View Post

Hi folks,

Is there any fix for us Windows users streaming Netflix content, who get the awful vertical tearing problems? It makes any movie with notable motion scenes almost unwatchable. I've heard many theories about the causes but no solutions yet.

I'm on W7 HP x32 and get the tearing either through WMC via the NF App or from IE / Firefox going to the Netflix site. I have a 1080i plasma and have tried sending it either 1080i resolution or the panel's native 1366x768. Same deal either way. I believe I've tried Aero on and off (I've got it off at the moment I think).

Would greatly appreciate any suggestions for fixing this. What I see during motion scenes is a flickery artifact where at some point the top of the video and at some point lower are displaying different video frames. Happens on all content streamed through netflix without exception, constantly whenever there is motion on screen.

Help!

Marc

Netflix streaming picture quality seems really sensitive to network issues. How do you connect to the Internet? If you have, for example, a PPoE DSL connection, you can try reducing your MTU at the Netflix viewing PC to match the PPoE MTU. (usually set to 1492)

If you have any intermediary firewalls or routers, you could just try reducing the MTU there. Often times, these intermediary firewalls or routers (sometimes even the DSL modem itself) doesn't relay the ICMP messages necessary for PMTU discovery and this results in some packets not making it through reliably.

Try that and see if the picture quality improves..
ivanhoek is offline  
post #5 of 34 Old 03-21-2010, 01:57 PM
AVS Special Member
 
kapone's Avatar
 
Join Date: Jan 2003
Posts: 4,437
Mentioned: 8 Post(s)
Tagged: 0 Thread(s)
Quoted: 89 Post(s)
Liked: 128
You can also try a couple of "hacks".

Exit Media Center if it's running.
Fire up Netflix in IE, DON'T make it full screen.
Select SHIFT+ALT on your keyboard and CLICK somewhere inside the player (which is not full screen at this point, and running within IE)
This will bring up a Silverlight Diagnostics menu.

Select A/V Stats
Observe the Playing bitrate and the buffering bitrate. Generally you'll find the playing bitrate to be 500 and the buffering bitrate to be 1500
Exit the diagnostics screen by clicking on the X at top right (the diagnostics is just an overlay over the underlying video)

Go into the diagnostics menu again by SHIFT+ALT + click
Select Stream Manager this time, and set it to "manual" and 1500. Apply

Exit Diagnostics menu
Reenter Diagnostics menu and go into AV stats again.
Observe the rates again. They "should" both be 1500 now.

These rates should persist even in the player in Media Center as the changes seem to be global. Reboot if you need to.

Now, this may still not help the tearing issue, but atleast you have removed the whole PQ based on network connection speed variable out of the equation.
kapone is offline  
post #6 of 34 Old 03-21-2010, 02:06 PM
 
googlegod's Avatar
 
Join Date: Nov 2008
Posts: 1,387
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Vertical Sync
Turn it on
Thats all
googlegod is offline  
post #7 of 34 Old 03-21-2010, 06:46 PM - Thread Starter
Advanced Member
 
Marc_G's Avatar
 
Join Date: Dec 2005
Location: Indianapolis Metro Area
Posts: 939
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 17 Post(s)
Liked: 34
Hi folks,

Thanks for the replies. I'll work through the suggestions posted here, though I must say I'm intrigued by the last one about VSync. HOW do I turn it on for NF streaming?

Meanwhile to answer the questions:

Sorry I forgot to post my specs. Forgot my sig doesn't list it.

It's an Athlon X2 Kuma a 2.7, so speedy enough for anything I need to do on the HTPC side. GPU is a nice new ATI HD5670 though I got the exact same issue on an HD 4550.

Internet connection is DSL and rock solid at 5 to 5.5 Mbps. I have no problems buffering to the max and Hulu runs like a champ. There's no change in performance for NF Streaming based on time of day or anything, and I had this same problem when I had a cable modem at 10-12Mbps. So, I really don't think it's a connectivity issue. It's a Vertical sync issue.

If Googlegod can tell me how to enable VSync for this application I'll be happy as a clam most likely! Meanwhile I'll try out the other items mentioned.

Marc

Sometimes, I see dead pixels...
Marc_G is offline  
post #8 of 34 Old 03-22-2010, 04:32 AM - Thread Starter
Advanced Member
 
Marc_G's Avatar
 
Join Date: Dec 2005
Location: Indianapolis Metro Area
Posts: 939
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 17 Post(s)
Liked: 34
I checked my network stuff out and found the player was already playing at 1500 (and buffering at 1500). Setting it to manually play at 1500 as expected had no effect since it was already doing it.

Poked around my DSL settings had no effect either... I've got a good solid network connection that's faster than anything NF is trying to do.

So I've ruled out connectivity issues.

I tried steaming on a completely different computer. This is W7 Home PRemium on a quad core Athlon 9550 at 2.2 GHz with an ATI HD4550. The tearing is there too but less noticeable probably due to the craptastic LCD monitor it's hooked up to. It's hard to pick up real details there.

Any other thoughts? I agree it sounds like a VSync issue.

Marc

Sometimes, I see dead pixels...
Marc_G is offline  
post #9 of 34 Old 03-22-2010, 05:09 AM
 
googlegod's Avatar
 
Join Date: Nov 2008
Posts: 1,387
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
You have a ATI video card "ATI HD5670" . Did you install the FULL ATI CCC driver suite ? Here is a link. Besure to pick the right windows os.
http://game.amd.com/us-en/drivers_catalyst.aspx
Once installed you will have full control over video.
Look under 3D for V sync
And also look under Display Management and Video Settings for other useful tools. I am behind the tech curve, still with xp, much hasn't changed, but this info should help you greatly as vertical tearing is a V sync problem with panels. Use settings 60hz , 720p or 1080i or maybe 30/24 hz.. Its a try it and see which works best for your setup. Someone with the same setup as you could tell you step by step, but till then this should help you, now that you have the tools needed to solve your vertical tearing.
googlegod is offline  
post #10 of 34 Old 03-22-2010, 05:03 PM - Thread Starter
Advanced Member
 
Marc_G's Avatar
 
Join Date: Dec 2005
Location: Indianapolis Metro Area
Posts: 939
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 17 Post(s)
Liked: 34
Folks,

I went into the CCC and in the 3D section turned the vertical refresh to Always On (There were several settings... by default it was midway on the range between performance and quality).'

No effect whatsoever on the tearing issue.

Since I'm currently running at 1366x768 (my panel native res) and it only gives me 30hz (not sure why, need to investigate), and because I've seen the same at 1080i (30hz), I decided to try a test at a 60 hz resolution.

I set the screen to 1280x720 60 hz. This gave a noticeable improvement for the tearing issue in NF Streaming, but didn't cure it. Basically, the tearing was still there just as much, but because of the faster refresh, each tear was somewhat less noticeable.

So I'm still looking for a fix to the original issue, and also looking for a way to optimally drive my panel (connected via HTML) at a 60 hz resolution that doesn't look crappy in general. So far, the only "good" settings are 1366x768 and 1080i in terms of regular usage.

OK gang, what's next to look at? Does anyone have this working without tearing? Particularly with an ATI card and a 1080i display, using W7?

Marc

Sometimes, I see dead pixels...
Marc_G is offline  
post #11 of 34 Old 03-22-2010, 08:43 PM
 
googlegod's Avatar
 
Join Date: Nov 2008
Posts: 1,387
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Marc_G View Post

Folks,

I went into the CCC and in the 3D section turned the vertical refresh to Always On (There were several settings... by default it was midway on the range between performance and quality).'

No effect whatsoever on the tearing issue.

Since I'm currently running at 1366x768 (my panel native res) and it only gives me 30hz (not sure why, need to investigate), and because I've seen the same at 1080i (30hz), I decided to try a test at a 60 hz resolution.

I set the screen to 1280x720 60 hz. This gave a noticeable improvement for the tearing issue in NF Streaming, but didn't cure it. Basically, the tearing was still there just as much, but because of the faster refresh, each tear was somewhat less noticeable.

So I'm still looking for a fix to the original issue, and also looking for a way to optimally drive my panel (connected via HTML) at a 60 hz resolution that doesn't look crappy in general. So far, the only "good" settings are 1366x768 and 1080i in terms of regular usage.

OK gang, what's next to look at? Does anyone have this working without tearing? Particularly with an ATI card and a 1080i display, using W7?

Marc

Good to hear its somewhat better.
I do not remember the steps on how to, but there is a way for you to lock 3D settings to 2D (desktop) FORCING the settings.
Its tearing on the big panel, is it the same on a small PC monitor, Before we get to crazy, is the source material clean ? Check it out at 800x600 or lower which is less demanding on the system, the 5670 should have no problems handling this.
googlegod is offline  
post #12 of 34 Old 03-22-2010, 09:29 PM - Thread Starter
Advanced Member
 
Marc_G's Avatar
 
Join Date: Dec 2005
Location: Indianapolis Metro Area
Posts: 939
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 17 Post(s)
Liked: 34
Source material should be clean. Note, I see this on 100% of NF streaming content.

When I tried a lower resolution, 1280x720 60Hz (which looked crappy in other ways since it's not optimal for the panel), I could still see the exact type of tearing. I can try an even lower resolution as a test. Still, this isn't a solution as the WAF would be awful if she had to change resolution before watching a streamed movie! But good for troubleshooting.

On my other PC, I'm at I think 1680x1080 60Hz (LCD monitor) and the tearing is still visible but just barely.

Will try to look up force vertical sync on 2D but not sure if there's a way to do this. I'm ignorant in this field.

The 5670 is quite a fast GPU. No problems of any sort with any other content including Hulu streaming.

Tomorrow night I should have some chance to test a few things. Thanks for hanging in there with me.

Marc

Sometimes, I see dead pixels...
Marc_G is offline  
post #13 of 34 Old 03-22-2010, 09:38 PM
 
googlegod's Avatar
 
Join Date: Nov 2008
Posts: 1,387
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Marc_G View Post

Source material should be clean. Note, I see this on 100% of NF streaming content.

When I tried a lower resolution, 1280x720 60Hz (which looked crappy in other ways since it's not optimal for the panel), I could still see the exact type of tearing. I can try an even lower resolution as a test. Still, this isn't a solution as the WAF would be awful if she had to change resolution before watching a streamed movie! But good for troubleshooting.

On my other PC, I'm at I think 1680x1080 60Hz (LCD monitor) and the tearing is still visible but just barely.

Will try to look up force vertical sync on 2D but not sure if there's a way to do this. I'm ignorant in this field.

The 5670 is quite a fast GPU. No problems of any sort with any other content including Hulu streaming.

Tomorrow night I should have some chance to test a few things. Thanks for hanging in there with me.

Marc

Just give it some more time and check back, I'm sure your not the only one. When the kiddys get back from spring break, there good with this.
googlegod is offline  
post #14 of 34 Old 03-23-2010, 03:37 PM - Thread Starter
Advanced Member
 
Marc_G's Avatar
 
Join Date: Dec 2005
Location: Indianapolis Metro Area
Posts: 939
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 17 Post(s)
Liked: 34
I will try various resolutions and related things this evening to pin down further the impact of 30 vs. 60 hz as relates to my case of tearing.

Sometimes, I see dead pixels...
Marc_G is offline  
post #15 of 34 Old 03-23-2010, 06:55 PM - Thread Starter
Advanced Member
 
Marc_G's Avatar
 
Join Date: Dec 2005
Location: Indianapolis Metro Area
Posts: 939
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 17 Post(s)
Liked: 34
I tried lots of resolutions and both 30 / 60 Hz refresh. Faster refresh makes less noticeable tearing but it's still obviously there.

See some experimentation and folks responses here:

http://thegreenbutton.com/forums/t/87411.aspx

Marc

Any other suggestions welcomed!

Sometimes, I see dead pixels...
Marc_G is offline  
post #16 of 34 Old 03-25-2010, 06:05 PM - Thread Starter
Advanced Member
 
Marc_G's Avatar
 
Join Date: Dec 2005
Location: Indianapolis Metro Area
Posts: 939
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 17 Post(s)
Liked: 34
I found something interesting:

At 1080i Hulu looks perfect (and NF tears).
At 1366x768x30 Hulu has a persistent tear (and NF tears).

Sigh. I prefer the 1366 resolution because of other reasons but need to switch back to 1080i for Hulu. Grr.

Sometimes, I see dead pixels...
Marc_G is offline  
post #17 of 34 Old 03-26-2010, 02:50 PM
AVS Special Member
 
PanamaMike's Avatar
 
Join Date: Nov 2000
Location: Austin, TX, US
Posts: 2,794
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Marc_G View Post

I found something interesting:

At 1080i Hulu looks perfect (and NF tears).
At 1366x768x30 Hulu has a persistent tear (and NF tears).

Sigh. I prefer the 1366 resolution because of other reasons but need to switch back to 1080i for Hulu. Grr.

Do you have all of the Aero eye candy turned on?
I noticed that there's a setting in Aero that will convert tearing to stutter. Depending on how severe, the stutter might be more to your liking.

Mike
PanamaMike is offline  
post #18 of 34 Old 03-28-2010, 10:52 AM - Thread Starter
Advanced Member
 
Marc_G's Avatar
 
Join Date: Dec 2005
Location: Indianapolis Metro Area
Posts: 939
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 17 Post(s)
Liked: 34
PanamaMike:

Thanks for the suggestion about Aero. Choosing the default Windows Aero theme actually seems to have improved the situation quite a bit. I will watch a few different movies this way to gauge the extent. Also haven't tried Hulu yet. I had a weird problem with 1366x768 there that didn't show up on 1080i resolution.

I wonder what Aero does that helps? I had turned it off while troubleshooting a stutter/judder issue with some CBS content (the "stutter/judder bug") and never turned Aero back on.

Thanks again. Will report back in a week or so.

Marc

Sometimes, I see dead pixels...
Marc_G is offline  
post #19 of 34 Old 03-29-2010, 12:49 PM - Thread Starter
Advanced Member
 
Marc_G's Avatar
 
Join Date: Dec 2005
Location: Indianapolis Metro Area
Posts: 939
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 17 Post(s)
Liked: 34
With Aero on, my Hulu problem at 1366x768 x 30 has cleared up, and so far Netflix looks much much better. Will continue to monitor.

Marc

Sometimes, I see dead pixels...
Marc_G is offline  
post #20 of 34 Old 03-30-2010, 03:40 PM
AVS Special Member
 
PanamaMike's Avatar
 
Join Date: Nov 2000
Location: Austin, TX, US
Posts: 2,794
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
NP glad to help. Let us know if you end up having any stutter.

Mike
PanamaMike is offline  
post #21 of 34 Old 03-30-2010, 05:54 PM
Newbie
 
104wb's Avatar
 
Join Date: Nov 2007
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I also had annoying tearing with Flash / Silverlight streaming video. Thanks for the tip about the Aero theme; I mistakenly had the Windows 7 'basic' theme set. Now with the Aero theme, I only have slight stutter on some videos, and no tearing.

Zotac MAG Atom 330 / Nvidia ION
Panasonic TH-58PE75U plasma
Windows 7 Home Premium 64 bit
Nvidia drivers 195.62 -> 196.21 -> 197.13
Flash 10.1 p1 -> 10.1 p2 -> 10.1 p3
104wb is offline  
post #22 of 34 Old 03-31-2010, 08:05 AM
AVS Special Member
 
PanamaMike's Avatar
 
Join Date: Nov 2000
Location: Austin, TX, US
Posts: 2,794
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I'm still getting stutter on streaming videos with Aero turned on. I wish I knew what was causing the stutter. I'm not sure what Aero does, but AFAIK it justs masks the problem.

I wish I knew the actual cause of the stutter/tearing.

Mike
PanamaMike is offline  
post #23 of 34 Old 03-31-2010, 12:13 PM
Senior Member
 
gonzo90017's Avatar
 
Join Date: Apr 2006
Posts: 435
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Liked: 17
I have a Onboard Radeon HD 3200. The only way I was able to reduce some of the stutter using Silverlight is by downgrading my Catalyst Drivers all the way back to 9.1.

Edit: had to go back to Catalyst 8.12 because 9.1 caused wake from hibernate issues.
gonzo90017 is offline  
post #24 of 34 Old 03-31-2010, 12:38 PM
AVS Special Member
 
fcorona76's Avatar
 
Join Date: Nov 2007
Posts: 1,226
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Read these as they may be relevant and why you get it with Netflix & don't with Hulu.

http://www.unitzeroone.com/blog/2009...creen-tearing/

http://thebackbutton.com/post_oldblogpost_64

The first article has some test videos you can play and it's obvious the difference it can make. Have you tried turning OFF hardware acceleration? Just curious...I dont use Netflix and none of my other Flash stuff has problems (Youtube & Hulu).
fcorona76 is offline  
post #25 of 34 Old 04-20-2010, 07:24 PM
Newbie
 
Rulo's Avatar
 
Join Date: May 2009
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I have a GA-MA785GM-US2H with Windows 7 Ultimate, CCC 10.3; onboard Radeon HD4200 with an Athlon II X2 240 and all this is connected via HDMI with sound to a Samsung LN52A650 and the judder and tearing in Netflix is horrible. It seems to me that this is a problem of the Netflix player lousy coding.
I hope they fix it.
Rulo is offline  
post #26 of 34 Old 04-20-2010, 10:50 PM
AVS Special Member
 
PanamaMike's Avatar
 
Join Date: Nov 2000
Location: Austin, TX, US
Posts: 2,794
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Rulo View Post

I have a GA-MA785GM-US2H with Windows 7 Ultimate, CCC 10.3; onboard Radeon HD4200 with an Athlon II X2 240 and all this is connected via HDMI with sound to a Samsung LN52A650 and the judder and tearing in Netflix is horrible. It seems to me that this is a problem of the Netflix player lousy coding.
I hope they fix it.

Other people around these parts are getting acceptable playback. You have some other issue if it's terrible.

Do you happen to use DSL?

Mike
PanamaMike is offline  
post #27 of 34 Old 04-21-2010, 07:22 PM
Newbie
 
Rulo's Avatar
 
Join Date: May 2009
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Nope, I have Comcast with "Power Boost" haha, I don't think is a broadband issue, It's something related to either the drivers, the Netflix Player or Silverlight. I have just downloaded Silverlight 4 and still have the same issue, altough it is a little better. The picture is not unwatchable, I mean my kids enjoy Kids movies and stuff, but I can never pay attention to anything since the thing is so distracting.
Rulo is offline  
post #28 of 34 Old 06-21-2010, 11:52 AM
Member
 
sonicfrequency's Avatar
 
Join Date: Nov 2005
Posts: 115
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 10
Sorry to wake this thread from a couple months in the grave....

I have my HTPC connected to a 120hz TV via HDMI and one thing I know for certain, this thing is sensitive to dropped frames when I run it at any refresh rate 23.976hz, 24hz, 29hz, 30hz, 59hz or 60hz. With smooth motion on or off, I can definitely see hiccups when the card is not accelerating video.

Sadly, my HTPC is the only entertainment medium in my house, with my goal of solely relying on Media Center to launch any video/music/multimedia. When there are problems, I suppose Im bound to find them given how frequently I interact with WMC. Maybe other people haven't ran into some of these issues yet. Netflix though is my last hurdle to jump.

When I run any BluRay vids, either from BD DVD or H.264 container, things run great. I'm using TMT3 integrated into Media Center for BD playback and the Klite Codecpack 64bit for k.264 playback. I can verify video is accelerated with "AMD GPU Clock Tool." No Blu Ray playback problems.

When I run Hulu Desktop (also integrated into Media Center with Media Center Studio) or Hulu browser version, things run great. "AMD GPU Clock Tool" reports video is accelerated. No flash problems at all.

When playing Netflix through the browser all content is accelerated verified by shift-alt-left click. The video is very smooth. When playing Netflix through WMC plugin, only cartoons are accelerated and some standard video. When switching from an accelerated video to one that wasn't previously accelerated (Enabled - False) and choppy (without stopping the video), somehow the flag stays on for the next video and there are no hiccups or choppiness!

This only occurs on the AMD/ATI based HTPC, even after a fresh install of the Win7x64 OS with no codec packs installed. It does not occur on my Intel based laptop with integrated graphics. Netflix with the Silverlight engine appears to be the only content type suffering from this problem accelerating certain video with the HTPC.
sonicfrequency is offline  
post #29 of 34 Old 11-17-2012, 08:32 AM
Newbie
 
BradChesney79's Avatar
 
Join Date: Nov 2012
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hey, thanks.

I just wanted to thank you and append extra information for problems your solution also fixes.
I don't have a problem anymore and just came to add more information.

I have a netbook that I gave to my wife as a gift.

The problem was the netflix video and audio falling out of sync in all browsers. Horrible annoying, unwatchable annoying.

I am still having minor tearing in Netflix (minor, not going to put any more effort in).

Okay what is the base problem? Hardware. The lenovo S10-3 netbook is barely powerful enough to handle netflix with it's atom processor and anemic video hardware running Windows 7 Starter that no one likes-- no one.

So in order:

I tried running netflix in the Google Chrome browser. -- Better playback, same problems after a slightly longer span of time.

I bumped up the memory to the fastest 2GB module it would take which is the maximum quantity as well since there is only one slot. --No noticable improvement.

I removed as many (TSR) crapware lenovo helper utilities I could; veriface, something else (at this time I kept the hard drive drop protection utility because we are butterfingered people). But TSRs were heavily reduced. --Slight improvement, barely noticeable.

I defragged the factory installed platter hard drive which is very active, often. --No noticeable improvement.

I replaced the factory installed WD Blue 250GB platter HD with an Intel 330 series 180GB HD and cloned the old hard drive to it using Clonezilla. (Clonezilla no longer automatically lets you clone a bigger hard drive to a smaller hard drive even if the data will fit, you may need to resize your partitions and you will need the advanced menu options and specifically the -icds option http://sourceforge.net/projects/clonezilla/forums/forum/663168/topic/5125793 ) -- Much better playback, same problem after yet more time and especially if ANY multitasking whatsoever. Resizing the window would throw it out of sync.

Remove the last TSR I felt safe getting rid of, namely the disk protection utility that tries to eliminate damage to your platter disk in the event of a drop. Didn't need this anymore, the new disk has no moving parts. --No noticeable improvement.

Turned off scheduled disk defragmentation. Reran the Windows Experience Index (in computer properties). --No noticeable improvement.

Lowered most of my video settings to turn off advanced features my non-gaming wife will never use. --Barely, any improvement.

Left hardware acceleration on. --No change in setting, no change in performance.

And here was the breakthrough.
In the post I am replying to, the avsforum member suggested setting the buffer doodad to 1500 in the Silverlight diagnostics menu.
I did not have a 1500 and was set at 1750.
The onboard video seemingly powered by gerbils on a wheel had a 1050 buffering setting which was the highest that was below 1500.
I used IE 8 in the regular standard windowed mode holding shift + alt then clicking on the playing selection to get the diagnostics menu.
This key combination also worked in Chrome when I tried it because I was curious.

--You sir are a man among men. This solved all of the audio and video syncing issues I had allowing a full episode to be played with the sounds matching the moving pretty picture. Thank you so much.
BradChesney79 is offline  
post #30 of 34 Old 01-07-2013, 02:23 PM
Newbie
 
dn83's Avatar
 
Join Date: Jan 2013
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I wanted to reply to at least one of the main forums recently discussing this, since it took me a lot of digging to find. I recently was dumbfounded myself as to why, with more than ample hardware and bandwidth, would I get such horrible, abnormal and unacceptable video tearing with Netflix on Windows 7 64-bit. After trying many different things, it turned out that the cause was because I had Aero turned off, because I had set my visual settings to the "adjust for best performance" mode. Once I re-enabled it, NO TEARING AT ALL!!

It seems like if you turn off Aero / choose "adjust for best performance", it actually puts Windows into a reduced video performance mode, hah! Oh, the irony...anyway, just re-enable Aero / Apply the default Windows 7 theme (customize afterwards but leave Aero on) and you're good! Spread the light, spread the love!
dn83 is offline  
Reply Home Theater Computers

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off