No sound for Video in Windows 7 Media Center 64Bits - AVS Forum
Home Theater Computers > No sound for Video in Windows 7 Media Center 64Bits
madmatrix's Avatar madmatrix 10:15 PM 08-25-2010
Hi All,

I think this maybe an old problem asked here a lot of times. I followed some suggestions but still doesn't work. I have sound when clicking the menu and play the video which media center carrys by itself. But no sound when I play the testing video downloaded from sticky post "Windows 7 Setup".

My setup:

ATI 5450
Windows 7 64 Bits
HDMI from HTPC to Denon 3311CI and then to 5.1 Speakers and Optoma HD20

Installed shark007 win7 codecs and 64bits component. Followed the guide in the sticky post section B.

I haven't installed ffdshow. I think shark007 already installed for me, is this right?

The auto volume in task-setting-tv-audio in win7 media center is unchecked.
Disable microsoft audio decoder is checked in shark007 and 64 bits component.

Haven't restarted the computer yet.

Please help me get this through. Frustrating......

Thanks a lot!!!

Lou

rdunnill's Avatar rdunnill 11:55 PM 08-25-2010
I had to disable the onboard audio hardware in Control Panel for video audio.
Shark007's Avatar Shark007 04:37 AM 08-26-2010
On the MKV TAB(s), try disabling the DivX MF splitter.
madmatrix's Avatar madmatrix 07:38 PM 08-26-2010
I disabled on-board audio and disabled the DivX MF splitter in codecs and 64 bits component. It still doesn't work in win 7 media center. The video file works well in MPC-HC anyway. Wierd...
Shark007's Avatar Shark007 09:14 PM 08-26-2010
in the x64 app, choosing to disable the Microsoft Video decoder will probably fix it but you will lose LiveTV until you re-enable it.
madmatrix's Avatar madmatrix 08:48 PM 08-27-2010
Quote:
Originally Posted by Shark007 View Post

in the x64 app, choosing to disable the Microsoft Video decoder will probably fix it but you will lose LiveTV until you re-enable it.

Thanks Shark007. I saw that. The audio for live tv just repeated forever. So is there any settings can allow me watch both movie and live tv in win7 media center? If not I may try xmbc to see what I will get there.
Shark007's Avatar Shark007 05:48 AM 08-28-2010
If your system was 32bit this wouldnt be a problem...
but for x64 users there are no alternative LiveTV decoders.
johnjack11's Avatar johnjack11 09:16 AM 11-09-2011
Have a similar problem.

Win 7 64bit, have shark codecs installed.

I have a few files will not pay audio in WMC, or the audio is slightly off. The same files play just fine in VLC.

Any ideas?

Thanks
Shark007's Avatar Shark007 09:21 AM 11-09-2011
Quote:
Originally Posted by johnjack11 View Post

Have a similar problem.

Win 7 64bit, have shark codecs installed.

I have a few files will not pay audio in WMC, or the audio is slightly off. The same files play just fine in VLC.

Any ideas?

Thanks

Install current releases. MajorGeeks is the proper source as i release directly to them. (at this time, version 325 for both installers)
For x64 users, there are 2 installations, the 32bit Win7codecs and the x64Components addon
Upgrade installations are known to cause problems. UNINSTALL before installing a new version.

After installation you are taken to a Setup and Usage page - read it, follow it, and all will be well.
johnjack11's Avatar johnjack11 09:35 AM 11-09-2011
Thank you, I will do that tonight.

It has been about a year since I installed them.

Appreciate the help.

Jack
Up
Mobile  Desktop