Silent stream bug? - Page 5 - AVS | Home Theater Discussions And Reviews
Forum Jump: 
 
Thread Tools
Old 01-27-2014, 02:36 AM - Thread Starter
Member
 
MarcD2K11's Avatar
 
Join Date: Feb 2011
Posts: 84
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 20
Have NVIDIA finally fixed this? I was messsing about with my app today and i noticed that when I exited it, I still had PCM on my receiver, and it switches back to PCM automatically after exiting a file, just like AVR Audio Guard does... please quit AVR Audio Guard if you have an NVIDIA card and the latest 322.21 drivers and let me know..
MarcD2K11 is offline  
Sponsored Links
Advertisement
 
Old 01-27-2014, 07:48 AM
Senior Member
 
carageuw's Avatar
 
Join Date: Aug 2010
Location: Miami
Posts: 479
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 35 Post(s)
Liked: 16
Quote:
Originally Posted by MarcD2K11 View Post

Have NVIDIA finally fixed this? I was messsing about with my app today and i noticed that when I exited it, I still had PCM on my receiver, and it switches back to PCM automatically after exiting a file, just like AVR Audio Guard does... please quit AVR Audio Guard if you have an NVIDIA card and the latest 322.21 drivers and let me know..

No, and in fact it may have gotten worse.
Now, after switching off the screen for extended periods and turning it back on, I will have to reinitialize device twice or more to get the audio stream initiated again. rolleyes.gif
carageuw is offline  
Old 01-28-2014, 05:22 AM - Thread Starter
Member
 
MarcD2K11's Avatar
 
Join Date: Feb 2011
Posts: 84
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 20
i wonder what's different about my setup then. Do you have Geforce Experience installed? I don't have my program running now and i've got PCM on my receiver, and it switches to DD/DTS and back again correctly when playing videos, so on my PC at least, the bug is no longer there!

I have a GTX 660 connected to a Pioneer receiver, using 322.21 drivers and Geforce Experience 1.8.1, and i'm on Windows 8.1 x64

I also have a secondary sound card attached for my recon3d omega headset but it's only set as my default communication device

I'm actually building a new pc later this week, so it'll be interesting to see what occurs then!

I would love to hear from more people who use AVR Audio Guard, is the bug still there on your system?
MarcD2K11 is offline  
Old 01-28-2014, 02:15 PM
Newbie
 
Gyakusetsu's Avatar
 
Join Date: Sep 2012
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 12
Quote:
Originally Posted by MarcD2K11 View Post

i wonder what's different about my setup then. Do you have Geforce Experience installed? I don't have my program running now and i've got PCM on my receiver, and it switches to DD/DTS and back again correctly when playing videos, so on my PC at least, the bug is no longer there!

I have a GTX 660 connected to a Pioneer receiver, using 322.21 drivers and Geforce Experience 1.8.1, and i'm on Windows 8.1 x64

I also have a secondary sound card attached for my recon3d omega headset but it's only set as my default communication device

I'm actually building a new pc later this week, so it'll be interesting to see what occurs then!

I would love to hear from more people who use AVR Audio Guard, is the bug still there on your system?

From what I can tell, it has only gotten worse, if anything, as carageuw stated. I have to re-initialize basically every time I turn my AVR on. I have since started using a DLNA media server through my blu-ray player to stream content from my PC, so I don't run in to the issue as much, but yeah... it is definitely still a problem.
Gyakusetsu is offline  
Old 01-28-2014, 08:43 PM
Senior Member
 
carageuw's Avatar
 
Join Date: Aug 2010
Location: Miami
Posts: 479
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 35 Post(s)
Liked: 16
Quote:
Originally Posted by MarcD2K11 View Post

i wonder what's different about my setup then. Do you have Geforce Experience installed? I don't have my program running now and i've got PCM on my receiver, and it switches to DD/DTS and back again correctly when playing videos, so on my PC at least, the bug is no longer there!

I have a GTX 660 connected to a Pioneer receiver, using 322.21 drivers and Geforce Experience 1.8.1, and i'm on Windows 8.1 x64

I also have a secondary sound card attached for my recon3d omega headset but it's only set as my default communication device

I'm actually building a new pc later this week, so it'll be interesting to see what occurs then!

I would love to hear from more people who use AVR Audio Guard, is the bug still there on your system?

Yes, I have GeForce Experience.

Standard 322.21 WHQL driver set install.

GTX 670 connected to a Yamaha RX-A2020。

Windows 7 Ultimate x64
carageuw is offline  
Old 01-30-2014, 06:35 PM
Senior Member
 
nvidio's Avatar
 
Join Date: Nov 2010
Location: beer city (aka Belgium)
Posts: 270
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 80 Post(s)
Liked: 26
Quote:
Originally Posted by MarcD2K11 View Post

I would love to hear from more people who use AVR Audio Guard, is the bug still there on your system?
Yes, it is still there. I am on an Intel i3 3110M laptop with Intel HD 4000 running Windows 8.1 x64 and using latest drivers.

To avoid the UAC prompt when AVR Audio Guard starts, I have created a shortcut following this guide and have put this shortcut in my Startup folder C:\Users\{username}\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup instead of choosing AVR Audio Guard | Configuration | Add to Startup.
nvidio is offline  
Old 01-31-2014, 02:17 PM
Advanced Member
 
sawfish's Avatar
 
Join Date: Feb 2013
Posts: 870
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 72 Post(s)
Liked: 122
I think Nvidia finally fixed this. I just replaced the GTX460 in my gaming PC with a GTX660, and the new card is keeping my AVR in 5.1 PCM all the time, even sitting at the desktop. When I play sound effects in Windows 7 through the Sound control panel applet, they're not cut off, and there are no clicking noises. This is very different than the behavior with the 460.

I can also say audio works perfectly using a plain old DVI -> HDMI cable.
sawfish is online now  
Old 01-31-2014, 03:06 PM - Thread Starter
Member
 
MarcD2K11's Avatar
 
Join Date: Feb 2011
Posts: 84
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 20
Quote:
Originally Posted by sawfish View Post

I think Nvidia finally fixed this. I just replaced the GTX460 in my gaming PC with a GTX660, and the new card is keeping my AVR in 5.1 PCM all the time, even sitting at the desktop. When I play sound effects in Windows 7 through the Sound control panel applet, they're not cut off, and there are no clicking noises. This is very different than the behavior with the 460.

I can also say audio works perfectly using a plain old DVI -> HDMI cable.

yeah, same with me. It's still fixed after i built my new PC too so it wasn't some random occurrence. You have the same graphics card as me, but a different OS, and you have the same OS as carageuw who still has the issue, so that categorically proves the OS has no effect on it. It also appears the drivers have no effect because carageuw had the same drivers as me but still had the bug. It would be strange if only the 660 has the bug fixed, but i know at least the previous 460 and 560 range had a different chipset to the other geforce cards in that series x70, x80, so i suppose it's possible if the 660 does too.

Which receiver do you have, out of interest? Mine is Pioneer
MarcD2K11 is offline  
Old 01-31-2014, 03:44 PM
Advanced Member
 
sawfish's Avatar
 
Join Date: Feb 2013
Posts: 870
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 72 Post(s)
Liked: 122
It's a Pioneer Elite VSX-21TXH, a 2009 model. The OS is Windows 7 x64. I've never installed any software to mitigate the bug, so this definitely seems to be something Nvidia has done.
sawfish is online now  
Old 02-18-2014, 12:59 PM
Senior Member
 
carageuw's Avatar
 
Join Date: Aug 2010
Location: Miami
Posts: 479
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 35 Post(s)
Liked: 16
I found this interesting tidbit from the GeForce Driver 334 Release Notes:

HD Audio Power Saving
Added the ability for the audio codec to go to a low-power state when not in use.

I hope this new feature doesn't mess up your creation.
carageuw is offline  
Old 02-16-2015, 03:40 AM
Member
 
The111's Avatar
 
Join Date: Jun 2007
Posts: 164
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 10
Does the silent stream bug described in this thread happen randomly, or repeatably at the same point in media file?

As I describe here, I have something that seems to resemble a silent stream error, but it happens at fixed places in certain media files only, and only when the audio is passing through in pure Dolby Digital mode. The fix in the OP does not seem to work, so I assume I have a different (but similar) problem?

To be clear, the fix in the OP does cause the receiver to display a constant PCM signal when the computer is idle at desktop. But when I open a media player that streams pure Dolby Digital to the receiver, the normal bad behavior begins again.

Last edited by The111; 02-16-2015 at 03:49 AM.
The111 is online now  
Old 02-16-2015, 08:26 AM
AVS Special Member
 
Selden Ball's Avatar
 
Join Date: Jan 2001
Location: upstate NY
Posts: 8,370
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 1145 Post(s)
Liked: 632
The "silent stream bug" happens with audio being sent over HDMI. It normally happens at the start of an audio "transmission": the first second or so of sound is lost while the HDMI protocol is waiting for the HDMI/HDCP handshake to complete. As a result, many Windows notification sounds can't be heard at all, since they're less than a second long. Dropouts don't happen in the middle of a transmission unless something changes in the HDMI configuration (e.g. a TV is turned off).

At least that's what I experience. AVR Audio Guard prevents the symptoms I've described above. It also provides a hardware reset function which often can fix other HDMI related problems.

In my experience, most intermittent recurring dropouts are caused by deficient or broken HDMI cables. Make sure you're using cables that are Certified High Speed. You don't have to use expensive boutique cables like Monster, though. Monoprice is a popular supplier on AVS.

Selden

Marantz SR7009+MM9000/Atmos 7.1.4 (FH+TM:DefTech PM1000)/LCR+TM amped
Selden Ball is online now  
Old 02-16-2015, 01:20 PM
Advanced Member
 
sawfish's Avatar
 
Join Date: Feb 2013
Posts: 870
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 72 Post(s)
Liked: 122
Quote:
Originally Posted by The111 View Post
Does the silent stream bug described in this thread happen randomly, or repeatably at the same point in media file?

As I describe here, I have something that seems to resemble a silent stream error, but it happens at fixed places in certain media files only, and only when the audio is passing through in pure Dolby Digital mode. The fix in the OP does not seem to work, so I assume I have a different (but similar) problem?

To be clear, the fix in the OP does cause the receiver to display a constant PCM signal when the computer is idle at desktop. But when I open a media player that streams pure Dolby Digital to the receiver, the normal bad behavior begins again.
Quote:
Originally Posted by The111 View Post
I have an HTPC connected to my RX-V673 over HDMI. The HTPC has Realtek onboard audio and Intel HD 4600 video (Gigabyte GA-H97M-D3H mobo).

If I just let the audio pass through the PC and have the receiver do the processing, which is obviously preferable, I run into a small issue from time to time. The audio will drop out for a fraction of a second, and the receiver screen will change from "Dolby Digital" to "Decoder Off" while this is happening. The weirdest part is it is not random; it happens at fixed places in certain media files only. For example it will happen at 19:45-19:46 on a certain media file, I can play that section again and it will happen at exactly the same place. It is typically places where the background noise in the movie drops to almost nothing, and the dialogue too gets very quiet, for example the actor is mumbling. I read about the silent stream bug and excitedly thought that was my problem, but unfortunately I don't think it is, since the fix in that thread does not change anything, nor does the integrated setting in XBMC to "keep audio device alive."
Not the silent stream bug. As long as the file stays in the same audio format, it should not be dropping out in quiet or even dead silent sections. What is common is a split second tick noise when watching TV, and there's a switch between the main program and a commercial that uses a different audio format. My guess would be (1) your file is damaged, or if happens in all files, (2) AVR quirk, hopefully due to some feature you can disable like volume leveling.
sawfish is online now  
Old Today, 07:26 PM
Member
 
The111's Avatar
 
Join Date: Jun 2007
Posts: 164
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 10
Quote:
Originally Posted by sawfish View Post
Not the silent stream bug. As long as the file stays in the same audio format, it should not be dropping out in quiet or even dead silent sections. What is common is a split second tick noise when watching TV, and there's a switch between the main program and a commercial that uses a different audio format. My guess would be (1) your file is damaged, or if happens in all files, (2) AVR quirk, hopefully due to some feature you can disable like volume leveling.
Yeah, it seems to be damaged file most likely, especially since it occurs consistently at the same place, though it is still disappointing that somehow when PC is handling the audio processing it can get past the "damage" and not let sound drop out, but streaming to receiver causes dropouts. Weird.
The111 is online now  
 
Thread Tools


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off