MPC-HC jitter graph question - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 6 Old 03-06-2011, 06:08 AM - Thread Starter
Member
 
aequalszero's Avatar
 
Join Date: Mar 2011
Location: UK
Posts: 141
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hi guys - this forum has been of invaluable help before, let's hope my first question isn't too difficult.

I performed a complete Win7 re-install on my Acer Revo R3610 (Atom N330, Nvidia ION) in order to rid the machine of all its Acer bloatware. In doing so, I've managed to mess up my once perfect judder issues!

It used to be the case that as long as I changed the refresh rate to match my content, every played fine. Now, anything at 23.976 judders slightly when set to the 23Hz setting in Nvidia Control Panel. The only difference I can see is if I bring up the jitter graph - the red line no longer sits exactly on 0ms. It used to, and in every online screen grab I've seen, it always does. Mine sits (pretty flat, mind you) at about 5ms:



Is there a way of shifting the red line back to 0ms? Would this even help?

MPC-HC reports no actual frame drops, but the image 'jumps' slightly every so often, in that way it does when you have the wrong refresh rate set. Also, I know about Reclock and had it installed in the past, but I never needed it all the time. What's happened?

Thanks!
aequalszero is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 03-06-2011, 11:24 AM
Senior Member
 
winterescape's Avatar
 
Join Date: May 2009
Posts: 314
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Not sure but two things to check...

In Nvidia control panel, manage 3d settings, try vertical sync "force on"

Also, You have win7 Aero enabled?
winterescape is offline  
post #3 of 6 Old 03-06-2011, 02:29 PM - Thread Starter
Member
 
aequalszero's Avatar
 
Join Date: Mar 2011
Location: UK
Posts: 141
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hi winterescape - thanks for getting the ball rolling.

Firstly, Aero is on as standard - but I'd previously tried having MPC-HC turn it off, and it made no difference (if what I read is correct, V-Sync is usually better with Aero on, right?). As for "Force Vertical Sync", I forced it to 'on' and again, no difference. I've also messed with the V-Sync options in MPC-HC, the results being that Vsync and Accurate Vsync need to be on; Alternative Vsync does seem to have any effect whether on or off.

I seem to have calmed the judder problem slightly by uninstalling the newest Nvidia drivers I had put on (266.58) and the letting Windows install its own driver, followed by a Windows Update. This has left me on version 258.96 - the exact version I was running before the reinstall.

Here's a fresh screenie:


Ignore the blips in the graph - hard as I try, I don't see them have an effect on playback. That damn red line still finds its home at 5ms, though. I've never seen it anywhere but the 0 line on everyone else's screenshots. Does it even need to be on the 0 line?
aequalszero is offline  
post #4 of 6 Old 03-06-2011, 03:03 PM
Qaq
Senior Member
 
Qaq's Avatar
 
Join Date: Nov 2009
Posts: 459
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 12
Maybe you will find some useful information here: http://forum.slysoft.com/showthread....094#post261094

Burned by the Audio Inquisition
Qaq is offline  
post #5 of 6 Old 03-07-2011, 07:10 AM - Thread Starter
Member
 
aequalszero's Avatar
 
Join Date: Mar 2011
Location: UK
Posts: 141
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Thanks Qaq - my extensive Google expedition this weekend had already landed me on that page (and the Reclock forum generally) more than once. The difference is, they're all using Reclock over there and I'm not.

They do get a lot of jitter questions on that forum though (the very nature of the program, I guess) - maybe they'll be better suited to answer my non-standard red line question...
aequalszero is offline  
post #6 of 6 Old 03-10-2011, 03:24 PM - Thread Starter
Member
 
aequalszero's Avatar
 
Join Date: Mar 2011
Location: UK
Posts: 141
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Small update on this issue (mainly for the benefit of anyone who finds this thread in the future):

Although my red line query is still without answer, I have managed to stop the odd judders, at least on 23.976fps content. It turns out that MPC-HC (1.5.0.2827) was incorrectly recognising the frame rate as 24fps - but I cannot, as yet, diagnose why. It seems that if I do a refresh rate change in Nvidia Control Panel, MPC-HC starts to get the video frame rate correct from that point onwards. I thought it was just happening on first boot, but today I tried it out immediately after turning the machine on and it recognised 23.976 correctly, first time. Very odd.

I might roll back to MPC-HC 1.4.2499 (which I was running before the re-install) to see if that version is more consistent.

[side note - after 'fixing' 23.976, I also tried some previously perfect PAL DVD 25fps content at 50Hz and MPC-HC's jitter graph was all over the place!]
aequalszero is offline  
Reply Home Theater Computers

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off