Why when using mkvmerge to remove unwanted audio or subtitles do the files not play? - AVS Forum
Forum Jump: 
 
Thread Tools
Old 11-18-2011, 11:35 AM - Thread Starter
AVS Special Member
 
ogormask's Avatar
 
Join Date: Sep 2009
Posts: 1,796
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 10
I sometimes get mkv files that contain foreign to me languages or subtitles that WMC and or wmpc hc tend to play multiple tracks at once or force multiple subtitles. I have a workaround with my remote to turn off the subtitles but I cant seem to get it to always work especially with the audio tracks. But when I use mkvmerge to remove the tracks by unchecking the files I dont want and then making a new mkv file for whatever reason the files dont work then. What can I do?
ogormask is offline  
Sponsored Links
Advertisement
 
Old 11-18-2011, 11:52 AM
Senior Member
 
tgrinch's Avatar
 
Join Date: Mar 2006
Posts: 411
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 17
I found that I need to set the compression flag of each track (video and audio) to "none" - physically changing it to that value, that is. Not sure if this is your issue though.
tgrinch is offline  
Old 11-18-2011, 09:14 PM
Senior Member
 
elm_sd's Avatar
 
Join Date: Nov 2000
Location: Mar,Ontario,Canada
Posts: 307
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Any chance your also using global tages, they make files unplayable for my system....

ELM_SD


Quality TV = C-Band
elm_sd is offline  
Old 11-19-2011, 09:32 AM - Thread Starter
AVS Special Member
 
ogormask's Avatar
 
Join Date: Sep 2009
Posts: 1,796
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 10
Well here is what I was doing.



I see the ones listed and then the ones I dont want I uncheck like that and then start muxing. Maybe I am doing it entirely wrong?
ogormask is offline  
Old 11-19-2011, 09:54 AM
AVS Special Member
 
Pagali's Avatar
 
Join Date: Feb 2000
Location: Elk Grove, CA
Posts: 1,025
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Liked: 17
I see 2 problems...

1. You don't have any video or audio tracks checked! You're selecting only one subtitle track, that's all.

2. What is an MKS file? (your output filename) Shouldn't it be MKV?
Pagali is offline  
Old 11-19-2011, 10:10 AM - Thread Starter
AVS Special Member
 
ogormask's Avatar
 
Join Date: Sep 2009
Posts: 1,796
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 10
Sorry that was bad example as it doesnt have english audio for some reason but the rest of the tracks are all foreign to me. And yeah IDK why it says mks but even if its mkv it doesnt play. Normally I just keep english audio and strip the rest but it just wont play after that.
ogormask is offline  
Old 11-19-2011, 10:13 AM
Member
 
AMenard's Avatar
 
Join Date: Feb 2011
Posts: 144
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by ogormask View Post

Sorry that was bad example as it doesnt have english audio for some reason but the rest of the tracks are all foreign to me. And yeah IDK why it says mks but even if its mkv it doesnt play. Normally I just keep english audio and strip the rest but it just wont play after that.

You have to keep the video track also. You can't just select the audio track.

Alain Menard
www.lacrimosae.net
AMenard is offline  
Old 11-19-2011, 10:35 AM
Senior Member
 
elm_sd's Avatar
 
Join Date: Nov 2000
Location: Mar,Ontario,Canada
Posts: 307
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
You will get mks as an extension because all that is selected for the job is subtitles, same with audio only, is mka file which plays fine in zoom player,subtitles wont show with out video either even in a mka file...

ELM_SD


Quality TV = C-Band
elm_sd is offline  
 
Thread Tools


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off