Help a confused new guy: how do I get DTS/Dolby from HDMI? - Page 2 - AVS Forum
Forum Jump: 
Reply
 
Thread Tools
post #31 of 55 Old 01-10-2012, 12:26 PM
Member
 
capsid's Avatar
 
Join Date: Nov 2011
Posts: 58
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by steelfrog View Post

Both Dolby Digital and DTS aren't being sent to the receiver as far as I can tell. At least, my receiver's indicators aren't lighting up which prompted me to start looking in the first place.

I just can't figure it out. I'm starting to assume that the PC simply doesn't do 'em via HDMI, only via optical/SPDIF.

Your HDMI audio card won't output the DD or DTS but it will pass 7.1 channels which will sound fine. It's better that your amp does the processing anyway.
capsid is offline  
Sponsored Links
Advertisement
 
post #32 of 55 Old 01-10-2012, 01:30 PM
Member
 
mephiska's Avatar
 
Join Date: Nov 2007
Posts: 51
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
It sounds like you're getting 7.1 channels of LPCM audio just fine over HDMI, so Windows is doing the DTS-HD and Dolby Digital HD decoding. The only thing you're missing here is a fancy light on your new receiver telling you it's doing the decoding. Let windows do it, there's no difference.
mephiska is offline  
post #33 of 55 Old 01-10-2012, 02:47 PM
AVS Special Member
 
ricabullah's Avatar
 
Join Date: Mar 2007
Posts: 1,782
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Install LAV Filters:
http://forum.doom9.org/showthread.php?t=156191

Select installer file and install it.

Unselect all the internal filters in MPC-HC, select Lav Filters and set them to "preferred" individually under external filters option.

Click on LavAudio Decoder and configure it as:



For more details, see my threads:

http://forum.doom9.org/showthread.php?t=152520

http://www.avsforum.com/avs-vb/showthread.php?t=1376533

btw, you don't need to select ReClock for bitstreaming.

EDIT: If above recibe doesn't work with your HW, you should use SPDIF output with the same configuration. (For SD audio bitstreaming, you don't need HDMI at all.)
_ _ _ _

Chronical Tester
ricabullah is offline  
post #34 of 55 Old 01-12-2012, 05:26 AM - Thread Starter
Member
 
steelfrog's Avatar
 
Join Date: Jun 2008
Posts: 93
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I sent an e-mail to ASRock support and they provided me with an answer a few days later. As it turns out, the unit simply doesn't support DTS via HDMI - only via optical. Guess I'll be looking into getting that working with my receiver now!

Thanks for all the help and suggestions, guys. I really appreciate it!

[Just providing an answer here in case someone stumbles onto this thread via Google or some other search engine]

XBOX Live: Steelfrogg
PSN: Steelfrog
----------
Come play Battlefield3 with me!
steelfrog is offline  
post #35 of 55 Old 01-12-2012, 05:39 AM
Member
 
capsid's Avatar
 
Join Date: Nov 2011
Posts: 58
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by steelfrog View Post

I sent an e-mail to ASRock support and they provided me with an answer a few days later. As it turns out, the unit simply doesn't support DTS via HDMI - only via optical. Guess I'll be looking into getting that working with my receiver now!

Thanks for all the help and suggestions, guys. I really appreciate it!

[Just providing an answer here in case someone stumbles onto this thread via Google or some other search engine]

I'd still listen to the multichannel sound you can get out of the HDMI and compare to the optical. It may be better.
capsid is offline  
post #36 of 55 Old 01-12-2012, 06:22 AM
AVS Special Member
 
spivonious's Avatar
 
Join Date: Aug 2009
Location: Lancaster, PA, USA
Posts: 1,941
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by capsid View Post

I'd still listen to the multichannel sound you can get out of the HDMI and compare to the optical. It may be better.

Normally, I'd agree, but DTS is a lossy format. The sound quality should be identical whether he has his computer decode it or his receiver decode it.
spivonious is offline  
post #37 of 55 Old 01-12-2012, 06:28 AM - Thread Starter
Member
 
steelfrog's Avatar
 
Join Date: Jun 2008
Posts: 93
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by spivonious View Post

Normally, I'd agree, but DTS is a lossy format. The sound quality should be identical whether he has his computer decode it or his receiver decode it.

See, this is why I love this place. I basically announce the thread as 'closed' and you're still providing useful information!

I think I understand what you're saying regarding DTS. Since it's a lossy format to begin with, you're saying that it doesn't matter if I'm sending the signal to the receiver directly and it decodes it rather than letting the PC decode the DTS and converting it into multichannel (or is it PCM?), right?

My speakers are definitely nowhere close to picking up that kind of a difference in terms of loss. I'm really only concerned that I'm getting the proper surround (e.g., sounds that should be coming from the back speakers are being produced as expected)

XBOX Live: Steelfrogg
PSN: Steelfrog
----------
Come play Battlefield3 with me!
steelfrog is offline  
post #38 of 55 Old 01-12-2012, 06:37 AM
AVS Special Member
 
spivonious's Avatar
 
Join Date: Aug 2009
Location: Lancaster, PA, USA
Posts: 1,941
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Right. If it was DTS-HD or Dolby TrueHD, then you would want the computer to decode it first and send multi-channel PCM to the receiver (unless your PC could send those over HDMI and your receiver could decode them).

But since it's regular DTS/DD, the audio in the multi-channel PCM will be identical to the audio encoded in DTS/DD.
spivonious is offline  
post #39 of 55 Old 01-12-2012, 06:47 AM - Thread Starter
Member
 
steelfrog's Avatar
 
Join Date: Jun 2008
Posts: 93
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by spivonious View Post

Right. If it was DTS-HD or Dolby TrueHD, then you would want the computer to decode it first and send multi-channel PCM to the receiver (unless your PC could send those over HDMI and your receiver could decode them).

But since it's regular DTS/DD, the audio in the multi-channel PCM will be identical to the audio encoded in DTS/DD.

Gotcha. So I can freely use HDMI or Optical; the only difference is where the decoding takes place then. This is some great information - many thanks! I'm starting to understand all of this.

XBOX Live: Steelfrogg
PSN: Steelfrog
----------
Come play Battlefield3 with me!
steelfrog is offline  
post #40 of 55 Old 01-12-2012, 07:08 AM
Member
 
capsid's Avatar
 
Join Date: Nov 2011
Posts: 58
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by spivonious View Post

Right. If it was DTS-HD or Dolby TrueHD, then you would want the computer to decode it first and send multi-channel PCM to the receiver (unless your PC could send those over HDMI and your receiver could decode them).

But since it's regular DTS/DD, the audio in the multi-channel PCM will be identical to the audio encoded in DTS/DD.

Just so I'm clear, when I play blu rays with PowerDVD I use the non-decoded audio option which I assume passes the audio direct to the amp where it is decoded. If so, what's happening in steelfrog's situation where the HDMI card is not outputting DTS or Dolby?
capsid is offline  
post #41 of 55 Old 01-12-2012, 07:22 AM
AVS Special Member
 
spivonious's Avatar
 
Join Date: Aug 2009
Location: Lancaster, PA, USA
Posts: 1,941
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by capsid View Post

Just so I'm clear, when I play blu rays with PowerDVD I use the non-decoded audio option which I assume passes the audio direct to the amp where it is decoded. If so, what's happening in steelfrog's situation where the HDMI card is not outputting DTS or Dolby?

Right, that option causes PowerDVD to simply pass the bitstream out to your receiver.

In steelfrog's case, the HDMI port didn't support bitstreaming DTS, so his only options were to decode it on the computer and pass multi-channel PCM through HDMI, or bitstream through the optical output.
spivonious is offline  
post #42 of 55 Old 01-12-2012, 07:59 AM
Member
 
capsid's Avatar
 
Join Date: Nov 2011
Posts: 58
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by spivonious View Post

Right, that option causes PowerDVD to simply pass the bitstream out to your receiver.

In steelfrog's case, the HDMI port didn't support bitstreaming DTS, so his only options were to decode it on the computer and pass multi-channel PCM through HDMI, or bitstream through the optical output.

Can't he bitstream as non DTS though?
capsid is offline  
post #43 of 55 Old 01-12-2012, 08:03 AM
AVS Special Member
 
spivonious's Avatar
 
Join Date: Aug 2009
Location: Lancaster, PA, USA
Posts: 1,941
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by capsid View Post

Can't he bitstream as non DTS though?

He said that neither DTS nor DD worked over HDMI and confirmed that with ASRock. His only option for HDMI audio is PCM. PCM is the pure audio data, so nothing is being bitstreamed.
spivonious is offline  
post #44 of 55 Old 04-12-2013, 06:45 PM
Newbie
 
Siovhan's Avatar
 
Join Date: Apr 2013
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
ac3filter full and media player classic worked for me. in ac3filter on the 'Main' tab under "Output Format" i selected "Do not change" and checked the "use spdif" box, even though i'm using hdmi. now 2-channel audio stays 2-channel & hd audio (including DTS) plays in hd
Siovhan is offline  
post #45 of 55 Old 04-13-2013, 11:05 PM
Newbie
 
dasjude's Avatar
 
Join Date: Apr 2013
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Siovhan View Post

ac3filter full and media player classic worked for me. in ac3filter on the 'Main' tab under "Output Format" i selected "Do not change" and checked the "use spdif" box, even though i'm using hdmi. now 2-channel audio stays 2-channel & hd audio (including DTS) plays in hd
Does it passthrough true DD and DTS, or is it converted to LPCM?
dasjude is offline  
post #46 of 55 Old 08-28-2013, 08:33 AM
Newbie
 
pullmulder's Avatar
 
Join Date: Aug 2013
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hi guys,

I am new to this forum and I do have a similar issue.

I recently formatted my Windows 7 partition and now that I got everything up and running again, there's one thing that still doesn't work. The DTS 5.1 audio to my receiver. frown.gif
I've been playing with this since forever and would appreciate some help if possible.

First of all, before I formatted the partition, I'd get DTS 5.1 just fine for my .mkv movies. All movies/shows that I have are in 5.1. My connection is a straight HDMI cable (no S/PDIF) for audio and video that goes from my Sony Vaio laptop into my receiver. Again, this always worked fine before, nothing has changed here.

All I get from my receiver's display (LG) is a PCM 2.00 instead of DTS 5.1. I was able to get all 5 speakers working simultaneously but only in 2.0, the audio signal was not split into 5.1. The receiver's display even says so (PCM 2.00).

What I've tried so far:

-updated audio drivers from Sony's website for Win7;
-installed the latest K-lite pack and messed around with the ffdshow codec settings (Output - Passthrough/HDMI checkboxes checked, not checked: DTS, AC3, etc;
-still under ffdshow, I went to 'Mixer' and changed the tab to 'same as input' (I believe that's how I got it working in the past) but still no luck, I also tried 5.1 there;
-then, I installed AC3 filter, applied the filter to External Filters tab in MPC-HC and set it as preferred. Under ac3 config, I tried all the combinations possible. S/PDIF checked (I get no audio at all when checked, not even 2.0), not checked; setting audio to 5.1 or none or 2.0, etc. Modified that on both 'Main' and 'S/PDIF' tabs. In fact, if I change one tab, the other one automatically changes to the same settings. I thought I could set them separately. Don't know if that's an issue or what.

This issue has been bugging me for the last 4 days at least and it's driving me crazy!! I think it should be working by now.

Can't think of anything else to do right now. If anyone could help, I'd appreciate.

Please let me know If more info is required and I'll post here what's needed.

Thank you.
pullmulder is offline  
post #47 of 55 Old 08-28-2013, 09:14 AM
AVS Club Gold
 
renethx's Avatar
 
Join Date: Jan 2006
Posts: 15,954
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 87 Post(s)
Liked: 325
I recommend:

- Uninstall all codecs and MPC-HC.
- Download the latest version of LAV Filters (the only filter set you will need [initially]) and MPC-HC (with "Rest settings").
- Start MPC-HC and open "Options". In Internal Filters, uncheck "Matroska" and "DTS" (to avoid using internal codecs for them). In External Filters, add LAV Video/Audio Decoders and set them Preferred.
- Run LAV Audio Decoder configuration and make sure to check "DTS" bitstreaming.
renethx is offline  
post #48 of 55 Old 08-28-2013, 10:22 AM
Newbie
 
pullmulder's Avatar
 
Join Date: Aug 2013
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Thanks for the info. Followed all the steps, but still no luck. I also tried AC3 auddio files and nothing either. Still outputs PCM 2.0 Do you think there might be an issue with my audio driver? Just wondering..

Here's the media info for one of my files:

General
Complete name : J:\HD Movies\The Hobbit\the.h.0bbit.an.unexpected.j.0urney.2012.1080p.bluray.x264-sparks.mkv
Format : Matroska
Format version : Version 2
File size : 13.1 GiB
Duration : 2h 49mn
Overall bit rate : 11.1 Mbps
Writing application : mkvmerge v4.1.1 ('Bouncin' Back') built on Jul 3 2010 22:54:08
Writing library : libebml v1.0.0 + libmatroska v1.0

Video
ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L4.1
Format settings, CABAC : Yes
Format settings, ReFrames : 5 frames
Codec ID : V_MPEG4/ISO/AVC
Duration : 2h 49mn
Bit rate : 9 559 Kbps
Width : 1 920 pixels
Height : 800 pixels
Display aspect ratio : 2.40:1
Frame rate mode : Constant
Frame rate : 23.976 fps
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.260
Stream size : 11.1 GiB (84%)
Writing library : x264 core 129 r2245 bc13772
Encoding settings : cabac=1 / ref=5 / deblock=1:0:0 / analyse=0x3:0x133 / me=umh / subme=7 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=0 / chroma_qp_offset=-2 / threads=12 / lookahead_threads=2 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=3 / b_pyramid=2 / b_adapt=1 / b_bias=0 / direct=1 / weightb=1 / open_gop=0 / weightp=2 / keyint=250 / keyint_min=23 / scenecut=40 / intra_refresh=0 / rc_lookahead=40 / rc=2pass / mbtree=1 / bitrate=9559 / ratetol=1.0 / qcomp=0.60 / qpmin=0 / qpmax=69 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / ip_ratio=1.40 / aq=1:1.00
Language : English
Default : Yes
Forced : No

Audio
ID : 2
Format : DTS
Format/Info : Digital Theater Systems
Mode : 16
Format settings, Endianness : Big
Codec ID : A_DTS
Duration : 2h 49mn
Bit rate mode : Constant
Bit rate : 1 509 Kbps
Channel(s) : 6 channels
Channel positions : Front: L C R, Side: L R, LFE
Sampling rate : 48.0 KHz
Bit depth : 24 bits
Compression mode : Lossy
Stream size : 1.79 GiB (14%)
Title : English
Language : English
Default : Yes
Forced : No

Text
ID : 3
Format : UTF-8
Codec ID : S_TEXT/UTF8
Codec ID/Info : UTF-8 Plain Text
Language : English
Default : No
Forced : No
pullmulder is offline  
post #49 of 55 Old 08-28-2013, 10:50 AM
AVS Club Gold
 
renethx's Avatar
 
Join Date: Jan 2006
Posts: 15,954
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 87 Post(s)
Liked: 325
Check Properties > Supported Formats of your sound playback device. You should see "DTS" in Encoded Formats. Otherwise there may be an EDID problem.

The screeshot below is my PC monitor's built-in speakers (LG D2342P). As this support only stereo PCM, there is no entry in Encoded Formats.

renethx is offline  
post #50 of 55 Old 08-28-2013, 11:04 AM
Newbie
 
pullmulder's Avatar
 
Join Date: Aug 2013
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Thanks for the fast response renethx. You are right, I don't see DTS there. "No compress formats found" it shows.

But I don't get it, even though the icon is a tv, These are the settings for the receiver, right?

Can I fix this EDID problem by installing new driverson my laptop? I wouldn't even know which ones I need... I get them from Sony Vaio's UK website, model VGN-FW41M under Windows 7 downloads.

http://www.sony.co.uk/support/en/product/VGN-FW41M_H/updates 1.jpg 51k .jpg file 2.jpg 52k .jpg file


Thanks.
pullmulder is offline  
post #51 of 55 Old 08-28-2013, 12:09 PM
AVS Club Gold
 
renethx's Avatar
 
Join Date: Jan 2006
Posts: 15,954
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 87 Post(s)
Liked: 325
Your screenshots indicate that the proper HD audio driver is not installed, your device is working only under Microsoft's generic HD audio driver, perhaps that's the cause of the problem.

VGN-FW41M uses ATI Mobility Radeon HD 4650, right? Then you have to install AMD HDMI audio driver. "Audio Driver (Realtek) 6.0.1.5886" looks like the correct driver (Realtek provided AMD/ATI with audio technology). If this does not work, try to dowload AMD display driver from the AMD website (that includes HDMI audio driver, unlike "7UPG_Graphics Driver (ATI)_64").
renethx is offline  
post #52 of 55 Old 08-28-2013, 12:57 PM
AVS Special Member
 
Shark007's Avatar
 
Join Date: Apr 2007
Location: BC, Canada
Posts: 1,062
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Liked: 40
Quote:
Originally Posted by renethx View Post

VGN-FW41M uses ATI Mobility Radeon HD 4650

I dont think this GPU supports DTS, DTS MA, or TrueHD audio.

source: AMD Spec sheet for HD4000/HD4600 mobile gpu
Quote:
HDMI® output support
◦Integrated HD audio controller with up to 2 channel 48 kHz stereo or multi-channel (7.1) AC3 enabling a plug-and-play cable-less audio solution

Use Shark007 Codecs and retain your sanity.
Shark007 is offline  
post #53 of 55 Old 08-28-2013, 01:02 PM
Newbie
 
pullmulder's Avatar
 
Join Date: Aug 2013
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Thank you. I got it working now!

I didn't even have to download the whole package again, what I did instead was to go to the Driver settings under Device Manager and clicked on Update Driver. Now I have 'ATI HDMI' driver installed and it's been working just fine with that one. I tested it with AC3, DTS and other formats too, all good. Thanks for your help.

But there's one minor issue that is bugging me now... every time I disconnect from the 'projector' back to the laptop screen and then back to the projector again, the audio is lost. It only shows audio for the built-in speakers instead of switching the audio to the TV/Receiver HDMI. I found a work-around to this which consists going to the Device Manager - 'ATI HDMI' and disable/enable the driver. That makes it work again, until I disconnect HDMI from the TV....

Do you have any tips/suggestions on this? Thank you.
pullmulder is offline  
post #54 of 55 Old 08-28-2013, 01:13 PM
AVS Club Gold
 
renethx's Avatar
 
Join Date: Jan 2006
Posts: 15,954
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 87 Post(s)
Liked: 325
Quote:
Originally Posted by Shark007 View Post

Quote:
Originally Posted by renethx View Post

VGN-FW41M uses ATI Mobility Radeon HD 4650

I dont think this GPU supports DTS, DTS MA, or TrueHD audio.

source: AMD Spec sheet for HD4000/HD4600 mobile gpu
Quote:
HDMI® output support
◦Integrated HD audio controller with up to 2 channel 48 kHz stereo or multi-channel (7.1) AC3 enabling a plug-and-play cable-less audio solution

Yup, he is talking about DTS / AC3 bitstreaming over HDMI.
renethx is offline  
post #55 of 55 Old 08-28-2013, 01:46 PM
AVS Club Gold
 
renethx's Avatar
 
Join Date: Jan 2006
Posts: 15,954
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 87 Post(s)
Liked: 325
Quote:
Originally Posted by pullmulder View Post

Thank you. I got it working now!

I didn't even have to download the whole package again, what I did instead was to go to the Driver settings under Device Manager and clicked on Update Driver. Now I have 'ATI HDMI' driver installed and it's been working just fine with that one. I tested it with AC3, DTS and other formats too, all good. Thanks for your help.

But there's one minor issue that is bugging me now... every time I disconnect from the 'projector' back to the laptop screen and then back to the projector again, the audio is lost. It only shows audio for the built-in speakers instead of switching the audio to the TV/Receiver HDMI. I found a work-around to this which consists going to the Device Manager - 'ATI HDMI' and disable/enable the driver. That makes it work again, until I disconnect HDMI from the TV....

Do you have any tips/suggestions on this? Thank you.

This is an ancient problem and rarely happens with the latest AMD graphics cards. Perhaps you could do the same thing by opening Sound control panel > Playback (by right-clicking the speaker icon in the system tray), right-click the device and enable it. I remember there is a little utility to do this quickly or you may create a small file by using AutoHotkey. Audio device switcher for Windows 7? That's not a correct tool.

The command line to open Sound control panel > Playback device is
Code:
C:\Windows\System32\rundll32.exe Shell32.dll,Control_RunDLL Mmsys.cpl,,0

Then creating a batch file should not be difficult.
renethx is offline  
Reply Home Theater Computers

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off