Help! Upgraded to GT430, but no HD audio streaming?? - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 12 Old 01-07-2012, 08:24 AM - Thread Starter
AVS Special Member
 
landshark1's Avatar
 
Join Date: Nov 2004
Location: Silver Spring, MD
Posts: 1,448
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Liked: 59
I finally upgraded my HTPC from the Nvidia 9400m onbroad to a GT430 hoping to get HD audio bitstream. I installed the latest driver from Nvidia (285.xx?). Video, everything plays fine as before. However, I just can't get the HD audio bitstreamed?? I'm use FFDshow and checked bitstream all HD audio format. I noticed under Windows Sound properties, it only shows DD as supported format? No DTS, no TrueHD, no DTS-MA, nothing! And it called it as SPDIF, not HDMI connection too!

I'm thinking there might be something wrong with the audio driver.... Tried to reinstall the driver, nothing changed!

What should I do now??
landshark1 is offline  
Sponsored Links
Advertisement
 
post #2 of 12 Old 01-07-2012, 02:57 PM - Thread Starter
AVS Special Member
 
landshark1's Avatar
 
Join Date: Nov 2004
Location: Silver Spring, MD
Posts: 1,448
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Liked: 59
100+ views and still no solution?
landshark1 is offline  
post #3 of 12 Old 01-07-2012, 03:45 PM
Member
 
fa1321tx's Avatar
 
Join Date: Jan 2012
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I posed a question here too and never got any tips either. As for Audio I also had a problem with HDMI and it turned out to be the way I was routing my audio (long story) try posting on the green button forum there are few helpful people there. I can tell you the GT430 is a good card and is capable of carring your audio. I had some issue until I installed 285.79 driver then had to make sure the nvidia was set as my default device in the windows control panel under sounds. I also know shows Dolbly DTS under device properties in windows. My problem was I was runnig the HDMI to my TV then toslink to my Denon AVR the computer knows my TV only has 2 speakers so it wound not send anything like DTS to my TV even though the TV will pass 5.1 to the toslink.
fa1321tx is offline  
post #4 of 12 Old 01-07-2012, 04:53 PM
AVS Club Gold
 
Davinleeds's Avatar
 
Join Date: Mar 2006
Posts: 5,410
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Using those codecs FFDshow can be confusing as I read that's all you have and a 430. Until you get proper codecs under playback...

I have a 430 and install was effortless. You need to provide more info and FFDshow by itself will not get playback.

"The purpose of diplomacy is to prolong a crisis." Spock, Mark of Gideon, TOS
Davinleeds is offline  
post #5 of 12 Old 01-07-2012, 05:11 PM - Thread Starter
AVS Special Member
 
landshark1's Avatar
 
Join Date: Nov 2004
Location: Silver Spring, MD
Posts: 1,448
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Liked: 59
The HTPC is running WinVista, Media Portal, and SAF 5.0 codec. It runs & plays Bluray rips fine before & after. The only problem is under Windows, Sound properties, it only shows DD as supported format versus I saw others that should have DD, TrueHD, DTS, DTS-MA, etc.

When tried to play a Bluray rip (1:1) with a HD audio track, it only output as PCM. It seems like the HTPC thought it doesn't support HD audio bitstream and decode the HD track to PCM.

I've been running fine for the past few years for playback Bluray rip but with flac audio track as my previous setup doesn't support bitstreaming (Nvidia 9400 onboard). That's why I want to upgrade to a GT430 to finally take advantage on bitstream and "see" the logo lights up in my AVR.

Btw, it's connected to my AVR via a single HDMI cable.
landshark1 is offline  
post #6 of 12 Old 01-07-2012, 05:39 PM
AVS Club Gold
 
Davinleeds's Avatar
 
Join Date: Mar 2006
Posts: 5,410
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
You should put those to the side and try a trial of PDVD or/and TMT to just try the bitstreaming. That will tell you you can do it. You can add those WinVista etc but until playback devices show hd codecs it won't happen. You'll have to read the MP thread to setup audio.

"The purpose of diplomacy is to prolong a crisis." Spock, Mark of Gideon, TOS
Davinleeds is offline  
post #7 of 12 Old 01-07-2012, 07:30 PM
Member
 
BBrinks's Avatar
 
Join Date: Jun 2006
Posts: 36
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Under sound settings, you should have one listed as NVIDIA High Definition Audio and that should be set as the default device. What devices are listed?
BBrinks is offline  
post #8 of 12 Old 01-07-2012, 08:35 PM
AVS Special Member
 
Postmoderndesign's Avatar
 
Join Date: Jul 2007
Posts: 1,111
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 31 Post(s)
Liked: 32
Do you have an AVR with HDMI 1.3 or 1.4a which can accept and decode bitstreamed audio. You did not mention what audio visual receiver you have.
Postmoderndesign is offline  
post #9 of 12 Old 01-08-2012, 07:15 AM - Thread Starter
AVS Special Member
 
landshark1's Avatar
 
Join Date: Nov 2004
Location: Silver Spring, MD
Posts: 1,448
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Liked: 59
Quote:
Originally Posted by BBrinks View Post

Under sound settings, you should have one listed as NVIDIA High Definition Audio and that should be set as the default device. What devices are listed?

Under Windows, Sound setting, it only said "Digital Output Device (SDIF), High Definition Audio Device, Working" And if I go deeper into Properties, under controller information, it said "High Definition Audio Device, Microsoft"!

That's why I suspect either it wasn't installed correctly or is a driver issue. (not software!)

Quote:
Originally Posted by Postmoderndesign View Post

Do you have an AVR with HDMI 1.3 or 1.4a which can accept and decode bitstreamed audio. You did not mention what audio visual receiver you have.

Yes, the AVR that's is connected to is HDMI1.3 and could decode HD audio. Otherwise, I wouldn't expect all these HD audio bitstreaming from the HTPC.
landshark1 is offline  
post #10 of 12 Old 01-08-2012, 07:52 AM
AVS Special Member
 
Postmoderndesign's Avatar
 
Join Date: Jul 2007
Posts: 1,111
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 31 Post(s)
Liked: 32
Good...Have you set your AVR to bitstream DTS-HD/MA and TrueHD. My AVR requires this extra step. This is all the simple advice I can offer.

The other thing I would suggest is to follow the sticky thread: Advanced MPC-HC Setup
Guide. I am running 7MC, not Vista. I do not use Media Portal and I do not know anything about SAF 5.0 codec. So, I would be suggesting a major setup change to current setup and there is probably someone using Media Portal and Vista who may have a less radical solution.
Postmoderndesign is offline  
post #11 of 12 Old 01-08-2012, 08:20 AM
AVS Special Member
 
GreenEyez's Avatar
 
Join Date: Jan 2010
Posts: 2,258
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 20
I`m not sure if the Nvidia Vista drivers support HD audio codecs, the 7 ones sure do (i have a GT520 & WIndows 7 in my main HTPC now and it bitstreams HD audio fine).
GreenEyez is offline  
post #12 of 12 Old 01-08-2012, 12:18 PM
AVS Special Member
 
Tong Chia's Avatar
 
Join Date: Nov 2002
Posts: 1,140
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 16
Use the HDMI audio device for HD bitstreaming. You may have to power on the receiver before booting the HTPC.

If you still do not see the HDMI audio device, the EDID handshake may not be working correctly and it gets more complicated.

The link below has general HD setup information and tips on how to fix the EDID issue.

http://forum.doom9.org/showthread.ph...34#post1370134
Tong Chia is offline  
Reply Home Theater Computers

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off