new HTPC build, won't stay in sleep for more than a few seconds - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 8 Old 01-18-2012, 08:54 PM - Thread Starter
AVS Special Member
 
chad473's Avatar
 
Join Date: Dec 2004
Location: Comcast-Lancaster, PA
Posts: 2,269
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Have run into a problem here that google has been unable to solve. No matter what, when I put my system into sleep it will resume within 5-10 seconds back into ready state. I've looked in the event viewer, and the only action taking place after going into the sleep state is a 'kernel-general' system time change. It updates the system time by a couple of seconds. The next item in the event log is the system has resumed from sleep. wake source is listed as "unknown"

I did some googling and found that some people fixed it by disabling the asus acpi. I have an asrock mobo (H67M) and this was nowhere to be found on my system. There are a few options listed under acpi in the bios (suspend to ram, check ready bit, ps/2 keyboard power on, pci devices power on, ring in power on, rtc alarm power on). Disabling all or different combinations of each did not help.

any suggestions to try here? It's driving me nuts. I'd rather not leave the PC on all the time, but it will be the only option to prevent missed recordings.

I can certainly give more detailed info on my system, but i'm not sure any of that matters at this point. Seems to be the time sync.

xbox live/PSN: Chad473
chad473 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 01-18-2012, 10:31 PM - Thread Starter
AVS Special Member
 
chad473's Avatar
 
Join Date: Dec 2004
Location: Comcast-Lancaster, PA
Posts: 2,269
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
I seem to have fixed this, so I'll update just in case someone comes across this in a search. I found that the only devices able to wake from sleep on my computer were the keyboard, mouse, and network adapter. My fix was to go into the device manager, and adjust the power management for my LAN to only wake from sleep via a magic packet. Seems to have done the trick as the computer is now going to sleep properly and staying there until I wake it.

now, we'll see if I run into the lost tuner issue with the hauppage 2650...

xbox live/PSN: Chad473
chad473 is offline  
post #3 of 8 Old 01-19-2012, 09:39 AM
Senior Member
 
rsoares28's Avatar
 
Join Date: Dec 2006
Posts: 302
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 13
thank you very much as ive had this problem since building my htpc last month. i never got a chance figure out why but i'll try your fix and report back later.

Thanks again
rsoares28 is offline  
post #4 of 8 Old 01-19-2012, 10:50 AM - Thread Starter
AVS Special Member
 
chad473's Avatar
 
Join Date: Dec 2004
Location: Comcast-Lancaster, PA
Posts: 2,269
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
hopefully it works for you. I googled several solutions that didn't pan out for me. The key for me though was finding out exactly which devices were able to wake from sleep, and then just systematically disabling and checking to see when the issue resolved.

xbox live/PSN: Chad473
chad473 is offline  
post #5 of 8 Old 01-19-2012, 11:00 AM
AVS Special Member
 
Foxbat121's Avatar
 
Join Date: Jul 2003
Location: VA
Posts: 9,737
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 67 Post(s)
Liked: 190
I always disable wake up from mouse and LAN (but allow magic packets). For me, mouse is the biggest problem. If you leave it on, everytime you walk by your PC, you will very likely wake up the PC due to the slight movement of the mouse.
Foxbat121 is offline  
post #6 of 8 Old 01-19-2012, 11:06 AM
AVS Special Member
 
erickotz's Avatar
 
Join Date: Feb 2003
Location: Charlotte, NC
Posts: 1,123
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 30
Try "powercfg -lastwake" and see what it says woke the PC

Quality Assurance Manager, Ceton Corporation
erickotz is offline  
post #7 of 8 Old 01-23-2012, 10:58 AM
Advanced Member
 
tlniec's Avatar
 
Join Date: Jan 2006
Posts: 742
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 13
Eerie - I have the same mobo, and was noticing the same problem during the middle of last week (so at the same time, too! ). I ended up digging into it a bit, and also found the solution of updating wake-on-LAN settings to "magic packet only." This solved the problem for me. Now my HTPC will sleep until prompted via keyboard/mouse/remote, when either of my Xbox360 extenders 'pings' it to start WMC mode, or when I have a recording scheduled.
It's nice, while sleeping my already quiet HTPC becomes essentially silent. And instead of sitting at ~35W idling at the desktop, it drops down to ~5W in sleep mode when not in use.
tlniec is offline  
post #8 of 8 Old 01-23-2012, 11:30 AM
AVS Special Member
 
NewOrlnsDukie's Avatar
 
Join Date: May 2006
Posts: 1,407
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 22
I think you just started this thread so that you could get giggles from typing the words 'magic packet'.
NewOrlnsDukie is offline  
Reply Home Theater Computers

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off