Low sound playback on .mkv files - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 9 Old 01-25-2012, 01:01 PM - Thread Starter
Member
 
xreyuk's Avatar
 
Join Date: Feb 2011
Posts: 74
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 10
Hey guys

When playing .avi files etc, I can have the volume at a reasonable level on the TV, and all .avi files play at the same volume level.

However, when I play the mkv files, the output from the computer is really low, and I have to crank the volume right up on the TV.

I am using Shark's codec pack, and playing back the audio through my HDMI cable from my graphics card, which is an ATI HD5450.

Anyone got any ideas?
xreyuk is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 01-25-2012, 01:07 PM
AVS Club Gold
 
renethx's Avatar
 
Join Date: Jan 2006
Posts: 16,110
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 177 Post(s)
Liked: 358
Usually WASAPI exclusive mode via ReClock fixes the low-volume problem of FLAC/LPCM audio tracks.
renethx is offline  
post #3 of 9 Old 01-25-2012, 01:20 PM
AVS Special Member
 
Shark007's Avatar
 
Join Date: Apr 2007
Location: BC, Canada
Posts: 1,080
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 20 Post(s)
Liked: 48
Quote:
Originally Posted by xreyuk View Post

I am using Shark's codec pack, and playing back the audio through my HDMI cable from my graphics card, which is an ATI HD5450.

Anyone got any ideas?

On the Audio TAB, click the button, [setup LAV audio]
check the boxes as shown below


Use Shark007 Codecs and retain your sanity.
Shark007 is offline  
post #4 of 9 Old 01-25-2012, 02:18 PM - Thread Starter
Member
 
xreyuk's Avatar
 
Join Date: Feb 2011
Posts: 74
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 10
Quote:
Originally Posted by renethx View Post

Usually WASAPI exclusive mode via ReClock fixes the low-volume problem of FLAC/LPCM audio tracks.

I'm sorry, but I haven't a clue what this means

Quote:
Originally Posted by Shark007 View Post

On the Audio TAB, click the button, [setup LAV audio]
check the boxes as shown below


Hi Shark,

They weren't, and I'll give it a try now, but I haven't setup for bitstreaming, as the HDMI is plugging directly into my TV.

*EDIT*

Just tried it and it made no difference unfortunately.
xreyuk is offline  
post #5 of 9 Old 01-25-2012, 03:45 PM
AVS Special Member
 
Shark007's Avatar
 
Join Date: Apr 2007
Location: BC, Canada
Posts: 1,080
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 20 Post(s)
Liked: 48
sorry, for some reason I thought you were using an AVR.
you will need to uncheck those boxes.

Afterwards, click the button to [disable LAV audio] which will automatically set FFDshow to decode the audio
maybe that will give you better results.

Use Shark007 Codecs and retain your sanity.
Shark007 is offline  
post #6 of 9 Old 01-25-2012, 04:52 PM
Advanced Member
 
Limp Fox's Avatar
 
Join Date: Aug 2009
Location: Newmanstown PA
Posts: 583
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Liked: 10
When I had my HTPC hooked up to my TV I remember having to have the TV volume near max to get a mid level sound. With the HTPC off I would only need the volume at about 25/100 to get great mid level sound. I always figured this was a software issue, but didn't pay much mind to it since I knew I'd eventually hook it up to my AVR anyhow.

With that said I'd imagine it's a software issue. I even did what Shark told you to do, but again he thought you had a AVR. I didn't know any better and checked those boxes, but then got NO sound.

Good luck

US ARMY 42A2T/11C2T

another Deployment? ...you don't say
Limp Fox is offline  
post #7 of 9 Old 01-30-2012, 12:30 PM - Thread Starter
Member
 
xreyuk's Avatar
 
Join Date: Feb 2011
Posts: 74
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 10
Hi Shark/Guys

I tried doing what you said Shark, and disabled the LAV filter, and unfortunately still had the same problem. It seems strange, but sometimes when I reboot, the quietness isn't anywhere near as bad. I only have to raise the volume half of what I usually do to get the sound (but it still needs raising).

I was also wondering could it be to do with the file using surround sound? I am only playing through TV speakers, and I know at least one of the programs is usually surround sound (however, all sound is quiet, as opposed to just voice. If it was a surround sound issue, I'd expect to hear loud music/effects, and low voice). However, when I watch the same thing on an xvid rip, there are no issues.

I've noticed that sometimes the avi files need to be louder than the volume for live tv in WMC. It all appears to be very random.

Any other ideas?

*EDIT*

I just noticed in the Shark codec settings that 'disable auto speaker configuration' wasn't checked. I checked it, and selected 2.0 stereo. It is no longer as bad, but still requires significantly higher volume on the TV than other files.
xreyuk is offline  
post #8 of 9 Old 01-30-2012, 12:53 PM - Thread Starter
Member
 
xreyuk's Avatar
 
Join Date: Feb 2011
Posts: 74
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 10
Solved!

I went into the Windows sound settings and selected the properties tab for my speaker. I then selected 'Loudness Equalisation' under the enhancements tab and everything is coming out at the same volume

Can anyone see this causing any problems?
xreyuk is offline  
post #9 of 9 Old 01-30-2012, 12:56 PM
AVS Addicted Member
 
assassin's Avatar
 
Join Date: Jul 2004
Posts: 12,948
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 44 Post(s)
Liked: 239
Quote:
Originally Posted by xreyuk View Post

Solved!

I went into the Windows sound settings and selected the properties tab for my speaker. I then selected 'Loudness Equalisation' under the enhancements tab and everything is coming out at the same volume

Can anyone see this causing any problems?

I posted this a while ago for anyone that wants more detail:

http://www.avsforum.com/avs-vb/showt...2#post20779052
assassin is offline  
Reply Home Theater Computers

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off