Mediabrowser and NAS problem - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 7 Old 01-26-2012, 06:34 AM - Thread Starter
Senior Member
 
Heuer's Avatar
 
Join Date: Sep 2005
Location: UK
Posts: 232
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 12
I am trying to use a ReadyNAS Ultra to hold my media (mkv's) but when I select a file to play in MB there can be a delay of up to a minute before it will run. I have tried using a mkv file on a ReadyNAS NV and a Qnap TS101 with the same result. All the switches, NAS and HTPC are gigabit enabled and normal file transfer speeds are lightening quick. Disk spin down on the NAS is disabled. Media files on the HTPC HDD play instantly as do media files hosted on a networked PC. The ReadyNAS Ultra hosts all my FLAC music and the Squeezebox plays them flawlessly but there seems to be a big problem with MB and the NAS. I have tried optimising the settings on the Ultra with no improvement. Sometimes the file takes so long to load it locks MB or MPC-HC.

Is this level of performance to be expected from a NAS or am I doing something wrong?

NB: using MPC-HC + ffdshow + MadVR + Reclock
Heuer is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 01-26-2012, 10:49 AM - Thread Starter
Senior Member
 
Heuer's Avatar
 
Join Date: Sep 2005
Location: UK
Posts: 232
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 12
Update: VLC media player starts playing immediately from the NAS and the WMC native player does exactly the same. Seems the problem is with MPC-HC and/or the video or audio renderers. Running MPC-HC directly (rather than via MB) to the NAS gets a movie playing in about 12 seconds but if you stop it and start another movie it takes 60 seconds before it starts playing. Same behaviour as via MB. Same movies play immediately in VLC.

I wonder if I should do a fresh install of MPC-HC and the codecs?
Heuer is offline  
post #3 of 7 Old 01-26-2012, 11:07 AM
Advanced Member
 
Calcvictim's Avatar
 
Join Date: Nov 2007
Posts: 859
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 10
I think it has to do with buffering, what splitter is mpc-hc using?
Calcvictim is offline  
post #4 of 7 Old 01-26-2012, 12:12 PM - Thread Starter
Senior Member
 
Heuer's Avatar
 
Join Date: Sep 2005
Location: UK
Posts: 232
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 12
LAV splitter is being used.
Heuer is offline  
post #5 of 7 Old 01-26-2012, 12:51 PM
Senior Member
 
xfett's Avatar
 
Join Date: Jan 2008
Posts: 294
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 18
How do you have MB configured to look for the drives/files ? Here are a couple of ideas ...http://community.mediabrowser.tv/per...on-htpc-wakeup....or this http://community.mediabrowser.tv/per...ct-on-playback


Im using a FreeNAS 8 server with a Giga switch, startup and playback with mkv's, vob's, and iso's with no delays.

"Man, I told you we shouldn't have shot Niedermeyer"

xfett is offline  
post #6 of 7 Old 01-26-2012, 02:31 PM - Thread Starter
Senior Member
 
Heuer's Avatar
 
Join Date: Sep 2005
Location: UK
Posts: 232
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 12
Thanks. I saw that but am using UNC anyway and the NAS is showing as connected. There seems to be something in MPC-HT causing the problem but no idea what.
Heuer is offline  
post #7 of 7 Old 06-07-2012, 07:18 PM
Advanced Member
 
Dodgexander's Avatar
 
Join Date: Mar 2007
Location: Nr Brighton, England.
Posts: 855
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Liked: 12
Just wanted to point out that I also have this problem.

At first I found this, its correct. If you look in resource monitor, you will see the player showing higher than playback disk activity whilst loading the file and once playing, that activity ends.

So, the problem is the same with Zoom Player and MPC. That means it exists with Lav Splitter, mpc avi splitter, haali splitter and zoom players built in splitter.

What could be stopping it from being streamed?

EDIT# just checked .mkv files and they stream instantly. Problem relates only to .avi files.

Natalya Simonova: Do you destroy every vehicle you get into?
James Bond: Standard operating procedure. Boys with toys.
Goldeneye
Dodgexander is offline  
Reply Home Theater Computers



Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off