HTPC and Receiver suddenly don't comm anymore - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 7 Old 02-25-2012, 03:46 PM - Thread Starter
Senior Member
 
arttext's Avatar
 
Join Date: May 2008
Posts: 253
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I run a htpc with win7 already for couple of years without a hitch. Suddenly two days ago my Onkyo TX-875 doesn't pass through the hdmi video signal anymore. And even stranger: when I plug out the hdmi cable running from the Onkyo to the tv, the sound is will come through, although downsampled. But the moment I plug in the Tv again there's nothing. Even with simple pc sounds or avi's so it's not a DCHP problem. When I connect the htpc directly to a tv screen evererything comes through to, but I don't want, for obvious reasons, the sound processed by the tv.
So it's clearly something between the htpc and the onkyo.
But everything else, PS3, DVB-C work ok on every hdmi input on the Onkyo and that includes DCHP protected content.
So to summarize:
NOTHING was changed prior to these events.
All Sound AND video are not processed between htpc and onkyo
Sound only when I disconnect hdmi from TV, but then downsampled
Sony PS3 and DVB-T cable work ok with Okyo
Replaced DCHP compliant video card with a new one, no difference
Restored to an earlier restore point; no difference
Did a clean Win install; no difference
The only thing I can think of here is a mobo malfunction, so I ordered a new mobo.
For the rest I am clueless here.
Any ideas?
arttext is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 02-26-2012, 12:45 PM
AVS Special Member
 
audit13's Avatar
 
Join Date: Sep 2007
Location: Toronto
Posts: 1,668
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 24
Is it possible the hdmi board in your Onkyo has failed?

http://www.avsforum.com/avs-vb/archi...t-1343576.html
audit13 is offline  
post #3 of 7 Old 02-27-2012, 03:22 AM - Thread Starter
Senior Member
 
arttext's Avatar
 
Join Date: May 2008
Posts: 253
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by audit13 View Post

Is it possible the hdmi board in your Onkyo has failed?

http://www.avsforum.com/avs-vb/archi...t-1343576.html

Thanks for the reply.
Basically it's possible, but in that case I don't understand why the streams from the Sony PS3 and DVB-C are processed correctly. And the problem is not related to one hdmi-in port on the receiver either; when I connect the PC-out hdmi to other hdmi-in ports the problem stays.
arttext is offline  
post #4 of 7 Old 02-27-2012, 03:40 AM
 
Solid-State's Avatar
 
Join Date: Aug 2004
Posts: 671
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
In the Onkyo receiver make sure you have HDMI audio passthrough disabled. I'd also nuke ARC option in the TV and AVR if you don't use it. And physically don't use the ARC port on the TV.

From that point it's gotta be driver/software related on the computer. Please share what hardware you are using with model details, the way it's hooked up etc.

BTW it's not DHCP it's called HDCP or High Definition Content Protection. DHCP stands for Dynamic Host Configuration Protocol. Neither are related in any way... also if the other HDMI devices work then no it's not the video section on the AVR.

Please share you methodology for say... swapping out those video adapters or "reinstalling" Windows so I can gauge your competency level in terms of understanding the software element of hardware devices and their install and use.

It has nothing to do with your motherboard I'll tell you that right now...

My bet would be a change in settings on the TV... if nothing changed prior on the PC on a software or hardware level... that or the AVR. The two chan down sampling after HDMI display segment disconnect suggests this. Make sure you have HDMI audio passthrough DISABLED on the AVR bro!

On a hardware level I could only see the PROM space storing the EDID date being currupted. Sometimes reflashing firmware into the device can cure that...
Solid-State is offline  
post #5 of 7 Old 02-27-2012, 03:56 AM
 
Solid-State's Avatar
 
Join Date: Aug 2004
Posts: 671
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
If only I owned a Quantum Data 980





The amount of screwy devices that get past the ATC at the HDCP lab in Oregon and in particular ATCs in Asia is absolute total BS.

Even a 780 handheld without the protocol analysis is VERY HANDY and a dream machine for an integrator or calibrator!

Solid-State is offline  
post #6 of 7 Old 02-27-2012, 04:23 AM
 
Solid-State's Avatar
 
Join Date: Aug 2004
Posts: 671
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Hey Rik, Bryan and Ashley we need a CHEAP PC software based solution that can do this! A nice HDMI in/out with USB to notebook device that can do all the same things those Quantum Data devices can do!

I'd drop perhaps a grand for such a device Entech, Spectracal and all the others in the field!
Solid-State is offline  
post #7 of 7 Old 02-29-2012, 01:59 PM - Thread Starter
Senior Member
 
arttext's Avatar
 
Join Date: May 2008
Posts: 253
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
After replacing the MOBO in the HTPC it turned out that, as in other places already was suggested, the Onkyo is the perp, probably the HDMI board of Onkyo. Very disappointing for a 4 year old rather expensive receiver. I checked all the setting in chain again. And I now indeed the difference between DHCP and HDCP, but it's more of a burned in typo .

Tomorrow I'm gonna try another receiver, and of course HDMI pass through was always already disabled, but THX for pointing that out.

But at the end of the day the first testing happens always WITHOUT any live screen connected to HDMI out, because I first want see something else than "no signal" for that hdmi in port at the Onkyo screen and only then attach a (simple small Led TV screen with none of those options on board) a screen. And the PS3 and DVB-t work fine on the Onkyo.
arttext is offline  
Reply Home Theater Computers

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off