A strange request. (Disable Nvidia Display but keep audio over hdmi) - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 3 Old 03-11-2012, 09:28 AM - Thread Starter
Newbie
 
userben's Avatar
 
Join Date: May 2011
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Firstly let me say I have tried searching the net with regards to this issue and while you get millions of results on how to disable the audio, I'm looking to do the opposite and disable the display (if at all possible)

As we are all aware with HDMI, the handshaking can be a pita especially on a PC, and using an AVR between seems to only make things worse, with seemingly pointless breaks in the signal when you for example open a game.

To get around this I decided to connect my TV (42LD450) directly to the GPU (GTX580) via DVI-HDMI cable and connect the AVR (Onkyo 876) aswell using the mini-HDMI.

This created it's own set of problems that seem to be recurring each boot and is making me consider going back to anologue 5.1 again.

Let me explain the problem I'm (and I'm sure others are) having.

If I boot with both the receiver and TV on I'm left with a flickering mess as the AVR is detected as having a 29Hz interlaced display which is obviously conflicting with the 60Hz TV.

I can get around this by leaving the AVR off until I get onto the desktop and then it will work okay (most of the time). However it will have changed back the AVR to 29Hz again which causes the GPU to run at full 3D clocks/volts so I have to remember to switch it.

So is there anyway I can get Windows to see it as an audio device without having it as a display?

Or perhaps a way to force the 60Hz refresh rate for the AVR?

I have since connected a dell monitor to the AVR over HDMI, which has the same resolution and refresh rate as the TV, so long as it is on at boot then everything works as it should, but I don't want to have to run a second display all the time. (Switching it off or disconnecting results in the same flickering/handshaking issues.)
userben is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 03-11-2012, 01:22 PM
AVS Special Member
 
erickotz's Avatar
 
Join Date: Feb 2003
Location: Charlotte, NC
Posts: 1,123
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 30
I believe HDMI needs display sync signals to send audio. Perhaps the older Asus HDMI sound-only sound card?

Quality Assurance Manager, Ceton Corporation
erickotz is offline  
post #3 of 3 Old 03-13-2012, 06:39 AM - Thread Starter
Newbie
 
userben's Avatar
 
Join Date: May 2011
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by erickotz View Post

I believe HDMI needs display sync signals to send audio. Perhaps the older Asus HDMI sound-only sound card?

If what you are saying in your first sentence was true, your second sentence wouldn't make sense.

I believe HDMi simply needs to "handshake" with a hdcp device in order to send the signal (audio and/or video).

I seem to have got it working now and I think I know the problem.

When I had originally installed the video drivers with just the TV connected, because I have to use override flags to disable audio for 4:4:4, there was no "set up digital audio" pane in nvcpl.

So I removed everything nvidia and with both TV and AVR connected, installed just the driver+lg edid override, so it's now running on windows hdmi audio driver (which actually supports more formats!?)

Now I have the audio pane in nvcpl and it seems both dvi and hdmi support audio.
The best thing is that the refresh rate is now being detected at 60Hz so no more crazy flickering or wasted power.
userben is offline  
Reply Home Theater Computers

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off