Problems with Multichannel Sound via HDMI - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 9 Old 04-25-2012, 01:04 PM - Thread Starter
Newbie
 
wuerrer's Avatar
 
Join Date: Apr 2012
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hi,

I need help with the following please:

I have connected a HTPC (Zotac Zbox AD05, AMD RADEON 6320, Win 7 Ultimate x64) via HDMI with my AVR (Denon 3808). Unfortunately I do not recieve any kind of multichannel sound.

As long as the windows settings are on stereo I recieve DD2.0, once I change the settings to multichannel (5.1 or 7.1) I only recieve "normal" stereo (not even DD).

I have tried the following players: VLC, XBMC, WinMediaPlayer
I have tried it with video (DD5.1 and DTS) and audio (DTS and DTS-HD) files. Always the same result.

Drivers:
ATI Catalys (as of today I am not sure about the version)
Realtek High Definition Audio R 2.68 for Win 7 x64

Any ideas?
Thanks
Stefan
wuerrer is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 04-25-2012, 01:31 PM
AVS Special Member
 
hirent's Avatar
 
Join Date: Apr 2008
Location: In my imagination!
Posts: 1,648
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 14
Quote:
Originally Posted by wuerrer View Post

Drivers:
ATI Catalys (as of today I am not sure about the version)
Realtek High Definition Audio R 2.68 for Win 7 x64

Do you have audio pass-through enabled in your AVR?
If so, the HTPC is seeing the two TV speakers. Turn it OFF.

No need of Realtek drivers. Use the HDMI driver in the CCC package.
Then click on 'Playback Devices' (vol. control) and configure the HDMI device for 5.1/7.1 sound.
hirent is offline  
post #3 of 9 Old 04-26-2012, 01:38 AM - Thread Starter
Newbie
 
wuerrer's Avatar
 
Join Date: Apr 2012
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Thanks for the reply.

Pass through is dissabled on the AVR. Sound never comes through the TV but always through the speakers of the 5.1 System.

I only installed the Realtek drivers because they came with the Zotac. I will try to deeinstall them tonight.

I just found out that every Stereo signal (no matter if DD or not) gets treated correct by the AVR, but once the software on the HTPC recognises multichannel sound (DD, DTS) it seems that the multichannel does not reach the AVR as it does not switch to the correct format but treats it always like a stereo signal.

BR
Stefan

Do you think it still could be a pprobelm with the EDID altough Sound and Video works basically?
wuerrer is offline  
post #4 of 9 Old 04-26-2012, 11:53 AM - Thread Starter
Newbie
 
wuerrer's Avatar
 
Join Date: Apr 2012
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I tried the edid override as well as the ati drivers without the realtek ones. Unfortunately the results are the same.
Any ideas?
wuerrer is offline  
post #5 of 9 Old 04-26-2012, 11:55 AM - Thread Starter
Newbie
 
wuerrer's Avatar
 
Join Date: Apr 2012
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by hirent View Post

Do you have audio pass-through enabled in your AVR?
If so, the HTPC is seeing the two TV speakers. Turn it OFF.

No need of Realtek drivers. Use the HDMI driver in the CCC package.
Then click on 'Playback Devices' (vol. control) and configure the HDMI device for 5.1/7.1 sound.

As I said once i change to 5.1 the signal apears to be stereo only
wuerrer is offline  
post #6 of 9 Old 04-26-2012, 11:58 AM
Advanced Member
 
James_stewart's Avatar
 
Join Date: Jan 2003
Location: Portland
Posts: 500
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by wuerrer View Post

I tried the edid override as well as the ati drivers without the realtek ones. Unfortunately the results are the same.
Any ideas?

I may be wrong here, but don't you have to enable passthrough within these players? Instead of choosing the multi-channel options, don't you have to manually select spdif/hdmi passthrough?
James_stewart is offline  
post #7 of 9 Old 04-26-2012, 11:59 AM
AVS Special Member
 
hirent's Avatar
 
Join Date: Apr 2008
Location: In my imagination!
Posts: 1,648
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 14
Quote:
Originally Posted by wuerrer View Post

As I said once i change to 5.1 the signal apears to be stereo only

Do you see 'AMD High Def. Device' in Playback Devices?
What codecs are listed under its properties?
hirent is offline  
post #8 of 9 Old 04-26-2012, 12:11 PM - Thread Starter
Newbie
 
wuerrer's Avatar
 
Join Date: Apr 2012
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I see the AMD HD Device and nearly all DD / DTS Formats are Listed.

But I just found out what is the reason for the problem:

If the DENON AVR is in "detect imput signal automaticly" mode the AVR does not realise the change from "multichannel" (in windows) to DD5.1 or DTS. Once I changed this, everything works fine.

However thanks a lot for your help.

BR
Stefan
wuerrer is offline  
post #9 of 9 Old 04-26-2012, 01:35 PM
AVS Special Member
 
hirent's Avatar
 
Join Date: Apr 2008
Location: In my imagination!
Posts: 1,648
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 14
Quote:
Originally Posted by wuerrer View Post

But I just found out what is the reason for the problem:
If the DENON AVR is in "detect imput signal automaticly" mode the AVR does not realise the change from "multichannel" (in windows) to DD5.1 or DTS. Once I changed this, everything works fine.
However thanks a lot for your help.
BR
Stefan

Oh well, you learn something new everyday.
Good that you posted the solution here.
All too often, people solve their issues and never report back. This might help someone else, somewhere down the line.
hirent is offline  
Reply Home Theater Computers

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off