Sudden problem with mpc-hc under madvr/lav video - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 9 Old 05-03-2012, 09:49 AM - Thread Starter
Member
 
theod78's Avatar
 
Join Date: Mar 2010
Posts: 38
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
My setup was playing 1080p@24Hz content without any issues and all of a sudden when I play 1080p files (mkvs) i get numerous dropped frames, on the other hand when I play 720p i get no frames dropped.Is it the last versions of the software (madvr,lavcuvid,mpc-hc) or the nvidia drivers?My display is a Sony 1080p tv capable of playing 23,976
theod78 is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 05-03-2012, 12:16 PM
AVS Special Member
 
jriver's Avatar
 
Join Date: Nov 2001
Location: Minneapolis
Posts: 1,428
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 16
What changed on the PC?

Jim Hillegass / JRiver Media Center
jriver.com or Owners Thread at AVSForum
jriver is offline  
post #3 of 9 Old 05-03-2012, 01:10 PM
Advanced Member
 
JMGNYC's Avatar
 
Join Date: Mar 2007
Posts: 506
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 12
MPC-HC with LAV/madVR had been rock solid playing back virtually everything for me until recently where I've started having the same problem with dropped frames. Tracking it down it seems to stem from my use of either DXVA Copy-Back or Native with my ATI card. Very high bitrate BD rips and even 59fps 720p files caused the problem.

If you have a nVidia card try turning CUVID off in LAV video and see if that helps.
JMGNYC is offline  
post #4 of 9 Old 05-04-2012, 12:19 AM - Thread Starter
Member
 
theod78's Avatar
 
Join Date: Mar 2010
Posts: 38
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by JMGNYC View Post

MPC-HC with LAV/madVR had been rock solid playing back virtually everything for me until recently where I've started having the same problem with dropped frames. Tracking it down it seems to stem from my use of either DXVA Copy-Back or Native with my ATI card. Very high bitrate BD rips and even 59fps 720p files caused the problem.

If you have a nVidia card try turning CUVID off in LAV video and see if that helps.

What do you mean cuvid off?Choose different hardware decoder?
theod78 is offline  
post #5 of 9 Old 05-04-2012, 10:41 AM
Advanced Member
 
JMGNYC's Avatar
 
Join Date: Mar 2007
Posts: 506
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 12
Quote:
Originally Posted by theod78 View Post

What do you mean cuvid off?Choose different hardware decoder?

If you open up the LAV Video properties/settings page (not the nVidia control panel) there are some options for it to use CUVID or not.

Check out the Video Decoding section of the first post in this thread.
http://www.avsforum.com/avs-vb/showthread.php?t=1357375
JMGNYC is offline  
post #6 of 9 Old 05-05-2012, 06:00 AM - Thread Starter
Member
 
theod78's Avatar
 
Join Date: Mar 2010
Posts: 38
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by JMGNYC View Post

MPC-HC with LAV/madVR had been rock solid playing back virtually everything for me until recently where I've started having the same problem with dropped frames. Tracking it down it seems to stem from my use of either DXVA Copy-Back or Native with my ATI card. Very high bitrate BD rips and even 59fps 720p files caused the problem.

If you have a nVidia card try turning CUVID off in LAV video and see if that helps.

The thing is that I use the same files(mkvs) that previously ran ok and this only happens with 1080p rips.Even if I play 720p x264 rips at 1920x1080@24Hz I don't get any dropped frames
theod78 is offline  
post #7 of 9 Old 05-05-2012, 06:42 AM
Advanced Member
 
Alan Winslow's Avatar
 
Join Date: Dec 2000
Location: Cape Coral, Florida
Posts: 541
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 12
In the Nvidia Control Panel located at the Windows Control Panel, if possible change the refresh rate from 24hz to 23 hz.
It worked for me. I was having a terrible stutter with WMPC/MadVR/Cuvid and it's running flawlessly now with the above change.
I am using a GT430 video card.
I hope it helps
Alan Winslow is offline  
post #8 of 9 Old 05-05-2012, 11:36 AM - Thread Starter
Member
 
theod78's Avatar
 
Join Date: Mar 2010
Posts: 38
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Alan Winslow View Post

In the Nvidia Control Panel located at the Windows Control Panel, if possible change the refresh rate from 24hz to 23 hz.
It worked for me. I was having a terrible stutter with WMPC/MadVR/Cuvid and it's running flawlessly now with the above change.
I am using a GT430 video card.
I hope it helps

But its not a 23,976 related problem because the same time I have dropped frames madvr reports 1 frame drop every 2 or 3 hours!
theod78 is offline  
post #9 of 9 Old 05-11-2012, 08:14 AM - Thread Starter
Member
 
theod78's Avatar
 
Join Date: Mar 2010
Posts: 38
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Well I discover something interesting, when I'm using madvr without lavcuvid or DXVA2 native or DXVA2cb I'm getting 0 frames dropped apart from the start of the file.When I pick DXVA2 native or DXVA2cb I get a few!
theod78 is offline  
Reply Home Theater Computers

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off