Files with DTS-HD MA 7.1 show up as 5.1? - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 5 Old 08-27-2012, 02:56 PM - Thread Starter
Member
 
Venturai's Avatar
 
Join Date: Oct 2009
Location: Perth, Western Australia
Posts: 129
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Is there a known issue where files containing DTS-HD Master Audio 7.1 only show up as 5.1? A couple of my Blu-ray mkv rips, most notably The Avengers and Thor (among others), are showing up as 5.1 and only 6 channels. It's only something I realised when I noticed that Transformers 3, which instead uses Dolby TrueHD, shows up as 7.1 in XBMC but my others do not.

I use Makemkv to rip and am definitely selecting the DTS-HD MA track. Since I typically bitstream to my receiver, I can be pretty sure I'm getting 7.1, right? I have the Onkyo NR1007 avr, and I'm not sure if the display changes when its receiving 7.1 over 5.1, but I'll check that again tonight.
Venturai is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 08-27-2012, 03:09 PM
AVS Special Member
 
almostinsane's Avatar
 
Join Date: Sep 2002
Posts: 4,027
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 23
Ripped Avengers w/ MakeMKV and my Pioneer receiver showed 7.1 DTS HD MA.
almostinsane is offline  
post #3 of 5 Old 08-27-2012, 04:19 PM - Thread Starter
Member
 
Venturai's Avatar
 
Join Date: Oct 2009
Location: Perth, Western Australia
Posts: 129
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Thanks mate I'll check mine again tonight while playing. I was just wondering if it's a known issue or something. It's a bit misleading scrolling through the list in XBMC or checking file properties in Potplayer/MPC-HC because you don't know what's really 5.1 and what's 7.1.
Venturai is offline  
post #4 of 5 Old 08-28-2012, 03:24 AM
Member
 
cheeky chappie's Avatar
 
Join Date: Aug 2007
Posts: 97
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Go you mean the GUI interface reports the files as being 5.1? or that you only get 5.1 when you playback the files?

If just the GUI reporting then I'll think you find this is down to the programs using ffmeg to provide the media info, since ffmeg can't decode DTS-MA files I think it only reports 5.1 from the DTS core track. The reported number of channels for TrueHD is fine because ffmeg can decode that.
cheeky chappie is offline  
post #5 of 5 Old 08-28-2012, 05:56 AM - Thread Starter
Member
 
Venturai's Avatar
 
Join Date: Oct 2009
Location: Perth, Western Australia
Posts: 129
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by cheeky chappie View Post

Go you mean the GUI interface reports the files as being 5.1? or that you only get 5.1 when you playback the files?
If just the GUI reporting then I'll think you find this is down to the programs using ffmeg to provide the media info, since ffmeg can't decode DTS-MA files I think it only reports 5.1 from the DTS core track. The reported number of channels for TrueHD is fine because ffmeg can decode that.

I read that somewhere about ffmpeg, yeah. They need to update that.

It is the only problem though, because playing back my Avengers rip tonight, I could see the surround back speaker graphics lit up on the avr's display where they weren't with 5.1 material. It had me a little concerned to be honest, either that my ripping program was doing it wrong, or that I figured I'd only be getting 5.1 because that's all my computer thought was present.

I must admit, I wasn't getting a lot from the back channels while watching The Avengers though. I'm thinking about bumping them up a few dBs to be honest, just to help give them some emphasis because they're so easily drowned out by the fronts and sides.
Venturai is offline  
Reply Home Theater Computers

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off