HTPC unable to bitstream - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 16 Old 08-28-2012, 02:22 AM - Thread Starter
Newbie
 
HwKok's Avatar
 
Join Date: Aug 2012
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hello all,

This is my first post on this forum. The reason I'm here is someone send me here to ask you about a problem with my HTPC. I've been searching and trying to enable my HTPC to correct ly bitstream DTS-HD and TrueHD, but with no luck.
Here comes the story:

I recently build a brand new HTPC, dedicated for playing HD movies.
Playing movies with Dolby and DTS works fine. My receiver, type HT-R548 (part of the HT-S5405 package), shows up the red Dolby or DTS light on the front panel.

So far so good. But when I want to bitstream, my receiver says it's LPCM (when playing TrueHD) or DTS (when playing DTS-HD) input. I tried a lot of things in the receiver menu without any result. The receiver supports DTS-HD and TrueHD. It seems that the source, my HTPC, is doing something wrong. I'm playing mt2s sample files.

To give you some more info about my setup: this is it:

The specs of my HTPC are:
  • Motherboard: Asrock A75M
  • RAM: 2x 2GB Gskill F3-12800
  • APU: AMD A4-3400
  • HDD: Western Digital 2TB WD20EARX
  • Running W7 Ultimate.

Connected via HDMI to HDMI port 1 (BD/DVD) of my Onkyo HT-R548 receiver.
From the receiver HDMI out there is a HDMI connection to my TV, a Samsung UE46ES6570.

So, it seems to be a problem with the HTPC. I've tried a lot of things:
  • In the sound settings of W7 I set ATI HDMI to default device
  • I disabled all the Realtek sound devices of my AsRock mobo and deleted the drivers of it
  • I calibrated the output to 5.1 surround.
  • I checked if all the HD-formats are listed in the Supported formats tab in the Encoded Formats box, they are.
  • I checked both boxes under Exclusive Mode in Advanced tab to 'on'
  • I disabled all enchanchements
  • I downloaded Total MediaTheatre 5 and set the mixing mode to 'Original primary audio only'. No result. TMT5 shows in its info that it is sending DTS-HD or TrueHD, but receiver says its getting LPCM or DTS.
  • I set the mixing mode to 'Mix to PCM uncompressed audio': receiver shows input of LPCM audio with all formats (sounds better BTW).
  • Tried to play a BluRay disc with DTS-HD sound in PowerDVD: before playing I set output to let the receiver to the job, during play it goes back to PCM-setting and I can't change it anymore.

Well I tried almost everything. The last thing I'm thinking of is that this is a handshake problem with my TV. Would an EDID-override do the trick? Or can I try to change some other settings on my HTPC.
Thanx for all your help!
HwKok is offline  
Sponsored Links
Advertisement
 
post #2 of 16 Old 08-28-2012, 09:34 AM
Senior Member
 
acejh1987's Avatar
 
Join Date: Dec 2006
Posts: 226
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 20
Do you have anything else that can bitstream HD audio (Like a standalone Blu-ray player or PS3 Slim) that you can try with the receiver, just to check that it works correctly?
What video drivers are you using?
acejh1987 is offline  
post #3 of 16 Old 08-28-2012, 11:59 PM - Thread Starter
Newbie
 
HwKok's Avatar
 
Join Date: Aug 2012
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by acejh1987 View Post

Do you have anything else that can bitstream HD audio (Like a standalone Blu-ray player or PS3 Slim) that you can try with the receiver, just to check that it works correctly?
What video drivers are you using?

Nope, unfortunately not.
The drivers I use are the latest ATI drivers, downloaded with the 12.8 CCC update package.
Someone told me to use the Realtek AMD HDMI drivers, instead of the AMD HDMI drivers delivered in the CCC package. I'll give this a try..
HwKok is offline  
post #4 of 16 Old 08-29-2012, 03:16 AM
Senior Member
 
acejh1987's Avatar
 
Join Date: Dec 2006
Posts: 226
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 20
Quote:
Originally Posted by HwKok View Post

Nope, unfortunately not.
The drivers I use are the latest ATI drivers, downloaded with the 12.8 CCC update package.
Someone told me to use the Realtek AMD HDMI drivers, instead of the AMD HDMI drivers delivered in the CCC package. I'll give this a try..

The AMD HDMI drivers should be what you use (That's what I use).
When you look in the info tab in TMT5, does it say "True-HD passthrough" or just "TrueHD"
Do you have a BD drive in your HTPC? it might be a good idea to try a proper disc instead of sample file and see what happens with that.
acejh1987 is offline  
post #5 of 16 Old 08-29-2012, 05:18 AM - Thread Starter
Newbie
 
HwKok's Avatar
 
Join Date: Aug 2012
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by acejh1987 View Post

The AMD HDMI drivers should be what you use (That's what I use).
When you look in the info tab in TMT5, does it say "True-HD passthrough" or just "TrueHD"
Do you have a BD drive in your HTPC? it might be a good idea to try a proper disc instead of sample file and see what happens with that.

It says just TrueHD or DTS-HD without 'passtrough'.
I tested with a BluRay which has DTS-HD sound ('Life' from the BBC Earth series).

When using sample files, and I have set 'Original primary audio only', when DTS-HD is playing, the receiver shows up DTS and at some moments in the sample files you hear a very noisy "bang". Like it can't handle the sound. When using mix to PCM, sound is ok and receiver is showing up LPCM Multichannel input.
HwKok is offline  
post #6 of 16 Old 08-29-2012, 07:21 AM
Senior Member
 
acejh1987's Avatar
 
Join Date: Dec 2006
Posts: 226
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 20
I don't think TMT5 is bitstreaming properly, it should say passthrough in the info if it is working correctly.
It might be worth a try setting up MPC-HC with Lav Filters, just to see if that will bitstream correctly.
If that also has issues, it might be a good idea to start over and clear all the drivers and try installing the AMD Video/HDMI drivers from scratch.
acejh1987 is offline  
post #7 of 16 Old 08-29-2012, 04:10 PM - Thread Starter
Newbie
 
HwKok's Avatar
 
Join Date: Aug 2012
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by acejh1987 View Post

I don't think TMT5 is bitstreaming properly, it should say passthrough in the info if it is working correctly.
It might be worth a try setting up MPC-HC with Lav Filters, just to see if that will bitstream correctly.
If that also has issues, it might be a good idea to start over and clear all the drivers and try installing the AMD Video/HDMI drivers from scratch.

Well, I followed the MPC-HC wit Lav filters-guide step by step. Walked trough it again and again. But with DTS-HD and TrueHD I get no sound at all!
When playing DTS or Dolby, sound is ok. Video is not ok (not in sync, stuttering with some movies). Not a succes as you can read.

So I will delete my current driver, clean the traces with DriverSweeper and start all over again.
As I'm thinking about this, I never installed the current Catalyst package (12.8) from scratch, the version I was running (v12.6) was updated after I got an automatic message that there was an update. Maybe that's the problem. I'll let you know the results.
HwKok is offline  
post #8 of 16 Old 09-03-2012, 12:09 AM - Thread Starter
Newbie
 
HwKok's Avatar
 
Join Date: Aug 2012
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Another update:
I deleted the 12.6 driver files. Ran DriverSweeper in safe mode and deleted al files which remained after uninstalling the drivers. Uninstalled XBMC and everything I didn't need anymore.
Rebooted.

Installed the 12.8 CCC driver package. Configured the ATI HDMI Output as 5.1 and all the other things like exclusive mode etc.
Started MPC-HC and played a normal DTS file: worked.
Played a DTS-HD file: no sound and no input at all (receiver showed no symbols, even the HDMI light dissappeared)
Played a Dolby TrueHd file: receiver showed PCM, but video and audio played extremely slow (about 3fps).

Reinstalled XBMC and followed this guide: http://forum.xbmc.org/showthread.php?tid=128480
But when playing a DTS-HD of TrueHD file, XBMC gives the warning: failed to initialize audio device.
HwKok is offline  
post #9 of 16 Old 09-03-2012, 12:47 AM
Advanced Member
 
steelman1991's Avatar
 
Join Date: May 2008
Posts: 981
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 31 Post(s)
Liked: 75
Sounds like you may have EDID issues - have a look here http://www.avsforum.com/t/1227161/edid-overrides-to-solve-bitstreaming-issues-for-ati-5xxxs. I know it quotes ATI 5xxx series, but I don't think it is exclusive in that regard.
steelman1991 is offline  
post #10 of 16 Old 09-03-2012, 06:39 AM
AVS Special Member
 
audit13's Avatar
 
Join Date: Sep 2007
Location: Toronto
Posts: 1,669
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 24
What's your primary display in Windows? Is it your receiver or tv?
audit13 is offline  
post #11 of 16 Old 09-03-2012, 07:13 AM - Thread Starter
Newbie
 
HwKok's Avatar
 
Join Date: Aug 2012
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by audit13 View Post

What's your primary display in Windows? Is it your receiver or tv?

Its my receiver I believe. When I'm in the resolution settings-screen, I see "R-548" as my display (which is the type of the receiver).
When I go to the device manager and I click monitor, I see "Generic PnP monitor".

Tulli has just posted a driver file for me in the EDID-override topic, I'm going to test this when I'm home from work.
Fingers crossed..
HwKok is offline  
post #12 of 16 Old 09-03-2012, 07:36 AM
AVS Special Member
 
audit13's Avatar
 
Join Date: Sep 2007
Location: Toronto
Posts: 1,669
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 24
Quote:
Originally Posted by HwKok View Post

Its my receiver I believe. When I'm in the resolution settings-screen, I see "R-548" as my display (which is the type of the receiver).
When I go to the device manager and I click monitor, I see "Generic PnP monitor".
Tulli has just posted a driver file for me in the EDID-override topic, I'm going to test this when I'm home from work.
Fingers crossed..

Everything you described is exactly how it should be. I assume your playback device is the AMD HDMI device.
audit13 is offline  
post #13 of 16 Old 09-03-2012, 08:27 AM - Thread Starter
Newbie
 
HwKok's Avatar
 
Join Date: Aug 2012
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by audit13 View Post

Everything you described is exactly how it should be. I assume your playback device is the AMD HDMI device.

Yep, that's right!
HwKok is offline  
post #14 of 16 Old 09-03-2012, 08:40 AM
AVS Special Member
 
Andy_Steb's Avatar
 
Join Date: Jan 2005
Location: New Orleans
Posts: 1,026
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 25 Post(s)
Liked: 153
a lot of people have problems bitstreaming if they set windows to 5.1.

Try stereo.

Andy_Steb is online now  
post #15 of 16 Old 09-03-2012, 01:38 PM - Thread Starter
Newbie
 
HwKok's Avatar
 
Join Date: Aug 2012
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Thanks everybody, but the solution was an EDID-override made by Tulli: http://www.avsforum.com/t/1227161/edid-overrides-to-solve-bitstreaming-issues-for-ati-5xxxs/3240#post_22366829

It's now working properly!!
Thread can be closed biggrin.gif
HwKok is offline  
post #16 of 16 Old 09-03-2012, 02:41 PM
Advanced Member
 
steelman1991's Avatar
 
Join Date: May 2008
Posts: 981
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 31 Post(s)
Liked: 75
Happy its worked out for you - enjoy smile.gif
steelman1991 is offline  
Reply Home Theater Computers

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off