Catalyst Control Center settings? - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 13 Old 09-08-2012, 02:46 AM - Thread Starter
AVS Special Member
 
Mike99's Avatar
 
Join Date: Sep 2004
Location: Illinois
Posts: 3,047
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 39 Post(s)
Liked: 51
I just installed an MSI HD 6450 video card & have questions on video black levels.

I mainly use WMC7 to record & play OTA recording. The black levels looked proper when playing a recording or standard DVD when I was using the Intel G620 integrated graphics. But after installing the 6450 card the blacks looked gray. I looked at a lot of settings in the Catalyst Control Center & one that affected black levels was under “My Digital Flat-Panels” & is called “Pixel Format“. There are 4 choices & the only one that made things look correct was #4.
1. YcbCr 4:4:4 Pixel Format
2. YCbCr 4:2:2 Pixel Format
3. RGB 4:4:4 Pixel Format Studio (Limited RGB)
4. RGB 4:4:4 Pixel Format PC Standard (Full RGB)

I used WMC7 & tried to play a standard DVD which also has the THX Optimizer on it but the test patterns hang up when playing. So I used WMPlayer. Now the #4 Pixel Format choice is way too dark & the “THX” letters do not even show up. However any of the first 3 choices look pretty good, the same goes when using MPC-HC to play the DVD.

However when using the WMC7 TV setup guide the #4 Pixel Format looks good, just like when playing a recording or a DVD. And this essentially matches what the black level looks like when playing a DVD on my Blu-ray player through the same HDMI input on the TV.

IOW the #4 Pixel Format is the only one that looks proper when using WMC7 and it’s the only one that does not look proper when using WMPlayer or MPC-HC.

What the heck is going on?
Mike99 is offline  
Sponsored Links
Advertisement
 
post #2 of 13 Old 09-08-2012, 03:59 AM
Newbie
 
Nomad2's Avatar
 
Join Date: Mar 2008
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Add this to the registry


Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\\SOFTWARE\\Debug\\ehPresenter.dll]
"NominalRange"=dword:1

[HKEY_LOCAL_MACHINE\\SOFTWARE\\Debug\\ehPresenter.dll]
"BoundByNativeSize"=dword:0


When creating registry files, be sure to end it with a blank line

Your washed out greys will be gone.

rgds Damon
Nomad2 is offline  
post #3 of 13 Old 09-08-2012, 05:56 AM
AVS Special Member
 
GreenEyez's Avatar
 
Join Date: Jan 2010
Posts: 2,258
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 20
Turn of Dynamic Contrast in the ATI Control Panel, that`s what is screwing up your black levels. Actually, turn OFF all those "picture quality" enhancements except for Edge Enhancements.

YcbCr 4:4:4 with Limited (16-235) or Full (0-255) levels should work fine.
GreenEyez is offline  
post #4 of 13 Old 09-08-2012, 06:05 AM - Thread Starter
AVS Special Member
 
Mike99's Avatar
 
Join Date: Sep 2004
Location: Illinois
Posts: 3,047
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 39 Post(s)
Liked: 51
Quote:
Originally Posted by Nomad2 View Post

Add this to the registry
Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\\SOFTWARE\\Debug\\ehPresenter.dll]
"NominalRange"=dword:1
[HKEY_LOCAL_MACHINE\\SOFTWARE\\Debug\\ehPresenter.dll]
"BoundByNativeSize"=dword:0
When creating registry files, be sure to end it with a blank line
Your washed out greys will be gone.
rgds Damon

Thanks -

I've been looking around since my initial posting & also came across the registry changes. The last time I changed a registry was years ago with Windows XP. How do I add the new entries in Windows 7?

I did Google this & came across 2 ways. Create a text file & save it as a .reg file, or open the registry & select New from the Edit menu. Any recommendations?

Which of the first 3 Pixel Formats is the correct one to use?
Mike99 is offline  
post #5 of 13 Old 09-08-2012, 12:35 PM - Thread Starter
AVS Special Member
 
Mike99's Avatar
 
Join Date: Sep 2004
Location: Illinois
Posts: 3,047
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 39 Post(s)
Liked: 51
Any idea why the black levels were OK when using the Intel integrated graphics?

Obviously the "Full RGB" setting is what works in WMC. But why? Isn't the HDTV expecting the 16-235 color range?
Mike99 is offline  
post #6 of 13 Old 09-08-2012, 01:01 PM
AVS Special Member
 
GreenEyez's Avatar
 
Join Date: Jan 2010
Posts: 2,258
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 20
Depends on the TV and Receiver. Some TVs can do YcbCr and RGB, some only YcbCr, some receivers can passthrough both 16-235 and 0-255, some can only do 16-235. For example my receiver can`t passthrough 0-255 RGB , so i have mine on YcbCr 4-4-4 and Full Dynamic Range (0-255), both on my previous ATI card, on the Intel iGPU i used and on my new GT610 . That`s why the settings are there, to accomodate every type of AVR and display.
GreenEyez is offline  
post #7 of 13 Old 09-08-2012, 04:22 PM - Thread Starter
AVS Special Member
 
Mike99's Avatar
 
Join Date: Sep 2004
Location: Illinois
Posts: 3,047
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 39 Post(s)
Liked: 51
When using a calibration DVD in either my stand alone DVD player or Blu-ray player the HDTV can display the B-T-B test pattern. I'm presuming this means the TV can handle 0-255.

My AVR does not have HDMI inputs & the HDTV has only one. So the satellite DVR, Blu-ray player & HTPC are fed into an HDMI switch which connects to the HDTV. The DVD players are using component to the TV. For all practical purposes the black levels look the same no which source is used, including the HTPC using WMC7 if the Pixel Format is set to "Full RGB". But then the HTPC using WMPlayer & MPC-HC is wrong.

I would like to try the registry mod. I haven't worked with a registry in years so am quite rusty on to properly add a file. Do you have any fool proof directions on how to do it?

Thanks
Mike99 is offline  
post #8 of 13 Old 09-08-2012, 05:29 PM - Thread Starter
AVS Special Member
 
Mike99's Avatar
 
Join Date: Sep 2004
Location: Illinois
Posts: 3,047
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 39 Post(s)
Liked: 51
Quote:
Originally Posted by GreenEyez View Post

Turn of Dynamic Contrast in the ATI Control Panel, that`s what is screwing up your black levels. Actually, turn OFF all those "picture quality" enhancements except for Edge Enhancements.
YcbCr 4:4:4 with Limited (16-235) or Full (0-255) levels should work fine.

I forgot to mention that I cannot find anything like Dynamic Contrast, Edge Enhancements or any other type of "picture quality" enhancements. I went through all the menu selections several times but the only thing similar was adjusting color brightness, contrast. hue & saturation. There were also several selections for deinterlacing.

But nothing like you mentioned. Being this is a pretty basic video card could it be that these enhancements are not included or offered?
Mike99 is offline  
post #9 of 13 Old 09-09-2012, 11:43 PM - Thread Starter
AVS Special Member
 
Mike99's Avatar
 
Join Date: Sep 2004
Location: Illinois
Posts: 3,047
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 39 Post(s)
Liked: 51
I did the registry hack for WMC & it worked beautifully. Now its black levels match those in WMP and MPC-HC, and also those from my Blu-ray player.
Mike99 is offline  
post #10 of 13 Old 09-11-2012, 11:17 AM
Senior Member
 
hithere's Avatar
 
Join Date: Jun 2004
Location: Delaware, US
Posts: 204
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 13
Are the problems that used to be experienced with YCbCr 4:4:4 and greenish cast to darker areas with 5xxx series cards fixed with regard to the 6450? Have they been fixed in the 5xxx series since I last visited the issue? I'm currently running a 5570 with RGB 4:4:4, 0-255, with nothing selected under video dynamic range and no enhancements. Black levels seem to be good, but the card is showing signs of failing ram from time to time, and i'm interested in the 6450 as a successor.
hithere is offline  
post #11 of 13 Old 09-11-2012, 03:04 PM - Thread Starter
AVS Special Member
 
Mike99's Avatar
 
Join Date: Sep 2004
Location: Illinois
Posts: 3,047
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 39 Post(s)
Liked: 51
I'm not aware of any greenish cast problems but will try the YCbCr 4:4:4 setting & let you know. Right now I'm using the Limited RGB setting. This is first video card I have used so I don't have any experience with any others.

I found the Dynamic Range & other enhancements. They were grayed out & I have to turn off Enforce Smooth Video Playback in order to enable them.
Mike99 is offline  
post #12 of 13 Old 09-11-2012, 06:40 PM - Thread Starter
AVS Special Member
 
Mike99's Avatar
 
Join Date: Sep 2004
Location: Illinois
Posts: 3,047
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 39 Post(s)
Liked: 51
hithere,

I tried all those first 3 pixel formats and could not tell any difference between them nor see any greenish cast.
Mike99 is offline  
post #13 of 13 Old 09-15-2012, 07:49 PM
AVS Special Member
 
cburbs's Avatar
 
Join Date: Aug 2003
Location: Somewhere in Oregon
Posts: 2,892
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 18
Quote:
Originally Posted by GreenEyez View Post

Turn of Dynamic Contrast in the ATI Control Panel, that`s what is screwing up your black levels. Actually, turn OFF all those "picture quality" enhancements except for Edge Enhancements.
YcbCr 4:4:4 with Limited (16-235) or Full (0-255) levels should work fine.

I am running ati 12.8 and I don't see anything listing the 16-235 or 0-255.....am I looking in the wrong place.

"Dang! You got shocks, pegs... lucky! You ever take it off any sweet jumps? "

Sony 55EX500 Settings
cburbs is online now  
Reply Home Theater Computers

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off