Urgent help with FlexRAID please - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 21 Old 09-22-2012, 03:51 PM - Thread Starter
Senior Member
 
maxse's Avatar
 
Join Date: Jun 2004
Posts: 490
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 10
Guys I need your help. I was not able to get much help from the flexraid forum and really hoping that some of you are more knowledgable and could really help me out: WHS 2011+FlexRAID on HP Proliant N36L. Had unRAID for 2 weeks prio that precleared all drives and ran without any problems.

For some reason last night when I Cam home from work to watch a movie of course, I was not able to write ANYTHING to do the disk or create a folder. I was able to read the files just fine. I looked at the log file which said I had to force re-sync, than I had to reconcile, and everything was back for a few hours. Than today once again same issue!

I removed the array config, all SMART data says drives are healthy. Set everything up from scratch again. and it worked! I was able to transfer a total of ONE movie and than BAM same issue! This is so frustrating as I just want to enjoy my movies. FlexRAID was working for 3-4 days before this point beautifully and I was going to by another license to set up a server in my parents' place so that I could remote into it. But now I can't even get it working at my house!

Here is the log:
[2012-09-22 18:16:15,859] WARN : /gwt/rpc
java.lang.RuntimeException: Login exception: unauthenticated user!
at java.lang.Void.(Unknown Source)
at java.lang.Void.(Unknown Source)
at java.lang.Void.(Unknown Source)
at java.lang.Void.(Unknown Source)
[2012-09-22 18:16:44,717] INFO : Saving FlexRAID...
[2012-09-22 18:18:27,752] INFO : *** Starting workers... ***
[2012-09-22 18:33:01,147] INFO : RealTime RAID initial parity success!
[2012-09-22 18:33:03,253] INFO : Backing up Real-Time RAID filesystem DBs to C:\Program Files (x86)\OpenEgg.org\FlexRAID-Backups
[2012-09-22 18:33:03,253] INFO : Executing copy-live-dbs...
[2012-09-22 18:33:03,253] INFO : [copy-live-dbs] started at: Sat Sep 22 18:33:03 EDT 2012
[2012-09-22 18:33:03,300] INFO : [copy-live-dbs] completed at: Sat Sep 22 18:33:03 EDT 2012
[2012-09-22 18:33:27,682] INFO : Initiating FlexRAID Storage Pool...
[2012-09-22 18:33:28,540] INFO : Host OS = Microsoft Windows [Version 6.1.7601]
[2012-09-22 18:33:28,540] INFO : Building View Registry...
[2012-09-22 18:33:28,540] INFO : Building Auto View Registry...
[2012-09-22 18:33:28,665] INFO : Loading View options...
[2012-09-22 18:33:29,663] INFO : Using Auto-View definition...
[2012-09-22 18:33:29,663] INFO : Verifying real-time RAID previous exit state...
[2012-09-22 18:33:29,663] INFO : Building View Handler...
[2012-09-22 18:33:30,006] INFO : Mounting Storage Pool drive...
[2012-09-22 18:34:17,148] INFO : Reconnecting Shows="V:\ServerFolders\Shows" /GRANT:Everyone,FULL
[2012-09-22 18:34:29,144] INFO : Reconnecting Shows="V:\ServerFolders\Shows" /GRANT:Everyone,FULL
[2012-09-22 18:34:29,362] INFO : Reconnecting Movies="V:\ServerFolders\Movies" /GRANT:Everyone,FULL
[2012-09-22 18:34:36,335] INFO : Unmounting View...
[2012-09-22 18:34:36,429] INFO : Unmounting View complete...
[2012-09-22 18:34:36,429] INFO : Closing Registry...
[2012-09-22 18:34:36,429] INFO : Closing Registry complete...
[2012-09-22 18:34:57,176] INFO : Initiating FlexRAID Storage Pool...
[2012-09-22 18:34:57,238] INFO : Host OS = Microsoft Windows [Version 6.1.7601]
[2012-09-22 18:34:57,238] INFO : Building View Registry...
[2012-09-22 18:34:57,238] INFO : Building Auto View Registry...
[2012-09-22 18:34:57,363] INFO : Loading View options...
[2012-09-22 18:34:57,550] INFO : Using Auto-View definition...
[2012-09-22 18:34:57,550] INFO : Verifying real-time RAID previous exit state...
[2012-09-22 18:34:57,550] INFO : Building View Handler...
[2012-09-22 18:34:57,769] INFO : Mounting Storage Pool drive...
[2012-09-22 18:40:34,094] ERROR: Disabling all live synchronization operations due to un-recoverable error.
[2012-09-22 18:40:34,125] ERROR: {"callMode": 500, "parityHandle": 432393960, "parityOffset": 4368, "fileSize": 2560, "path": "\ServerFolders\Movies\Big Love\Thumbs.db", "realPath": "\\?\C:\FlexRAID-Managed-Pool\class1_0\{caa0c275-00df-42d2-b9c2-871b831ecbc2}\ServerFolders\Movies\Big Love\Thumbs.db", "targetPath": "null", "targetRealPath": "null", "message": "onTruncate: SetLengthByHandle error=5 for path=\ServerFolders\Movies\Big Love\Thumbs.db -> realPath=\\?\C:\FlexRAID-Managed-Pool\class1_0\{caa0c275-00df-42d2-b9c2-871b831ecbc2}\ServerFolders\Movies\Big Love\Thumbs.db"}
[2012-09-22 18:40:34,125] WARN : Disabling all live operations! All future operations will get an access denied error...


I really hope that you guys could help me, I'm really desperate at this point. I swtiched over to FlexRAID because I Felt that learning how to install sabnzbd and sickbeard etc... on unraid was too complicated, and that I wouldnt be able to remote log in if it was at my parents' house. So I've spent almost a month getting this thing to work.
maxse is offline  
Sponsored Links
Advertisement
 
post #2 of 21 Old 09-22-2012, 04:23 PM
AVS Addicted Member
 
assassin's Avatar
 
Join Date: Jul 2004
Posts: 12,946
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 43 Post(s)
Liked: 239
Why are you using realtime?
assassin is online now  
post #3 of 21 Old 09-22-2012, 05:14 PM - Thread Starter
Senior Member
 
maxse's Avatar
 
Join Date: Jun 2004
Posts: 490
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 10
Because I constantly add shows to it and photos. I feel safer knowing that as soon as the file is copied to the server it is automatically protected in parity... Which is similar to how unRAID works?

I just tried to disconnect the most recent hard drive that I just added (this specific one wasn't actually pre-cleared by unraid). Re-configured a new pool, and got the same error again! I know this can't be the drives, something is just going on. Here is the log as soon as I created a new pool without that last hard drive:

[2012-09-22 20:06:08,481] INFO : Reconnecting Shows="V:\ServerFolders\Shows" /GRANT:Everyone,FULL
[2012-09-22 20:07:02,170] ERROR: Disabling all live synchronization operations due to un-recoverable error.
[2012-09-22 20:07:02,170] ERROR: {"callMode": 500, "parityHandle": 385944600, "parityOffset": 4008, "fileSize": 2560, "path": "\ServerFolders\Movies\Big Love\Thumbs.db", "realPath": "\\?\C:\FlexRAID-Managed-Pool\class1_0\{caa0c275-00df-42d2-b9c2-871b831ecbc2}\ServerFolders\Movies\Big Love\Thumbs.db", "targetPath": "null", "targetRealPath": "null", "message": "onTruncate: SetLengthByHandle error=5 for path=\ServerFolders\Movies\Big Love\Thumbs.db -> realPath=\\?\C:\FlexRAID-Managed-Pool\class1_0\{caa0c275-00df-42d2-b9c2-871b831ecbc2}\ServerFolders\Movies\Big Love\Thumbs.db"}
[2012-09-22 20:07:02,170] WARN : Disabling all live operations! All future operations will get an access denied error...


I don't understand what's going on really. The drives are all 3tb Seagates except for the OS drive that came with the N36L. I don't really know what I should do at this point. I can't write anything to my server which is almost empty since I just started it.

The only thing I could think of, was when I converted everything from unRAID, I did a QUICK format (as opposed to a full format) on the drives within WHS2011. But I'm not sure if that could have anything to do with this?
maxse is offline  
post #4 of 21 Old 09-22-2012, 05:20 PM
AVS Addicted Member
 
assassin's Avatar
 
Join Date: Jul 2004
Posts: 12,946
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 43 Post(s)
Liked: 239
What do you mean by constantly?

I "constantly" add things as well and have it setup as snapshot and update once a day. You shouldn't be using it as backup anyway and if these files are that important I would recommend against using just raid --- any type of raid.
assassin is online now  
post #5 of 21 Old 09-22-2012, 05:37 PM - Thread Starter
Senior Member
 
maxse's Avatar
 
Join Date: Jun 2004
Posts: 490
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 10
Hmm I see. You are right assassin.

I just started this thing with unRAID and really liked how it works, then after strugglling saw that I could use WHS with FlexRAID for the same thing and that it was now out of beta and ready for realtime RAID.

Do you think that would solve my issue? Updating once a day would work perfectly fine I guess. Does it recreate the entire parity or just updates it with the changes (if any) since the last "snapshot?"

More importantly, do you think that would fix the issue I am having? I am willing to try anything at this point.
maxse is offline  
post #6 of 21 Old 09-22-2012, 06:00 PM
AVS Special Member
 
Andy_Steb's Avatar
 
Join Date: Jan 2005
Location: New Orleans
Posts: 1,016
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 20 Post(s)
Liked: 152
Quote:
Originally Posted by assassin View Post

Why are you using realtime?

Why not, he is paying for the feature. Your not implying that this software might be a little buggy are you?

Andy_Steb is offline  
post #7 of 21 Old 09-22-2012, 06:08 PM
AVS Addicted Member
 
assassin's Avatar
 
Join Date: Jul 2004
Posts: 12,946
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 43 Post(s)
Liked: 239
Quote:
Originally Posted by Andy_Steb View Post

Why not, he is paying for the feature. Your not implying that this software might be a little buggy are you?

Not at all. I don't get the point of realtime parity for home use regardless of what you are using.

Now for businesses or a website where you have multiple people altering or sharing critical data every minute then it makes more sense.
assassin is online now  
post #8 of 21 Old 09-22-2012, 06:10 PM
AVS Addicted Member
 
assassin's Avatar
 
Join Date: Jul 2004
Posts: 12,946
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 43 Post(s)
Liked: 239
When moving from one file system type to another I would have recommended a complete format instead of a quick format.
assassin is online now  
post #9 of 21 Old 09-22-2012, 08:20 PM - Thread Starter
Senior Member
 
maxse's Avatar
 
Join Date: Jun 2004
Posts: 490
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 10
Still, I don't think that is what's causing the issue. Seems to hang up on thumbs.db according to the log.

Maybe the WDTV is doing something that flexraid isn't liking? I am using it to stream for the server...

assassin could you give me a little more detail on the snapshot raid you have set up? Woudl I need to set someting up in the scheduler to have it run and update every night?

What I'm not sure about is the fact that I will have sickbeard and sabnzbd installed which would be downloading overnight or whenever sickbeard finds an episode available. And after the download it automatically renames the file and will move it to the "Shows" share on the pool.

Now what if flexraid happens to be updating the snapshot at that specific time. Wouldn't that cause a problem?

*EDIT* I just noticed that the WDTV Live SMP created a folder in both of my shares "Shows" and "Movies"
The folder starts with a period for some reason. A
".wd_tv"

That is the first folder in both of my shares I wonder if this is causing an issue. Anyone know what this is?
maxse is offline  
post #10 of 21 Old 09-23-2012, 07:38 AM - Thread Starter
Senior Member
 
maxse's Avatar
 
Join Date: Jun 2004
Posts: 490
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 10
Oh my goodness, woke up this morning and have the same issue! Guys help!
Here is the log again if it helps

[2012-09-22 21:07:30,560] INFO : Saving FlexRAID...
[2012-09-22 21:08:11,249] INFO : *** Starting workers... ***
[2012-09-22 21:23:03,428] INFO : RealTime RAID initial parity success!
[2012-09-22 21:23:07,344] INFO : Backing up Real-Time RAID filesystem DBs to C:\Program Files (x86)\OpenEgg.org\FlexRAID-Backups
[2012-09-22 21:23:07,406] INFO : Executing copy-live-dbs...
[2012-09-22 21:23:07,422] INFO : [copy-live-dbs] started at: Sat Sep 22 21:23:07 EDT 2012
[2012-09-22 21:23:08,717] INFO : [copy-live-dbs] completed at: Sat Sep 22 21:23:08 EDT 2012
[2012-09-22 21:23:20,121] INFO : Initiating FlexRAID Storage Pool...
[2012-09-22 21:23:20,933] INFO : Host OS = Microsoft Windows [Version 6.1.7601]
[2012-09-22 21:23:20,933] INFO : Building View Registry...
[2012-09-22 21:23:20,933] INFO : Building Auto View Registry...
[2012-09-22 21:23:21,042] INFO : Loading View options...
[2012-09-22 21:23:21,323] INFO : Using Auto-View definition...
[2012-09-22 21:23:21,323] INFO : Verifying real-time RAID previous exit state...
[2012-09-22 21:23:21,323] INFO : Building View Handler...
[2012-09-22 21:23:21,697] INFO : Mounting Storage Pool drive...
[2012-09-22 21:23:50,967] INFO : Reconnecting Movies="V:\ServerFolders\Movies" /GRANT:Everyone,FULL
[2012-09-22 21:24:00,109] INFO : Reconnecting Movies="V:\ServerFolders\Movies" /GRANT:Everyone,FULL
[2012-09-22 21:24:00,297] INFO : Reconnecting Shows="V:\ServerFolders\Shows" /GRANT:Everyone,FULL
[2012-09-23 10:28:54,662] ERROR: Disabling all live synchronization operations due to un-recoverable error.
[2012-09-23 10:28:54,677] ERROR: {"callMode": 500, "parityHandle": 459442160, "parityOffset": 10992, "fileSize": 12288, "path": "\ServerFolders\Movies\Ace Ventura Pet Detective\Thumbs.db", "realPath": "\\?\C:\FlexRAID-Managed-Pool\class1_0\{caa0c275-00df-42d2-b9c2-871b831ecbc2}\ServerFolders\Movies\Ace Ventura Pet Detective\Thumbs.db", "targetPath": "null", "targetRealPath": "null", "message": "onTruncate: SetLengthByHandle error=5 for path=\ServerFolders\Movies\Ace Ventura Pet Detective\Thumbs.db -> realPath=\\?\C:\FlexRAID-Managed-Pool\class1_0\{caa0c275-00df-42d2-b9c2-871b831ecbc2}\ServerFolders\Movies\Ace Ventura Pet Detective\Thumbs.db"}
[2012-09-23 10:28:54,677] WARN : Disabling all live operations! All future operations will get an access denied error...
maxse is offline  
post #11 of 21 Old 09-23-2012, 09:02 AM
Member
 
pohh-bah's Avatar
 
Join Date: May 2004
Location: Los Angeles
Posts: 69
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 13
Coincidence that both of you had a failure on a thumbs.db file? I generally disable those on my clients to avoid unintended locking of server folders.
pohh-bah is offline  
post #12 of 21 Old 09-23-2012, 09:58 AM
Member
 
OneFast3's Avatar
 
Join Date: Apr 2009
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
I had the same problems with real time with FlexRaid, I just went to snapshot for now until he fixes all the problems.

From what I get and understand from the forum is the problem comes from how programs write to the raid. Think it is the same as why people are having problems with teracopy.
OneFast3 is offline  
post #13 of 21 Old 09-24-2012, 12:35 PM
AVS Special Member
 
EricN's Avatar
 
Join Date: May 2002
Posts: 1,187
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 22 Post(s)
Liked: 182
Quote:
Originally Posted by assassin View Post

Not at all. I don't get the point of realtime parity for home use regardless of what you are using.
Now for businesses or a website where you have multiple people altering or sharing critical data every minute then it makes more sense.

That arbitrary home use/business use classification doesn't survive impact with reality. I have users that remotely adjust their recording schedules using the external web interface. That data is no less critical to the proper functioning of my systems just because it's a htpc and not a "real" server.

If I answered the question of "why didn't my show record?" with "because I don't see the point in realtime data protection", I'd have to make my own dinner...and I don't like my own cooking.
EricN is offline  
post #14 of 21 Old 09-24-2012, 01:53 PM
Advanced Member
 
ncarty97's Avatar
 
Join Date: Mar 2006
Posts: 746
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Liked: 16
Quote:
Originally Posted by pohh-bah View Post

Coincidence that both of you had a failure on a thumbs.db file? I generally disable those on my clients to avoid unintended locking of server folders.

How do you do that? I really hate getting my server folders locked.
ncarty97 is offline  
post #15 of 21 Old 09-24-2012, 01:53 PM
Advanced Member
 
ncarty97's Avatar
 
Join Date: Mar 2006
Posts: 746
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Liked: 16
Quote:
Originally Posted by EricN View Post

That arbitrary home use/business use classification doesn't survive impact with reality. I have users that remotely adjust their recording schedules using the external web interface. That data is no less critical to the proper functioning of my systems just because it's a htpc and not a "real" server.
If I answered the question of "why didn't my show record?" with "because I don't see the point in realtime data protection", I'd have to make my own dinner...and I don't like my own cooking.

If you were using a RAID4 or 5 solution for the drive which you record to, you've already made a huge error.
ncarty97 is offline  
post #16 of 21 Old 09-25-2012, 07:01 AM - Thread Starter
Senior Member
 
maxse's Avatar
 
Join Date: Jun 2004
Posts: 490
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 10
Thanks guys. I took assassin's advice and switched over to Snapshot RAID. I am finally able to write to the drive again.
The live RAID is definitely buggy and I am a bit disappointed that I can't use it. But assassin is write in that snapshot RAID should be sufficient.

-Could you guys just help me out with setting up the Snapshot RAID on this thing in terms of having a scheduler run the update function? I am unsure how to set that up.
Also, is that the only thing that needs to be scheduled the "update" function? Or do you recommend scheduling something else with it, like a parity check or verify, etc...?

Thanks so much.
maxse is offline  
post #17 of 21 Old 09-25-2012, 07:52 AM
Member
 
OneFast3's Avatar
 
Join Date: Apr 2009
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Quote:
Originally Posted by maxse View Post

Thanks guys. I took assassin's advice and switched over to Snapshot RAID. I am finally able to write to the drive again.
The live RAID is definitely buggy and I am a bit disappointed that I can't use it. But assassin is write in that snapshot RAID should be sufficient.
-Could you guys just help me out with setting up the Snapshot RAID on this thing in terms of having a scheduler run the update function? I am unsure how to set that up.
Also, is that the only thing that needs to be scheduled the "update" function? Or do you recommend scheduling something else with it, like a parity check or verify, etc...?
Thanks so much.

I created a expression script named "RunUpdate" with the following in it:
Code:
@config Media
@queued true
@execute @task update

Media is the name of my raid configuration and I just run this every day from the scheduler at a time I think I'm not gonna be doing much on the server (for me its 11:15 pm).
OneFast3 is offline  
post #18 of 21 Old 09-25-2012, 07:59 AM
Member
 
bomberjim's Avatar
 
Join Date: Jan 2008
Posts: 136
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 13
Not sure what you mean by help you set up the update function. In the scheduler, you select your configuration, then update and the frequency from the drop down menus. Make sure to add it to the schedule. To get it to show up in the scheduled jobs manager you need to "refresh".

I do an update nightly, validate weekly, and do a verify once a month. The verify I set up manually so it doesn't conflict with a validate.

Hope that helps.
bomberjim is offline  
post #19 of 21 Old 09-25-2012, 11:26 AM - Thread Starter
Senior Member
 
maxse's Avatar
 
Join Date: Jun 2004
Posts: 490
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 10
Not really sure what you guys mean by these scripts. I'm a newbie and have no idea where or how to write them and where they go... Totally confused.

Are you guys talking about 2 different things?
Is the scheduler a WHS 2011 scheduler, or within flexRAID?
maxse is offline  
post #20 of 21 Old 09-25-2012, 02:57 PM
Member
 
OneFast3's Avatar
 
Join Date: Apr 2009
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
All from the FlexRaid Web Client. Scheduler is on main screen. Expression scripts are under System control panel.
OneFast3 is offline  
post #21 of 21 Old 09-25-2012, 09:20 PM - Thread Starter
Senior Member
 
maxse's Avatar
 
Join Date: Jun 2004
Posts: 490
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 10
Ohhh man, so I moved some more files over tonight, clicked on update, and BAM! Another error, and the update could not be completed!

IT says to see "logs" for further info, but I'm not sure which log file. I've been opening the "flexraid" file from within "C:\" drive, but I don't think that's the one it refers to because it doesn't give me much info there. Is there some other log file?

I tried restarting the server just in case and it worked now! Updated successfully.

But boy this thing is giving me so many problems. How are you guys running it smoothly??

I was going to put a box at my parent's place but now I don't know because they would never be able to fix all these issues, especially when I can't even figure out how to run it smoothly myself...

At this point all I want is snapshot raid every night. Geez,..

What should I do guys?

*EDIT* Also, I am getting stuttering playback now on my movies with my WDTV. IT just pauses for 3 seconds and then continues playing. I have no idea why this is happening all of a sudden.

*EDIT 2* So I opened event viewer (not sure how to read it) but it seems like there are a few Disk errors! I'm not sure if this is normal or if this indicated a big problem and could be the cause of my issues? I ran the SMART and ANALYZE short tests WITHIN FlexRAID and all the drived passed. So I don't really know. I have attached 2 screen shots, maybe it could help you guys help me out?
The second screen shot is me double clicking on the actual error

maxse is offline  
Reply Home Theater Computers

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off