video "tearing" in VLC on Windows 7 - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 2 Old 09-30-2012, 02:57 PM - Thread Starter
Member
 
ratsrcute's Avatar
 
Join Date: Apr 2008
Posts: 49
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I have been using VLC successfully for a long time on XP. When I recently switched to windows 7, keeping all the hardware the same, I'm now getting "tearing" (the appearance of horizontal lines) on shots that have a lot of horizontal panning. I tried to find information about this on the web. One thing I found was the instruction to confirm that my windows 7 refresh rate matched my video card refresh rate. So my video card said 60 and windows 7 said 59. I set it to 60 in windows 7 and the screen went dark for a moment as though it were recalibrating, but afterward Windows 7 still said 59. I read somewhere else that this isn't important. It has to do with the real refresh rate which is a decimal somewhere between 59 and 60 and how the video card just rounds off the display differently than windows, but in reality they are the same rate. I don't know if that is true.


Anyway, any help appreciated. What should I try next to debug this issue?

Incidentally, if I give up on VLC, are there any other free video players that are known to work without issues on windows 7?
ratsrcute is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 01-14-2015, 12:08 PM
Newbie
 
Join Date: Jan 2015
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 0
I have had the same problem ever since I found VLC over 11 years go. I didn't know what it was called, all I knew was that whenever an action scene was playing VLC player would have horizontal lines during the fast motion part of the video. This happened on every Windows computer I've Owned, nomatter what settings I tried changing so I thought that this was just a defect in VLC that everyone had to live with. Once I found out that this is called "Video Tearing" I did a search and found this post today. Setting VLC to DirectX or DirectDraw does fix this problem. In the new version of VLC Ver 2.1.5 Rincewind: 1. Click Tools 2. Click Preferences 3. At the bottom left under "Show Settings" Click "ALL" 4. Under the Video section click on "OutPut Modules" 5. Change from "Automatic" to "DirectX (DirectDraw) Video Output" 6. Click the "Save" Button at the bottom 7. Close VLC 8. Restart VLC 9. Enjoy Tear Free Videos ;-) If I only helped one person to fix this problem then it will have been worth signing up for this forum and writing this post.
1Tech is offline  
Sponsored Links
Advertisement
 
Reply Home Theater Computers



Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off