windows media center standard issues? still not fixed after much time - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 9 Old 12-10-2012, 08:23 PM - Thread Starter
Senior Member
 
robertkjr3d's Avatar
 
Join Date: Jan 2008
Posts: 214
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Liked: 10
There are a few standard bugs in WMC, that I quite understand why Microsoft hasn't just produced a simple hotfix or windows update for:
I've got some work-arounds for these. And I've employed them:

1) I have dual-monitors. So when you make WMC full-screen on the 2nd monitor, what does it do? - Your mouse is locked on the 2nd monitor. (help I cannot escape). It is clear the software was never designed for a multiple monitor system. - This is particularly annoying when your 2nd monitor is also mirrored on your HDTV.

workaround: I found software out there called 'the maxifier' http://www.mods.com.au/Maxifier/ - There are some great advantages here. Because it gives you some wonderful shortcuts from the taskbar to WMC as well as keeping the Mouse-lock issue at bay.

Drawback: - to be discussed later...

2) Mute the audio... (not all the audio!!!) - Yes when you click mute in WMC. It mutes all sounds. -

Workaround: I found a work around for this as well. I found instructions on how to set up desktop icon, to just mute WMC.

Drawback: This will not work from my mobile remote. I have to be sitting at the machine to find that icon on my desktop that I created.

3) Some might think this is related to my configuration but--- I don't believe it: When going to 'Full-Screen Mode' within WMC- I clearly lose frame-rate, and the picture gets choppy. No matter whether I'm watching a HD-Live, HD-Recorded, Regular-Recorded. Doesn't matter. - However if I take the picture out of 'full-screen' mode, and tell 'The Maxifier' to 'Fit-To-Screen'... The program runs smoothly. I also get a smooth picture when watching the same file (.wtv) in WMP or VLC. Something happens in 'Full-Screen' mode that causes WMC to behave improperly and slowly.

Workaround: Stated above... But Use 'The Maxifier' and select 'Fit-To-Screen' instead of 'Full-Screen'.

DrawBack: Unfortunately this leaves bars around the very edges of the picture. It will be particularly annoying when I get the proper connections for the route between my computer and the hdtv. I suppose the real workaround is to not use WMC at all for playback of recorded tv... but actually to use WMP, or VLC, in which I'm not seeing these issues.

Edit: Number 3--- above is not a real WMC issue: (see below posts) But here is one:
3) WMC will not prevent the windows screen saver from kicking in: If you configure windows to have a Screen saver. And your playing a video, movie through WMC. Lets say your sitting in the living room... All of sudden you'll see your Screen Saver. I'm not referring to the WMC screen saver. I'm talking about the Windows 7 bubbles... or other custom screen savers.
robertkjr3d is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 12-10-2012, 09:17 PM
AVS Special Member
 
StardogChampion's Avatar
 
Join Date: Dec 2007
Location: New Hampshire, USA
Posts: 3,015
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 40 Post(s)
Liked: 126
Quote:
Originally Posted by robertkjr3d View Post

There are a few standard bugs in WMC, that I quite understand why Microsoft hasn't just produced a simple hotfix or windows update for:
I've got some work-arounds for these. And I've employed them:
1) I have dual-monitors. So when you make WMC full-screen on the 2nd monitor, what does it do? - Your mouse is locked on the 2nd monitor. (help I cannot escape). It is clear the software was never designed for a multiple monitor system. - This is particularly annoying when your 2nd monitor is also mirrored on your HDTV.
workaround: I found software out there called 'the maxifier' http://www.mods.com.au/Maxifier/ - There are some great advantages here. Because it gives you some wonderful shortcuts from the taskbar to WMC as well as keeping the Mouse-lock issue at bay.

Alt+tab, select a window or desktop on the other monitor and you're good. Just don't close the window you're in otherwise it'll go back to the fullscreen WMC monitor and you'll have to Alt+Tab out again.

 

 

StardogChampion is online now  
post #3 of 9 Old 12-11-2012, 02:56 AM - Thread Starter
Senior Member
 
robertkjr3d's Avatar
 
Join Date: Jan 2008
Posts: 214
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Liked: 10
Yes I know (I found that an annoying work around alt-tab, or start-menu key)... Here is the real problem: However when you click full-screen in the native WMC as opposed to 'the maxifier' here are the problems:

1) for about 1 second... all screens are black ( at least on my machine while the machine is trying to figure out what is trying to display or something )
2) After it gets to 'Full screen' and figures out what it is doing... than as stated above... I lose framerate and the video is slow. Other people are not getting this?

As stated above, something weird occurs when WMC goes to 'full-screen' mode. Like it is broken.

Yet I can view video smoothly with WMC in 'fit-to-screen' mode, WMP, and VLC.-- Explain that?
robertkjr3d is offline  
post #4 of 9 Old 12-11-2012, 03:16 AM - Thread Starter
Senior Member
 
robertkjr3d's Avatar
 
Join Date: Jan 2008
Posts: 214
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Liked: 10
Well I should retract one of my statements. Not being next to the computer at the moment. I haven't tried running video in full-screen without using the maxifier in a long time. This is what this guy says about it. I've been reading around the web that it's possible that in full-screen mode that it uses direct-x like a video-game and that is why it locks your mouse. However this is still very annoying and this is what should be changed. VLC and WMP do not do this. After all this time, why not a windows update for this?

http://www.avsforum.com/t/1397874/wmc-performance-issues-with-dual-displays

see this too and the subsequent microsoft link
http://www.neowin.net/forum/topic/784498-windows-media-center-full-screen/

Confirmed: 'Tested it this morning' In Full-Screen 'Mouse Locked mode' or Full-Screen (and hitting Alt-Tab) the video is smooth. Drawbacks are: Annoying interaction. Also in both cases. Hitting the '+' for full screen causes a 1sec delay and black on both monitors until WMC figures out what it is doing. The same thing happens when you hit 'Alt-Tab'... 1 sec delay and black on both monitors while you await your mouse being released (then the picture comes back)

2nd Edit) Try teaching this to my Non-Techie wife? That she has to Alt-Tab... I'm sorry this just needs to be patched. This is a long-time and far-away bug. I will try the solution suggested on the above link. That of removing 'transparency' and see if that will removing the 'jitter', or as I put it above the 'frame-rate' loss.
robertkjr3d is offline  
post #5 of 9 Old 12-12-2012, 05:58 AM - Thread Starter
Senior Member
 
robertkjr3d's Avatar
 
Join Date: Jan 2008
Posts: 214
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Liked: 10
hmm... It seems the screen flick: Is not a problem everyone is getting:
http://forums.overclockers.com.au/showthread.php?t=1034659

This is what I experience: When I go to native full-screen mode. For a half second as I reported above: My WMC will cause all monitors to go black like its changing the resolution. Then when I hit alt-tab, it does it yet again. Then when I click back into the WMC to do anything like pause, or change a channel.. it will do it yet again... very annoying!!!

How to solve this issue? It seems this has been a problem for some, in addition to mouse-lock.
robertkjr3d is offline  
post #6 of 9 Old 12-12-2012, 06:50 AM - Thread Starter
Senior Member
 
robertkjr3d's Avatar
 
Join Date: Jan 2008
Posts: 214
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Liked: 10
I might try this fix: experts exchange link
How annoying that I have to go through these struggles...
robertkjr3d is offline  
post #7 of 9 Old 12-12-2012, 08:34 AM
AVS Special Member
 
Postmoderndesign's Avatar
 
Join Date: Jul 2007
Posts: 1,109
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 28 Post(s)
Liked: 32
If misery loves company I am company. The dual monitor locked screen thing has been going on for years. I just use the keyboard windows key to move between monitors and put up with the momentary black out. I have tried the maxifier and did not like its bugs.

The dual monitor problem that gets my panties in a wad is that 7MC loses its video drivers randomly from time to time when changing between recorded TV and live TV or PowerDVD or Media Browser. Then 7MC and the monitor need to be shut down and restarted.

I think all of Microsoft's resources are tied up in the Windows 8 disaster and I am pessimistic that our problems are going to get solved.
Postmoderndesign is online now  
post #8 of 9 Old 12-12-2012, 08:59 AM - Thread Starter
Senior Member
 
robertkjr3d's Avatar
 
Join Date: Jan 2008
Posts: 214
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Liked: 10
I haven't tried it yet... But check out that link that I marked 'experts...' A guy there gives you steps to fix the 'screen black out'. (annoyance) It seems to be due to 7MC attempting to change the refreshrate of the monitor.
robertkjr3d is offline  
post #9 of 9 Old 12-13-2012, 05:14 AM - Thread Starter
Senior Member
 
robertkjr3d's Avatar
 
Join Date: Jan 2008
Posts: 214
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Liked: 10
To postmoderdesign: If your still subscribing... I tested this fix with 'the maxifier' A link mentioned earlier, and it did work. In the advanced Aero Settings. 'Turn off' transparency. It worked. I do not notice jitter/framerate loss. I haven't had time to fully compare 'full-screen' 7mc to 'the maxifier'-->full-screen yet, but so far it seems to work. Drawback: 1st thing I noticed. My windows7 windows didn't look as cool, but I can live with that, if this is the benefit. 1step closer to going back to Windows 2000...hehe.
robertkjr3d is offline  
Reply Home Theater Computers

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off