Have an ASUS Xonar DX 7.1 card, 4.1 speaker setup. Center speaker will not disable - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 10 Old 01-09-2013, 08:41 PM - Thread Starter
Newbie
 
airscottie's Avatar
 
Join Date: Oct 2007
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I hope someone can help me out. There's another thread out there that is similar to what I'm about to post, but some key parts of the advice are unclear to me and my issue remains.

I have a 4.1 speaker setup running through an ASUS Xonar DX 7.1 card. There is absolutely no option to disable the center speaker in the Asus software, so I followed the advice in this thread to enable a phantom center:

http://www.avsforum.com/t/1255993/4-1-with-xonar-card-possible

I've had mixed results. I have ffdshow running fine and enabled the 2/0/2 setup in the "Mixer" tab checked along with the LFE box selected, but it does not always work correctly. It is my understanding that ffdshow should override everything else, but many applications (games in particular) are still running audio through a center speaker that does not exist. For example, Far Cry 3 works fine, yet Assassin's Creed 3 and Batman Arkham City do not at all.

I have enabled 4 audio channels and 5.1 under "analog out" in the Xonar DC Audio Center and I have unchecked the center speaker in Windows 8's sound management settings. A piece of advice in that previous thread mentions to ensure that ffdshow is enabled for ALL applications, but I cannot find anything that does that. I played around with "DirectShow control" in ffdshow and enabled no limitations for the application as well as setting the "merit" control to "very high," which also does nothing. I also tried to uninstall the Xonar software and just have Windows and ffdshow manage the audio, but the sound card drivers must be hardcore linked to the audio center because doing that completely removes the sound card from device manager altogether.

Does anyone have any ideas of what I could do? Is there a setting in ffdshow that I'm missing? Is there something in the Xonar DX audio center that I need to check? Frankly, I think it's ridiculous that the card's software doesn't have the option to remove or mute an individual speaker. I don't like center speakers and prefer the 4.1 setup to 5.1, especially on a desktop. Moreover, I find it completely absurd that the Xonar DX manual lists 4.1 as an option but links it with the 4.0 page, and following the limited directions printed there just results in 4.0 sound. Thanks in advance if anyone has any advice.
airscottie is offline  
Sponsored Links
Advertisement
 
post #2 of 10 Old 01-11-2013, 08:33 PM - Thread Starter
Newbie
 
airscottie's Avatar
 
Join Date: Oct 2007
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Damn. I guess I've stumped most of the early responders. Anyone have any ideas here? I'm at a dead end. I've sent a few messages to Asus support and have heard NOTHING back in return. Pretty crappy support in my opinion, I've only just purchased the thing in December. They're not doing much to try to retain me as a customer in this.
airscottie is offline  
post #3 of 10 Old 01-15-2013, 09:06 PM - Thread Starter
Newbie
 
airscottie's Avatar
 
Join Date: Oct 2007
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Bump. Hoping that there's someone out there that has an idea.
airscottie is offline  
post #4 of 10 Old 04-21-2013, 07:32 AM
AVS Special Member
 
T-Bone's Avatar
 
Join Date: May 2001
Location: Central Florida
Posts: 1,529
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 11
Quote:
Originally Posted by airscottie View Post

Bump. Hoping that there's someone out there that has an idea.

Let me take a shot although I no longer use analog audio on my HTPC.

To get FFDShow to handle all audio. I use Shark007 codec pack. I forget how I did it back then, but I think if you select the check box on the Shark app to use the shark suggested settings, that's a start. Then visit the Audio tab in Shark and ensure LAV is disabled (thus defaults the codecs to use FFDShow). Then visit the SWAP tab in Shark, and ensure FFDShow is selected for all check boxes that are related to FFDSHow. But visiting the Shark007 forums is probably a good thing to do.

Actually, as i think about it, you may not need the steps I just posted from memory. On the FFDShow mixer tab, did you try selecting the "custom matrix" check box, and then replace the "1" with a "0" in the cell that corresponds to the center channel? That cell in question is on the second row, and in the second column. Just a guess, but that may disable the center completely.

-T
airscottie likes this.
T-Bone is offline  
post #5 of 10 Old 05-04-2013, 12:53 PM - Thread Starter
Newbie
 
airscottie's Avatar
 
Join Date: Oct 2007
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by T-Bone View Post

Let me take a shot although I no longer use analog audio on my HTPC.

To get FFDShow to handle all audio. I use Shark007 codec pack. I forget how I did it back then, but I think if you select the check box on the Shark app to use the shark suggested settings, that's a start. Then visit the Audio tab in Shark and ensure LAV is disabled (thus defaults the codecs to use FFDShow). Then visit the SWAP tab in Shark, and ensure FFDShow is selected for all check boxes that are related to FFDSHow. But visiting the Shark007 forums is probably a good thing to do.

Actually, as i think about it, you may not need the steps I just posted from memory. On the FFDShow mixer tab, did you try selecting the "custom matrix" check box, and then replace the "1" with a "0" in the cell that corresponds to the center channel? That cell in question is on the second row, and in the second column. Just a guess, but that may disable the center completely.

-T

Thanks so much for posting. I just tried the second option first to see if the quick fix would work, and no dice. Checking "custom matrix" and then changing 1 to 0 on the C cell didn't change anything. I'm going to try the first suggestion now and see if that works. Stay tuned.
airscottie is offline  
post #6 of 10 Old 05-04-2013, 01:22 PM - Thread Starter
Newbie
 
airscottie's Avatar
 
Join Date: Oct 2007
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Update - nothing is working. I first installed the Shark007 win8 codec and changed the recommended settings, and then after it failed I read that the Windows 8 codec removed FFDshow. So I uninstalled that and tried the win7 codec, which didn't work either. I tried with both x86 and x64 versions, neither one worked. I went into every settings tab and changed everything I possibly could to FFDshow, still nothing worked.

I do really appreciate the help, but this is a pretty ridiculous problem. For a sound card that regularly costs over $100 to not have an option to match my speaker set up is pretty embarrassing for Asus, considering that most people don't have a center speaker on their freaking desktop PC anyway. I really don't get it. If I had realized this within the 30 day return window, this card would have been on its way back to Amazon long ago. I emailed Asus support weeks ago and haven't heard a damn thing.
airscottie is offline  
post #7 of 10 Old 05-04-2013, 02:22 PM
Advanced Member
 
MlNDBOMB's Avatar
 
Join Date: Oct 2010
Posts: 847
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Liked: 48
it's actually rare for someone to have a true 4.1 system. it is usually correct to select 4.0/2.0 for 4.1 and 2.1. The .1 is usually created by a crossover in the computer speakers themselves.

So select 4 speakers in the asus control panel's analog out. you don't even need to use ffdshow's mixer or have to mess with phantom channels. It's just that simple. Set windows up as 5.1 full range with all the channels present.
airscottie likes this.
MlNDBOMB is offline  
post #8 of 10 Old 05-04-2013, 03:54 PM - Thread Starter
Newbie
 
airscottie's Avatar
 
Join Date: Oct 2007
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by MlNDBOMB View Post

it's actually rare for someone to have a true 4.1 system. it is usually correct to select 4.0/2.0 for 4.1 and 2.1. The .1 is usually created by a crossover in the computer speakers themselves.

So select 4 speakers in the asus control panel's analog out. you don't even need to use ffdshow's mixer or have to mess with phantom channels. It's just that simple. Set windows up as 5.1 full range with all the channels present.

Wow - now I feel like a complete idiot.

While that didn't work by itself, the combination of the FFDshow 2/0/2 setting with LFE checked AND the 4 speakers in the Asus control panel worked together. Thanks so much for the help.
airscottie is offline  
post #9 of 10 Old 05-04-2013, 04:42 PM
Advanced Member
 
MlNDBOMB's Avatar
 
Join Date: Oct 2010
Posts: 847
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Liked: 48
what speakers do you have btw?
if it is just a green and black 3.5mm connector, that means it is 4.0 from the computer's perspective. (each connector carries 2 channels)
Also, you shouldn't need ffdshow, since the sound card should do the same thing- mixing input to 4.0 for output
MlNDBOMB is offline  
post #10 of 10 Old 05-06-2013, 02:22 AM
Senior Member
 
rlhowell's Avatar
 
Join Date: Apr 2007
Location: Atlanta, Ga NE
Posts: 204
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I emailed Asus Tech support about something like this 2-3yrs back and they said just move slider all the way down and the sound for center would come out of front speakers. It would work for 2.1 or 4.1 according to them.

Bob
rlhowell is offline  
Reply Home Theater Computers

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off