Random 24p stuttering problem in MPC-HC - AVS Forum
Home Theater Computers > Random 24p stuttering problem in MPC-HC
w1zzL3's Avatar w1zzL3 10:27 AM 03-05-2013
I have been troubleshooting this for months, but I haven't found the cause. Every 2-3 weeks, 24p audio and video playback on my HTPC will begin to stutter. The symptoms are dropped frames/choppy video, and audio that stutters and pops during playback in MPC-HC. However, recorded and live HDTV played back from W7MC will not stutter.

Software: W7MC => MediaBrowser => MPC-HC (MadVR + LAV)
Hardware: Shuttle MB, Intel Core2 Quad, nVidia GT430 => HDMI => receiver => HDTV

I tried the following, which have no effect: restart, uninstall/reinstall nVidia drivers (with & without full reset). uninstall/reinstall audio drivers, update/rollback nVidia drivers.

However these steps *do* fix the problem, albeit temporarily (2-3 weeks): shutdown HTPC, remove GT430, cold boot (no graphics card, no change to IGP jumper setting on MB), remote shutdown, add GT430, cold boot (fixed...for now).

Any ideas on what could be going on here? Since I can't invoke the problem, it's been pretty difficult to test.

Thanks for any help!

aliaskary77's Avatar aliaskary77 01:02 PM 03-05-2013
passive GPU? could it be heat related? dust build up?
w1zzL3's Avatar w1zzL3 01:36 PM 03-05-2013
That's correct, passive GPU. But still don't think it's heat related (and case is fairly dust-free). I used to have problems with heat, but the symptom was that it would just shut down when it got too hot. So I cut a hole in the side of the case and now there is a 120mm fan blowing directly on the GPU. It typically runs fairly cool now (for a passive CPU).

And if it were heat related, wouldn't the stuttering issue come and go with heat level? I can't explain why removing the card and putting it back fixes the problem, when reinstalling drivers (even completely removing the device in device manager) doesn't.
renethx's Avatar renethx 03:51 PM 03-05-2013
What LAV video deocder (none, cuvid, dxva2cb, dxva2n) / madVR (chroma/image upscaling algorithms) settings?
Sammy2's Avatar Sammy2 04:01 PM 03-05-2013
What versions of MPC-HC, LAV and madVR are you using?

The stutter could be content related if your settings in madVR are too high for your card so that is why it is intermittent.
w1zzL3's Avatar w1zzL3 04:56 PM 03-05-2013
It's not intermittent in that sense. The behavior is more like: It's fine for weeks, then something triggers (?) the stuttering. And then literally everything 24p stutters. I have several MKVs - some 1080p, some 720p - that I have tested, and they all run fine normally. However, once I notice something starts stuttering, the test MKVs will all then exhibit stuttering too.

I suspected the GPU could be overloaded, so a few months ago I tried running a 720p MKV in a loop for several hours to see if the upscaling to 1080p would overload it or invoke the stutter, but it never did.

Versions:

MPC-HC v.1.5.2.3456
LAV v.0.52.0
madVR ... can't find version number (probably 1 year old)

Settings:

LAV => hardware CUVID decoding.
MadVR => chroma: Mitchell-Natravali; luma upscale: spline 3-tap; luma downscale: Lanczos 3-tap; all other settings: default; auto refresh rate switching: 1080p24, 1080p23, 1080p60

Also, I just noticed that I had madVR set to software decode MPEG-2 and H.264 with ffmpeg, so LAV was probably not in use (it was at some point), but I unchecked all of those options. So now it should be back to LAV doing the decoding and madVR doing the rendering.
Sammy2's Avatar Sammy2 05:06 PM 03-05-2013
Maybe make sure that CUDA is used too..
w1zzL3's Avatar w1zzL3 05:10 PM 03-05-2013
Quote:
Originally Posted by Sammy2 View Post

Maybe make sure that CUDA is used too..

I think I have made sure, but just to double check, this is what I've done: Set LAV settings to use CUVID, Set MPC-HC to use LAV in external filters, disable any internal filters that overlap with LAV, (just now) disable decoding in madVR.

Anything else?
renethx's Avatar renethx 05:25 PM 03-05-2013
What about the source splitter filter?

I would try dxva2cb and dxva2n too.
w1zzL3's Avatar w1zzL3 05:38 PM 03-05-2013
Quote:
Originally Posted by renethx View Post

I would try dxva2cb and dxva2n too.

Are those decoders or spltters (it's been a while since I set this up)?

I just noticed something else that could be wrong. All of the MPC-HC internal source filters were selected. I unchecked all of them, added LAV Splitter to the external filter settings, and checked that. Any reason not to use LAV for splitting (I prefer less moving parts in my setup)?
renethx's Avatar renethx 05:49 PM 03-05-2013
DXVA2 (copy-back) and DXVA2 (native) are decoders, found in "Hardware Decoder to use" in LAV Video Decoder property. Basically all of cuvid, dxva2cb and dxva2n use the same hardware decoder of the graphics card, but in different ways.

I recommend LAV Source Splitter filter for many video file formats (mkv, m2ts etc.). Adding it to "External Filters" and set it to preferred is often not enough (nor necessary). Reinstall LAV Filters or use Codec Tweak Tool (> "Preferred splitters (x86)").
w1zzL3's Avatar w1zzL3 09:42 AM 03-06-2013
After making the changes I mentioned above, my display refresh rate is now running at 59.97 instead of 23.97 for 24p material. I'm going to look into this - I might Hail Mary with a reinstall of LAV per renethx's suggestion.

Once that's corrected, I'll just wait. If I don't get stuttering in the next few weeks, I'll assume it's corrected and post an update. Thanks for all the suggestions.
Sammy2's Avatar Sammy2 11:03 AM 03-06-2013
Do you have frame rate switching set up in madVR?
w1zzL3's Avatar w1zzL3 02:13 PM 03-06-2013
Yes, I do. I recently added some formats, and that appears to have been the problem. When I add "720p23, 720p24" to the list, anything 720p23 is played back at 59.97Hz. However, when I remove them, and only include 1080pXX formats, it plays the 720p content back at upscaled 1080p at 23.97Hz. I'm not sure what's going on, but that's the behavior I want, so I'll leave it. Maybe my display can't do 720p23Hz? It's a Pioneer.
renethx's Avatar renethx 03:52 PM 03-06-2013
If your display is 1080, then you'd better output 1080, leaving upsaling to madVR instead of TV (good upsaling algorithms is one of the main features of madVR). GT 430 can handle Bicubic75+AR chroma upscaling and Lanczos3+AR image upscaling.
w1zzL3's Avatar w1zzL3 03:59 PM 03-06-2013
Okay, thanks. Are those the settings you recommend? I'm currently using Mitchell-Natravali chroma upsampling and spline 3-tap for luma upsampling. I was trying to allow a slightly softer image to eliminate the possibility of introducing any scaling artifacts. I didn't do extensive A/B tests to compare though. I assume you are suggesting the GT430 would be able to handle the madVR settings and LAV decoding.
Sammy2's Avatar Sammy2 04:15 PM 03-06-2013
GT 430 can handle all but the most aggressive madVR settings..

There's a chart around here somewhere. Rene made it so he should be able to point you to it.
renethx's Avatar renethx 04:29 PM 03-06-2013
Differences between chroma upscaling algorithms are not so easily seen. M-N is a good choice for softer scaling. BC75+AR is sharper. Jinc3+AR is the best. As for image upscaling, Jinc3+AR is again the best, it is not too soft, not too sharp, very natural looking. Unfortunately GT 430 can't handle it. Spline3+AR is more or less equivalent to LZ3+AR, but slightly softer. These are the best algorithms GT 430 can handle.
w1zzL3's Avatar w1zzL3 05:36 PM 03-06-2013
Thanks for the suggestions. I am going to keep these settings/software versions for now, and see if the stuttering returns. If it doesn't (or does) I'll do a full system backup and start upgrading LAV, MPC, and madVR piecemeal, to keep track of regressions.
fschris's Avatar fschris 06:34 AM 03-07-2013
Try a new HDMI cable !!! not kidding.
w1zzL3's Avatar w1zzL3 10:00 AM 04-29-2013
After several weeks of good performance, the stuttering came back. I double checked all of the settings suggested here, and nothing has changed. (I also got a new HDMI cable, just in case)

I am thinking this must be lower level than decoder/renderer software. I've tried new/old nVidia drivers, and completely uninstalling the card from Windows. However, the only thing that works is booting the machine without the card, shutting down, and booting with it back in again. Maybe downgrade to the previous motherboard firmware? I could try different/newer versions of madVR, MPC-HC, LAV if anyone thought that might help.

Thanks again for the suggestions.
Andy_Steb's Avatar Andy_Steb 06:19 PM 04-29-2013
Starting to sound like you need a new card.
w1zzL3's Avatar w1zzL3 06:33 PM 04-29-2013
Quote:
Originally Posted by Andy_Steb View Post

Starting to sound like you need a new card.

Gah, I hope not. This one I received RMA after the previous one fried. It may not be under warranty. I'll double check...
MlNDBOMB's Avatar MlNDBOMB 07:38 PM 04-29-2013
press ctrl+j and note how full the various queues are as well as the rendering time.

that will tell you where the problem is.
w1zzL3's Avatar w1zzL3 08:53 PM 04-29-2013
Quote:
Originally Posted by MlNDBOMB View Post

press ctrl+j and note how full the various queues are as well as the rendering time.

that will tell you where the problem is.

Okay, good idea. It's working now, but when it starts up again I'll take some screenshots of the debug output and post here. I'm not sure what I should be looking for though. If you have any suggestions, please let me know. Thanks.
w1zzL3's Avatar w1zzL3 11:00 AM 04-30-2013
Also, if anyone has any suggestions on how to invoke the stuttering, please let me know.
Up
Mobile  Desktop