HTPC keeps powering itself back up - AVS Forum
Forum Jump: 
 
Thread Tools
Old 04-05-2013, 05:34 PM - Thread Starter
AVS Special Member
 
TornadoTJ's Avatar
 
Join Date: Jan 2008
Location: Dallas, TX
Posts: 3,934
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Liked: 36
Short story - ASRock H67M-ITX motherboard, Windows 7... etc.

I got rid of an old 2.5" laptop drive that was dying and was making the UI very laggy. Installed an SSD I had around. I rebuilt the box from scratch while I was at it, just seemed like the thing to do.

System worked perfectly with the platter drive. Now that SSD is in there, when I hit the power button on my Harmony, it goes to sleep then wakes back up (Windows is set for power button to go to S3 Sleep)

I cannot figure out why it sleeps then wakes back up.

Took case back apart, checked BIOS for latest version, checked all power settings in BIOS, even messed around with them to try to get it working right. Removed all apps from Windows 7. Unplugged all USB devices. Still no luck.

Guess that's what I get for saying I never have any power on/off issues. Damnit.
TornadoTJ is offline  
Sponsored Links
Advertisement
 
Old 04-05-2013, 07:10 PM
Member
 
Josea's Avatar
 
Join Date: Feb 2012
Location: Swarthmore, PA
Posts: 97
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
How long does the system remain in sleep before the wake? Also is there an applicable firmware update for the SSD? IT seems you have already checked out all the usual suspects for sleep/wake issues...
Also have you tried this http://windows.microsoft.com/en-US/windows7/Open-the-Power-troubleshooter ? It helped me fix an issue with my Asus laptop where all lights used to turn on after wake.

Josea is offline  
Old 04-05-2013, 07:32 PM
AVS Addicted Member
 
Foxbat121's Avatar
 
Join Date: Jul 2003
Location: VA
Posts: 10,052
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 250 Post(s)
Liked: 250
The Windows Event Viewer will tell you what causes your PC to wake up.
Foxbat121 is offline  
Old 04-05-2013, 11:23 PM
Member
 
mungee's Avatar
 
Join Date: Dec 2009
Location: So Cal
Posts: 139
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 13
On a Win7 box:
Run CMD with Admin Privileges
CD to Users/whateveryour_username_is

type in powercfg -energy

let it do its thing and goto to where it outputs the HTML report

and see what the "warnings" are

My bet is that you have "srvnet" is preventing sleep.
mungee is offline  
Old 04-06-2013, 03:58 AM
Newbie
 
Pacmania's Avatar
 
Join Date: Apr 2013
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 12
We have a similar issue in regards to putting the HTPC to sleep and then it wakes up after a couple of seconds.

I'm using an Asrock Z77 extreme4 and I thought that there's something wrong with my motherboard the fact that I already set the sleep mode to S5 which is recommended for W7 for this particular motherboard according to Asrock tech. I also tried to isolate the problem by removing the USB bluetooth/ IR receiver but the problem still persist. Furthermore, I was advised by Asrock tech to RMA the board which leaves me no system to record the scheduled shows and the cost to send the board back to them is a total pain.

What I did was google a similar wake up issue and found a solution. I went to the device manager and unchecked the " Allow this device to wake up the computer " under the power mangement. I've unchecked the USB bluetooth device and the unifying receiver except the IR receiver for the remote. I also unchecked my network adapters which also wakes my HTPC up.

power managment.PNG 30k .PNG file
Attached Images
File Type: png power managment.PNG (30.3 KB, 11 views)
Pacmania is offline  
Old 04-07-2013, 04:14 PM
Senior Member
 
kesawi's Avatar
 
Join Date: Jun 2006
Location: Brisbane, Australia
Posts: 330
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 28 Post(s)
Liked: 23
Try running powercfg -lastwake at the command prompt. It should tell you what caused the PC to resume from sleep.

Also make sure you've unchecked Allow this device to wake the computer under the Power Management tab of you network device properties. If you still want to have wake-on-lan then make sure Only allow a magic packet to wake the computer is checked.

Finally, try using MCE Standby Tool (slicksolutions.eu/mst.shtml) to configure your settings. I found it fixed a lot of problems for me.

kesawi is offline  
Old 04-08-2013, 08:05 AM - Thread Starter
AVS Special Member
 
TornadoTJ's Avatar
 
Join Date: Jan 2008
Location: Dallas, TX
Posts: 3,934
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Liked: 36
MCE Standby Tool has been a savior on many of my machines. I did uninstall it just to make sure it wasn't the issue. The machine turns on immediately after powering down. The SSD is up to date on firmware. I will try all these items right now and let you know the results. Thank you so much for your assistance, this is a strange problem.
TornadoTJ is offline  
Old 04-08-2013, 08:22 AM - Thread Starter
AVS Special Member
 
TornadoTJ's Avatar
 
Join Date: Jan 2008
Location: Dallas, TX
Posts: 3,934
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Liked: 36
Thanks everyone, knowing powercfg -lastwake helped me find the culprit, and sure enough it was the wake on LAN on the NIC. I've learned something new, so it's the start of a good day.

Now I just have to get this 3TB drive working in this new machine... smile.gif
TornadoTJ is offline  
 
Thread Tools


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off