Confused - Yamaha receiver shows PCM when playing Dolby Digital Plus / TrueHD - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 10 Old 04-29-2013, 08:51 PM - Thread Starter
Advanced Member
 
andyd2k's Avatar
 
Join Date: Jun 2005
Posts: 568
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 14
Regardless of whether I use MPC-HD or TMT 5 / 6, my receiver will show PCM as the audio output. If I play Dolby Digital or DTS movies, those are shown correctly. I thought if I have bitstreaming capable hardware that it would show up as TrueHD when playing a movie with TrueHD. Or wrong to think that? My main parts...

AMD 7850 connected to a Yamaha RX-V673 via HDMI

Sound properties in Windows is below.





properties.jpg 49k .jpg file
Attached Images
File Type: jpg properties.jpg (48.8 KB, 24 views)
andyd2k is online now  
Sponsored Links
Advertisement
 
post #2 of 10 Old 04-29-2013, 10:22 PM
AVS Special Member
 
vladd's Avatar
 
Join Date: Jun 2006
Location: Louisville, KY
Posts: 5,469
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 36
You need to use an audio decoder that is capable of bitstreaming HD audio and make sure that it is configured to do so. LAV decoders are the most common choice for MPC-HC. TMT 5/6 should to be configured within the application.
vladd is offline  
post #3 of 10 Old 04-29-2013, 10:32 PM - Thread Starter
Advanced Member
 
andyd2k's Avatar
 
Join Date: Jun 2005
Posts: 568
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 14
I'll check on MPC-HC but I see no options in TMT 5 or 6 that would help with bitstreaming. The options are very limited actually.
andyd2k is online now  
post #4 of 10 Old 04-29-2013, 10:59 PM - Thread Starter
Advanced Member
 
andyd2k's Avatar
 
Join Date: Jun 2005
Posts: 568
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 14
I followed the guide here...

http://www.mediasmartserver.net/2011/06/30/guide-setting-up-lav-filters-mpc-hc-for-all-your-splitter-and-audio-needs/

To set up MPC-HC with LAV decoders - still getting PCM
andyd2k is online now  
post #5 of 10 Old 04-30-2013, 09:48 AM
AVS Special Member
 
vladd's Avatar
 
Join Date: Jun 2006
Location: Louisville, KY
Posts: 5,469
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 36
Quote:
Originally Posted by andyd2k View Post

I'll check on MPC-HC but I see no options in TMT 5 or 6 that would help with bitstreaming. The options are very limited actually.
You need to select "Use original format" on the audio output or something like that. It's been a long time since I used TMT.
Quote:
Originally Posted by andyd2k View Post

I followed the guide here...

http://www.mediasmartserver.net/2011/06/30/guide-setting-up-lav-filters-mpc-hc-for-all-your-splitter-and-audio-needs/

To set up MPC-HC with LAV decoders - still getting PCM
Make sure that your receiver is not set to pass HDMI audio to the TV.
vladd is offline  
post #6 of 10 Old 04-30-2013, 10:39 AM
Advanced Member
 
MlNDBOMB's Avatar
 
Join Date: Oct 2010
Posts: 848
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Liked: 49
see what filters are in use while your playing the video with truehd.
(right click in the window>filters)
MlNDBOMB is offline  
post #7 of 10 Old 04-30-2013, 03:33 PM
Member
 
haubrija's Avatar
 
Join Date: Jan 2004
Location: Culver City, CA
Posts: 189
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 11
Recently, my install of LAV was turning on the downmixing options present on the second tab of the LAV audio decoder upon re install. It took me awhile to figure out what was wrong as I normally would just adjust the options on the main tab of the audio decoder properties. Make sure that downmixing is not enabled.
haubrija is offline  
post #8 of 10 Old 04-30-2013, 10:53 PM - Thread Starter
Advanced Member
 
andyd2k's Avatar
 
Join Date: Jun 2005
Posts: 568
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 14
vladd - You're right that there was a drop down box that allowed me to switch from mix pcm to original audio. DTS is now bitstreaming in TMT but not True HD. That keeps showing up as PCM

The HDMI audio to TV is off

Mindbomb - I'll give that a look in the morning. Both formats show up as PCM while playing in MPC

Haubrija - Not sure what option you're referring to I don't see it


As it is right now, the only player that actually works properly is Windows Media Player with Shark007 codecs. I used his suggested settings and this is the first time that I see my receiver actually bitstream TrueHD and Dolby Digital Plus. I checked the information window in my recevier.

I was already thinking that I would have to get my receiver replaced but I now see that it's not the receiver but software. I don't understand why TMT is not working properly. As for MPC, I need to check the settings.
andyd2k is online now  
post #9 of 10 Old 05-01-2013, 06:50 AM - Thread Starter
Advanced Member
 
andyd2k's Avatar
 
Join Date: Jun 2005
Posts: 568
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 14
Looks like there is a bug in XBMC that won't allow bitstreaming of DD+ files. Everything else seems to be working now. I don't have MPC set up for bitstreaming but the end game was to get XBMC to work properly and I wanted to make sure that my receiver was also working properly.

I still have to figure out why TMT is not bitstreaming some formats but I'll have talk to their support about that

Thanks for all the help guys
andyd2k is online now  
post #10 of 10 Old 05-01-2013, 11:24 AM
Member
 
haubrija's Avatar
 
Join Date: Jan 2004
Location: Culver City, CA
Posts: 189
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 11


The mixing option in LAV is found in the setting in the attached picture. If it is enabled, LAV will downmix everything to stereo and you will not get bitstreaming. Double check that it is not enabled.

As for DD+ sources, LAV is the only decoder I've ever found that can properly bitstream it. TMT does not, nor any other third party software.
haubrija is offline  
Reply Home Theater Computers



Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off