Not getting 5.1 Output from Quicktime Files - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 4 Old 07-04-2013, 07:59 AM - Thread Starter
Newbie
 
cw4u's Avatar
 
Join Date: Jul 2011
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 10
I'm having trouble getting 5.1 output from my quicktime files. All .mov files I play are outputting as PCM 2.0. Any other format outputs correctly. I'm using a Mac Mini with optical audio output into my receiver. I'm running Windows 7 64 bit with Shark007 installed.

Any help would be appreciated.
cw4u is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 07-04-2013, 08:17 AM
AVS Special Member
 
Shark007's Avatar
 
Join Date: Apr 2007
Location: BC, Canada
Posts: 1,066
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)
Liked: 46
few MOV files have 5.1 audio but those that do usually use AAC.
To get control over them, disable the Microsoft Audio decoder on the SWAP TAB.
This should give you multi-channel pcm to the receiver.

To know the actual contents of any video (speaker count etc), use the button on the Misc TAB to [Analyze a media file]

Use Shark007 Codecs and retain your sanity.
Shark007 is offline  
post #3 of 4 Old 07-04-2013, 08:53 AM - Thread Starter
Newbie
 
cw4u's Avatar
 
Join Date: Jul 2011
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 10
I've got LAV Audio now showing that it's inputting 5.1 AAC and outputing 5.1 PCM. However, my receiver is still showing that it's receiving 2.0 PCM.

Any other suggestions?
cw4u is offline  
post #4 of 4 Old 07-04-2013, 09:02 AM
AVS Special Member
 
Shark007's Avatar
 
Join Date: Apr 2007
Location: BC, Canada
Posts: 1,066
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)
Liked: 46
Quote:
Originally Posted by cw4u View Post

I've got LAV Audio now showing that it's inputting 5.1 AAC and outputing 5.1 PCM. However, my receiver is still showing that it's receiving 2.0 PCM.

Any other suggestions?

Sorry, I overlooked the fact that you are using optical to carry the audio to the receiver.
Optical cannot carry 5.1 pcm, only 2.0

Although I rarely recommend it, you'd need to use ffdshow to decode the audio and use it to re-encode to AC3 on the fly.
To do this, on the Audio TAB, use the button to [disable LAV audio]
Then, on the Config TAB, use the button to access [FFDshow Audio config]
Scroll the leftside and click on Output then check the box for [x] AC3 (SPDIF encode mode)
and also check the box for [x] Encode 5.1 streams only

Use Shark007 Codecs and retain your sanity.
Shark007 is offline  
Reply Home Theater Computers

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off