HELP- built new HTPC - No SOUND (but usin as server for MB3 & JRiver and streaming to Oppo 93 - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 14 Old 11-19-2013, 12:38 PM - Thread Starter
Senior Member
 
Hoots's Avatar
 
Join Date: Oct 2002
Location: DFW
Posts: 405
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 13
I built a nice i7 win8.1 HTPC but connecting HDMI to TV or Oppo as pre/amp I can't get any sound. I can push videos & music to my Oppo 103 w/Jriver and play movies/music just fine with great sound. When I use oppo w/Roku stick I get only 2ch pullin from MB3 Server on new PC despite selecting 5.1.


Here is my status:

No video or sound card....just ASUS Z87 Pro motherboard with onboard devices

ASUS aduio controller enabled in BIOS w/SPDIF HDMI selected

Realtek audio driver downloaed from ASUS DVD

ASUS Realtek HD Audio Manaer screen shows "Digital"l and HDMI port

Right click on RealTek HD Audio Manaer in system tray shows:
* RealTeck HDMI Output (Default)
* under Supported Formats I only see 2 CH and can't change. I also see 44.1, 48, 96, 192 but can't change
* no encoded formats. When I go to advanced to change to DTS it says not supported by device but I can check the "allow DTS" box and reboot and select DTS but that doesn't help. Supported Formats are still 2CH
* none of the test tones make sound
* Properties says HDMI output


Help? I'm out of ideas.
Hoots is offline  
Sponsored Links
Advertisement
 
post #2 of 14 Old 11-19-2013, 03:54 PM
AVS Special Member
 
Andy_Steb's Avatar
 
Join Date: Jan 2005
Location: New Orleans
Posts: 1,017
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 20 Post(s)
Liked: 152
Uninstall the Realtek stuff. Then install Intel video drivers and Intel chipset drivers.

https://downloadcenter.intel.com/default.aspx

Andy_Steb is offline  
post #3 of 14 Old 11-19-2013, 07:37 PM - Thread Starter
Senior Member
 
Hoots's Avatar
 
Join Date: Oct 2002
Location: DFW
Posts: 405
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 13
Here is my current situation:

uninstalled RealTek Audio Driver.
Intel Graphics 4600 is display adapter
Installed Intel Chipset Driver from ASUS DVD
HD Audio Device shown under Sound in Control Panel
Playback device in tray is HDMI output
When I plug headphones into the PC jacks they play and it switches device from HDMI to headphones

BIOS has enabled HD Audio Controller set to HDMI audio output

NO sound from HDMI
Hoots is offline  
post #4 of 14 Old 11-23-2013, 03:02 PM - Thread Starter
Senior Member
 
Hoots's Avatar
 
Join Date: Oct 2002
Location: DFW
Posts: 405
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 13
I added a Radeon card and can get Stereo sound only (movies and music). No sound from Motherboard. I spent a few hours at MicroCenter and they escalated to back office tech who couldn't get it to work. Swapped motherboard...no help.

windows 8.1....

Any suggestions?

Mircocenter suggested doing a complete new build returning the motherboard for another brand, reloading the OS, etc. $140 which actually would be worth it as I've spent a lot of time & money on this and don't have much to show.
Hoots is offline  
post #5 of 14 Old 11-23-2013, 03:06 PM
AVS Addicted Member
 
Mfusick's Avatar
 
Join Date: Aug 2002
Location: Western MA
Posts: 22,833
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 165 Post(s)
Liked: 827
sounds like a codec issue.. What software are you using to bitstream HD audio over HDMI ?

-

"Too much is almost enough. Anything in life worth doing is worth overdoing. Moderation is for cowards."
Mfusick is offline  
post #6 of 14 Old 11-23-2013, 03:43 PM - Thread Starter
Senior Member
 
Hoots's Avatar
 
Join Date: Oct 2002
Location: DFW
Posts: 405
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 13
I have tried MPC-HC
I am wanting to use JRiver and am trying that too but use MPC-HC as a simpler test.

I am trying to watch a DVD and BD rip in surround sound. I get 2ch. My driver says max ch 2.


Supported formats are listed but I can't check any boxes. Max CH -2. It seems to think my device is 2 channel only.
Hoots is offline  
post #7 of 14 Old 11-23-2013, 04:15 PM
AVS Special Member
 
Andy_Steb's Avatar
 
Join Date: Jan 2005
Location: New Orleans
Posts: 1,017
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 20 Post(s)
Liked: 152
I'm not understanding how you expect to get 5.1 sound through your tv.

You need to tell us exactly how you have everything hooked up. Why are you hooking the PC up to the Oppo?

Andy_Steb is offline  
post #8 of 14 Old 11-23-2013, 06:03 PM - Thread Starter
Senior Member
 
Hoots's Avatar
 
Join Date: Oct 2002
Location: DFW
Posts: 405
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 13
I have a new HTPC w/JRiver and media files like BD movies, BD Music, DVD-A, DTS Audio, DVD Movies, DVD Music, etc.

I have a HT system but no HDMI pre/pro other than the Oppo103 is my pre-pro (for now). I was thinking of buying the future Emotiva XMC-1 pre/pro for HDMI and room correction plus USB DAC

I currently have:

Oppo 103
Verizon FIOS TV HD Tuner w/DVR
Emotiva DMC-1 pre/pro w/component, optical, coax, 8-ch
Emoitiva MPS-1 7-CH amp
2 Seaton Sound MFW-15 SUBs
7 Onix Ref Ninja modified speakers (4 full range towers, center, 2 bookshelves)
Panasonic ZT60 65" Plasma

I can play everything disc at a time on my Oppo but I like my JRiver setup for ease of use.

My HTPC has a ASUS Z87-Pro motherboard with HDMI out
Haswell i7 4770k processor
16 GB Ballistic RAM
NO VIDEO card until I just added the low end ASUS Radeon 5450 as a test to replace motherboard HDMI out. If there was a benefit in a $200 video card I would buy it (note I don't play video games).

My Realtek HDMI driver say max channels 2 and I only hear stereo. With the motherboard I couldn't hear anything unless I used my USB Focal PC Speakers instead of HDMI. ASUS tech support had me swap motherboards but that didn't help.

I can use JRiver and send DLNA to Oppo and get surround sound movies.
Hoots is offline  
post #9 of 14 Old 11-23-2013, 06:38 PM - Thread Starter
Senior Member
 
Hoots's Avatar
 
Join Date: Oct 2002
Location: DFW
Posts: 405
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 13
I added the HD 5450 Radeon card and downloaded the Catalyst driver package from AMD site (vs. the VGA driver provided on the DVD) and now I get 8 CH max vs. 2 CH. I can now get surround sound.

Yeah! I'm not sure why I couldn't get the motherboard HDMI out to work but now that isnt' an issue.

Is there any reason to get a better VIDEO card for BD Video watching? not that I want to take a chance on another problem smile.gif
Hoots is offline  
post #10 of 14 Old 11-24-2013, 12:18 AM
Advanced Member
 
jbcain's Avatar
 
Join Date: Jul 2010
Posts: 868
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 63
Did you ever go into playback devices in windows and do the configure speakers tab?
jbcain is offline  
post #11 of 14 Old 11-24-2013, 07:26 AM
AVS Addicted Member
 
Mfusick's Avatar
 
Join Date: Aug 2002
Location: Western MA
Posts: 22,833
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 165 Post(s)
Liked: 827
Quote:
Originally Posted by jbcain View Post

Did you ever go into playback devices in windows and do the configure speakers tab?

Lol. I thought the same thing.

-

"Too much is almost enough. Anything in life worth doing is worth overdoing. Moderation is for cowards."
Mfusick is offline  
post #12 of 14 Old 11-24-2013, 07:28 AM
AVS Addicted Member
 
Mfusick's Avatar
 
Join Date: Aug 2002
Location: Western MA
Posts: 22,833
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 165 Post(s)
Liked: 827
Quote:
Originally Posted by Hoots View Post

I added the HD 5450 Radeon card and downloaded the Catalyst driver package from AMD site (vs. the VGA driver provided on the DVD) and now I get 8 CH max vs. 2 CH. I can now get surround sound.

Yeah! I'm not sure why I couldn't get the motherboard HDMI out to work but now that isnt' an issue.

Is there any reason to get a better VIDEO card for BD Video watching? not that I want to take a chance on another problem smile.gif

Jriver has an advanced video rendering option called "red october"

This is basically MadVR integrated into the Jriver software you are using. Both MadVR and Jriver will benefit from a better video card. You would be able to utilize better processing and PQ. A Radeon 7790 would be a good choice without spending too much. Some of the 7870's have been showing up on sale cheap too.

-

"Too much is almost enough. Anything in life worth doing is worth overdoing. Moderation is for cowards."
Mfusick is offline  
post #13 of 14 Old 11-24-2013, 09:07 AM - Thread Starter
Senior Member
 
Hoots's Avatar
 
Join Date: Oct 2002
Location: DFW
Posts: 405
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 13
Is there a difference in sound between the low-end 5450 and say the 7870? My AMD HDMI driver is only showing supported formats of DTS etc and 96Hz vs. DTSHD and 192Hz. My JRIVER won't let me play BD MKV rips BITMAPPED and won't play my 192kHz music w/o downsampling to 96Hz.
Hoots is offline  
post #14 of 14 Old 11-24-2013, 10:10 AM
AVS Addicted Member
 
Mfusick's Avatar
 
Join Date: Aug 2002
Location: Western MA
Posts: 22,833
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 165 Post(s)
Liked: 827
Quote:
Originally Posted by Hoots View Post

Is there a difference in sound between the low-end 5450 and say the 7870? My AMD HDMI driver is only showing supported formats of DTS etc and 96Hz vs. DTSHD and 192Hz. My JRIVER won't let me play BD MKV rips BITMAPPED and won't play my 192kHz music w/o downsampling to 96Hz.

No there is a difference in PQ but not sound.

-

"Too much is almost enough. Anything in life worth doing is worth overdoing. Moderation is for cowards."
Mfusick is offline  
Reply Home Theater Computers

Tags
Oppo Bdp 93 Blu Ray Player , Oppo Bdp 103 3d Blu Ray Player

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off