FlexRaid (tRAID) issue - advice needed - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 7 Old 09-02-2014, 10:06 AM - Thread Starter
Advanced Member
 
ElJimador's Avatar
 
Join Date: Mar 2011
Posts: 532
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 37 Post(s)
Liked: 86
FlexRaid (tRAID) issue - advice needed

Hi there. I finally got FlexRaid up and running on my new Win8 all-in-one desktop/server/htpc but I noticed that if I try to watch something off the array at the same time I'm writing to it, XBMC playback becomes glitchy and has to pause periodically to rebuffer.

It's never been an issue for me to play a movie off my unRAID server at the same time I'm writing to it and that machine has a super low end C-60 processor vs. a Xeon E3-1230 v3 in the Win8 machine. Has anyone else here using FlexRaid run across the same issue? Any advice on settings to tweak, etc? I'm in the 21 day trial and want to get this sorted before I actually pay for the software. Thanks.
ElJimador is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 09-02-2014, 12:21 PM
Senior Member
 
signcarver's Avatar
 
Join Date: May 2007
Location: Phoenix, AZ
Posts: 324
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Liked: 16
This sounds similar to the problem that flexraid has with WMC in that it does not allow simultaneous reads/writes... I believe with WMC the buffer had to be moved to another drive but usually it was best/easiest to record to a non-flexraid drive and then just move the files on a nightly basis. I don't know all the details as I don't use it since I am stuck with WMC and DRM (sure I could use it elsewhere for the library but find no reason to) but my understanding it would lock the sectors being written to and had to complete the write and possibly verify before it would allow it to be read... I didn't think it affected reading other files at the same time but that was probably my interpretation of the problem.
signcarver is offline  
post #3 of 7 Old 09-02-2014, 01:28 PM - Thread Starter
Advanced Member
 
ElJimador's Avatar
 
Join Date: Mar 2011
Posts: 532
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 37 Post(s)
Liked: 86
Thanks signcarver. Can anyone else confirm that this is just a limitation of FlexRaid (tRAID version at least) that you can't write to and read from the array at the same time without this kind of performance issue? I've got a 500GB SSD already installed as a scratch drive which I could use as a landing disk and schedule the writes to run automatically at night. Just doesn't seem to me that this should really be a limitation of the software if it isn't in unRAID. Maybe I should think about the fRAID version instead, or SnapRAID or some other parity solution for Windows? Anyone know if there's the same problem w/those?
ElJimador is offline  
post #4 of 7 Old 09-02-2014, 02:14 PM
Advanced Member
 
spectrumbx's Avatar
 
Join Date: Jun 2007
Posts: 818
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 28 Post(s)
Liked: 37
No such limitation. It would be a silly limitation in fact.
You will do best posting your configuration settings and try to resolve whatever performance issue there might be.

Also, not recording directly to the pool pertains to an old bug affecting the Storage Pooling in RAID-F, which affected some users.
I think most resolved the issue by setting the disk to fixed with a file system of NTFS. Even then, it was still recommended to record to a disk outside of the pool because of the Snapshot RAID aspect.

If you have any issue recording directly to the pool with tRAID or multi-tasking, that would be bug/issue to report as those are not expected behaviors.
So detail your configuration and if you have any useful info from Resource Monitor, provide those too.
spectrumbx is offline  
post #5 of 7 Old 09-02-2014, 03:21 PM
Senior Member
 
smitbret's Avatar
 
Join Date: Nov 2005
Location: East Idaho - Pocatello
Posts: 268
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 71 Post(s)
Liked: 32
I can't speak for tRAID, but I don't have this problem with RAID-F or at least I haven't run into it in 18 months of use.
smitbret is online now  
post #6 of 7 Old 09-02-2014, 06:00 PM
AVS Addicted Member
 
assassin's Avatar
 
Join Date: Jul 2004
Posts: 12,961
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 50 Post(s)
Liked: 241
assassin is offline  
post #7 of 7 Old 09-02-2014, 09:53 PM - Thread Starter
Advanced Member
 
ElJimador's Avatar
 
Join Date: Mar 2011
Posts: 532
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 37 Post(s)
Liked: 86
Quote:
Originally Posted by spectrumbx View Post
No such limitation. It would be a silly limitation in fact.
You will do best posting your configuration settings and try to resolve whatever performance issue there might be.

...

If you have any issue recording directly to the pool with tRAID or multi-tasking, that would be bug/issue to report as those are not expected behaviors.
So detail your configuration and if you have any useful info from Resource Monitor, provide those too.
Thanks. Good to know it's not a limitation of the software itself (which didn't make sense to me either). I'll review my settings when I have time to take a deeper dive and see if I can figure out where the problem is.
ElJimador is offline  
Reply Home Theater Computers

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off