Turning receiver on turns monitor off when connected via HDMI - AVS Forum | Home Theater Discussions And Reviews
Baselworld is only a few weeks away. Getting the latest news is easy, Click Here for info on how to join the Watchuseek.com newsletter list. Follow our team for updates featuring event coverage, new product unveilings, watch industry news & more!


Forum Jump: 
 
Thread Tools
Old 04-11-2015, 02:06 PM - Thread Starter
Newbie
 
GeoffAk's Avatar
 
Join Date: Oct 2009
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 10
Question Turning receiver on turns monitor off when connected via HDMI

Hi all. I have a HTPC problem that's been driving me nuts for the better part of a year.

When my computer is connected via HDMI to my receiver, turning the receiver ON turns off my monitor. It says "Entering Power Save Mode." Nothing I can do will get it to "wake up" or display video. I can get video through my projector. But it's impossible for me to get my monitor to stay on, while the receiver is on.

If I keep the receiver/projector on, then switch my display settings to "PC monitor only," my monitor will intermittently turn on and off. If I turn the projector off, but keep the receiver on, the monitor will turn off.

Is this an Nvidia problem? Is it an Onkyo problem? I've tried switching my monitor cable from DVI to DisplayPort. That didn't help either.

Here are my specs:
Windows 8.1 x64
Dell U2412M monitor
Onkyo SR-508 receiver
Nvidia GTX 660 video card

I've attached a quick diagram of what my setup looks like.

Update: It was a driver issue. Downgrading to the 306 driver fixed it.
Attached Thumbnails
Click image for larger version

Name:	htpc.png
Views:	21
Size:	8.0 KB
ID:	660962  

Last edited by GeoffAk; 04-19-2015 at 03:52 AM.
GeoffAk is offline  
Sponsored Links
Advertisement
 
Old 04-11-2015, 02:17 PM
Senior Member
 
Shadowed's Avatar
 
Join Date: Mar 2014
Location: Central British Columbia
Posts: 273
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 105 Post(s)
Liked: 67
My AMD graphics card and Denon combo dont have that issue.
Have you tried the latest nVidea driver ?


(I use hdmi and dvi connections)
Shadowed is offline  
Old 04-11-2015, 02:23 PM
AVS Addicted Member
 
Foxbat121's Avatar
 
Join Date: Jul 2003
Location: VA
Posts: 10,510
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 481 Post(s)
Liked: 308
You need setup you dual screen settings. Sounds like you currently is set to single screen only mode.
Foxbat121 is online now  
Old 04-13-2015, 06:02 PM - Thread Starter
Newbie
 
GeoffAk's Avatar
 
Join Date: Oct 2009
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 10
Thanks for the responses.

Quote:
Originally Posted by Shadowed View Post
My AMD graphics card and Denon combo dont have that issue.
Have you tried the latest nVidea driver ?


(I use hdmi and dvi connections)
Yes, I am using the latest 347.88 driver.


Quote:
Originally Posted by Foxbat121 View Post
You need setup you dual screen settings. Sounds like you currently is set to single screen only mode.
Where do I change this? I tried using the "PC screen only" setting in Windows 8. I also tried the same thing in the NVIDIA control panel, on the "Set up multiple displays" page.
GeoffAk is offline  
Old 04-13-2015, 06:21 PM
AVS Addicted Member
 
Foxbat121's Avatar
 
Join Date: Jul 2003
Location: VA
Posts: 10,510
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 481 Post(s)
Liked: 308
Quote:
Originally Posted by GeoffAk View Post

Where do I change this? I tried using the "PC screen only" setting in Windows 8. I also tried the same thing in the NVIDIA control panel, on the "Set up multiple displays" page.

There are a few ways to do it. Easiest in Win8 is using the home screen charm bar (right side)->Devices->Project, choose Duplicate or extend in order to use both screens at the same time. Choose other two options means you only want use one screen at any time which is what you have today,


Make sure both are powered on before you can make the changes.
Foxbat121 is online now  
Old 04-14-2015, 05:53 PM - Thread Starter
Newbie
 
GeoffAk's Avatar
 
Join Date: Oct 2009
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 10
Quote:
Originally Posted by Foxbat121 View Post
There are a few ways to do it. Easiest in Win8 is using the home screen charm bar (right side)->Devices->Project, choose Duplicate or extend in order to use both screens at the same time. Choose other two options means you only want use one screen at any time which is what you have today,


Make sure both are powered on before you can make the changes.
Turning off (or disconnecting) the projector while the screen is duplicated or extended results in my monitor being turned off, just as it does in single screen mode.
GeoffAk is offline  
Old 04-14-2015, 06:26 PM
AVS Addicted Member
 
Foxbat121's Avatar
 
Join Date: Jul 2003
Location: VA
Posts: 10,510
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 481 Post(s)
Liked: 308
That probably has a lot to do with NVidia driver settings, e.g. which output considers to be primary and which to be second screen. But your original problem should already been resolved, e.g. you need duplicate or extended mode for both screen to show.


There are also hot keys you can use to cycle through different screen modes. I don't remember the details.
Foxbat121 is online now  
Old 04-15-2015, 06:21 PM - Thread Starter
Newbie
 
GeoffAk's Avatar
 
Join Date: Oct 2009
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 10
Quote:
Originally Posted by Foxbat121 View Post
That probably has a lot to do with NVidia driver settings, e.g. which output considers to be primary and which to be second screen. But your original problem should already been resolved, e.g. you need duplicate or extended mode for both screen to show.


There are also hot keys you can use to cycle through different screen modes. I don't remember the details.
Nvidia considers my monitor to be the primary screen. Yes, I can use my monitor when the screens are duplicated, and the projector is on. However, turning off the projector leads to the original problem. Leaving my projector on 24/7 is not something I want to do.

I'm in contact with Nvidia support, as this seems to be a driver bug.
GeoffAk is offline  
Old 04-15-2015, 06:30 PM
AVS Addicted Member
 
Foxbat121's Avatar
 
Join Date: Jul 2003
Location: VA
Posts: 10,510
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 481 Post(s)
Liked: 308
What I see here is that your HDMI connection was considered as primary screen by the driver. Your PC monitor as secondary. When you turn off the projector. It is like turning off the primary.


What you can try is going to desktop mode and open NVidia control panel. Assign your PC monitor as primary and HDMI/pj as secondary. That hopefully solves your problem.
Foxbat121 is online now  
Old 04-16-2015, 11:38 AM - Thread Starter
Newbie
 
GeoffAk's Avatar
 
Join Date: Oct 2009
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 10
Quote:
Originally Posted by Foxbat121 View Post
What I see here is that your HDMI connection was considered as primary screen by the driver. Your PC monitor as secondary. When you turn off the projector. It is like turning off the primary.


What you can try is going to desktop mode and open NVidia control panel. Assign your PC monitor as primary and HDMI/pj as secondary. That hopefully solves your problem.
The monitor has always been my primary in the Nvidia control panel.

Update: It was a driver issue. Downgrading to the 306 driver fixed it.

Last edited by GeoffAk; 04-19-2015 at 03:52 AM.
GeoffAk is offline  
 
Thread Tools


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off