Cliff Watson EPG add-on for MyHD, FusionHDTV, and HD Homerun - Page 22 - AVS Forum
Forum Jump: 
 1Likes
Reply
 
Thread Tools
post #631 of 4145 Old 09-11-2006, 10:28 PM
Senior Member
 
lonndoggie's Avatar
 
Join Date: Feb 2002
Location: Encinitas, CA
Posts: 280
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by sengsational View Post

Yeah, I think I know what you mean, but I don't use that feature, so am not 100% about what the FAV entries are. I think I have it turned off in MyHD. That would be where, when you record a file, the file name goes into MyHD-land somewhere, like the registry maybe?

Yeah, that's it.

And Tim, to clear up your confusion, yes it's the playlist list, but to get there via the remote, you hit the FAV button whilst in file play mode, and up they pop (thus my confusing use of FAV == playlist).

Turn it off, eh? Man, if I can do that, I'm set. I don't use the playlist either, so not having it would suit me fine. Oh! I guess that's what that "add captured file to the playlist checkbox is" Duh! Now unchecked.

Oh, and I do record to one big ol' file per program...up to 10GB, anyway--. Hmmm...there are a few PBS programs that have spanned multiple files, I'll have to be on the lookout for one of those, and see if it gets the job done.

"Remove This Row" doesn't delete the file or take it out of CW_EPG's database...does that mean it comes back next time you refresh, or does it remember to leave it out?

Lonnie
lonndoggie is offline  
Sponsored Links
Advertisement
 
post #632 of 4145 Old 09-11-2006, 10:48 PM
Senior Member
 
lonndoggie's Avatar
 
Join Date: Feb 2002
Location: Encinitas, CA
Posts: 280
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
EDIT: Tabs don't preserve, so the dump from MyShows below would be pretty hard to parse. Let me know if I can do an attachment, or maybe send attached to a regular email.

--------------------

I've got three files that don't show any program information from CW_EPG, just what can be derived from the file name. One is OK because I deleted the info from CW_EPG's history, as previously described. The other two seems like they ought to work.

Here's a cut'n'paste of what I can see for one of these files from the CW_EPG history listing (I hope tabs are preserved):

9/11/2006 7:00:00PM EP0007460105 California's Gold See's Candy

And here's the row for that file when I export from MyShows (note all the leading blank columns:

0 99 99 1 0 2006 9 11 2 0 0 19 1 19 30 0 8 0 KOCE-SD-0911-1901-California's Gold.tp

Can't see anything obvious why this failed to find the data in the lookup.

Lonnie
lonndoggie is offline  
post #633 of 4145 Old 09-11-2006, 10:59 PM
AVS Special Member
 
hdtvincr's Avatar
 
Join Date: Nov 2003
Location: Cedar Rapids, IA
Posts: 1,863
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by lonndoggie View Post

And Tim, to clear up your confusion, yes it's the playlist list, but to get there via the remote, you hit the FAV button whilst in file play mode, and up they pop (thus my confusing use of FAV == playlist).

Thanks... I don't use that playlist stuff either. I'm used to looking at the channels marked as Favorites in MyHD for CW_EPG, so that's what I had on my brain....

Dale - I guess you can disregard that email I sent!
hdtvincr is offline  
post #634 of 4145 Old 09-12-2006, 01:07 AM
AVS Special Member
 
miimura's Avatar
 
Join Date: Apr 2002
Location: Cupertino, CA
Posts: 1,345
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Vanished recorded at the wrong time tonight on KTVU. However, it looks the guide data was bad. Here's relevant part of the log.
Code:
CW_EPG AUTOMATIC MODE STARTED AT : 9/11/2006 3:30:01 PM
*************************************************************
\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\
       2day.xtvd Data Downloaded on 9/11/2006 3:30:03 PM
       Timeframe : 2006-09-11T22:32:00Z  -  2006-09-14T07:00:00Z
**********   ZAP2IT SERVER MESSAGE   **********
       Your subscription will expire: 2006-10-11T04:55:14Z


       Old Schedule Entries Deleted.........
       Converting 2day.xtvd Data To Schedule Database on 9/11/2006 3:30:06 PM
\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\
       10day.xtvd Data Downloaded on 9/11/2006 3:30:18 PM
       Timeframe : 2006-09-24T07:00:00Z  -  2006-09-25T07:00:00Z

       Converting 10day.xtvd Data To Schedule Database on 9/11/2006 3:30:18 PM
*************************************************************
       Writing EPG to MyHD on : 9/11/2006 3:30:28 PM
*************************************************************
       Deleting Previous Channel Records.....
       Writing New Channel Records.....
       Deleting Outdated EPG Records.....
       Writing New EPG Records.....
       11555 EPG Records Written.....

*************************************************************
CW_EPG capture output generated : 9/11/2006 3:30:48 PM
!!!!!!!!!!!!!!!!   AUTOMATIC MODE   !!!!!!!!!!!!!!!!
=============================================================
CAPTURE ATTEMPT :   Vanished - Before the Flood   ** NEW  **
AIRS :   KTVUDT  -  09/11/06 21:17-22:19    Episode #: EP8464710004
SUCCESS : KTVUDT (D56)2.1  Ant: 1  Tuner: AIR
Scheduled Time: 09/11/06 21:17 - 09/11/06 22:19
I opened the cw_sched.mdb file in Access and found the corresponding entry. It matches what the log says, less the 1 minute padding I have set on both ends as default. Does anyone know if there was a good reason for the data to be like this? Perhaps an east coast adjustment for a live event like maybe Dubyuh speaking?

Thanks for any insight. Love the program and can't wait for the new version.

- Mike
miimura is offline  
post #635 of 4145 Old 09-12-2006, 07:13 AM
AVS Special Member
 
rdwalt's Avatar
 
Join Date: Jul 2003
Location: Kennesaw, GA
Posts: 1,086
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Quote:
Originally Posted by TPeterson View Post

Walt, from all of your descriptions I'm pretty sure that you're not looking at CW_EPG's OSD data. You're seeing the PSIP data from the broadcasters.

You can confirm (or disprove) this by looking ahead a couple of days in the table. If you see data for next week, it's CW_EPG's. If you see "No Information", you haven't succeeded in setting up CW_EPG correctly. (Most likely, I guess, because you're not using the MyHD.exe that was in the CW_EPG bundle--in the next release, we're going to make sure to have a diagnostic for that--but it could have to do with MyHD's sometimes not being able to access the cw_epg.mdb file for whatever reason)

I'll have to check the table tonight but I know I'm definitely using the MyHD.exe from the CW_EPG bundle.

Wouldn't I have to look ahead more than a couple of days to see data for next week?

"If you never did, you should. These things are fun and fun is good."- Dr. Seuss
rdwalt is offline  
post #636 of 4145 Old 09-12-2006, 07:20 AM
AVS Special Member
 
hdtvincr's Avatar
 
Join Date: Nov 2003
Location: Cedar Rapids, IA
Posts: 1,863
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by rdwalt View Post

I'll have to check the table tonight but I know I'm definitely using the MyHD.exe from the CW_EPG bundle.

Wouldn't I have to look ahead more than a couple of days to see data for next week?

Most stations do not send more than a day or so of PSIP programming data, so 2 or 3 days ahead should be fine. In fact, IIRC, MyHD will only let you advance to 1 day ahead of the data it has anyways.

I'm with Terry... Sounds like not having the proper MyHD.exe.

{EDIT: In fact, a good test to see if you have the latest MyHD.exe is to use the "Next" key on the remote. It SHOULD take you 1 day ahead into the schedule....}
hdtvincr is offline  
post #637 of 4145 Old 09-12-2006, 01:03 PM
AVS Special Member
 
rdwalt's Avatar
 
Join Date: Jul 2003
Location: Kennesaw, GA
Posts: 1,086
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
I've done the "Next" 1 Day Ahead manuver however now that I think about it, when I upgraded from v.15 to v.16b there wasn't a MyHD.exe file so I'm still using the one from v.15

"If you never did, you should. These things are fun and fun is good."- Dr. Seuss
rdwalt is offline  
post #638 of 4145 Old 09-12-2006, 01:23 PM - Thread Starter
AVS Addicted Member
 
TPeterson's Avatar
 
Join Date: May 2002
Location: San Carlos, CA
Posts: 11,957
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 77 Post(s)
Liked: 17
Walt, that's OK the .15 one should be fine. (It should have a last-modified date of 4/25/06) Just see if it will display more than a couple of days of data. If it does, then my conclusion was wrong and you are actually seeing CW_EPG's data.
TPeterson is offline  
post #639 of 4145 Old 09-12-2006, 05:10 PM
Advanced Member
 
sengsational's Avatar
 
Join Date: Mar 2003
Location: NC
Posts: 921
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 10
Quote:
Originally Posted by lonndoggie View Post

Turn it off, eh? Man, if I can do that, I'm set. I don't use the playlist either, so not having it would suit me fine. Oh! I guess that's what that "add captured file to the playlist checkbox is" Duh! Now unchecked.

If I were going to monkey with the playlist through the MyHD API, that would have taken twice the entire effort I've put into the program so far. So I'm glad you don't want it!

Quote:
Originally Posted by lonndoggie View Post

"Remove This Row" doesn't delete the file or take it out of CW_EPG's database...does that mean it comes back next time you refresh, or does it remember to leave it out?

That's a leftover from when this UI was connected to something that 'remembered' things. This program only remembers how big the window was, where on the screen, the font, and column order/width. In other words, remove this row is sort of useless, because a refresh will bring it right back, like nothing happened.

Quote:
Originally Posted by lonndoggie View Post

Can't see anything obvious why this failed to find the data in the lookup.

I can. It looks like apostrophe issues. You're good! Now I need to record something with an apostrophe so I can get it working.

--Dale--
sengsational is offline  
post #640 of 4145 Old 09-12-2006, 05:34 PM
AVS Special Member
 
sic0048's Avatar
 
Join Date: Apr 2004
Location: South Carolina
Posts: 1,481
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Quote:
Originally Posted by miimura View Post

I opened the cw_sched.mdb file in Access and found the corresponding entry. It matches what the log says, less the 1 minute padding I have set on both ends as default. Does anyone know if there was a good reason for the data to be like this? Perhaps an east coast adjustment for a live event like maybe Dubyuh speaking?

Thanks for any insight. Love the program and can't wait for the new version.

- Mike

I know on the east coast all the shows started 18 minutes late. So my entries all recorded at the correct time. If you are in another time zone, then the data was simply incorrect.

- Brian

CQC user since 2005

SageTV user since 2007

PBX in a Flash user since 2012

sic0048 is offline  
post #641 of 4145 Old 09-12-2006, 05:37 PM
Advanced Member
 
sengsational's Avatar
 
Join Date: Mar 2003
Location: NC
Posts: 921
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 10
Quote:
Originally Posted by sengsational View Post

I can. It looks like apostrophe issues. You're good! Now I need to record something with an apostrophe so I can get it working.

Nope, that wasn't it. I opened the app and found a title with apostrophe working. But then I looked at your paste (which preserved the tabs, btw, when I clicked the 'quote' button), I saw the cuprit: 1901. On rare occasion, MyHD will start a minute or two late, usually if your machine is really crankin' on something. If you renamed that file to 1900, it would work.

--Dale--
sengsational is offline  
post #642 of 4145 Old 09-12-2006, 05:42 PM - Thread Starter
AVS Addicted Member
 
TPeterson's Avatar
 
Join Date: May 2002
Location: San Carlos, CA
Posts: 11,957
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 77 Post(s)
Liked: 17
So...let me guess...the next feature-enhancement request will be for a fuzzy-logic match of the title data that accounts for minor differences in time, etc., right, Dale?
TPeterson is offline  
post #643 of 4145 Old 09-12-2006, 07:46 PM
AVS Special Member
 
rdwalt's Avatar
 
Join Date: Jul 2003
Location: Kennesaw, GA
Posts: 1,086
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Quote:
Originally Posted by TPeterson View Post

Walt, that's OK the .15 one should be fine. (It should have a last-modified date of 4/25/06) Just see if it will display more than a couple of days of data. If it does, then my conclusion was wrong and you are actually seeing CW_EPG's data.

Today all is good. MyHD.exe Date Created: 4/25/06 5:20PM "Next" 1 Day Ahead up to the 24th contained channel descriptions.

Pressing "Next" seemed to have fixed the problem. But the really good news is I received my HTPC parts from newegg today! Well everything except for the mobo which is an ASUS P4P800-SE and coming in hopefully tomorrow from http://www.aberdeeninc.com/index.html, sweet!

"If you never did, you should. These things are fun and fun is good."- Dr. Seuss
rdwalt is offline  
post #644 of 4145 Old 09-13-2006, 01:20 AM
Senior Member
 
lonndoggie's Avatar
 
Join Date: Feb 2002
Location: Encinitas, CA
Posts: 280
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by TPeterson View Post

So...let me guess...the next feature-enhancement request will be for a fuzzy-logic match of the title data that accounts for minor differences in time, etc., right, Dale?

I can DREAM, can't I, "A.J."?

My logic's pretty fuzzy all by itself, don't need no help there. And I'm not adverse to renaming a file now and then, either! Btw, renaming the file did work...but hitting f5 after having done so initially gave me two rows for that file, one as it was and one corrected! Closed and reopened and all was well.

On to less pressing concerns...ala the "remove this row" question...why's it say "dialog" next to the font size selector drop-down? I guess that and the "font" edit menu item are two more vestigal parts from the program that served as a launch pad for MyShows.

EDIT 1: Ha! I'm such a ditz! NOW I see the little drop-down arrow far to the right of where it says "dialog" that lets me select a font! But the font edit menu thing doesn't seem to do anything...

And one last thing (heh, as if)...somehow, I got the notion that MyShows would remember the column size/placement settings. It's not--every time I open it it's back to the initial order/sizes.

EDIT 2: Hmmm...it appears that MyShows is still updating MyShows.dat--I just closed MyShows and MyShows.dat was modified. My guess is that it's reading MyShowsFull.dat, and writing MyShows.dat.

EDIT 3: In fact, I'm sure of it. I renamed MyShows.dat to .old and opened MyShows. Got the "stock" column settings. Close MyShows, and a new MyShows.dat was created. MyShowsFull.dat sits in that folder, untouched since I plopped it there.

Thanks, as always--

LDog
lonndoggie is offline  
post #645 of 4145 Old 09-13-2006, 04:17 PM
Advanced Member
 
sengsational's Avatar
 
Join Date: Mar 2003
Location: NC
Posts: 921
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 10
Quote:
Originally Posted by lonndoggie View Post

But the font edit menu thing doesn't seem to do anything...

Oops, I meant to take that out. It's not doing anything.
Quote:
Originally Posted by lonndoggie View Post

And one last thing (heh, as if)...somehow, I got the notion that MyShows would remember the column size/placement settings. It's not--every time I open it it's back to the initial order/sizes.

If you set font, column position/width, etc, it should be the same next time you open it (if you're not monkeying around with MyShows.dat, that is). MyShowsFull.dat is read-only, but MyShows.dat is read upon startup, if it exists, and sets your columns and font. If it's not doing that, go to a command prompt, change to the directory that holds the jar file and type "java -jar MyShows.jar > output.txt", then look at output.txt and see if it's complaining about not finding a file or something. It could be it's not starting in the right directory, and so can't find the MyShows.dat file. What happens when one double clicks a jar file might be different on different machines.

--Dale--
sengsational is offline  
post #646 of 4145 Old 09-13-2006, 11:02 PM
Senior Member
 
lonndoggie's Avatar
 
Join Date: Feb 2002
Location: Encinitas, CA
Posts: 280
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by sengsational View Post

If you set font, column position/width, etc, it should be the same next time you open it (if you're not monkeying around with MyShows.dat, that is).

I wasn't, until I got down to trying to figure out what was going on. As you'll recall from my post, MyShows.dat was being updated every time I closed MyShows.

However, it appears that MyShows is choosing not to read MyShows.dat.

Quote:
If it's not doing that, go to a command prompt, change to the directory that holds the jar file and type "java -jar MyShows.jar > output.txt", then look at output.txt and see if it's complaining about not finding a file or something.

It's complaining about a lot of stuff, but most notable is this:

Using default. MyShows.dat not used.
new settings
refreshAllHDFileStatus looping 10 items.
Current system matches MyShowsFull.dat file: true

Note that this is running MyShows0120.jar, not MyShows.jar.

Quote:
It could be it's not starting in the right directory, and so can't find the MyShows.dat file.

The shortcut I use has the correct "start in" folder--plus this little experiment was done after CDing to it on the command line, so it's definitely not the problem for the test run.

Quote:
What happens when one double clicks a jar file might be different on different machines.

Double-clicking the jar is one thing I didn't try. Did now...didn't work.

Bleah.

The folder in question, btw, is D:\\Program Files\\CW_EPG. The space in the path name isn't a problem, izzit?
lonndoggie is offline  
post #647 of 4145 Old 09-13-2006, 11:20 PM - Thread Starter
AVS Addicted Member
 
TPeterson's Avatar
 
Join Date: May 2002
Location: San Carlos, CA
Posts: 11,957
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 77 Post(s)
Liked: 17
Ain't these "platform independent" languages great?

(Sorry, Dale, couldn't stop meself)

LD: The spacey pathname doesn't seem to cause a problem on my test machine, even though it's Win2k and may not be as forgiving as XP about that. (Edit: Sonnuvagun...I just tried 'CD \\program files' (i.e., no quotes around path) on the Win2k box and it worked there too)
TPeterson is offline  
post #648 of 4145 Old 09-14-2006, 12:02 AM
Senior Member
 
lonndoggie's Avatar
 
Join Date: Feb 2002
Location: Encinitas, CA
Posts: 280
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by TPeterson View Post

Ain't these "platform independent" languages great?

Back in the day, we used to say "Java--write once, run...nowhere!"

Quote:
LD: The spacey pathname doesn't seem to cause a problem on my test machine, even though it's Win2k and may not be as forgiving as XP about that. (Edit: Sonnuvagun...I just tried 'CD \\program files' (i.e., no quotes around path) on the Win2k box and it worked there too)

Well, I wonder. I *swear* that the first version worked in the same folder.

However...I just copied the whole CW_EPG folder from D:\\program files to d:\\...

and...

wait for it...

IT WORKED.

So...I'll probably just leave it there. I'm easy (if wordy).

EDIT:

No, it didn't.

I was fooled...it's not working there (I looked too quickly, it was the same).

But, what does work is this:

MyShows.jar, if you use it, and only it, it'll save and restore the settings just fine.

If you use MyShows0120, it won't read it, but it does save it--the defaults--so it loses the settings.

Furthermore, Dale's output.txt file trick shows no errors relating to MyShows.dat.

So the old version *did* work, and the new doesn't. For me, anyway.

LDog
lonndoggie is offline  
post #649 of 4145 Old 09-14-2006, 12:27 AM - Thread Starter
AVS Addicted Member
 
TPeterson's Avatar
 
Join Date: May 2002
Location: San Carlos, CA
Posts: 11,957
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 77 Post(s)
Liked: 17
Well...0120 is what I'm using too (without changing the jar file name in case that matters).
TPeterson is offline  
post #650 of 4145 Old 09-14-2006, 12:59 AM
Senior Member
 
lonndoggie's Avatar
 
Join Date: Feb 2002
Location: Encinitas, CA
Posts: 280
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Right, I didn't change the jar file name, either.

So...if you move a column in 0120, close it and open it back up, the column is where you put it? Doesn't work for me.

However, fiddling some more, if I do the above, and then open MyShows.jar (the old one), it does retain the column positions--verifying that 0120 is saving its settings, but just can't read them.

Wonder if it's my version of Java? I've got Java auto updates turned on, so I ought to be pretty current.
lonndoggie is offline  
post #651 of 4145 Old 09-14-2006, 01:31 AM - Thread Starter
AVS Addicted Member
 
TPeterson's Avatar
 
Join Date: May 2002
Location: San Carlos, CA
Posts: 11,957
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 77 Post(s)
Liked: 17
Quote:
Originally Posted by lonndoggie View Post

So...if you move a column in 0120, close it and open it back up, the column is where you put it?

Indeed.

My Java reports JRE "build 1.5.0_06-b05" and a bunch of other gibberish that repeats this number a few times. AFAIK, I have not updated this since installing it, whenever that was.
TPeterson is offline  
post #652 of 4145 Old 09-14-2006, 08:38 AM
Senior Member
 
lonndoggie's Avatar
 
Join Date: Feb 2002
Location: Encinitas, CA
Posts: 280
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I have to admit I don't now how to find the version of my JRE, but the java control panel is version shows "Version 1.5.0 (build 1.5.0_06-b05)", which would indicate it's the same as yours (assuming they all run along together....of course, the "welcome.html" file in the program files\\java folder says "Java 2 Platform". Ah, naming/version number conventions...).

But anyway, that's probably not it.

Tried moving it to the C: drive. No change.
Got the latest .ini file and edited it to reference my video directory. No change.

Terry, did you delete the old jar file?
lonndoggie is offline  
post #653 of 4145 Old 09-14-2006, 09:06 AM - Thread Starter
AVS Addicted Member
 
TPeterson's Avatar
 
Join Date: May 2002
Location: San Carlos, CA
Posts: 11,957
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 77 Post(s)
Liked: 17
I have all three versions that Dale's supplied and they all find the regular .dat file just fine. (The Full.dat was another story, but not relevant to this problem)

If you're seeing error messages in the CMD window upon running the .jar, the clue is likely there for the deciphering. I'm seeing none at all when I run it that way.

P.S.: I used "java -version" in the cmd window. After inspecting the list generated by "java -?"...after "java ?" produced nothing very useful.
TPeterson is offline  
post #654 of 4145 Old 09-14-2006, 09:26 AM
Senior Member
 
lonndoggie's Avatar
 
Join Date: Feb 2002
Location: Encinitas, CA
Posts: 280
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Tried deleting MyShows.jar to no affect (I had both in the same directory).

The only error unique to the 0120 is the one reported previously:

Using default. MyShows.dat not used.
new settings


Other than that, they're pretty much the same--in place of the above, MyShows.jar produces this:

Accessing Database...done after 0 seconds.
found size as 800,492
found location as 0,0


That 0120 is not using MyShows.dat is obvious--the why would be good to know.

Waiting for any insight Dale might have.

PS--results from Java version check:

java version "1.5.0_06"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_06-b05)
Java HotSpot(TM) Client VM (build 1.5.0_06-b05, mixed mode)

Terry--when you say you get no errors at all, you don't get things like this:

TSFile.composeRegData case 1 failed with KCET-SD-0910-1300-American Masters.tp For input string: "SD"

I get a bunch of those, but it doesn't seem to be a problem.
lonndoggie is offline  
post #655 of 4145 Old 09-14-2006, 10:31 AM - Thread Starter
AVS Addicted Member
 
TPeterson's Avatar
 
Join Date: May 2002
Location: San Carlos, CA
Posts: 11,957
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 77 Post(s)
Liked: 17
I think that I see things like that in the ">output.txt" file but not I see nothing in the cmd window, whereas I was seeing errors there when the Full.dat file was misnamed--and in fact one of the errors said that it couldn't find "MyShowFull.dat" which tipped me off to the problem. Once the file name error was corrected there were no messages emitted to the cmd window anymore.
TPeterson is offline  
post #656 of 4145 Old 09-14-2006, 06:16 PM
Advanced Member
 
sengsational's Avatar
 
Join Date: Mar 2003
Location: NC
Posts: 921
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 10
Quote:
Originally Posted by lonndoggie View Post

TSFile.composeRegData case 1 failed with KCET-SD-0910-1300-American Masters.tp For input string: "SD"

I get a bunch of those, but it doesn't seem to be a problem.

It's trying to tease the channel number info out of the file name when it's not there. The critical bit of file naming is that the third to the last "-" has the date in MMDD after it, and the second to the last "-" has the time after it. If that holds true, then it stands a chance of matching. This may prove to be interesting if we had a way to record more than one show at a time (cross that bridge when we come to it).

Quote:
Originally Posted by TPeterson View Post

Ain't these "platform independent" languages great?

I've heard 'em all. "Write once, debug everywhere."

I'm not even sure that the path is the case anymore, since it's writing out the danged file. It might be something unexpected in the data that can save okay, but doesn't make it back into the app when I try to "reconstitute it". I'm sure we'll get to the bottom of it.

--Dale--
sengsational is offline  
post #657 of 4145 Old 09-14-2006, 06:27 PM
Advanced Member
 
sengsational's Avatar
 
Join Date: Mar 2003
Location: NC
Posts: 921
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 10
Quote:
Originally Posted by lonndoggie View Post

Using default. MyShows.dat not used.

Is there a bunch of "junkish looking hard to read stuff" right below the line above? That might prove interesting to me.
sengsational is offline  
post #658 of 4145 Old 09-14-2006, 08:21 PM
Senior Member
 
lonndoggie's Avatar
 
Join Date: Feb 2002
Location: Encinitas, CA
Posts: 280
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by sengsational View Post

Is there a bunch of "junkish looking hard to read stuff" right below the line above? That might prove interesting to me.

I'd posted a larger snippet above--nothing hard to read:

Using default. MyShows.dat not used.
new settings
refreshAllHDFileStatus looping 10 items.
Current system matches MyShowsFull.dat file: true

I'll re-run it later tonight (not yet home), paying attention to the command window--a lot of stuff did scroll by there, but I ignored it (I think MyShows.jar did that, too). I was looking for what was in the output.txt file.

Thanks for continuing to deal with this (I hate it when I'm the only guy with the problem). At least this way we're keeping this thread alive!
lonndoggie is offline  
post #659 of 4145 Old 09-14-2006, 10:33 PM
Senior Member
 
lonndoggie's Avatar
 
Join Date: Feb 2002
Location: Encinitas, CA
Posts: 280
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Here's the contents of the cmd window when invoking MyShows0120. Looks like there's two exceptions with some amazingly long call stacks...hope this gives you something to go on, Dale:

D:\\CW_EPG>java -jar MyShows0120.jar > output.txt
java.io.WriteAbortedException: writing aborted; java.io.NotSerializableException: com.sun.java.swing.plaf.windows.XPStyle
at java.io.ObjectInputStream.readObject0(Unknown Source)
at java.io.ObjectInputStream.defaultReadFields(Unknown Source)
at java.io.ObjectInputStream.readSerialData(Unknown Source)

... and so on. Edited to remove about a zillion extra lines, per Dale.

LJB
lonndoggie is offline  
post #660 of 4145 Old 09-14-2006, 10:36 PM
Senior Member
 
lonndoggie's Avatar
 
Join Date: Feb 2002
Location: Encinitas, CA
Posts: 280
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
And while we're at it...here's the full output.txt file from the same run that produced the cmd window output in the previous:

version 0.1.2.0
f:\\video capture starting thread..... - ok
there were 13 tp files
TSFile.composeRegData case 1 failed with KCET-HD-0903-1930-California's Gold.tp For input string: "HD"
TSFile.composeRegData case 1 failed with KCET-HD-0914-1200-Visiting ... With Huell Howser.tp For input string: "HD"
TSFile.composeRegData case 1 failed with KCET-SD-0904-1800-California's Gold.tp For input string: "SD"
TSFile.composeRegData case 1 failed with KCET-SD-0910-1300-American Masters.tp For input string: "SD"
TSFile.composeRegData case 1 failed with KCET-SD-0913-2200-American Masters.tp For input string: "SD"
TSFile.composeRegData case 1 failed with KCET-SD-0914-0030-Visiting ... With Huell Howser.tp For input string: "SD"
TSFile.composeRegData case 1 failed with KFMB-DT-0903-0235-CSI; Crime Scene Investigation.tp For input string: "DT"
TSFile.composeRegData case 1 failed with KFMB-DT-0914-2100-CSI; Crime Scene Investigation.tp For input string: "DT"
TSFile.composeRegData case 1 failed with KOCE-HD-0802-1930-Jean-Michel Cousteau; Ocean Adventures.tp For input string: "HD"
TSFile.composeRegData case 1 failed with KOCE-SD-0903-2200-Great Performances.tp For input string: "SD"
Accessing Database...done after 0 seconds.
Using default. MyShows.dat not used.
new settings
refreshAllHDFileStatus looping 13 items.
Current system matches MyShowsFull.dat file: true
TSFile.composeRegData case 1 failed with KCET-HD-0903-1930-California's Gold.tp For input string: "HD"
lonndoggie is offline  
Reply Home Theater Computers

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off