1080p from ATI card - Page 4 - AVS Forum
Forum Jump: 
Reply
 
Thread Tools
post #91 of 285 Old 06-11-2007, 10:12 PM
Senior Member
 
shud's Avatar
 
Join Date: Nov 2004
Posts: 258
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by louky View Post

answer my own question...in the CCC under dtv/dvi attributes i unchecked the default dvi setting (reduce dvi frequency) and now 60hz works.

now i'm back to the same issue as the original poster, the CCC doesn't allow custom resolutions for 1080p so i have overscan.

Well holy crap. That worked for me too. What's the deal? It seems like when it's checked that higher resolutions should work better, not worse. Strange.
shud is offline  
Sponsored Links
Advertisement
 
post #92 of 285 Old 06-11-2007, 11:17 PM
AVS Special Member
 
Mark_A_W's Avatar
 
Join Date: Dec 2002
Location: Melbourne, Australia
Posts: 8,110
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
In powerstrip 60hz interlaced is 30hz with interlaced picked.

To send it 1080p 60hz, you would untick interlaced and pick 60hz.

But I would use 48hz if you can, to avoid judder.

Loving my Electric Bike!!
Mark_A_W is offline  
post #93 of 285 Old 06-12-2007, 07:41 AM
Advanced Member
 
fdisker's Avatar
 
Join Date: Apr 2003
Posts: 516
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Mark_A_W View Post

Is there some reason why Powerstrip won't help you guys?

I've been through the opposite experience - Nvidia cards are hopeless for HTPCs, had much more success with a 9500pro and x1950.

I don't know. In the hours I've spent researching the problem on this forum I haven't come across a Vista32/ATI/Bravia/DVI-HDMI/1080p user who's fixed the problem with Powerstrip. If I can use Powerstrip to fix the problem I certainly will. If not I'll pick up a nvidia 8600gt and give that a go. According to this post the nvidia card should work in Vista.
fdisker is offline  
post #94 of 285 Old 06-12-2007, 11:07 AM
Member
 
Scott Davey's Avatar
 
Join Date: May 2007
Posts: 19
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Well I have a different 1080p LCD (AKAI)... but I got 1080p working finally in XP with an X800 XL although at 50Hz.

Make sure you have the latest ATI drivers (catalyst 7.5) and set the res to 1080p and 50Hz. Works like a charm. I thought there was overscan at first but the TV defaulted to a zoom mode... pushing zoom on the remote fixed everything.

Also... someone said they cant set custom resolutions at 1080p.... that's not my experience... just make sure centered timings (not scaled) is checked... and there should even be an option of something like 1750x1000 to eliminate overscan.

Cheers and good luck.
Scott Davey is offline  
post #95 of 285 Old 06-12-2007, 04:27 PM
Advanced Member
 
fdisker's Avatar
 
Join Date: Apr 2003
Posts: 516
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Well that was easy and painless. Powerstrip worked like a charm on the first try. I'm now at 1:1 on the Bravia with no black border. Hopefully the next Catalyst release will eliminate the need for Powerstrip.

Special thanks to Mark_A_W for the tip.
fdisker is offline  
post #96 of 285 Old 06-12-2007, 04:56 PM
Senior Member
 
shud's Avatar
 
Join Date: Nov 2004
Posts: 258
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by fdisker View Post

Well that was easy and painless. Powerstrip worked like a charm on the first try. I'm now at 1:1 on the Bravia with no black border. Hopefully the next Catalyst release will eliminate the need for Powerstrip.

Special thanks to Mark_A_W for the tip.

I think people have been hoping for the bolded statement to be true since early in the 6 series for this driver and it's not going to happen.

AMD wants you to get the ATI AIW series for this sort of thing.
shud is offline  
post #97 of 285 Old 06-12-2007, 06:01 PM
Member
 
QuietKungFu's Avatar
 
Join Date: Oct 2006
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Well, I suffer from this problem with a x1900xt card on my 52in Sharp LCD. I've switched to my Silent 7600GT card for now. It works absolutely great and uses passive cooling. I was hoping to use my x1900xt and get some better framerates on the big screen in games.

Anyway, I've gone back and forth with ATI about the problem, and surprisingly they gave me a web link to this site to explain how to use 1080p. Sadly, it was an old thread from 2005 and not too pertinent. ( http://www.avsforum.com/avs-vb/showthread.php?t=597362 )

Ultimately they said this was a documented issue with Catalysts 7.2 and up. They told me to continue to use 7.1 and wait until the 7.6 version due early July (based on the numbering, I'd think it would be out in June...). Hopefully 7.6 has a fix, but I'm definitely not expecting much. I'll have to try messing around with PowerStrip, or just leave my 7600GT in the HTPC for a while.

Quote:
Originally Posted by shud View Post

I think people have been hoping for the bolded statement to be true since early in the 6 series for this driver and it's not going to happen.

AMD wants you to get the ATI AIW series for this sort of thing.

QuietKungFu is offline  
post #98 of 285 Old 06-13-2007, 06:50 AM
Advanced Member
 
fdisker's Avatar
 
Join Date: Apr 2003
Posts: 516
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Glad to hear your Nvidia card is working well. Given the new features of the 8 series cards (DX10, Purevideo HD) I'm going to pick up a 8600GT to play with. I haven't heard great things about their Vista drivers but I'm sure they'll mature over time. At the very least I'll be able to do 1:1 mapping at 1080p.

On a side note the 40v2500 Bravia is excellent. Picture quality is much closer to my SXRD than I thought it would be. The Bravia can't match the black level of the SXRD but contrast and color are excellent.
fdisker is offline  
post #99 of 285 Old 06-13-2007, 03:50 PM
Member
 
QuietKungFu's Avatar
 
Join Date: Oct 2006
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Small update. I heard back from the ATI support rep, and he said that he couldn't say for certain that the 7.6 version would solve or help our issue. He did say that I should fill out the Catalyst Crew Feedback form, and that items that are reported in great numbers do get prioritized. So, I filled out the form and pointed them to this thread, maybe we'll get some help on this problem. If anyone else wants to help get this problem bumped at ATI, I included the Catalyst Crew Feedback survey link I got below.

http://support.ati.com/ics/survey/su...D=486&type=web
QuietKungFu is offline  
post #100 of 285 Old 06-13-2007, 04:01 PM
Member
 
freshmayka's Avatar
 
Join Date: Dec 2006
Posts: 19
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by QuietKungFu View Post

Small update. I heard back from the ATI support rep, and he said that he couldn't say for certain that the 7.6 version would solve or help our issue. He did say that I should fill out the Catalyst Crew Feedback form, and that items that are reported in great numbers do get prioritized. So, I filled out the form and pointed them to this thread, maybe we'll get some help on this problem. If anyone else wants to help get this problem bumped at ATI, I included the Catalyst Crew Feedback survey link I got below.

http://support.ati.com/ics/survey/su...D=486&type=web

I've been trying to get people to do this since December.... Obviously we are in the minority =(

Either way, keep sending them feedback and complaints. If WE can fix this issue with workarounds (albeit lame ones) then they HAVE to be able to fix this via a Catalyst update.
freshmayka is offline  
post #101 of 285 Old 06-13-2007, 04:39 PM
Advanced Member
 
fdisker's Avatar
 
Join Date: Apr 2003
Posts: 516
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
It's the fear of the bug not getting fixed for months that drove me to pick up an 8500GT at Best Buy an hour ago. Just finished a fresh install of Vista Ultimate. After the latest forceware install I was greeted with a gorgeous edge to edge, non black border, 1920x1080p desktop. It's beautiful!! Two thumbs up for the Bravia and new nvidia card.

Media Center configuration is next.
fdisker is offline  
post #102 of 285 Old 06-14-2007, 06:32 PM
Newbie
 
devguy's Avatar
 
Join Date: Jun 2007
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hi, I'm new here, but I've been following this thread. I just purchased a Magnavox 19" LCD with an HDMI input and I just received a dvi->hdmi converter for use on my ATI x800. The monitors native resolution is 1440x900 but will take 720p or 1080p signals.

When I set the video card to 1080p, I have no under/overscanning issues at any refresh rate, but the image looked quite squished, and besides, the x800 isn't the best card to run games at 1080p resolution. When I try 720p, I get a massively overscanned image at any refresh rate I try. Ideally, I would like the monitor to run at 1440x900, but when I choose that resolution, I get massive underscan. Oddly, 800x600, 1024x768, and 1280x1024 all seem to work fine, but they look like crap on a widescreen tv. Any ideas?

TV is Magnavox 19mf337b, Video card is Radeon x800 128mb, OS is xp x64, catalyst is 7.5.

This seems like a helpful forum, thanks for the info I've already received.
devguy is offline  
post #103 of 285 Old 06-15-2007, 08:07 AM
Newbie
 
novalis's Avatar
 
Join Date: Jun 2007
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I have the MSI K9AGM2-FIH with integrated Xpress 1250 and HDMI hooked up to my Sharp 46D62 and of course I get the underscan. I first installed the catalyst 7.5, read up on here that 7.1 would let me do the 75hrz trick. So I uninstalled 7.5 and tried 7.1 but it said no devices found, so I assume I need a newer driver. I will try a clean install of windows with the 7.1 again to see what happens. Oh, never mentioned I'm running Vista Ultimate 32.

This is pretty frustrating. I never thought to check if the HDMI output would work at 1080p correctly before buying the motherboard because I assumed it would be fine. I may be forced to buy a nvidia card, dangit...
novalis is offline  
post #104 of 285 Old 06-15-2007, 08:51 AM
Member
 
Mevlock's Avatar
 
Join Date: Oct 2006
Posts: 62
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Lots of people are complaining about underscan. If you get underscan (using 720p OR 1080p resolutions) and want rid of it just fire up regedit and do a search for "underscan". You should come up with a bunch of ATI registry keys that can be edited. Just change them so they are a string of 00's. This will get rid of any underscan.

Sorry that I can't be more specific but I'm at work atm. There is however a detailed post somewhere on this forum detailing the exact steps.
Mevlock is offline  
post #105 of 285 Old 06-15-2007, 12:50 PM
Senior Member
 
StratMangler's Avatar
 
Join Date: Dec 2005
Posts: 241
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Boy, that is weird. I own a Sony SXRD 60" TV and for the 1st time, I'm getting perfect 1:1 pixel mapping at 60 hertz without the need of the 75 hertz bug using the 7.1 drivers minus the CCC. I don't understand it (and I'm a PC tech in the daytime), but I ain't complaining. The CCC is a ridiculously bloated piece of software (not to say another "s" word, lol).

I'm hoping to get a slight performance boost from having used 6.12 in the past. *crossing fingers*

In the meantime, I'm enjoying my current setup.
StratMangler is offline  
post #106 of 285 Old 06-15-2007, 01:34 PM
Member
 
Scott Davey's Avatar
 
Join Date: May 2007
Posts: 19
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by devguy View Post

Hi, I'm new here, but I've been following this thread. I just purchased a Magnavox 19" LCD with an HDMI input and I just received a dvi->hdmi converter for use on my ATI x800. The monitors native resolution is 1440x900 but will take 720p or 1080p signals.

When I set the video card to 1080p, I have no under/overscanning issues at any refresh rate, but the image looked quite squished, and besides, the x800 isn't the best card to run games at 1080p resolution. When I try 720p, I get a massively overscanned image at any refresh rate I try. Ideally, I would like the monitor to run at 1440x900, but when I choose that resolution, I get massive underscan. Oddly, 800x600, 1024x768, and 1280x1024 all seem to work fine, but they look like crap on a widescreen tv. Any ideas?

TV is Magnavox 19mf337b, Video card is Radeon x800 128mb, OS is xp x64, catalyst is 7.5.

This seems like a helpful forum, thanks for the info I've already received.

You should be able to get this to work...

You definitely do NOT want to run a 1440x900 monitor @ 1080p all that is doing is rescaling a 1920x1080 image back down to the 1440x900 resolution that the monitor displays... this will make images look worse! You need to get that 1440x900 res working! If you're getting under-scanning at that res... something is scaling it down. The 1st thing I'd check is the auto-zoom-modes with the "format" button on the remote... cycle them all to see if anything fits the image correctly.

If it still fails... for a short-term fix... try the resolution of 1280x768 (or better yet 1280x800) for a less awkward looking image. Part of the problem is that this set's aspect ratio is squarely between 16:9 & 4:3... 1280x800 is precisely the same ratio as 1440x900 so that's your best bet (well 2nd best to native) for a clean image.

Good luck and let me know if you fix it!
Scott Davey is offline  
post #107 of 285 Old 06-15-2007, 02:45 PM
Newbie
 
devguy's Avatar
 
Join Date: Jun 2007
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Scott Davey View Post

You should be able to get this to work...

You definitely do NOT want to run a 1440x900 monitor @ 1080p all that is doing is rescaling a 1920x1080 image back down to the 1440x900 resolution that the monitor displays... this will make images look worse! You need to get that 1440x900 res working! If you're getting under-scanning at that res... something is scaling it down. The 1st thing I'd check is the auto-zoom-modes with the "format" button on the remote... cycle them all to see if anything fits the image correctly.

If it still fails... for a short-term fix... try the resolution of 1280x768 (or better yet 1280x800) for a less awkward looking image. Part of the problem is that this set's aspect ratio is squarely between 16:9 & 4:3... 1280x800 is precisely the same ratio as 1440x900 so that's your best bet (well 2nd best to native) for a clean image.

Good luck and let me know if you fix it!

So, my tv only allows one type of format (16x9) in the options for hdmi (VGA had a nice scan to size mode, tv and component have a nice 4:3 option or letterbox). 1280x800 suffers from the exact same massive underscanning that 1440x900 does. As a temporary fix, I'm running the monitor at 1680x1050 which is widescreen and full screen, but it still doesn't look as sharp as 1440x900 should look.
devguy is offline  
post #108 of 285 Old 06-15-2007, 06:02 PM
Senior Member
 
StratMangler's Avatar
 
Join Date: Dec 2005
Posts: 241
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Damnit! I was enjoying the 7.1 drivers, but now there's a problem with the HDMI handshake between the card & the TV. I need to reboot the PC to get video after I turn off then back on the TV.

I'll reinstall the drivers to see if that fixes it. Otherwise, I'll be going back to 6.12
StratMangler is offline  
post #109 of 285 Old 06-15-2007, 08:31 PM
Member
 
Yraen's Avatar
 
Join Date: Jan 2007
Posts: 72
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 12
Quote:
Originally Posted by StratMangler View Post

Damnit! I was enjoying the 7.1 drivers, but now there's a problem with the HDMI handshake between the card & the TV. I need to reboot the PC to get video after I turn off then back on the TV.

I'll reinstall the drivers to see if that fixes it. Otherwise, I'll be going back to 6.12

I had the same problem also. It ended up being the computer needed to go into power saving mode, then it would detect the tv again when I switched back to it. I ended up getting a DVI Detective (1080p support) and all is well. I was going to pick one up anyway so it wasn't an additional cost to me.
Yraen is offline  
post #110 of 285 Old 06-16-2007, 01:47 AM
Newbie
 
wirrunna's Avatar
 
Join Date: Apr 2007
Location: South Coast, NSW, Australia
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
novalis, I also have a MSI K9AGM2-FIH, but it is connected to a Sony Bravia X TV via HDMI.
To get a full screen I run at 1360 x 768 and then have the "Scale Image to Full Panel Size" set. The Sony then displays the picture at full screen while showing that the connection is at 1080i.
I was able to get the display to run at 1920x1080p but TV and video was jerky.
This is using Win XP SP2 and Catalyst 7.5
I also logged a ticket with ATI and they told me to use the 1360x768 and scale the image.
We will see what the 7.6 drivers do.
wirrunna is offline  
post #111 of 285 Old 06-18-2007, 07:52 AM
Advanced Member
 
rjeffb's Avatar
 
Join Date: Jun 2007
Posts: 897
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Quote:
Originally Posted by jkaiser View Post

I can only run 1080p over VGA to my Samsung (DVI/HDMI are 1080i only - but not recommended by Samsung). When I use the overscan utility (for 1080p), the Samsung reports "unsupported resolution".

Your lack of 1080p control may be related to what the ATI driver is detecting as your display (it doesn't think you display supports 1080p so it doesn't give you that option in catalyst).

Hi folks, I did some experimenting and found that this is neither a hardware nor a driver issue, it's simply a bug. Here's the proof.

Requirements: a 1080p-capable monitor with both HDMI and DVI inputs (mine's a Westy), a Radeon card (mine is an X1300, but as you'll see, I suspect any Radeon will do), a DVI-DVI cable, and a DVI-HDMI cable.

1. Connect the monitor to the ATI via DVI. Set it to 1920x1080x60 (or, in Catalyst, 1080p). Verify that display works with no borders.
2. WITHOUT TURNING OFF ANYTHING OR CHANGING ANYTHING ON THE PC OR MONITOR, disconnect the DVI and hook up the HDMI. If your monitor doesn't auto-detect the new input, manually change the monitor's input selection to HDMI.
3. If you get a Catalyst warning about not receiving audio through HDMI, ignore it.
4. Verify that the display works with no borders.

That's right - the Radeon is pumping out pure 1080p perfectly through HDMI with no underscanning, no borders, no nothing. If your monitor is capable of this in its menus, you can verify that the monitor is receiving a 1080p signal.

5. Reboot the PC. (On my PC I can change resolutions and change back to accomplish the same thing, but YMMV and rebooting is the one sure bet.)
6. Verify that your picture now sucks.

This rules out any hardware or basic driver inability to display 1080p through HDMI - because it did before the reboot. Now things really get interesting.

7. If your monitor supports it, verify that the current resolution is still 1080 (p or i).

How is that possible? It's because the HDMI cable is still pushing a 1080 signal, but somewhere the screen size is getting downsized and a black border is ADDED to total up to 1080. I first thought of this when I turned my brightness way up on a 1280x1024 setting on the same monitor and saw a "black" (now gray) border around the Windows desktop (normally invisible because the black color put out by the ATI blends in with the blank area of the monitor). Somehow a border was being added...

8. WITHOUT TURNING OFF ANYTHING OR CHANGING ANYTHING ON THE PC OR MONITOR, disconnect the HDMI and hook up the DVI. If your monitor doesn't auto-detect the new input, manually change the monitor's input selection to DVI.
9. Verify that the picture still sucks.

WHAT?!? But you're running off DVI now! What has this got to do with the HDMI?
Answer: Nothing! Oh wait, maybe it does...maybe selecting HDMI somehow latched something in the hardware and now your video card is permanently screwed up and will display those borders forever. Let's disprove that theory:

10. Reboot the computer and verify that everything is back to normal.

So: there is nothing wrong with the drivers, and the hardware is fully capable of producing perfect 1080p images regardless of whether it's going through DVI or HDMI. It's just a stupid, stupid bug that ATI refuses to publicly acknowledge (as of this date there's nothing on it in their FAQs or Knowledge Base). Someone in this thread mentioned uninstalling Catalyst, and I'm going to give that a try, because clearly what is happening is some ATI routine outside the core driver is intercepting the 1080p, forcing it into an underscanned size, and adding a black border around it to make it still come out 1920x1080. It CANNOT be the hardware and it CANNOT be the driver because otherwise you would have seen it the moment you switched from DVI to HDMI.
rjeffb is offline  
post #112 of 285 Old 06-18-2007, 08:18 AM
Senior Member
 
PapaSloth's Avatar
 
Join Date: Jan 2001
Location: Somerville, MA
Posts: 315
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I fixed the underscan issue on my machine with both Catalyst 7.4 and 7.5 on Windows XP MCE as follows:
1). Start/Run.../regedit
2). Open HKEY_LOCAL_MACHINE\\SYSTEM\\Current Control Set\\Contol\\Video
3). You'll see 5 or so subkeys labelled {hex number-hex number-etc.-} (a thirty-two digit GUID). Under each of these subkeys, you'll see a 0000 key. Each of these GUID subkeys corresponds to a different display driver. Two of these have subkeys under 0000, one for the primary display and one for the secondary display. Find the one for the primary display, it will both have subkeys under 0000 and also have a "Device Description" value with a name that matches your Radeon card (and doesn't have "Secondary" in the Device Description).
4). If you've found the right GUID, when you select 0000 there should be a whole bunch of values under there.
5). Right click on the values pane and select New/Binary Value.
6). Set the name of the new value to be "DALR6 DFPUnderscan1920x1080x1920x1080x0x0"
7). Doubleclick on the new key to edit the value. An Edit Binary Value popup will appear. Type 00 sixteen times. Click OK.
8). Close regedit.
9). You may have to reboot and/or open Catalyst Control Center for the settings to "take."

This worked for an X1950 Pro with DVI out, a DVI to HDMI cable, going to an Onkyo receiver to a JVC RS1 projector.
PapaSloth is offline  
post #113 of 285 Old 06-18-2007, 08:37 AM
Senior Member
 
StratMangler's Avatar
 
Join Date: Dec 2005
Posts: 241
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Yraen View Post

I had the same problem also. It ended up being the computer needed to go into power saving mode, then it would detect the tv again when I switched back to it. I ended up getting a DVI Detective (1080p support) and all is well. I was going to pick one up anyway so it wasn't an additional cost to me.

Ok. A few days of testing and reinstalling the drivers does nothing to fix the issue. The HDMI handshake between the card & the TV just ain't happening after a few hours. Don't know why it keeps happening and only with the 7.1 drivers, but it does. So it looks like it's back to 6.12 drivers for me, at least until ATI can actually fix the bugs in their display drivers.

Sucks.
StratMangler is offline  
post #114 of 285 Old 06-18-2007, 09:00 AM
Senior Member
 
santiagodraco's Avatar
 
Join Date: Apr 2007
Posts: 372
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by rjeffb View Post

Hi folks, I did some experimenting and found that this is neither a hardware nor a driver issue, it's simply a bug. Here's the proof.

Requirements: a 1080p-capable monitor with both HDMI and DVI inputs (mine's a Westy), a Radeon card (mine is an X1300, but as you'll see, I suspect any Radeon will do), a DVI-DVI cable, and a DVI-HDMI cable.

1. Connect the monitor to the ATI via DVI. Set it to 1920x1080x60 (or, in Catalyst, 1080p). Verify that display works with no borders.
2. WITHOUT TURNING OFF ANYTHING OR CHANGING ANYTHING ON THE PC OR MONITOR, disconnect the DVI and hook up the HDMI. If your monitor doesn't auto-detect the new input, manually change the monitor's input selection to HDMI.
3. If you get a Catalyst warning about not receiving audio through HDMI, ignore it.
4. Verify that the display works with no borders.

That's right - the Radeon is pumping out pure 1080p perfectly through HDMI with no underscanning, no borders, no nothing. If your monitor is capable of this in its menus, you can verify that the monitor is receiving a 1080p signal.

5. Reboot the PC. (On my PC I can change resolutions and change back to accomplish the same thing, but YMMV and rebooting is the one sure bet.)
6. Verify that your picture now sucks.

This rules out any hardware or basic driver inability to display 1080p through HDMI - because it did before the reboot. Now things really get interesting.

7. If your monitor supports it, verify that the current resolution is still 1080 (p or i).

How is that possible? It's because the HDMI cable is still pushing a 1080 signal, but somewhere the screen size is getting downsized and a black border is ADDED to total up to 1080. I first thought of this when I turned my brightness way up on a 1280x1024 setting on the same monitor and saw a "black" (now gray) border around the Windows desktop (normally invisible because the black color put out by the ATI blends in with the blank area of the monitor). Somehow a border was being added...

8. WITHOUT TURNING OFF ANYTHING OR CHANGING ANYTHING ON THE PC OR MONITOR, disconnect the HDMI and hook up the DVI. If your monitor doesn't auto-detect the new input, manually change the monitor's input selection to DVI.
9. Verify that the picture still sucks.

WHAT?!? But you're running off DVI now! What has this got to do with the HDMI?
Answer: Nothing! Oh wait, maybe it does...maybe selecting HDMI somehow latched something in the hardware and now your video card is permanently screwed up and will display those borders forever. Let's disprove that theory:

10. Reboot the computer and verify that everything is back to normal.

So: there is nothing wrong with the drivers, and the hardware is fully capable of producing perfect 1080p images regardless of whether it's going through DVI or HDMI. It's just a stupid, stupid bug that ATI refuses to publicly acknowledge (as of this date there's nothing on it in their FAQs or Knowledge Base). Someone in this thread mentioned uninstalling Catalyst, and I'm going to give that a try, because clearly what is happening is some ATI routine outside the core driver is intercepting the 1080p, forcing it into an underscanned size, and adding a black border around it to make it still come out 1920x1080. It CANNOT be the hardware and it CANNOT be the driver because otherwise you would have seen it the moment you switched from DVI to HDMI.

I really don't know to say to this other than I doubt it has much real truth. First off not everyone has 1080p displays with DVI, I sure don't. So your basis tests are invalid for anyone with those displays.

Secondly the fact that this worked with older drivers but not with newer ones, and ATI has admitted that it is an issue/bug, leads me to believe it is exactly that.
santiagodraco is offline  
post #115 of 285 Old 06-18-2007, 06:37 PM
Advanced Member
 
rjeffb's Avatar
 
Join Date: Jun 2007
Posts: 897
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Quote:
Originally Posted by santiagodraco View Post

I really don't know to say to this other than I doubt it has much real truth. First off not everyone has 1080p displays with DVI, I sure don't. So your basis tests are invalid for anyone with those displays.

Secondly the fact that this worked with older drivers but not with newer ones, and ATI has admitted that it is an issue/bug, leads me to believe it is exactly that.

I think you missed my point. I do indeed appreciate that my monitor is unusual in that it can input both DVI and HDMI; I was simply giving results on some experiments that most HDMI owners are unable to conduct on their own. In return, I am grateful to people who have posted results running at 75Hz, because my low-end X1300 is incapable of 75Hz above a certain resolution (1280x1024 I believe).

Your statement that ATI "has admitted that it is an issue/bug" is not entirely correct, in a non-obvious and possibly significant way. Actually, they recognize it is an issue for one particular card (and then say it might apply to others, much like I said about my X1300), and then they go on to refer the reader to their KB page on component overscanning ("see KB article 737-26076") for a workaround. What my experiment shows is that the problem isn't inherent in the hardware or in the core driver, because they can produce accurate 1-to-1 1080p @ 60 over HDMI under certain circumstances (by first tricking them into thinking they're outputting to DVI).

I know this isn't a fix or even a workaround; hell, it's not even usable for someone like me who DOES have both inputs. I just presented it because there are clever people working on a solution, and any information about how the issue does or does not arise might be the clue they're looking for to solve it.

BTW I tried PapaSloth's registry fix with no results, but I had tons more display variations than he did so his solution might be configuration-specific. Clever approach, though. I tried uninstalling Catalyst but instead of the tried-and-true "one thing at a time" approach I stupidly tried also installing the latest standalone driver, which hosed everything. I'll re-try just the Catalyst uninstall once my backup finishes restoring...cheers, Jeff.
rjeffb is offline  
post #116 of 285 Old 06-18-2007, 07:33 PM
Member
 
Atomic Skull's Avatar
 
Join Date: Jun 2007
Posts: 119
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Scott Davey View Post

Hey quick related question...

I have a (cheap) 1080p akai LCD TV...

@1080p (DVI to HDMI) my x800 xl radeon doesn't underscan per se... but there's like an odd refresh rate issue which shows in odd horizontal lines where ever there is motion... static images, however, are fine. There's also some fast pixel "waves" moving on the right 6 inches of the screen occasionally.

The TV apparently works fine at 1080p with Blu-ray and HD-DVD but PC input seems a no go?

Anyone have a similar problem? (That you hopefully fixed? )

It's a problem with ATI cards. The work around is to use powerstrip and force the refresh rate to 1080p 50hz then (with powerstrip still running) go to the windows display properties (not CCC) and set the display mode to 1080i. Powerstrip won't let it actually change the refresh rate but somthing windows does tells the monitor to map pixels 1:1.

50hz is fine for normal computer usage, though I'd really like 60hz. I'm hoping ATI fixes this. For most games I use 1366x768 60hz (1080p makes chat boxes and status displays too small in most games anyway).
Atomic Skull is offline  
post #117 of 285 Old 06-18-2007, 08:52 PM
 
nyboy42's Avatar
 
Join Date: Mar 2007
Posts: 221
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Guys I need some major help,

I have the panasonic th-42px75u plasma. The native resolution is 1024x768, i connected my graphics card (ATI x1300) using DVI--> HDMI, get a picture to show up on my screen but it does not fill the screen ENTIRELY. When i set to 720p or 1080i, the whole screen doesnt fill, it almost does but maybe a inch within the frame, so i get a frame within a frame.

I tried then using the TV's native resolution of 1024x768 and got the same result. It is it possible to send a 1080i signal to my set when it is not TRUE 1080i (1024x768 resolution) shouldnt my tv downscale a 1080i resoultion and fill my screen entirely, why do you think that it doesnt, any help would be great. thanks a lot for ur time

I tried using a custom resolution, but when i change the dimensions, nothing happens. The size of the display is the exact same. Anyone can help me out??
nyboy42 is offline  
post #118 of 285 Old 06-19-2007, 11:19 AM
Newbie
 
jedijoe's Avatar
 
Join Date: Jun 2007
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by PapaSloth View Post

I fixed the underscan issue on my machine with both Catalyst 7.4 and 7.5 on Windows XP MCE as follows:
1). Start/Run.../regedit
2). Open HKEY_LOCAL_MACHINE\\SYSTEM\\Current Control Set\\Contol\\Video
3). You'll see 5 or so subkeys labelled {hex number-hex number-etc.-} (a thirty-two digit GUID). Under each of these subkeys, you'll see a 0000 key. Each of these GUID subkeys corresponds to a different display driver. Two of these have subkeys under 0000, one for the primary display and one for the secondary display. Find the one for the primary display, it will both have subkeys under 0000 and also have a "Device Description" value with a name that matches your Radeon card (and doesn't have "Secondary" in the Device Description).
4). If you've found the right GUID, when you select 0000 there should be a whole bunch of values under there.
5). Right click on the values pane and select New/Binary Value.
6). Set the name of the new value to be "DALR6 DFPUnderscan1920x1080x1920x1080x0x0"
7). Doubleclick on the new key to edit the value. An Edit Binary Value popup will appear. Type 00 sixteen times. Click OK.
8). Close regedit.
9). You may have to reboot and/or open Catalyst Control Center for the settings to "take."

This worked for an X1950 Pro with DVI out, a DVI to HDMI cable, going to an Onkyo receiver to a JVC RS1 projector.

I can confirm that this registry entry worked for me for both the 7.1 CATS and 7.5 CATS on a X1900XTX and a UK Sony Bravia KDL-40W2000 using DVI to HDMI cable!

I am now looking at 1:1 pixal mapping with no underscan and am able to directly select 60Hz in both the CCC and Windows own display settings.


Thanks Papasloth!

Joe
jedijoe is offline  
post #119 of 285 Old 06-19-2007, 11:44 AM
Senior Member
 
PapaSloth's Avatar
 
Join Date: Jan 2001
Location: Somerville, MA
Posts: 315
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by jedijoe View Post

I can confirm that this registry entry worked for me for both the 7.1 CATS and 7.5 CATS on a X1900XTX and a UK Sony Bravia KDL-40W2000 using DVI to HDMI cable!

I am now looking at 1:1 pixal mapping with no underscan and am able to directly select 60Hz in both the CCC and Windows own display settings.

Woohoo!
PapaSloth is offline  
post #120 of 285 Old 06-19-2007, 12:16 PM
Newbie
 
devguy's Avatar
 
Join Date: Jun 2007
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by PapaSloth View Post

I fixed the underscan issue on my machine with both Catalyst 7.4 and 7.5 on Windows XP MCE as follows:
1). Start/Run.../regedit
2). Open HKEY_LOCAL_MACHINE\\SYSTEM\\Current Control Set\\Contol\\Video
3). You'll see 5 or so subkeys labelled {hex number-hex number-etc.-} (a thirty-two digit GUID). Under each of these subkeys, you'll see a 0000 key. Each of these GUID subkeys corresponds to a different display driver. Two of these have subkeys under 0000, one for the primary display and one for the secondary display. Find the one for the primary display, it will both have subkeys under 0000 and also have a "Device Description" value with a name that matches your Radeon card (and doesn't have "Secondary" in the Device Description).
4). If you've found the right GUID, when you select 0000 there should be a whole bunch of values under there.
5). Right click on the values pane and select New/Binary Value.
6). Set the name of the new value to be "DALR6 DFPUnderscan1920x1080x1920x1080x0x0"
7). Doubleclick on the new key to edit the value. An Edit Binary Value popup will appear. Type 00 sixteen times. Click OK.
8). Close regedit.
9). You may have to reboot and/or open Catalyst Control Center for the settings to "take."

This worked for an X1950 Pro with DVI out, a DVI to HDMI cable, going to an Onkyo receiver to a JVC RS1 projector.

For this to fix underscan at 1440x900, would I make the binary/value
"DALR6 DFPUnderscan1440x900x1440x900x0x0" ?
devguy is offline  
Reply Home Theater Computers

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off