DScaler filters in 3.10...Can't really run any of them anymore - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 6 Old 11-03-2001, 09:33 PM - Thread Starter
AVS Special Member
 
Troubleshooter's Avatar
 
Join Date: Aug 2001
Location: Southern Cowhampshire
Posts: 1,670
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I can no longer run any of the filters without massive frame dropping since I upgraded to 3.10. This is on a 1GHz Athlon system under XP, Radeon VE video card and a wintv capture (same thing happening under 98 though). I really miss having the noise filter, it really worked well for me. Is there anything I can do to make them work again? I lose a constant 9 frames/sec the instant I turn any filters on. 0 dropped frames with them off no matter what deinterlacing mode is used. I played with priority settings to no avail. Any of you dscaler dev gods got any input on this? Please don't get me wrong here, DScaler still absolutley rules but I'm just whiney about losing my noise filter :) I just upgraded to the newest 3281 drivers from the 3276 drivers and it's still the same.
-Trouble
Troubleshooter is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 11-03-2001, 10:27 PM
AVS Addicted Member
 
trbarry's Avatar
 
Join Date: Jan 2000
Location: Gainesville FL USA
Posts: 10,138
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
DScaler's a bit more demanding this release but I'm still surprised you can't do that on your machine. Maybe try changing the Settings/Pixel Width to 640. And set Sleep_Interval to 0 in the dscaler.in file.

And of course the usual caveats about whatever else is running.

- Tom

Why don't we power our electric cars from greener, cheaper Liquid Fluoride Thorium Reactors?

Tom Barry - Find my video filters at www.trbarry.com
trbarry is offline  
post #3 of 6 Old 11-04-2001, 09:08 AM - Thread Starter
AVS Special Member
 
Troubleshooter's Avatar
 
Join Date: Aug 2001
Location: Southern Cowhampshire
Posts: 1,670
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Well I went through and cleaned house, turning off anything I could in msconfig, turning off the vnc controller in the system tray (not running vnc display regardless), setting sleep interval to 0 in the .ini file,and it's still the same. I tried setting all thread priorities to the highest settings as well. Also turned logging/debug level as low as posible and set pixel width to 640. Checking out the CPU, with no filters on, its at 39-42% CPU utilization, turning on any combination of filters (even turning all of them on) only brings utilization up to 43-48% utilization, so the CPU certainly isn't pegged, something else is up. It's gotta be something with my config since it is happening under 2 different OS's and (assumably) if nobody else is having problems. Just for grins, I fired up windvd in a window with dscaler still running (didn't think the overlay would do this anyway, but it did) and both played fine at the same time, 0DF/S in dscaler, cpu pretty much pegged at 98-100%, some tearing in windvd but still totally watchable and smooth (had to set dscaler thread priority back to normal of course). So I'm stumped, thanks for the input though
-Trouble
Troubleshooter is offline  
post #4 of 6 Old 11-04-2001, 01:31 PM
AVS Special Member
 
dschmelzer's Avatar
 
Join Date: Apr 2000
Location: Washington, D.C.
Posts: 2,641
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Trouble: have you flashed your CMOS with the latest? Have you upgraded your mobo drivers?

Dan
dschmelzer is online now  
post #5 of 6 Old 11-04-2001, 06:25 PM - Thread Starter
AVS Special Member
 
Troubleshooter's Avatar
 
Join Date: Aug 2001
Location: Southern Cowhampshire
Posts: 1,670
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Thanks for the input guys, fixed it! I updated to the latest via 4-in-1's (4.35) and the problem was instantly solved. I had the 4.33's in there which weren't really that old so I dunno what changed in them but something did. During this time, 3.09 had still worked fine so something specific to the dscaler changes must have been involved.. Thanks again, she's lookin wicked pissah (as we say round these here parts) now. 41% CPU util. solid with comb and noise filters on. Major kudos as always.
-Trouble
Troubleshooter is offline  
post #6 of 6 Old 11-05-2001, 09:25 AM
AVS Addicted Member
 
trbarry's Avatar
 
Join Date: Jan 2000
Location: Gainesville FL USA
Posts: 10,138
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Glad to hear it's fixed.

But I wanted to add a warning. Don't increase the priority of the processing thread with Sleep_Interval=0. If you get it higher than the priority of the Gui thread you can lock yourself out of the controls.

So leave it very low.

- Tom

Why don't we power our electric cars from greener, cheaper Liquid Fluoride Thorium Reactors?

Tom Barry - Find my video filters at www.trbarry.com
trbarry is offline  
Closed Thread Home Theater Computers

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off