MPC HC won't disable subtitle in mkv - AVS Forum
Forum Jump: 
 
Thread Tools
Old 10-09-2007, 12:04 PM - Thread Starter
Newbie
 
Spider2k7's Avatar
 
Join Date: Aug 2007
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hi Everybody,

i have a problem with my media player classic home cinema version under windows vista, when i select evr custom pres under output and activate direct 3d fullscreen (for removing tearing) and pixelshader 2.0, i can't disable any subtitle. everytime when i load a mkv-movie, i always see the subtitles, but i don't need them. what can do, to disable them?

i always looked for playback options and disabled auto-load subtitles, but nothing happend.
Spider2k7 is offline  
Sponsored Links
Advertisement
 
Old 10-09-2007, 12:20 PM
Senior Member
 
Wicked Klown's Avatar
 
Join Date: Feb 2007
Posts: 342
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
If the subtitles are hardcoded you will not be able to get rid of them. Seeing as you didn't say if they were I'm guessing they are.
Wicked Klown is offline  
Old 10-09-2007, 12:26 PM - Thread Starter
Newbie
 
Spider2k7's Avatar
 
Join Date: Aug 2007
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
they aren't hardcoded, because in the normal mpc i can disable them.
Spider2k7 is offline  
Old 10-09-2007, 12:37 PM
Member
 
blingo's Avatar
 
Join Date: Sep 2007
Posts: 142
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
In haali Media Splitter tray icon you can disable them in there. I had the same problem, and you dont need to use the direct 3d, if you use that it wont let you right click while the movie is playing. It doesn't effect the PQ. I was told this on doom9 forum.
blingo is offline  
Old 10-09-2007, 12:39 PM
Member
 
herm4n's Avatar
 
Join Date: Apr 2007
Location: old Europe
Posts: 24
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
maybe report your problem in this thread....

greets, riding herm4n
herm4n is offline  
Old 10-09-2007, 01:29 PM - Thread Starter
Newbie
 
Spider2k7's Avatar
 
Join Date: Aug 2007
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
well, i am not using haali, i use coreavc, is there an option to disable subtitles, too?

when i disable direct 3d, is the anti tearing option off too?
Spider2k7 is offline  
Old 10-09-2007, 02:42 PM
Advanced Member
 
trevisthomas's Avatar
 
Join Date: Sep 2001
Location: Saint Louis, MO, USA
Posts: 585
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Spider2k7 View Post

well, i am not using haali, i use coreavc, is there an option to disable subtitles, too?

when i disable direct 3d, is the anti tearing option off too?

I'd bet that you're using haali. CoraAVC wont split the video out of an mkv container. Haali does that and then coreAVC decompresses the x264 stream.

To see, just play an mkv and look at your task bar near the clock. If haali is running you''ll see the icon appear. Also, i'd bet that you're using DirectVobSub (vsfilter.dll) for the subtitles. It probably also appears near the clock. (it's a weird green arrow looking icon.)

You probably have the autoloading version of vsfilter registered on your box so whenever it sees subtitle content in the mkv it shows it. You should be able to configure it to come on when you want to use it but if not you can also unregister the vsfilter.dll component and then you'll never see subtitles.

the command to unregister it is something like

regsvr32 -u vsfilter.dll
trevisthomas is offline  
Old 10-09-2007, 03:52 PM - Thread Starter
Newbie
 
Spider2k7's Avatar
 
Join Date: Aug 2007
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
merci, i will test it tomorrow and report here, if it works or not.^^
Spider2k7 is offline  
Old 10-10-2007, 10:43 AM - Thread Starter
Newbie
 
Spider2k7's Avatar
 
Join Date: Aug 2007
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
well i looked for an icon in the task bar near the clock, during playing an mkv video, but there wasn't an icon from haali or else.

but i fixed the problem on my own way, i disabled direct3d to get into menu of mpc and than disabled the subtitles, after that i go back to direct3d with no subtitle in any movie.

so thank you all for helping me! :-)
Spider2k7 is offline  
Old 10-10-2007, 10:50 AM
AVS Special Member
 
arfster's Avatar
 
Join Date: Feb 2006
Posts: 2,919
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Spider2k7 View Post

well i looked for an icon in the task bar near the clock, during playing an mkv video, but there wasn't an icon from haali or else.

MPC has an internal mkv splitter, it'll use that by default.
arfster is offline  
Old 03-18-2009, 09:19 PM
Member
 
jb_alphamale's Avatar
 
Join Date: Apr 2007
Posts: 20
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
i disabled from Haali. It worked for me.Thank you blingo.
jb_alphamale is offline  
 
Thread Tools


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off