Disable stereo upmix on Realtek HD Audio? - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 6 Old 01-19-2008, 04:05 AM - Thread Starter
Advanced Member
 
Rigby Reardon's Avatar
 
Join Date: Jan 2007
Location: San Jose, CA
Posts: 970
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Possibly a stupid question: I have built a new media PC using the onboard Realtek ALC888 of the mainboard for audio. It's running under Windows XP. It is connected to my receiver via 5.1 analog connections, and the Windows speaker configuration is set to 5.1. The Realtek HD Audio is set as default DirectSound output device.

Now, whenever I play a stereo source via the default DirectSound Device, I get some sort of 5.1 upmix from all 6 speakers instead of just the fronts. But I would prefer to just get the pure, unprocessed stereo from the fronts. As far as I can tell, there are no additional DSound filters involved, so it seems the Realtek driver is doing the upmixing, or possibly some kind of HRTF filtering (I have of course set the "Environment" to "none" in the Realtek sound manager). Is there any way to turn this processing off?
Rigby Reardon is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 01-19-2008, 04:31 AM
Newbie
 
chungsters's Avatar
 
Join Date: Dec 2007
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Not sure what you are really asking? Do you just want a Stereo output? If so just change from 5.1 to Stereo for the front speakers. I run mine through the coaxial output from the (MB) to the receiver. I just change it to Stereo when I listen to CD's and change it back to 5.1 for movies...
chungsters is offline  
post #3 of 6 Old 01-19-2008, 04:54 AM - Thread Starter
Advanced Member
 
Rigby Reardon's Avatar
 
Join Date: Jan 2007
Location: San Jose, CA
Posts: 970
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by chungsters View Post

Not sure what you are really asking? Do you just want a Stereo output?

Yes. More generally, I want unprocessed output of the source material.
Quote:


If so just change from 5.1 to Stereo for the front speakers. I run mine through the coaxial output from the (MB) to the receiver. I just change it to Stereo when I listen to CD's and change it back to 5.1 for movies...

I would prefer not having to switch the speaker configuration back and forth depending on what material I want to play. If I output a stereo source, it should be played back as such regardless how many speakers are connected. I think an audio driver has no business mucking around with the source material unless it is explicitly told to do so.

Also, if this upmixing (or whatever it is) is applied to stereo, I assume it is also done to discrete multichannel sources, probably screwing up the imaging ...
Rigby Reardon is offline  
post #4 of 6 Old 01-19-2008, 05:22 AM
AVS Special Member
 
ES_Revenge's Avatar
 
Join Date: Jan 2007
Location: Toronto, ON Canada
Posts: 1,352
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 24 Post(s)
Liked: 22
I think Vista solves this problem... However I haven't actually tried analog output on my board yet, so I can't be sure. Sound handling in XP stinks compared to Vista though, I know that much.

I'm assuming that you also have S/PDIF on the receiver (I know there are some old-skool Pro-Logic receivers that had multi-channel input before built-in DD/DTS was popular but they are pretty old), so why not use optical/coaxial for stereo input and multi-channel analog for gaming, HD content, etc? I suppose that would still require switching your input mode or your input entirely, which would be almost as inconvenient... I know--I wish there was a way to turn off the optical output when using a program that does multi-channel analog but it seems there isn't
ES_Revenge is offline  
post #5 of 6 Old 01-19-2008, 06:52 AM - Thread Starter
Advanced Member
 
Rigby Reardon's Avatar
 
Join Date: Jan 2007
Location: San Jose, CA
Posts: 970
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Ok, after some fiddling, I have to take back my accusations against Realtek. Seems it is in fact not their driver, but some DirectShow filter that's screwing with my sound. If I directly select "Realtek HD Audio" as sound output device e.g. in Zoomplayer, it works fine and stereo is only output through the fronts. If I choose "Default Directsound Device" (which in turn is set to "Realtek HD Audio") I get the upmix again. Now I'm totally confused. Does anybody have an idea how to find out what is manipulating the sound? All this Directsound graph business is confusing as heck ...
Rigby Reardon is offline  
post #6 of 6 Old 01-20-2008, 08:53 PM
Newbie
 
rprice99's Avatar
 
Join Date: Jan 2008
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Quote:
Originally Posted by Rigby Reardon View Post

Possibly a stupid question: I have built a new media PC using the onboard Realtek ALC888 of the mainboard for audio. It's running under Windows XP. It is connected to my receiver via 5.1 analog connections, and the Windows speaker configuration is set to 5.1. The Realtek HD Audio is set as default DirectSound output device.

Hi There...what are you using exactly for you analog connections?

This is made specifically for a creative card...but will this work or do you use something else?

http://us.creative.com/products/prod...&product=14309
rprice99 is offline  
Reply Home Theater Computers

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off