Mackie 450 SRM - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 2 Old 02-13-2010, 04:31 AM - Thread Starter
Newbie
 
trixime's Avatar
 
Join Date: Feb 2010
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hi there i dont really know alot about speakers but 1 of my 450's doesnt sound right some1 has told me the driver has possibly gone but my sister has looked at the round circle bit and it seems in tact...could it possibly be the Amp?? i'm confused and dont want to be ripped off by a shop as i dont really know what the problem is any help would be grateful xx
trixime is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 02-13-2010, 06:59 AM
Newbie
 
djrob1208's Avatar
 
Join Date: Dec 2007
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I don't post here but I used to be a mobile dj and have used the 450s in the past.

Can you describe what you mean by "doesn't sound right"? Does the bass or highs sound distorted? does it make a sound at all? kind of hard to say since it can be anything at this point.
djrob1208 is offline  
Reply Tweaks and Do-It-Yourself

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off