How to connect an interconnect cable? - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 3 Old 01-16-2013, 01:52 PM - Thread Starter
Newbie
 
s210's Avatar
 
Join Date: Dec 2012
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I have just purchased a pair of microlab speakers. I have managed to get one working but the other is not. I suspect this is due to the fact that they connect via interconnect speaker cables which I have never seen before.



The above image is the picture of the back of my speakers. The interconnect speaker cable is in the image below.



It is the one with the plastic coating to the end. In the instructions manual it says connect it to the red and black screw bits. I am not sure if I am supposed to insert it from the back of the screws or from above/under. From the back, It does not hold at all and from above/under, the second speaker does not work.

Any help would be appreciated.
s210 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 01-16-2013, 02:09 PM
Advanced Member
 
dharel's Avatar
 
Join Date: Dec 2002
Location: The Isle of Long
Posts: 505
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Liked: 33
That's standard speaker wire and speaker posts. You need to strip the wire so that it looks like the one on the bottom. Unscrew the speaker terminals, put the wire in and tighten back down.
dharel is offline  
post #3 of 3 Old 01-18-2013, 02:01 PM
Senior Member
 
justtaint's Avatar
 
Join Date: Jun 2003
Location: Chicago
Posts: 386
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Definitely make sure you strip the insulator back to expose the wire. That may be why you're not getting any sound.

Tom
justtaint is offline  
Reply Tweaks and Do-It-Yourself

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off