My Batcave - MA rack, Rives designed room - Page 17 - AVS Forum
Forum Jump: 
Reply
 
Thread Tools
post #481 of 527 Old 04-10-2011, 07:05 AM - Thread Starter
AVS Club Gold
 
Mike_WI's Avatar
 
Join Date: Mar 2008
Location: SE Wisconsin
Posts: 2,510
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Quote:
Originally Posted by jim tressler View Post

mike - your theater looks fantastic! job well done..
I have an odd question - similar to what I asked husker - it looks like you have covered a utility box behind your screen - is is possible to get some close up pics of how it was done?

thanks

jim

Jim -

Here are some pics of the cabinet behind my false front wall.
This allows access easily to electrical, cable, ethernet, phone.

Mike
LL
LL
LL
LL
LL
Mike_WI is offline  
Sponsored Links
Advertisement
 
post #482 of 527 Old 04-23-2011, 04:08 AM
CIH USER
 
Franin's Avatar
 
Join Date: Aug 2007
Location: Western Australia
Posts: 17,439
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 220 Post(s)
Liked: 259
Happy Easter Mike_WI

_________________________

Frank
Franin is offline  
post #483 of 527 Old 04-23-2011, 04:09 AM
AVS Special Member
 
jim tressler's Avatar
 
Join Date: Apr 2004
Posts: 2,101
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 15
Mike - Much appreciated !! thanks!

Quote:
Originally Posted by Mike_WI View Post

Jim -

Here are some pics of the cabinet behind my false front wall.
This allows access easily to electrical, cable, ethernet, phone.

Mike

jim tressler is offline  
post #484 of 527 Old 04-23-2011, 06:39 AM - Thread Starter
AVS Club Gold
 
Mike_WI's Avatar
 
Join Date: Mar 2008
Location: SE Wisconsin
Posts: 2,510
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Quote:
Originally Posted by Franin View Post

Happy Easter Mike_WI

Thanks.
Happy Easter to yo and your family as well.

Mike
Mike_WI is offline  
post #485 of 527 Old 04-23-2011, 06:43 AM - Thread Starter
AVS Club Gold
 
Mike_WI's Avatar
 
Join Date: Mar 2008
Location: SE Wisconsin
Posts: 2,510
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Quote:
Originally Posted by jim tressler View Post

Mike - Much appreciated !! thanks!

No problem.
Good luck with your projects.

Mike
Mike_WI is offline  
post #486 of 527 Old 05-09-2011, 08:16 PM
AVS Special Member
 
UNICRON-WMD's Avatar
 
Join Date: Jan 2005
Location: Milwaukee, WI
Posts: 1,822
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 12
Hey man, great theater. You seem to upgrade alot too.

Do you ever have meet ups?

God loves me, but everyone else thinks I'm an a$$hole.
My small dedicated theater.
UNICRON-WMD is offline  
post #487 of 527 Old 05-10-2011, 03:34 AM - Thread Starter
AVS Club Gold
 
Mike_WI's Avatar
 
Join Date: Mar 2008
Location: SE Wisconsin
Posts: 2,510
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Quote:
Originally Posted by UNICRON-WMD View Post

Hey man, great theater. You seem to upgrade alot too.

Do you ever have meet ups?

Hi.
I haven't upgraded in a while.
Nothing new and fancy for people to see in the last few years.
I'll try to let you know if we do something.
My HT is highlighted in the AVS video DVD series. I forget which DVD #, but there should be a link above.

You might also check out SOWK's build thread on AVS for another Milwaukee area HT build (that is ongoing).

Mike
Mike_WI is offline  
post #488 of 527 Old 06-29-2011, 03:11 PM - Thread Starter
AVS Club Gold
 
Mike_WI's Avatar
 
Join Date: Mar 2008
Location: SE Wisconsin
Posts: 2,510
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Around 1440 hours on JVC RS20 projector.
Decided to order a replacement lamp from AVS.
Surprised to find out that Jason Turk isn't around anymore.

Mike
Mike_WI is offline  
post #489 of 527 Old 06-29-2011, 07:31 PM
AVS Club Gold
 
Happytobehere200's Avatar
 
Join Date: Jun 2006
Location: Geneva, IL
Posts: 441
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Really? Wow, what a bummer. Economy is hitting everyone. Well everyone that doesn't run.... Sorry, couldn't resist...
Happytobehere200 is offline  
post #490 of 527 Old 06-30-2011, 01:51 PM - Thread Starter
AVS Club Gold
 
Mike_WI's Avatar
 
Join Date: Mar 2008
Location: SE Wisconsin
Posts: 2,510
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Quote:
Originally Posted by Happytobehere200 View Post

Really? Wow, what a bummer. Economy is hitting everyone. Well everyone that doesn't run.... Sorry, couldn't resist...

HTBH200 -

I don't know the reason.
Just that Jason isn't at AVS anymore.

Now I need to do some FW updates for Lumagen Radiance in the future -- well, at least before next calibration. I guess I need to wait for this lamp to run out.

Mike
Mike_WI is offline  
post #491 of 527 Old 07-11-2011, 02:27 PM
 
TheHills44060's Avatar
 
Join Date: Feb 2011
Location: Cleveland, OH
Posts: 72
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Just read this thread from start to finish. Very impressed with all of the dedication you put into it unfortunately the cheap Emotiva gear kills it for me. Hopefully you upgrade soon and take advantage of all your hard work.
TheHills44060 is offline  
post #492 of 527 Old 07-13-2011, 07:28 AM - Thread Starter
AVS Club Gold
 
Mike_WI's Avatar
 
Join Date: Mar 2008
Location: SE Wisconsin
Posts: 2,510
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Quote:
Originally Posted by TheHills44060 View Post

Just read this thread from start to finish.
Very impressed with all of the dedication you put into it unfortunately the cheap Emotiva gear kills it for me.
Hopefully you upgrade soon and take advantage of all your hard work.


What do you mean?
Are you suggesting that I would notice a difference in my home theater enjoyment if I had a more expensive 3 channel external amplifier?
Really?

Emotiva may not be the most expensive equipment (so...) and may have problems with their processors, but I have heard very few complaints about their amplifiers.

Want to expand on that?

Mike
Mike_WI is offline  
post #493 of 527 Old 07-25-2011, 02:50 PM
AVS Special Member
 
SOWK's Avatar
 
Join Date: Dec 2004
Location: Wauwatosa, WI
Posts: 4,072
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 212 Post(s)
Liked: 124
Quote:
Originally Posted by Mike_WI View Post



What do you mean?
Are you suggesting that I would notice a difference in my home theater enjoyment if I had a more expensive 3 channel external amplifier?
Really?

Emotiva may not be the most expensive equipment (so...) and may have problems with their processors, but I have heard very few complaints about their amplifiers.

Want to expand on that?

Mike

Don't worry about it too much Mike, can't please them all.
SOWK is offline  
post #494 of 527 Old 09-11-2011, 07:14 AM
AVS Special Member
 
SOWK's Avatar
 
Join Date: Dec 2004
Location: Wauwatosa, WI
Posts: 4,072
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 212 Post(s)
Liked: 124
SOWK is offline  
post #495 of 527 Old 09-11-2011, 07:17 AM - Thread Starter
AVS Club Gold
 
Mike_WI's Avatar
 
Join Date: Mar 2008
Location: SE Wisconsin
Posts: 2,510
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Quote:
Originally Posted by SOWK View Post

Have you changed the lamp on the rs20 yet?

No. Not yet.
Lamp still working.
I realized that I can't do it "in situ" with the pillar behind the projector.
Really busy summer, so may do it some cold day this fall/winter when not much to do outside.

I will likely replace, update Lumagen Radiance FW, and after 100+ hours get it re-calibrated.

Have you checked out any of the new JVC projectors?
I know you are building.

I have no big desire to upgrade anything for a while except for a remote/integration setup -- and/or a house hard drive or something.

Mike
Mike_WI is offline  
post #496 of 527 Old 08-17-2012, 06:00 AM - Thread Starter
AVS Club Gold
 
Mike_WI's Avatar
 
Join Date: Mar 2008
Location: SE Wisconsin
Posts: 2,510
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Dug up this thread because NOW I am replacing the lamp.
I was going to look for the link for cleaning inside projector if I can find it...

Mike
Quote:
Originally Posted by SOWK View Post

Have you changed the lamp on the rs20 yet?

Quote:
Originally Posted by Mike_WI View Post


No. Not yet.

Lamp still working.

I realized that I can't do it "in situ" with the pillar behind the projector.

Really busy summer, so may do it some cold day this fall/winter when not much to do outside.


I will likely replace, update Lumagen Radiance FW, and after 100+ hours get it re-calibrated.


Have you checked out any of the new JVC projectors?

I know you are building.


I have no big desire to upgrade anything for a while except for a remote/integration setup -- and/or a house hard drive or something.


Mike
Mike_WI is offline  
post #497 of 527 Old 08-17-2012, 06:16 AM - Thread Starter
AVS Club Gold
 
Mike_WI's Avatar
 
Join Date: Mar 2008
Location: SE Wisconsin
Posts: 2,510
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Found this:

http://www.avsforum.com/t/1290294/jvc-dla-rs20u-owners-thread

http://www.avsforum.com/t/1096981/official-jvc-rs20-hd750-calibration-and-cms-thread


Good info about cleaning the "prism" assembly to improve/restore brightness levels:
http://www.avsforum.com/avs-vb/showthread.php?t=1223098


post #342 of 723 10/20/10 bches:
Quote:
Unscrew the two small screws on the plastic cover on the rear, then the two screws that hold the lens assembly in.
After unscrewing these, pull the handle on the lens assembly to remove it, and you will see the prism inside (it is stationary--don't try to remove it!).
You can reach it with a lens cloth over a finger, or you can use the eraser end of a pencil covered by the lens cloth.
Quote:
I just read about a piece of advice I hadn't seen before that might be of use: Wear latex gloves when doing this (or just when replacing a bulb). The grease from one's hands can harm the optical components, when it gets superheated, causing cracks or more severe structural integrity problems, apparently.
Quote:
Yes, it's very important to keep finger oils off high temp glass surfaces and gloves may be a good method.
Oils cause differential heating and different expansion rates can cause a bulb to fail.
The prism should be OK, though you'll want to clean everything off it regardless.
Quote:
...I cleaned my RS-20 rear optics again today, 7/9, and there was a definite reappearance of more residue, which was visible under flashlight, and which again cleaned off easily with a dry microfiber cloth. Appearance was cloudy, film layer upon the rear internal optics, and, as before, there was none visible on the front lamp protective glass. Last cleaned mine on 4/27, per previous post. I have no way of measuring resulting luminance improvement. What the heck is this stuff? And, I wonder if it is unique to JVC's design, or is the problem more universal?

millerwill:
Quote:
Only twice, and you motivated me to go back and look at the numbers:

1st cleaning (1300 hrs on lamp) ==> 115% increase in lumens
2nd cleaning (1830 hrs on lamp) ==> 55% increase

The values are all for low lamp mode, though the %'s were about the same in high lamp.


post #396 of 723 10/28/10 pepar:
http://www.avsforum.com/t/1223098/please-post-experience-of-jvc-hd750-350-550-950-bulb-lifetime-lamp-brightness-drop/390#post_19405330
Quote:
Hazy prism and flake of "debris" stuck to it (staticly?) The debris was removed and looked like part of the frame had cracked (lower left).

Second prism image is after one swipe with a lens cleaning pad.

Third image is prism completely cleaned. Night and day looking at the prism and night and day looking at the image projected.



Mike_WI is offline  
post #498 of 527 Old 08-17-2012, 07:27 AM - Thread Starter
AVS Club Gold
 
Mike_WI's Avatar
 
Join Date: Mar 2008
Location: SE Wisconsin
Posts: 2,510
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Got cleaned and installed.

Backing down to standard (non-high) brightness setting.
Figured out the lamp re-zeroing key sequence.


Pic of prism:


Pic of old and new lens:
Mike_WI is offline  
post #499 of 527 Old 09-10-2012, 07:29 AM - Thread Starter
AVS Club Gold
 
Mike_WI's Avatar
 
Join Date: Mar 2008
Location: SE Wisconsin
Posts: 2,510
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Much brighter.
Still need to calibrate.

My To Do List:
- watch more movies to up hours on new lamp
- d-load new RadianceXE FW
http://www.lumagen.com/testindex.php?module=radiancexe_updates
- look at Oppo BDP-103/105 Blu Ray players:
http://www.avsforum.com/t/1428214/official-oppo-bdp-103-bdp-105-anticipation-thread/150
Mike_WI is offline  
post #500 of 527 Old 09-11-2012, 10:57 AM
AVS Special Member
 
SOWK's Avatar
 
Join Date: Dec 2004
Location: Wauwatosa, WI
Posts: 4,072
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 212 Post(s)
Liked: 124
SOWK is offline  
post #501 of 527 Old 09-11-2012, 11:01 AM - Thread Starter
AVS Club Gold
 
Mike_WI's Avatar
 
Join Date: Mar 2008
Location: SE Wisconsin
Posts: 2,510
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Quote:
Originally Posted by SOWK View Post

Who are you having do the calibration?

Craig Rounds did it last time.

Excerpt from my post#1
Quote:
Projector: JVC RS20 1080p
-- FW: v1.1 updated 5/9/09
-- Calibrated by Craig Rounds (w/ Lumagen RadianceXE on 5/16/09) and _____ (update)
-- on 8/29/10 @ JVC RS20 937 hours - bumped up lamp to "high" mode and turned apeture from 0 to -3.
-- HDMI -> Enhanced, 4:2:2 (see video processor settings below)
Video processor: Lumagen RadianceXE
-- FW (XE update link): (Updated: 4-xx-11) -
Production 021611 FW-
-- Settings:
--- HDMI: enhanced, 4:2:2 - Notes on HDMI: recommended enhanced-- nathan_h rec - link - "...set the projector to enhanced (computer) levels (not AUTO) -- and adjust the brightness control on the projector to the point where the pluge pattern on your calibration patterns looks correct. I find this more reliable than choosing "normal" video HDMI in the RS20 menus, and more predictable than using AUTO, and is the way gregr recommends setting up the unit in the WSR review. Other people prefer to set the HDMI level to 'normal' on the projector, too -- but since that clips blacker-than-black levels, setting the right brightness is tougher -- and the end result, for me, was not only less accurate but also less pleasing."
--- Gamma: 2.28 -- (Note, in "The Rogers Report" on the JVC RS20 in Widescreen Review Jul/Aug 2009, Issue 141, p. 21 -- He used a 2.4 gamma.)
--- Cable "Input 1A" set to "Video" -- See Dave G Recs (link & explanation) -- Deinterlacing: Menu -> Input x -> Video Setup -> (choose resolution) -> Control -> Deint -> Mode (Video)
-- Other XE/RS20 measurements -- see link & subsequent post
Mike_WI is offline  
post #502 of 527 Old 09-12-2012, 05:18 AM
AVS Special Member
 
SOWK's Avatar
 
Join Date: Dec 2004
Location: Wauwatosa, WI
Posts: 4,072
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 212 Post(s)
Liked: 124
SOWK is offline  
post #503 of 527 Old 09-12-2012, 05:29 AM - Thread Starter
AVS Club Gold
 
Mike_WI's Avatar
 
Join Date: Mar 2008
Location: SE Wisconsin
Posts: 2,510
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Quote:
Originally Posted by SOWK View Post

You can still hire me if you would like.
Roger roger.
Craig has a lot of experience with the Lumagen/JVC combo.
I appreciate your good eye and have some friends with or starting to set up HT's that might not need/want the full calibration with gear expense.
Have you gotten any new calibration gear?

What is ETA (???) on your new JVC projector -- Dec? Jan?

Thanks.

Mike
Mike_WI is offline  
post #504 of 527 Old 09-12-2012, 08:33 AM
AVS Special Member
 
SOWK's Avatar
 
Join Date: Dec 2004
Location: Wauwatosa, WI
Posts: 4,072
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 212 Post(s)
Liked: 124
Quote:
Originally Posted by Mike_WI View Post

Roger roger.
Craig has a lot of experience with the Lumagen/JVC combo.
I appreciate your good eye and have some friends with or starting to set up HT's that might not need/want the full calibration with gear expense.
Have you gotten any new calibration gear?
What is ETA (???) on your new JVC projector -- Dec? Jan?
Thanks.
Mike

I did get some new calibration gear.

ChromaPure Software
Display 3
I reference it to my I1 Pro.

I will be getting the new JVC late Nov. or early Dec.
SOWK is offline  
post #505 of 527 Old 09-12-2012, 08:36 AM
AVS Special Member
 
SOWK's Avatar
 
Join Date: Dec 2004
Location: Wauwatosa, WI
Posts: 4,072
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 212 Post(s)
Liked: 124
Before you hire Craig, you should come over and see what a SOWK Setup / Calibration can be like... wink.gif
SOWK is offline  
post #506 of 527 Old 09-12-2012, 10:30 AM
AVS Special Member
 
HuskerOmaha's Avatar
 
Join Date: Sep 2010
Location: Omaha
Posts: 2,171
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 13 Post(s)
Liked: 34
Quote:
Originally Posted by SOWK View Post

I did get some new calibration gear.
ChromaPure Software
Display 3
I reference it to my I1 Pro.
I will be getting the new JVC late Nov. or early Dec.


And your old projector goes.................?
HuskerOmaha is offline  
post #507 of 527 Old 09-12-2012, 10:37 AM
AVS Special Member
 
SOWK's Avatar
 
Join Date: Dec 2004
Location: Wauwatosa, WI
Posts: 4,072
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 212 Post(s)
Liked: 124
What one... lol.

Over the Last year I have had the:

Samung A900B
Sony VPL-VW95ES
JVC RS-55
BenQ W7000
Mitsubsihi 9000D

All are sold at this point.


I am buying a BenQ W6000 as a temp projector that I will not sell, and keep if I switch between projectors.

I think I will be keeping the JVC RS48 for over a year though.

I wanted to see what each manufacurer was capible of and choose the best for me in the end.
SOWK is offline  
post #508 of 527 Old 09-13-2012, 07:36 PM - Thread Starter
AVS Club Gold
 
Mike_WI's Avatar
 
Join Date: Mar 2008
Location: SE Wisconsin
Posts: 2,510
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
Wow.

Much new after a long no new FW period...

Beta 090412- NEW 125 point CMS added! -- 'Official RadianceXD support thread' updated
http://www.lumagen.com/testindex.php?module=radiancexe_updates

Beta 090412- NEW 125 point CMS added!
That's a 5x5x5 matrix for color correction and calibration. A big upgrade from our previous 8 point matrix which allowed calibration from only the corners of the color cube. The new 125 point gamut has it's calibration points located at 0, 25, 50, 75,100% of video min/maximums. The older 8 point gamut was located at digital min/maximums which did not give quite as much precision. Previous calibration values in the CMS gamut menu are interpolated to the new gamut locations so the numbers displayed in the menu will be different. This doesn't change your previously performed calibration results. Instead, the changed values represent the same calibration but from the new gamut locations. You now have the option of calibrating with 8 or 125 points. If you perform an 8 point calibration you can change to the 125 point mode and keep the previously set 8 points. The other 117 points are interpolated from the original 8 when changing from 8 to 125 point mode. With this many points to adjust, auto calibration software from SpectraCal and ChromaPure really helps. They have both added support for our new 125 point gamut with excellent results. Note: We are in the process of updating the Configuration Utility to support backing up the new 125 point gamut data to a PC via rs232. This should be available by tomorrow.
Gamma correction: Range has been extended and can now be adjusted in steps of .01.
Test Patterns: Added 2.35 letterbox geometry overscan pattern.
Bugfixes,etc: Problems with Top/Btm 3D formats to Frame Packed and Frame Sequential output was fixed. An issue of using test patterns with certain settings not restoring the input aspect was fixed. Improvement to output setup menu allows multiple changes within the command to be performed more easily. Added sending 601/709 color information needed by Darbee Darblets with firmware before 2.8.2214. Added a direct command to globally disable video on output 1, "menu 0985". Other small fixes and improvements were also made.
Mike_WI is offline  
post #509 of 527 Old 12-17-2012, 09:33 AM - Thread Starter
AVS Club Gold
 
Mike_WI's Avatar
 
Join Date: Mar 2008
Location: SE Wisconsin
Posts: 2,510
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 11
I switched from Time Warner Cable to DirectTV "whole house" DVR with 5 channels of recording.
Lowered monthly cost and better interface, iPhone apps, etc.

To Do List for Dec/Jan includes:
Lumagen Radiance XE Firmware update
JVC RS20 re-calibration (now >100 hours on it)
Repair UPS for HT rack
Clean up rack with Direct TV much smaller receiver -- RSH4A2S DIRECTV C31700
Thinking about BDP-103

If I don't check in again, Happy Holidays all.

Mike
Mike_WI is offline  
post #510 of 527 Old 12-19-2012, 06:55 PM
AVS Special Member
 
tbraden32's Avatar
 
Join Date: Apr 2010
Location: Cicleville, OH
Posts: 1,177
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Mike,

I thought of doing that same switch, TW to Direct. I have heard horror stories of Direct and their service. TW has always been fairly good, but they are more expensive especially if you have multiple HD boxes.

Let me know your thoughts on Direct after a while of using them.

Thanks

tbraden32 is offline  
Reply What's Your System Configuration

Tags
Emotiva Xpa 3 Amplifier , Denon Avr 5308ci Receiver , Oppo , Oppo Bdp 103 3d Blu Ray Player , Svs Pb12 Nsd Black Vinyl 12 Inch Powered Subwoofer , Sony Bravia Ex700 Series 60 Inch Lcd With Led Back Lighting Hdtv Kdl 60ex700 , Samsung Bd P2550 1080p Blu Ray Disc Player
Gear in this thread - Ex700 by PriceGrabber.com

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off