Gorilla83's Humble Basement Hangout - Page 7 - AVS Forum
Forum Jump: 
Reply
 
Thread Tools
post #181 of 979 Old 02-24-2013, 09:48 PM
Advanced Member
 
SeekingNirvana's Avatar
 
Join Date: Dec 2012
Location: Santa Cruz California
Posts: 710
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 74 Post(s)
Liked: 85
Trick of the trade......rub baby powder all over any exposed skin. This will make it so the fiberglass can't get into your pores.

My dual sealed LMS 5400 Ultra build
http://www.avsforum.com/forum/155-di...0-build-4.html
SeekingNirvana is online now  
Sponsored Links
Advertisement
 
post #182 of 979 Old 02-25-2013, 05:04 AM
Advanced Member
 
blah450's Avatar
 
Join Date: Jan 2010
Posts: 910
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 32 Post(s)
Liked: 119
Rilla....I only proposed what I did thinking that perhaps treating half the ceiling might be a compromise between full-out black and keeping area as general purpose?
I know the nearest 50% still made a significant performance enhancement with my screen/projector.
blah450 is offline  
post #183 of 979 Old 02-25-2013, 05:44 AM - Thread Starter
AVS Special Member
 
Gorilla83's Avatar
 
Join Date: Aug 2011
Location: Delaware County, PA
Posts: 3,592
Mentioned: 40 Post(s)
Tagged: 0 Thread(s)
Quoted: 277 Post(s)
Liked: 412
Quote:
Originally Posted by SeekingNirvana View Post

Trick of the trade......rub baby powder all over any exposed skin. This will make it so the fiberglass can't get into your pores.

Great tip, thanks! I used up all that I purchased and have probably a little more than 2/3 of the space I want to treat done. I wore long sleeves, a sweatshirt, gloves, dust mask, and safety glasses when I could keep them from fogging up. biggrin.gif I'll give the baby powder a try next time. biggrin.gif
Quote:
Originally Posted by blah450 View Post

Rilla....I only proposed what I did thinking that perhaps treating half the ceiling might be a compromise between full-out black and keeping area as general purpose?
I know the nearest 50% still made a significant performance enhancement with my screen/projector.

I've been thinking about the ceiling some more and I'm thinking I might frame out an area that would cover 4-5' back from the screen that I could cover entirely with velvet or something like that. Something that could be easily removable in the event I want/need to, you know? I really don't want to paint the existing tracks - they can be a PITA to remove should I want to replace them with white tracks again. I like what Carp had done - basically extend a solid piece of velvet back from his screen frame at a slight angle to the ceiling. I'm thinking a framed variation of that might work out well and let me experiment with different approaches.
Gorilla83 is online now  
post #184 of 979 Old 02-25-2013, 05:52 AM
Senior Member
 
RyanA3's Avatar
 
Join Date: Mar 2006
Location: Philaburbia
Posts: 342
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 19 Post(s)
Liked: 18
No more pics of insulation. I was itchy for hours.

Photo Tour of my home - 2ch, 3.1, & 5.1 builds 
But a whole new house is getting wired now!
New media room shaping up: Sony XBR70X850B 4K, Denon AVR-X4100W, Studio 60s
Thanks to all the AVS members. This is a great community.
RyanA3 is offline  
post #185 of 979 Old 02-25-2013, 06:50 AM - Thread Starter
AVS Special Member
 
Gorilla83's Avatar
 
Join Date: Aug 2011
Location: Delaware County, PA
Posts: 3,592
Mentioned: 40 Post(s)
Tagged: 0 Thread(s)
Quoted: 277 Post(s)
Liked: 412
Quote:
Originally Posted by RyanA3 View Post

No more pics of insulation. I was itchy for hours.

I will grab some when I pick up the next bag. I was too anxious to get a shower after I was done cleaning up to take more pics, LOL! I haven't done any measurements yet, but the room does sound pretty awesome so far. It also seemed to help tame some more vibrations too which is a big plus. biggrin.gif
Gorilla83 is online now  
post #186 of 979 Old 02-25-2013, 11:59 AM
Senior Member
 
foraye's Avatar
 
Join Date: Dec 2003
Location: PA
Posts: 219
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 21
Quote:
Originally Posted by Gorilla83 View Post

So Box #3 is ready for the drivers and Box #4 is in the finishing stages. Austin (popalock) actually constructed the last box for use in yesterday's GTG. He had been attempting to procure 2 of the new SI 18's but unfortunately those did not get to us in time for the test. The good news is that he built it to my specs so that I could use it after the day was done. Thanks Austin! biggrin.gif The next 4 drivers were ordered yesterday morning. I'm hoping to have these boxes finished, alive, and kicking in another 7-10 days. Update: Just got shipping confirmation from PE, woot! They showed out of stock right after I ordered so maybe I got the last batch? smile.gif

Last night I started on the finishing process. The roundovers are done, and I've started sanding and filling in some voids that were present on the edges.


Can you please share the specifications on that box? Are you using SI D2 or D4 18"?

Thanks
foraye is online now  
post #187 of 979 Old 02-25-2013, 12:24 PM - Thread Starter
AVS Special Member
 
Gorilla83's Avatar
 
Join Date: Aug 2011
Location: Delaware County, PA
Posts: 3,592
Mentioned: 40 Post(s)
Tagged: 0 Thread(s)
Quoted: 277 Post(s)
Liked: 412
I'm using the Dayton 18" HO Drivers. Full details of the build are here:

http://www.avsforum.com/t/1435795/first-diy-project-for-a-guy-looking-to-upgrade-multiple-sealed-18s

Box is 23wx25hx28.75d for a total of just under ~7 net cubes.
Gorilla83 is online now  
post #188 of 979 Old 03-06-2013, 06:12 AM - Thread Starter
AVS Special Member
 
Gorilla83's Avatar
 
Join Date: Aug 2011
Location: Delaware County, PA
Posts: 3,592
Mentioned: 40 Post(s)
Tagged: 0 Thread(s)
Quoted: 277 Post(s)
Liked: 412
Couple updates:

Finally did some listening this morning since the ceiling has been treated. Wow. It's probably been a few weeks since I've done any critical listening but the bottom end sounds even better than before. It seems like there is even more output now. Man, I <3 my LFE setup.

I've begun the planning stages for my false wall/AT screen. I may start gathering materials in the next few weeks, but I'm going to hold off final construction until after the April 13th GTG at my place in case there are any complications. It will probably also be easier to swap speakers in/out throughout the day if we don't have to go behind the wall each time. With that said, if anyone is up for doing some 1:1 blind testing after April, let me know. smile.gif

I'm thinking the screen/wall will be 25" or so out from the back wall. I'm moving to a 130" screen (DIY of course) using the Seymour XD fabric. Chris Seymour has been a pleasure to work with so far and has been very helpful in thinking through all the aspects of the build. More info to come soon. cool.gif

I've also begun building some surrounds to match the SEOS front stage. I'm in the process of designing/testing crossovers for them now, but the boxes are built for 2 of them now and ready to be wired, stuffed, and finished.



I'm also thinking of upgrading my dedicated line to the subwoofer amplifier to 30A and building a relay box to turn it on/off via the 12V trigger.
Gorilla83 is online now  
post #189 of 979 Old 03-06-2013, 06:42 AM
AVS Special Member
 
JimWilson's Avatar
 
Join Date: Oct 2010
Location: Somewhere in New Joisey
Posts: 4,786
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 284 Post(s)
Liked: 431
Every time I turn around you're on to some other HT project. Do you ever sleep? Is this the male version of "nesting" perhaps? biggrin.gif

If you take yourself too seriously expect me to do the exact opposite
JimWilson is offline  
post #190 of 979 Old 03-06-2013, 09:10 AM - Thread Starter
AVS Special Member
 
Gorilla83's Avatar
 
Join Date: Aug 2011
Location: Delaware County, PA
Posts: 3,592
Mentioned: 40 Post(s)
Tagged: 0 Thread(s)
Quoted: 277 Post(s)
Liked: 412
Quote:
Originally Posted by JimWilson View Post

Every time I turn around you're on to some other HT project. Do you ever sleep? Is this the male version of "nesting" perhaps? biggrin.gif

Actually I'm pretty bad at sleeping, heh. As soon as one project ends my ADD kicks in and I need to start something new. I think I've pissed the wife off enough by spending so much in the last few months, maybe someone else should give me a project to do. biggrin.gif I actually volunteered to help a buddy with his theater (and some DIY stuff) so that should keep me tied up soon.
Gorilla83 is online now  
post #191 of 979 Old 03-06-2013, 09:30 AM
AVS Special Member
 
JimWilson's Avatar
 
Join Date: Oct 2010
Location: Somewhere in New Joisey
Posts: 4,786
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 284 Post(s)
Liked: 431
Get it out of your system now; once that little chimp or chimpette comes you're going to have your paws full. tongue.gif

Maybe I'll have you build me a sub cabinet. There are a few drivers I've been eyeing myself, but the only thing I can make is a mess. Although now that O Audio bit the dust I no longer have the amp I wanted to use.

If you take yourself too seriously expect me to do the exact opposite
JimWilson is offline  
post #192 of 979 Old 03-06-2013, 11:14 AM - Thread Starter
AVS Special Member
 
Gorilla83's Avatar
 
Join Date: Aug 2011
Location: Delaware County, PA
Posts: 3,592
Mentioned: 40 Post(s)
Tagged: 0 Thread(s)
Quoted: 277 Post(s)
Liked: 412
Quote:
Originally Posted by JimWilson View Post

Get it out of your system now; once that little chimp or chimpette comes you're going to have your paws full. tongue.gif

Maybe I'll have you build me a sub cabinet. There are a few drivers I've been eyeing myself, but the only thing I can make is a mess. Although now that O Audio bit the dust I no longer have the amp I wanted to use.

Yeah, I guess it's best to try to burn myself out of this stuff before August comes around. wink.gif I can guarantee I could help you make a box to whatever specs you want.

P.S. - My router jig only works for 18" drivers. Guess you will have to use that. Just kidding. biggrin.gif
Gorilla83 is online now  
post #193 of 979 Old 03-06-2013, 12:10 PM
AVS Special Member
 
JimWilson's Avatar
 
Join Date: Oct 2010
Location: Somewhere in New Joisey
Posts: 4,786
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 284 Post(s)
Liked: 431
Quote:
Originally Posted by Gorilla83 View Post

P.S. - My router jig only works for 18" drivers. Guess you will have to use that. Just kidding. biggrin.gif

18" drivers are for whimps. I wanted to build something using one of these! wink.gif

If you take yourself too seriously expect me to do the exact opposite
JimWilson is offline  
post #194 of 979 Old 03-06-2013, 02:36 PM
Member
 
NickThatStands's Avatar
 
Join Date: Feb 2013
Location: Ocala, FL
Posts: 186
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 12
Pheww!!! Well, today was a productive day at the office.. I read all the way through this thread smile.gif AWESOME setup! Im incredibly jealous. I was reading around because I was looking for a subwoofer for my ghetto system. Im a low-funds kind of guy, adn was going to splurge and spend $1K on a sub... after reviewing every option over and over, someone finally laid out the cost difference/performance difference from pre-made to DIY, and im convinced.. Im gonna start with one of the 18" ho's and an EP4000 and just go from there. Although im scared, as i am clueless. I have access to a couple of clamps, a drill/screwgun and a caulking gun... thats it. No sound testing equipment etc... not that i would know what to do with it. there is so much to learn. I just want to rock the walls of the building. Im a 60/40 music/movie person. and I like full volume all the time. I have no regaurd for my poor little ears.. I started a thread to ask questions specifically for my first build, but i havent had an response. If im out of line, i apologize, but if any of you folks (especially you, Mr.Gorilla sir) want to give it a quick run-through and give me pointers/advice/point me in the right direction, it would be massively appreciated. Dont bust my balls too much please, I openly admit to being a newb, but im very interested in making this my "thing".. which is probably silly for someone who makes as little mula as i do, but hey, what can ya do!! cool.gif

http://www.avsforum.com/t/1461915/will-you-pros-help-a-newb-with-his-first-build-please

Thats the thread of clueless little ole' me. If you have the time to help, thanks a million.. if not, either way, i really enjoyed this thread from start to finish.

PS: It took me to about page 5 before my brain clicked and i realized what GTG stood for biggrin.gif Sheesh
NickThatStands is offline  
post #195 of 979 Old 03-06-2013, 02:42 PM
Member
 
NickThatStands's Avatar
 
Join Date: Feb 2013
Location: Ocala, FL
Posts: 186
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 12
oh, and Jim.. damn that 30+ incher is rediculous! man, i'd love to hear one or three of them in action!
NickThatStands is offline  
post #196 of 979 Old 03-06-2013, 04:56 PM
Member
 
NickThatStands's Avatar
 
Join Date: Feb 2013
Location: Ocala, FL
Posts: 186
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 12
ok, one last time let me ask a question that has zero to do with the thread (i just havent got an answer when i asked elsewhere, and its getting frustrating being without sound..). I just got my second onkyo 809 in one week because i thought the first was faulty.. here's the problem, and i really need some sort of solution, i have no proper sound for music or tv mad.gif

Ive got 2 XLS Cerwin Vegas (dont judge, im broke smile.gif ) that i had hooked into a CV-1800 pro-amp, and then into a cheap little technoband EQ and then into my ipod.. it played fine, no hum or anything like that.. Now i just bought this receiver because i guess i needed the pre-out inputs. (so im on my 3rd brand new receiver now). I hook from the amp to the eq (and i tried bypassing the eq and going from the amp directly to the receiver) using dual 1/4" - to - dual RCA wires. i plugged them into the front left/right pre-outs.. all i get is a loud hum and really really weak volume, and it sounds like you are listening to people in a garbage can, it sounds horrible.. When i hook the speakers right into the receiver (using its internal amp) it sounds fine.. The problem is, i want to use my amp as thats why i bought it.. the speakers need more power.

I assume all wires are fine because the system works without the receiver.. Do i have a ground problem? if so, i dont see how, as both the receiver and the seperate amp and speaker system have been plugged in the same area since before this, and all work fine. its only when i connect the two... Onkyo support wasnt very helpful at all.. so now im stuck, clueless with a big hunk of expensive metal and no damn sound.. If ya'll could please help me out, i promise ill stop taking your thread off course.. I just want a solution from people who seem to know their S***


eek.gifeek.gifeek.gifeek.gifeek.gif HELP!!eek.gifeek.gifeek.gifeek.gif
NickThatStands is offline  
post #197 of 979 Old 03-06-2013, 05:02 PM
Member
 
NickThatStands's Avatar
 
Join Date: Feb 2013
Location: Ocala, FL
Posts: 186
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 12
if it matters, at first it was only hum and no sound until i did a master reset (and this is after i first plugged the thing in). now i have the sound to where it sounds normal, but still an extremely loud, unbareable hum...
NickThatStands is offline  
post #198 of 979 Old 03-07-2013, 05:53 AM - Thread Starter
AVS Special Member
 
Gorilla83's Avatar
 
Join Date: Aug 2011
Location: Delaware County, PA
Posts: 3,592
Mentioned: 40 Post(s)
Tagged: 0 Thread(s)
Quoted: 277 Post(s)
Liked: 412
Chances are the power cord to your receiver does not have a ground plug on it, correct? For sure sounds like a ground loop issue. You can try temporarily lifting the ground by using a cheater plug (grey plug about 1.00 from HD or lowes) to see if that is your issue.
Gorilla83 is online now  
post #199 of 979 Old 03-07-2013, 05:54 AM - Thread Starter
AVS Special Member
 
Gorilla83's Avatar
 
Join Date: Aug 2011
Location: Delaware County, PA
Posts: 3,592
Mentioned: 40 Post(s)
Tagged: 0 Thread(s)
Quoted: 277 Post(s)
Liked: 412
Quote:
Originally Posted by JimWilson View Post

18" drivers are for whimps. I wanted to build something using one of these! wink.gif

Hmm, with no T/S specs given, I've got to remain skeptical. smile.gif It does look massive though.
Gorilla83 is online now  
post #200 of 979 Old 03-07-2013, 07:38 AM
Member
 
NickThatStands's Avatar
 
Join Date: Feb 2013
Location: Ocala, FL
Posts: 186
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 12
yep, my receiver power cord has no ground plug. does radio shack have a "cheater plug" too? I only ask because they are right next door. Is that what its called? If i ask for that, they will point me in the right direction?


and thanks, btw.. Ive been frustrated as hell with it.
NickThatStands is offline  
post #201 of 979 Old 03-07-2013, 08:06 AM
Member
 
NickThatStands's Avatar
 
Join Date: Feb 2013
Location: Ocala, FL
Posts: 186
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 12
so i was reading on wiki that the cheater plug is pretty dangerous to use to eliminate hums in audio equipment. you are saying to use it just to see if thats my problem? And if it is my problem (It most likely is), what should i do from there? To fix the issue for the long term
NickThatStands is offline  
post #202 of 979 Old 03-07-2013, 08:18 AM
Member
 
NickThatStands's Avatar
 
Join Date: Feb 2013
Location: Ocala, FL
Posts: 186
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 12
hmm.. seems a cheater plug is to make a three prong plug into a two prong plug and eliminate the ground.. however, my receiver cord is already a two prong plug.. am i supposed to use the cheater plug on the amp power cord? I cant recall if it is 3 prong or two prong (im at work at the moment)
NickThatStands is offline  
post #203 of 979 Old 03-07-2013, 08:20 AM - Thread Starter
AVS Special Member
 
Gorilla83's Avatar
 
Join Date: Aug 2011
Location: Delaware County, PA
Posts: 3,592
Mentioned: 40 Post(s)
Tagged: 0 Thread(s)
Quoted: 277 Post(s)
Liked: 412
Quote:
Originally Posted by NickThatStands View Post

so i was reading on wiki that the cheater plug is pretty dangerous to use to eliminate hums in audio equipment. you are saying to use it just to see if thats my problem? And if it is my problem (It most likely is), what should i do from there? To fix the issue for the long term

Yes, use the plug to diagnose. From there you have to remove the ground from your signal into the amp. One option is to run a wire from the ground pin on your receiver to the grounding screw on an outlet. Another option is to make a custom RCA to XLR cable that would remove the ground coming into the amp. Do a search on here for "ground loop hum."
Gorilla83 is online now  
post #204 of 979 Old 03-07-2013, 08:37 AM
Member
 
NickThatStands's Avatar
 
Join Date: Feb 2013
Location: Ocala, FL
Posts: 186
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 12
NickThatStands is offline  
post #205 of 979 Old 03-07-2013, 02:02 PM
Member
 
NickThatStands's Avatar
 
Join Date: Feb 2013
Location: Ocala, FL
Posts: 186
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 12
last question (and i promise, ive been reading through ground loop hum threads all day).. Seems lots of people's hums come from the TV box co-ax.. is this true in your experience? Ive read a trillion ideas on how to remedy it, but i would like to here your opinion.. people talk about running a ground wire from the cable splitter to the damn ground rod outside and whatnot.. i live in an apartment, and ideas like these are of no help to me. if it is the cable box being plugged in causing the humming, is there other things you would do to resolve it?

Im basically trying to get all the answers while im at work, this way when i get home, i can go through them and get this handled, instead of waiting another day for new ideas.
NickThatStands is offline  
post #206 of 979 Old 03-07-2013, 02:56 PM - Thread Starter
AVS Special Member
 
Gorilla83's Avatar
 
Join Date: Aug 2011
Location: Delaware County, PA
Posts: 3,592
Mentioned: 40 Post(s)
Tagged: 0 Thread(s)
Quoted: 277 Post(s)
Liked: 412
Quote:
Originally Posted by NickThatStands View Post

last question (and i promise, ive been reading through ground loop hum threads all day).. Seems lots of people's hums come from the TV box co-ax.. is this true in your experience? Ive read a trillion ideas on how to remedy it, but i would like to here your opinion.. people talk about running a ground wire from the cable splitter to the damn ground rod outside and whatnot.. i live in an apartment, and ideas like these are of no help to me. if it is the cable box being plugged in causing the humming, is there other things you would do to resolve it?

Im basically trying to get all the answers while im at work, this way when i get home, i can go through them and get this handled, instead of waiting another day for new ideas.

The cable box/line has not been the issue in my place. Start with trying the cheater plug to see if that cleans up the issue and go from there.
Gorilla83 is online now  
post #207 of 979 Old 03-07-2013, 04:10 PM
Member
 
NickThatStands's Avatar
 
Join Date: Feb 2013
Location: Ocala, FL
Posts: 186
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 12
well, im home. radio shack didnt have a floater plug (and the kid working there didnt even know what i was talking about, lol). While i was waiting on my handy neighbor to locate one, i pulled the hdmi cord that goes from the cable box to the receiver out of the back of the receiver and boom. hum totally dissappeared.. i can play music via my ipod through my receiver adn amp (hooked together) with no hum. so what should i do now? I see many folks say to get that $10 ground isolation thingy from PE.. but right on the description at PE it says "not for digital cable, analog only". adn there are lots of contradictions.. people saying it worked, people saying it didnt.. hell even a staff member from PE said it works (when the PE description says otherwise).. let me know what you think i should do from here.

Always appreciated.
NickThatStands is offline  
post #208 of 979 Old 03-07-2013, 04:25 PM
Member
 
NickThatStands's Avatar
 
Join Date: Feb 2013
Location: Ocala, FL
Posts: 186
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 12
hmm. looks like this is working. i hooked a peice of speaker wire as a ground wire from the splitter on where my coax splits to go to my modem and cable box, and the other end i just put against the chassis of the amp (which i assume is properly gorunded as i am not using any inproper plugs) and the humming stopped. is this safe? If so, its not even visible, and will be one cheap/easy fix!
NickThatStands is offline  
post #209 of 979 Old 03-07-2013, 06:38 PM
AVS Special Member
 
JimWilson's Avatar
 
Join Date: Oct 2010
Location: Somewhere in New Joisey
Posts: 4,786
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 284 Post(s)
Liked: 431
I used this isolator and it cleared up my cable-induced hum.

If you take yourself too seriously expect me to do the exact opposite
JimWilson is offline  
post #210 of 979 Old 03-08-2013, 04:29 AM - Thread Starter
AVS Special Member
 
Gorilla83's Avatar
 
Join Date: Aug 2011
Location: Delaware County, PA
Posts: 3,592
Mentioned: 40 Post(s)
Tagged: 0 Thread(s)
Quoted: 277 Post(s)
Liked: 412
Quote:
Originally Posted by NickThatStands View Post

hmm. looks like this is working. i hooked a peice of speaker wire as a ground wire from the splitter on where my coax splits to go to my modem and cable box, and the other end i just put against the chassis of the amp (which i assume is properly gorunded as i am not using any inproper plugs) and the humming stopped. is this safe? If so, its not even visible, and will be one cheap/easy fix!

Yes, that is a fine solution. Just extend the wire long enough so it's out of your way and you're done!
Gorilla83 is online now  
Reply What's Your System Configuration

Tags
Denon Avr 4311ci 9 2 Channel Network Multi Room Home Theater Receiver With Hdmi 1 4a , Oppo Bdp 93 Blu Ray Player , Roku Hd Player , Xbox 360 Console , Panamax , Epson Home Cinema 8700 Ub Projector , Peavey Ipr2 7500 Power Amplifier 7500 Watts , Crown Nxls2000 0 Us Power Amplifier , Yorkville , Jbl Professional 8340 Cinema Surround Speaker , Basement Bar
Gear in this thread

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off