Abnormal sound from projector and not getting power on. - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 4 Old 02-24-2013, 08:31 PM - Thread Starter
Member
 
Jeemon Paul's Avatar
 
Join Date: Feb 2013
Posts: 21
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
i do have a optoma es511 projector and yesterday after wacthing a movie i powered it off and after n hour i tried to power it on and it started an abnormal sound and i powered it off instantly
after that its not getting started .even the standby LED bulb also not showing any sign of power ..

do this projector having any fuse ?? its under warranty and bought from dubai..can i get the warranty in india ???
Jeemon Paul is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 03-10-2013, 05:10 AM
Senior Member
 
domz777's Avatar
 
Join Date: Nov 2011
Location: NYC
Posts: 206
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 16 Post(s)
Liked: 25
I have an Optoma pj (an HD66) and have worked on several other models as well. I have no clue about your warranty being honored or not in india, but I can tell you this - more than 50% of the time when you hear a weird or loud noise from a pj - it's the cooling fan.

If the fan blades got blocked or shifted off their axis somehow, they can hit other components inside the pj, and that's the noise. The tolerances inside a pj are VERY close. A fan obstruction will shut the pj down almost immediately. If your handy with a screwdriver, and don't care about voiding the warranty(if it can't be honored in india anyway - what have you got to lose?) take off the top shell and see if the fan spins freely.

If your NOT handy with a screwdriver, or you DO care about voiding the warranty - call Optoma.
Jeemon Paul likes this.
domz777 is online now  
post #3 of 4 Old 03-10-2013, 11:05 AM - Thread Starter
Member
 
Jeemon Paul's Avatar
 
Join Date: Feb 2013
Posts: 21
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Thank you very much sir,, am planning to open up the cover and check as you adviced .am freindly with screw drivers anyway...soo the probable cause will be the fams fins got jammed and its cutting the power supply ...thank you once again...
Jeemon Paul is offline  
post #4 of 4 Old 03-18-2013, 03:17 AM
Senior Member
 
domz777's Avatar
 
Join Date: Nov 2011
Location: NYC
Posts: 206
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 16 Post(s)
Liked: 25
good luck - and don't forget to post the results of your effort.
domz777 is online now  
Reply Theater Room Items & Accessories

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off