Speakercraft mzc 66 keypad failures - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 2 Old 04-14-2012, 09:12 AM - Thread Starter
Newbie
 
mekcr's Avatar
 
Join Date: Apr 2012
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Have 2 mzc 66 units about 5 years old and within the last year the keypads seem to be failing and causing poping and hissing in the speakers. I've read similar issues described as amp issues but i've replaced 2 keypads and it fixes the issue but at 120$ a keypad if the unit itself is killing the keypads i don't want to keep throwing keypads at them. Has anyone else had similar issues and how did you resolve or welcome suggestions. Down 5 of 12 rooms right now and debating how to move forward? Thank you.
mekcr is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 04-14-2012, 11:18 AM
AVS Special Member
 
ifor's Avatar
 
Join Date: Mar 2003
Location: La Quinta, CA
Posts: 2,439
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Liked: 47
The amp cards were problematic in those units. Call Speakercraft for a fix.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
ifor is offline  
Reply Home A/V Distribution

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off