Russound CAA66 - No control, all 6 Zone LEDs blinking - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 3 Old 08-02-2012, 08:16 PM - Thread Starter
Member
 
srt4b's Avatar
 
Join Date: Jul 2006
Posts: 46
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I have had this unit since 2007, it has always worked perfect. I use it several hours daily.

Yesterday it stopped working. The key pads say NO CONTROL when I push any button with no backlight or any power coming on at all, it's just a scrolling message. The unit it self powers up but the 5 LEDs on the front blink and the LEDs under the cover are green, yellow, & red.

Pics below. Any ideas?
KCdJsl.jpg
ZZQHil.jpg
srt4b is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 08-03-2012, 06:37 PM - Thread Starter
Member
 
srt4b's Avatar
 
Join Date: Jul 2006
Posts: 46
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
This place is a graveyard. I cannot find any support for this unit anywhere online. Bummer.
srt4b is offline  
post #3 of 3 Old 08-03-2012, 07:54 PM
AVS Special Member
 
jautor's Avatar
 
Join Date: Jun 2001
Location: Houston, TX
Posts: 7,695
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 82 Post(s)
Liked: 341
Did you try calling Russound or emailing them?

Certainly the first thing to try is to disconnect every cable from the main unit and see what that does. Still likely it's something wrong inside, and you'll need to contact Russound for assistance or repair anyway.

Rock Creek Theater -- CIH, Panamorph, Martin Logan, SVS PB2000, Carada Masquerade, Grafik Eye, Bar table, Green Glue, JVC RS50 
Theater build photos: http://photobucket.com/autor-ht

jautor is offline  
Reply Home A/V Distribution

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off